15:00:37 <quaid> #startmeeting Infra weekly
15:00:37 <ovirtbot> Meeting started Mon Dec 10 15:00:37 2012 UTC.  The chair is quaid. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:37 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:52 <quaid> #chair dneary ewoud garrett dcaro
15:00:52 <ovirtbot> Current chairs: dcaro dneary ewoud garrett quaid
15:01:03 <quaid> #topic Howdy & agenda
15:01:33 <ewoud> http://www.ovirt.org/Infrastructure_team_meetings#2012-12-03
15:01:35 <quaid> ''Agenda''
15:01:35 <quaid> * How to add new Infra admin members (if not resolved on list)
15:01:35 <quaid> * IRC bot
15:01:35 <quaid> * Hosting
15:01:35 <quaid> * Puppet
15:01:37 <quaid> * Jenkins
15:01:40 <quaid> * Gerrit
15:01:42 <quaid> * Other business?
15:01:45 <quaid> * Trac review
15:01:47 <quaid> that was last weks
15:01:50 <quaid> week's
15:01:53 <quaid> I'm about to save out the page with this week agenda on it
15:02:07 <quaid> http://www.ovirt.org/Infrastructure_team_meetings#2012-12-10
15:02:15 <ewoud> you're right, I just looked under upcoming
15:02:25 <quaid> yeah, forgot to cleanup last week :)
15:03:30 <ewoud> brb
15:04:19 <quaid> ok, that's a quiet roll call/howdy but I saw some folks here for the meeting ... so we can move on
15:04:53 <quaid> #topic Adding new Infra admins (root)
15:05:14 <quaid> This is still here because we haven't talked about it on list yet :)
15:05:25 <quaid> I bet I had the task to start that discussion
15:06:12 <quaid> I'm just going to start the email over here and finish/send  by end of meeting
15:07:01 <quaid> #action quaid to send email at end of meeting to start discussion
15:07:48 <quaid> any comments before we move on?
15:09:27 <quaid> #topic IRC Bot
15:09:54 <quaid> ovirtbot's wiki change powers were relying upon being on the same host as the wiki engine
15:10:13 <quaid> the supybot extension author (ianweller) told me it should work from remote
15:10:32 <quaid> but I think it might be looking for info from MediaWiki on a port that OpenShift doesn't expose
15:10:47 <quaid> I've tried a few things, no luck yet
15:10:59 <quaid> dneary pointed this out: http://www.mediawiki.org/wiki/Manual:MediaWiki-Recent_Changes-IRCBot
15:11:38 <dneary> Yeah
15:11:39 <quaid> I'm not sure we can run that directly or not, it requires Perl
15:11:49 <quaid> but worth experimenting
15:11:57 <dneary> quaid, I asked on #OpenShift whether we could
15:12:04 <quaid> I guess I'd prefer one bot to maintain
15:12:16 <quaid> dneary: about supybot? or a Perl gear?
15:12:16 <dneary> Normally OpenShift doesn't give you access to port 6667
15:12:22 <ewoud> back
15:12:31 <dneary> Running a Perl script on the same host as the wiki
15:12:42 * dneary still thinking in terms of hosts not gears
15:12:59 <quaid> ok, I'll have to ask them about the supybot access, too
15:13:29 <quaid> you mean, inbound access to 6667?
15:13:39 <quaid> or a script can do an outbound request to 6667?
15:13:44 <quaid> s/can/can't/
15:13:57 <dneary> Outbount
15:14:09 <dneary> quaid, That's what I was told today
15:14:27 <quaid> ok
15:14:48 <ewoud> can you talk to supybot using jabber or something?
15:14:55 <quaid> well, supybot can live on another Infra VM outside of OpenShift, but it also has a non-standard port need (5050 iirc)
15:15:50 <quaid> http://www.mediawiki.org/wiki/Extension:SupybotNotify
15:16:05 <quaid> maybe we can just get it to use 80
15:16:29 <quaid> #action quaid to ask in #openshift about how to make supybot work (non-standard ports, etc.)
15:17:12 <dneary> quaid, The mechanism, as I understand it, is MediaWiki notifies of RC over UDp on a local port, and your perl script listens there, and converts messages to IRC
15:17:33 <dneary> So maybe we can notify Supybot of the changes directly on linode1?
15:17:35 <quaid> dneary: yeah, that's what supybot is doing aiui
15:17:55 <quaid> dneary: right, we should be able to do that
15:18:18 <quaid> it might simply be the ports used, get them to align with what OpenShift allows
15:18:38 <dneary> Anyway, the ports we can use are constrained by OpenShift. Needs looking at
15:18:57 <quaid> heh, I was wondering if anyone would notice or complain about the lack of wiki edits being announced here
15:19:06 <quaid> I miss it myself, but wasn't sure others cared
15:19:29 <quaid> ok, moving on?
15:20:36 <dcaro> ok
15:20:42 <quaid> #topic Hosting
15:21:42 <quaid> #info quaid should be meeting with RackSpace hopefully this week to start the new account for oVirt (and other needs his team has)
15:22:29 <ewoud> we had a discussion about libvirt vs ovirt
15:22:35 <quaid> ewoud: I guess I'll just have them put RHEL 6.x on there for now? we can then hook them in to Puppet
15:22:38 <quaid> right
15:23:10 <ewoud> and the rackspace machines are physical machines?
15:23:32 * eedri_ here
15:24:53 <quaid> ewoud: yes, aiui
15:25:03 <ewoud> aiui?
15:25:18 <ewoud> eedri_: maybe you have an opinion on libvirt vs ovirt?
15:25:35 <eedri_> ewoud, well.. foreman can manage both
15:25:56 <eedri_> ewoud, so even we use libvirt, we'll have a foreman mgmt ui to handling vms
15:26:10 <quaid> aiui = as I understand it
15:26:15 <eedri_> ewoud, personally, i don't have experience with using libvirt directly
15:26:28 <eedri_> ewoud, what are the cons against using ovirt?
15:26:30 <ewoud> eedri_: I know, but can we manage the machines at rackspace using the same ovirt instance?
15:27:29 <ewoud> pro: dogfooding, maybe easier separation of permissions (give new infra read-only at first)?
15:27:42 <quaid> right
15:27:58 <ewoud> con: there's a certain overhead
15:28:14 <ewoud> anything else?
15:28:39 <quaid> do we need to throw out some design ideas? how it all could fit together?
15:29:15 <eedri_> ewoud, i think we should keep to ovirt, managing libvirt might turn out to be bit difficult
15:29:32 <eedri_> ewoud, also i'm sure we'll want to migrate to ovirt at some point, when it's more stable
15:29:44 <eedri_> ewoud, not sure if we will be able to migrate the vms
15:29:53 <ohadlevy> ewoud: foreman supports rackspace too :)
15:30:26 <ewoud> ohadlevy: yes, but is that also for dedicated servers?
15:30:35 <ohadlevy> ewoud: what do you mean?
15:30:49 <ohadlevy> ewoud: it can create servers in rackspace(i think they are dedicated if you pay for them ;))
15:30:51 <ewoud> ohadlevy: physical servers hosted at rackspace
15:31:05 <ohadlevy> ewoud: ah, it can create it via the V2 API
15:31:10 <ohadlevy> not sure if thats a valid machine type or not
15:31:58 <ewoud> eedri_: I'm a bit worried about the memory the java stack might need
15:32:56 <ewoud> eedri_: so for me I think we should be able to manage more than just the standalone server for it to be a benefit
15:33:07 <ewoud> eedri_: and I'm sure we can manage a migration when we get to it
15:34:31 <eedri_> ewoud, well, maybe we can run the ovirt-engine elsewhere, and not on the phsyical host
15:34:54 <eedri_> ewoud, we're using vms with 1-2GB to install engine
15:35:11 <eedri_> ewoud, so an amazon vm might suffice?
15:35:20 <eedri_> ewoud, sorry..it won't work
15:35:28 <eedri_> ewoud, different networks
15:36:19 <ewoud> eedri_: then I'd propose we just use libvirt at alterways
15:36:35 <eedri_> ewoud, anyway, what do expect to achive by saving the java memory print? be able to run more vms?
15:37:05 <eedri_> ewoud, or better performance of the running vms
15:37:27 <ewoud> eedri_: I expect more VMs
15:38:42 <quaid> since we haven't had Kevin from Alter Ways here in this meeting, maybe we can take this discussion to the list
15:38:47 <quaid> do some design suggestions
15:39:33 <ewoud> ok
15:39:57 <quaid> #action team to discuss new hosting design ideas on list
15:40:30 <ewoud> shall we move on to the next item on the agenda?
15:41:17 <quaid> heh, I was wondering if anyone would notice or complain about the lack of wiki edits being announced herees
15:41:20 <quaid> argh
15:41:22 <quaid> yes
15:41:34 <quaid> #topic Puppet
15:42:14 <quaid> is this an open topic that is going to be discussed as part of the previous one?
15:42:17 <quaid> i.e., move on ...?
15:42:55 <ewoud> I think so
15:43:01 <ewoud> unless someone has something new to mention
15:43:15 <quaid> #info Puppet to be discussed as part of new hosting discussionon list
15:43:37 <quaid> #topic Jenkins
15:43:54 <quaid> anything new here until we have new hosting figured out?
15:44:20 <ewoud> eedri_: ^
15:44:36 <eedri_> nothing new.. other than waiting for migration
15:44:40 <eedri_> to new server
15:44:49 <eedri_> also, we might need to plan the migration
15:45:22 <eedri_> i also propose to add more admins to jenkins
15:45:42 <eedri_> so that more people can handle job errors quickly, while i'm not available
15:45:45 <dneary> eedri_, I haven't seen any requests for action re the new server on the list yet
15:45:59 <dneary> eedri_, I really need a "someone" to take charge there
15:46:08 <eedri_> dneary, the new server is ready?
15:46:13 <dneary> What do we need from AlterWay, when?
15:46:19 <eedri_> dneary, do we have root access to it?
15:46:27 <dneary> eedri_, We need to ask for it & say what we want :-)
15:46:30 <eedri_> dneary, well
15:46:36 <quaid> #info need to add more admins to Jenkins, when we can
15:46:46 <eedri_> dneary, if we'll move to the new jenkins bare metal server
15:46:50 <dneary> eedri_, On the list... Kevin Mazière is the AlterWay guy, and is available for requests
15:46:59 <eedri_> dneary, will we still be able to add the existing amazon vms as slaves?
15:47:01 <quaid> this I think comes up in the design discussion from two topics ago
15:47:15 <quaid> right, when we start talking about what Alter Way has and how to use it, he'll chime in
15:47:48 <dneary> also don't be shy about sending him an email off-list if something needs his attention & isn't getting it
15:48:04 <quaid> #info we need to plan Jenkins migration
15:48:06 <dneary> So - let's put a name on this
15:48:14 <eedri_> dneary, i'll take lead on it
15:48:19 <quaid> dneary: see two topics ago, too, please
15:48:20 <dneary> Who's taking the lead on setting up our new Jenkins server?
15:48:21 <eedri_> dcaro, can you help with the migration plan?
15:48:40 <dneary> Two topics ago? "Hosting"?
15:48:45 <dcaro> eedri_, sure
15:49:17 <quaid> dneary: yes, that we have lots of ideas in the air that include Jenkings, Alter Way, etc. and we need a single discussion on list to design the new hosting/networks
15:49:21 <dneary> Ah, yes - I see the end of the topic
15:49:31 <eedri_> quaid, ok, agreed me & dcaro will plan the migration and talk with alterway to get access to the server
15:49:39 <dneary> Missed it because I thought we were only taking about RackSpace
15:49:42 <quaid> #action eedri_ taking lead on Jenkings migration
15:49:57 <quaid> #agreed eedri_ and dcaro will plan migration of Jenkins and talk with Alter Way, etc. on infra@ list
15:49:58 <dneary> quaid, Yes, I'm happier having a name on it
15:50:03 <dneary> Thanks
15:50:25 <eedri_> dneary, np, we'll write a wiki on the plan and publish to the list
15:50:27 <quaid> I thought eedri_'s name has been on it for a while, sorry, I didn't think to ask/double-check
15:50:30 <quaid> +1
15:50:41 <eedri_> quaid, wasn't aware we have the server ready for it
15:50:42 <quaid> #action eedri_ to write a Jenkins migration plan on the wiki
15:51:00 <eedri_> quaid, i thought we're waiting for action from alterway
15:51:01 <quaid> eedri_: I think we may be ready to plan, I'm not sure if we're ready to take root yet
15:51:05 <quaid> dneary: which is the case?
15:51:31 <dneary> quaid, Yes!
15:51:39 <dneary> So, I'm happy about that
15:52:10 <quaid> dneary: oh! sorry, I didn't poke you during hosting discussion, we're good to fly contractually?
15:52:19 <dneary> quaid, No
15:52:38 <dneary> quaid, We're good to go without one, and I need to figure out hosting agreement stuff again
15:52:54 <quaid> oh, ok
15:53:04 <quaid> well, you can explain it to me later, i guess :)
15:53:36 <quaid> I'd like to see if we can hit the last agenda items, moving on ok?
15:54:30 <quaid> #topic Gerrit
15:54:42 <quaid> #info Gerrit plans are part of the overall hosting discussion, to be had on list
15:54:48 <quaid> #topic Trac review
15:55:33 <quaid> ok, let me hit some highlights
15:56:14 <quaid> eek, I'm sorry
15:56:26 <quaid> I have a meeting in four minutes, so I can't really do Trac review justice
15:56:36 * dneary stepping out of the meeting - I have another meeting starting in 5
15:56:39 <quaid> https://fedorahosted.org/ovirt/report/1
15:56:52 <quaid> that's the open ticket list, we'll have to review it later
15:57:03 <quaid> #topic Anything else?
15:58:18 <ewoud> I think we should make alterways a trac milestone
15:58:30 <ewoud> and add all tickets to it so we can see what's blocking on it
16:00:16 <quaid> ewoud: good call
16:00:50 <quaid> #action quaid to add Alter Ways as milestone in Trac
16:00:54 <quaid> (I'll do that right now)
16:01:02 <ewoud> cool
16:01:04 <quaid> ok, closing meeting ...
16:01:05 <ewoud> I think that's it for me
16:01:16 <backblue> it's there any windows guest agent app? I found the drivers, but I can't find the agent app.
16:01:24 <quaid> #endmeeting