21:03:06 <quaid> #startmeeting ovirt.org OpenShift transfer session
21:03:06 <ovirtbot> Meeting started Thu Nov 29 21:03:06 2012 UTC.  The chair is quaid. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:03:06 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:03:18 <quaid> just to make documenting easier, we can use meetbot (since we're not rebooting anything)
21:03:38 <quaid> we should have a sitenotice if it was aplicable
21:03:57 <quaid> I guess a notice on the front page is OK
21:04:18 <quaid> (we're not really going to break the wiki, but people may need to refresh their browser)
21:04:59 <ovirtbot> 14[[07Features/Design/DetailedExternalEvents14]]4 !10 02http://wiki.ovirt.org/w/index.php?diff=6164&oldid=6163&rcid=6293 5* 03Emesika 5* (+485) 10/* Permissions on Entities */ 
21:05:08 <quaid> oops
21:05:47 <quaid> dneary: make it quick, please
21:06:13 <ovirtbot> 14[[07Main Page14]]4 10 02http://wiki.ovirt.org/w/index.php?diff=6165&oldid=5538&rcid=6294 5* 03DNeary 5* (+203) 10Maintenance mode
21:06:17 <quaid> thx
21:06:47 <dneary> I'd a put it at the top of each page if I could wuickly do it, but I don't have access to the theme
21:06:59 <quaid> #info just started the backup script /root/bin/mediawiki.sh that locks the wiki before backing up the database and files
21:07:10 <quaid> well, it won't affect people reading the wiki
21:07:18 <quaid> and the readonly mode puts a notice in the page when people try to edit
21:07:23 <quaid> or, rather, save an edit iirc
21:09:16 <quaid> #info wiki.ovirt.org now set to readonly with a notice about migration to OpenShift
21:09:32 <dneary> quaid, Phone
21:09:37 <dneary> Will be back in a few
21:17:49 <quaid> dneary: I am about to push the change to openshift to make that wiki readonly as well
21:17:55 <quaid> so that will restart the gear
21:18:07 <dneary> ok
21:18:18 <quaid> #info new wiki in readonly mode by pushing change to LocalSettings.php
21:18:39 <quaid> #info 'rhc port-forward -a wiki' to setup port forwarding for uploading the new database
21:19:34 <mburns> quaid: does #info work when you're not in a meeting?
21:20:08 <jbrooks> mburns, quaid started a meeting for this
21:21:00 <quaid> #info 'mysql -u admin -h127.7.52.129 -pPASSWORD openshift_mediawiki < mediawiki_db_backup-20121129.sql' is now uploading the refreshed database
21:21:02 <mburns> jbrooks: ahh, just no new /topic
21:21:25 <quaid> oh, did ovirtbot lose ops?
21:21:36 <quaid> yep
21:21:43 <quaid> thus no topic change
21:21:52 <quaid> RobertM: can you op ovirtbot?
21:22:01 <quaid> we'll set a maintenance topic that way, I reckon
21:22:21 <quaid> dneary: data transfer has begun, according to the upload monitor from here
21:22:26 <quaid> I'm going to rsync files
21:22:48 <mburns> quaid: there, ovirtbot has ops now
21:22:52 <quaid> thx
21:22:54 <RobertM> quaid, looks like mburns bet me to it.
21:22:56 <quaid> forgot you can do that too
21:23:05 <quaid> #chair dneary mburns RobertM
21:23:05 <ovirtbot> Current chairs: RobertM dneary mburns quaid
21:23:07 <quaid> (just in case)
21:23:08 <mburns> quaid: had to op myself first...
21:23:27 <quaid> #topic Migrating www.ovirt.org to OpenShift, site may change or disappear temporarily; Wiki is frozen
21:25:42 <mburns> quaid: just a thought -- might want to send outage to announce@ and users@ for wiki/site outages...
21:25:52 <mburns> for future outages...
21:28:22 <quaid> mburns: this is not an outage for users
21:28:30 <quaid> the content will be available readonly throughout
21:28:49 <quaid> mburns: so i contemplated that but didn't end up doing it because ... well, I just didn't :)
21:28:49 <mburns> quaid: not all wiki editers are on arch@
21:29:00 <quaid> mburns: they should be :D
21:29:05 <mburns> perhaps...
21:29:08 <sgordon> in fairness there is also a maintenance banner on the page
21:29:14 <quaid> not all wiki editors are on announce@ either, I guess
21:29:16 <mburns> sgordon: yep
21:29:22 <mburns> quaid: but they should be on users@
21:29:24 <quaid> we have to have one email list that is for hitting all contributors
21:29:43 <sgordon> isnt that what announce is for? or dont we have the other lists subbed to it
21:30:04 <mburns> sgordon: no, announce doesn't send to other lists
21:30:09 <sgordon> fair enough
21:30:14 <mburns> (and shouldn't, imo)
21:30:53 <mburns> but i think announce should be the default for site outages (even if it's just a maintenance window that might not cause any downtime)
21:31:36 <quaid> #agreed Infra team change process and outage management needs to include sending email to too many lists rather than too few, e.g. users@, announce@, etc.
21:31:56 <quaid> just forwarded to those lists, thanks for the catch
21:32:01 <mburns> quaid: i forwarded to announce and users..
21:32:04 <quaid> quaid_transparency--
21:32:05 <quaid> oops
21:32:06 <mburns> oh...
21:32:09 <mburns> oh well...
21:32:11 <quaid> I guess we both just did :)
21:32:16 <mburns> too many is better than not enough...
21:32:17 <quaid> but at least I got a mea culpa in there
21:32:19 <quaid> right
21:32:29 <mburns> ok, /me goes back to other work
21:32:31 <quaid> dneary: mysql is still uploading
21:32:33 <mburns> ping if you need me
21:32:49 <quaid> dneary: I have a change in git ready to go to add in the new files, but I don't want to jam my upload bandwidth yet
21:32:52 <quaid> mburns: thanks!
21:32:58 <dneary> quaid, Are you picking up the files as well?
21:33:01 <quaid> yes
21:33:04 <dneary> Cool
21:33:14 <dneary> I uploaded company logos earlier
21:33:20 <dneary> For the Sponsors page
21:33:22 <quaid> I just did an rsync --- NOT with --delete siince that would have walloped your widgets, as -n showed me
21:33:35 <dneary> My widgets?
21:33:43 <dneary> Twitter and Twitter Search?
21:33:52 <dneary> (neither of them are in use just yet)
21:34:09 <quaid> stuff in images/widgets
21:35:57 <dneary> OK. Don't know exactly what might be in there
21:36:16 <dneary> Shouldn't be anything...
21:37:25 <quaid> kk
21:39:12 <quaid> dneary: when the sql is done, I can push the images I have, then I have to go for a short bit
21:39:30 <quaid> dneary: you can reach me via mobile - text or whatever - I'll be back at console in :45
21:39:35 <dneary> quaid, Do you want me to do the redirects?
21:39:49 <quaid> for the /releases?
21:39:50 <quaid> yes plz
21:39:55 <dneary> Cat you /msg cellphone #? I probably have it, but just to be sure...
21:40:29 <quaid> you can also use gtalk to chat to my handset
21:40:38 <quaid> and I can ssh here easily
21:41:09 <quaid> dneary: I'm going to leave it to you to change LocalSettings.php back to writeable
21:41:18 <quaid> I have to walk out the door, so I'm going to push the git commit
21:41:25 <quaid> it will slow down the dbase upload a bit, sorry
21:41:28 <dneary> It's not writable?
21:41:43 <quaid> nope, see last commit before this one
21:41:43 <dneary> I don't understand
21:41:46 <dneary> Ah, OK
21:41:49 <dneary> Will pull
21:42:02 <quaid> I turned off the target wiki so we don't write to it while I'm writing the new sql to the dbase
21:42:06 <quaid> just double-safety
21:42:21 <quaid> ooh, dbase upload finished
21:42:26 <quaid> #info dbase upload finished
21:42:38 <quaid> it's going to be about 10 min for the images to update
21:42:46 <quaid> then it's all on the OPenShift
21:42:47 <quaid> bbiab
21:50:20 <Rydekull> hmm
22:33:25 <quaid> dneary: I'm back
22:33:32 <quaid> well, at least back on the console
22:40:35 <quaid> working on the DNS situation
22:44:40 <dneary> quaid, Not much happened
22:44:48 <dneary> quaid, I'm falling asleep here :-(
22:45:05 <dneary> Looking for info on site nav & page rename
22:45:16 <dneary> "front âge"
22:45:31 <jbrooks> dneary, I notice that this is the older, more ambitious text; http://wiki-ovirt.rhcloud.com/Download
22:47:55 <dneary> jbrooks, it should get over-written with the new Download page
22:48:10 <dneary> quaid, Discovered how to change which page is the front page
22:48:20 <dneary> quaid, Is the database copy done now?
22:48:31 <dneary> I lmean, is the new data live?
22:48:41 <jbrooks> the develop page has the new content
22:49:20 <dneary> ! - I updated that sidebar already
22:49:26 <dneary> and it's different now
22:50:06 <dneary> http://wiki.ovirt.org/wiki/Download is different
22:50:14 <dneary> That is what is supposed to go live
22:50:56 <dneary> quaid, Can you let me know when the data is live, please? I want to work on changing the main page
22:53:18 <quaid> dneary: umm
22:53:22 <quaid> 13:42 < quaid> ooh, dbase upload finished
22:53:28 <quaid> it's been live for over an hour
22:53:31 <quaid> sorry that wasn't clear
22:54:02 <jbrooks> quaid, for some reason, the Download page at least doesn't appear to have updated
22:54:14 <dneary> quaid, Why is the content of some pages not the same, then?
22:54:27 <jbrooks> http://wiki.ovirt.org/wiki/Download vs http://wiki-ovirt.rhcloud.com/Download
22:54:29 <dneary> quaid, It looks like the wiki on ovirt-wiki has an old back-up
22:55:03 <quaid> is this 100% consistent?
22:55:19 <quaid> all I did was what I did before, which we agreed would overwrite the database
22:55:20 <dneary> quaid, The Download pages are different
22:55:39 <dneary> The http://wiki-ovirt.rhcloud.com/index.php?title=Home page is lacking the images I uploaded
22:55:57 <dneary> But Home is definitely newer
22:56:07 <jbrooks> dneary, I see the images on the new home page
22:56:58 <jbrooks> http://wiki.ovirt.org/wiki/Special:RecentChanges and http://wiki-ovirt.rhcloud.com/Special:RecentChanges, at a glance, seem to match pretty well
22:57:40 <quaid> ok, I do see some subtle differences on [[Download]]
22:58:55 * jbrooks admires the handsomeness of the site -- garrett did a nice job
22:59:04 <dneary> Revision history is identical there...
22:59:37 <quaid> yeah, [[Special:RecentChanges]] is accurate so that much at least worked
23:00:07 <dneary> Hmm
23:00:36 <quaid> that's odd
23:00:49 <quaid> I reckon we'll just need to check, it's possible that if some of the pages existed the drop-table didn't work?
23:02:17 <dneary> http://wiki-ovirt.rhcloud.com/Special:Log matches up too
23:02:50 <dneary> quaid, No, that doesn't make sense. "drop table" is "drop table"
23:03:02 <dneary> quaid, It has to be something on the filesystem
23:03:11 <quaid> oh interesting
23:04:42 <dneary> I don't understand why File:Icon-manage.png et al are not getting picked up on /Home
23:05:10 <dneary> For the main page, you just need to edit the MediaWiki:Mainpage page and set it to "Home"
23:05:43 <jbrooks> dneary, I see Icon-manage.png on /Home
23:05:59 <jbrooks> the three images from garrett
23:06:20 <quaid> #info to change main site page, edit [[MediaWiki:Mainpage]] and set it to [[Home]]
23:06:43 <dneary> jbrooks, Really? I don't
23:06:48 <dneary> I see the alt text
23:06:55 <jbrooks> I see the three images
23:07:11 <quaid> I see the images on [[Home]]
23:07:26 <quaid> but I'm logged in ...
23:07:40 <jbrooks> I just logged out, and I still see them
23:07:43 <quaid> and I see them logged out
23:07:44 <dneary> OK, Ctrl-F5 worked
23:08:15 <quaid> yay
23:08:16 <jbrooks> I don't see how to log back in, though. There used to be a thing for that in the footer
23:08:44 <quaid> so I think we're going to handle just the ovirt.org redirect
23:08:59 <quaid> we could do all the redirects ourselves, but then we'd lose the old URL access
23:12:05 <dneary> quaid, Can I get a copy of the database? I'd like to understand where this page difference is coming from (to be sure that there aren't other pages affected that we're not seeing)
23:12:37 <dneary> I don't understand what you mean by "just the ovirt.org redirect"
23:13:59 <quaid> we can't make a CNAME for ovirt.org, so the redirect has to be at the web proxy layer
23:14:13 <quaid> rather than ask RHT IT to be the proxy, we can do it ourselves on linode01
23:15:53 <quaid> they're ready to do the DNS switch, btw
23:17:49 <quaid> dneary: it's 52M compressed
23:18:22 <dneary> quaid, It's really weird, though
23:18:27 <quaid> yep
23:19:05 <dneary> It's like, I moved User:DNeary/Download to Download, and it's just using the old Download (maybe because User:DNeary/Download is gone?)
23:19:16 <quaid> oh!
23:19:22 <quaid> that could be, something like that?
23:19:26 <quaid> is this the only page like that?
23:19:33 <dneary> But this is all just revisions in the mw_revisions table
23:19:52 <dneary> That's exactly my question - are there other pages like this?
23:20:09 <dneary> We should, at the very least, check Develop and Documentation
23:21:10 <quaid> you know, it shouldn't happen
23:23:31 <dneary> They look identical
23:23:54 <dneary> When we set the wiki writable, I have 2-3 TODO tasks before we go live
23:24:04 <dneary> But nothing major
23:24:16 <dneary> But I will copy the Download page over
23:24:29 <dneary> (it's freaking me out though)
23:24:34 <dneary> jbrooks, Good catch
23:25:32 <dneary> quaid, Do you have any opposition to me resetting the new wiki r/w?
23:25:37 <quaid> go ahead
23:25:40 <dneary> Before the DNS switch gets made?
23:25:42 <quaid> I'd rather move forward and fix this way
23:25:53 <quaid> sure, it let's us start tweaking
23:26:00 <quaid> while still able to easily see the as-was state
23:26:12 <quaid> dneary: do you want the db now or another time?
23:26:47 <dneary> Another time
23:27:32 <quaid> kk
23:30:09 <dneary> quaid, Did you get a chance to read the [[Community guidelines]]?
23:30:17 <dneary> quaid, Main page changed to Home
23:30:38 <dneary> #info Main page has been changed to Home, and Download page has been synced with old wiki
23:30:59 <dneary> #info removing old TODOs from Documentation page
23:32:13 <quaid> dneary: no, I'm not familiar with that one - what's the question?
23:34:30 <quaid> dneary: at the least, the wiki page naming guidelines contradict what is/was in [[Help]]
23:34:38 <quaid> dneary: I presume these are adapted from somewhere etc.?
23:35:08 <quaid> ah, there's the adaption
23:35:16 <dneary> Yes
23:35:27 <dneary> The page naming guidelines contradict Help?
23:35:27 <quaid> dneary: I would think we'd want to have these guidelines ratified in some way by the Board and/or all project maintainers?
23:35:41 <dneary> In what way?
23:35:47 <quaid> yeah, we shouldn't really be using fakey-nesting e.g. [[Feature/Feature detail]]
23:36:01 <quaid> we should be using [[Category:Feature]] and [[Feature detail]]
23:36:40 <quaid> http://wiki-ovirt.rhcloud.com/Help:Wiki_structure
23:37:05 <quaid> it's some long-standing gardening, to rename a ton of pages
23:37:27 <quaid> anyway, point more is - guidelines like these should be ratified, maybe mark them as "Proposed" until then?
23:37:36 <quaid> that will give us a chance to sort out the differences
23:53:23 <dneary> quaid, That's just documenting practice at this point
23:53:28 <dneary> Have you seen Feature/?
23:54:14 <dneary> It really seemed like a big gap not having guidelines - especially with the copy that Garrett proposed. And I don't think there's anything too controversial there?
23:56:18 <dneary> Removed the potentially controversial "enforcement" section
23:56:44 <dneary> I'll post a thread asking for feedback on the guidelines next week
23:57:00 <dneary> quaid, Are we good to go for a DNS change? I think I'm OK.
23:57:33 <dneary> quaid, Do you want to do an /etc/host check first? mysql GRANTs could be affected, perhaps?
23:58:55 <quaid> hmm
23:59:11 <quaid> we can't expect things to act correctly until two conditions are met
23:59:27 <quaid> * openshift thinks it's www.ovirt.org instead of wiki-ovirt.rhcloud.com
23:59:38 <quaid> * localsettings thinks the same thing
00:00:17 <quaid> dneary: no worries, let's just ACK that we need ACK from others before we really start "enforcing", and give us a chance to fix minor discrepencies
00:02:21 <dneary> quaid, When we change LocalSettings, that will break the wiki until we've configured OpenShift
00:03:13 <dneary> quaid, It makes sense to do the LocalSettings change first, I think (but I couldn't explain why, beying "it's a hunch"
00:03:32 <dneary> It's 1am here, and I really want to go to bed...
00:03:37 <quaid> gotcha
00:03:43 <quaid> let's do the switch and clean-up from there
00:04:10 <dneary> So - LocalSettings first? Will I go ahead?
00:04:18 <quaid> sure
00:04:39 <dneary> Do you use ovirt.org or www.ovirt.org?
00:05:13 <dneary> Did you do the resources subdomain? I haven't added the redirects yet
00:06:39 <quaid> ovirt.org is going to redirect to www.ovirt.org
00:06:42 <quaid> so say www.ovirt.org
00:08:56 <quaid> ok, resources.ovirt.org is going to go in with the change
00:08:58 <quaid> *whew*
00:09:06 <quaid> thanks for the poke, I forgot to ask SOC to add that
00:11:48 <dneary> OK - ready to push & restart the gear
00:11:57 <dneary> Let me know if you need me to wait...
00:11:59 <quaid> go for it
00:12:07 <quaid> I'm ready to change the openshift side
00:12:10 <quaid> working on httpd stuff
00:12:24 <dneary> Hope I didn't forget a pull in between...
00:12:34 <quaid> resources.ovirt.org is ready to go
00:12:42 <quaid> so we can do the redirects
00:12:42 <dneary> All done
00:12:53 <dneary> It went with that push
00:13:04 <quaid> great
00:13:18 <quaid> did you use resources.ovirt.org for /meeting etc.?
00:13:21 <dneary> What's the /tl tree?
00:13:25 <dneary> Yes
00:13:41 <quaid> the /tl tree is a timeline app that Heiko worked on
00:13:59 <quaid> it lets you pull in iCal and show on a timeline, basically
00:14:03 <quaid> actually, other RSS feeds, too
00:14:13 <quaid> I didn't bother to pull it over because it's not used
00:14:17 <quaid> the /stats I'm using, though
00:14:44 <dneary> You don't think the DB user access will be an issue, if we're coming from a different host?
00:15:17 <dneary> OK, DNS changes pushed
00:16:35 <quaid> I presume openshift does the db user access magic on the  backend?
00:17:06 <quaid> from the Ops side, the simplification of PaaS is almost mind-bending - you can't be sure what is abstracted, etc.
00:17:49 <quaid> #info vhost for resources.ovirt.org in place and httpd HUP'd
00:18:07 <quaid> #info DNS change pushed
00:28:39 <quaid> #info this is the contents of /etc/httpd/conf.d/ovirt.org.conf :
00:28:41 <quaid> http://fpaste.org/YR4M/
00:28:45 <quaid> does that seem sane?
00:28:51 <quaid> jbrooks: dneary RobertM ^^^^
00:29:06 <quaid> linode01 is A for ovirt.org
00:29:17 <quaid> so it receives ovirt.org and redirects to www.ovirt.org
00:29:23 <quaid> which is really wiki-ovirt.rhcloud.com
00:29:44 <quaid> dneary: HOT DIGGITY
00:29:52 <dneary> quaid, I can't be sure. Is the RedirectMatch really necessary?
00:29:53 <quaid> I see it working fine, plain DNS
00:30:08 <quaid> dneary: I'm not sure if RedirectMatch is the right way, maybe Cond, Rule
00:30:25 <dneary> quaid, Let's check with ovirt.org and www.ovirt.org
00:30:28 <dneary> to be sure
00:30:40 <dneary> And then I'm going to protect all the 1st level pages
00:30:44 <dneary> And then I'm going to bed
00:30:46 <quaid> kk
00:30:48 <quaid> roger that!
00:30:53 <quaid> and I'll keep doing whatever is left
00:31:00 <quaid> and you can wake up tomorrow a happier man
00:31:15 <quaid> dneary: I see login/create account in footer when not logged in
00:31:26 <dneary> quaid, Let me log out & check
00:31:36 <quaid> dneary: and it disappears when logged in
00:31:42 <quaid> that's by design iirc
00:31:54 <dneary> I see ovirt.org still pointing at linode01.ovirt.org
00:32:03 <dneary> www.ovirt.org looks fine
00:32:14 <dneary> But this could all be because of my local DNS caching
00:32:25 <dneary> caching ruins the world in times of change
00:32:46 <quaid> right
00:34:04 <quaid> #info new resources domain is working:
00:34:06 <quaid> http://resources.ovirt.org/meetings/
00:34:16 <dneary> KO - all protected
00:34:19 <quaid> http://resources.ovirt.org/releases
00:34:22 <quaid> sweet
00:34:36 <dneary> quaid, Could you update the bot also for RecentChanges, please?
00:35:00 <dneary> quaid, Did you go to www.ovirt.org/releases?
00:35:38 <quaid> dneary: next {lager,stout,vodka} on me, your attention to detail and covering all the facing content and htaccess and everything was super-appreciated
00:35:47 <quaid> I did, looks good here except for a darn //
00:36:11 <dneary> Yeah,
00:36:12 <sgordon_> looks good guys
00:36:14 <dneary> spotted it
00:36:23 <dneary> I've fixed .htaccess
00:36:31 <quaid> it's fixed now, too, I think
00:36:33 <quaid> wow
00:36:33 <dneary> Want me to push & reboot?
00:36:40 <quaid> yes
00:37:14 <dneary> Coming...
00:37:31 * quaid sees ovirt.org/releases working, too
00:37:33 <dneary> Better now?
00:37:44 <quaid> s
00:37:45 <quaid> yes
00:37:45 <sgordon_> is http://resources.ovirt.org/stats/lists.ovirt.org.conf.txt still meant to be there?
00:38:11 <dneary> quaid, Unfortunately my attention to detail did not stretch as far as a couple of big details, resulting in a last-minute push from Garrett
00:38:14 <quaid> heh, wow, what's that from?
00:38:38 <quaid> dneary: I know, and I felt bad there too - I didn't think about the extensions and testing them, etc. which we could have done
00:38:59 <dneary> quaid, Might be a good idea to turn off Directory for linode1?
00:39:09 <quaid> hmm
00:39:17 <quaid> don't we need that in some cases?
00:39:25 <quaid> e.g. /meetings it's very useful
00:39:29 <quaid> we can tweak that
00:39:33 <dneary> quaid, I must admit it was frustrating not being able to do all I needed to do to get up & running. Adding youtube & RSS etc in the last 3 days has been intense
00:40:19 <quaid> sgordon_: I must have put that there for someone to look at, that's an old file, I'll ju\st remove it
00:40:24 <dneary> quaid, We should have had more sync meetings - we weren't all on the same page & aware of what was blocking (or a priority for) others. Lesson for the future.
00:40:31 <quaid> yep
00:40:50 <dneary> Anyway, night
00:40:55 <dneary> Tomorrow, I sleep in
00:41:02 <quaid> dneary: right, we could have found a way to add and test the extensions, etc. in advance - I completely forgot we had new extensions to consider, I didn't absorb that in my thinking from the new design
00:41:07 <quaid> good night
00:41:07 <quaid> yeah, I hear that
00:41:49 <quaid> last night I had to pull an IV at midnight, then 10 min later my youngest daughter started throwing up for throughout-the-night
00:42:09 <quaid> I needed that sleep-in this morning, but it sure put me back for this an hour or two
00:42:29 <dneary> My only fear is that we chose poorly & have given ourselves a security headache now :-)
00:42:56 <dneary> I'm going to have a look week after next at ConfirmAccounts to see why we're not getting our notifications
00:43:02 <quaid> dneary: I'm going to tell people the wiki is back up ... soon ... I'll poke arond a bit and be sure DNS is happily propagated by shelling in to some non-redhat.com boxes
00:43:11 <dneary> cool
00:43:12 <quaid> oh, you know, sheesh
00:43:17 <quaid> are we running your code?
00:43:21 <quaid> I have a bad feeling we aren't
00:43:40 <quaid> I'll create a ticket right now to look at it, maybe get it fixed before your travel is done :)
00:43:40 <dneary> not yet
00:43:46 <dneary> it's not a big patch
00:43:56 <dneary> And the last revision was not up to scratch
00:44:09 <dneary> It'll be an excuse to finally get it accepted upstream :)
00:44:24 <quaid> word
00:44:40 <quaid> ok, I'll stop talking now so you'll stop replying
01:31:56 <jbrooks> quaid, I'm checking out some ovirt links from google
01:32:36 <jbrooks> the events link leads to http://www.ovirt.org/News/ when it should lead to http://www.ovirt.org/News
01:33:03 <jbrooks> same with community
01:33:19 <quaid> hmm
01:33:23 <quaid> meaning, something we can fix?
01:33:28 <jbrooks> we need to lose that trailing /
01:33:37 <jbrooks> I imagine we can fix it
01:33:38 <quaid> or we need to make [[News/]] redirect to [[News]]?
01:33:45 <jbrooks> that'd work too
01:33:53 <jbrooks> I figure
01:33:58 <quaid> ok, so it's an http redirect, let me look
01:34:10 <jbrooks> http://www.ovirt.org/Category:Collateral/
01:34:37 <jbrooks> It seems that whatever redirect we're doing is appending that slash
01:34:39 <quaid> ewww, I didn't know dneary was doing fakey-nesting all over the place
01:35:12 <quaid> I wonder if we should be doing a duplicate rule for /foo new/foo & /foo/ /new/foo
01:35:45 <quaid> let me try a test with /News
01:37:39 <jbrooks> every redirect seems to have this: http://www.ovirt.org/2012/08/08/ovirt-3-1-release/
01:38:07 <jbrooks> ah, pushing?
01:38:31 <quaid> rightes
01:38:32 <quaid> yes
01:38:35 <quaid> one sec, sorry
01:38:47 <quaid> woah
01:39:39 <quaid> ok, my fix didn't work either
01:39:42 * quaid reverts
01:40:21 <jbrooks> https://www.google.com/search?q=ovirt+site:ovirt.org
01:40:47 <quaid> oh my
01:40:48 <jbrooks> All the WP links seem to have slashes appended
01:41:08 <jbrooks> And mw is redirecting right, but keeping the slashes
01:41:10 <quaid> do you have access to the openshift repo? did you send me a pubkey?
01:41:22 <jbrooks> I didn't but I can
01:41:33 <quaid> go ahead, then you can see and fix the .htaccess directly
01:41:40 <quaid> (if you're game :) )
01:41:56 <jbrooks> Ok, actually, I sent you a key a while back for the ovirt server
01:42:08 <quaid> you know, I do have that, I can use that, one sec
01:43:00 <quaid> why is that dated pathway getting redirected to as an article?
01:43:11 <quaid> oh, that's a wordpress article, yeek!
01:43:37 <jbrooks> But it's redirecting right -- I'd made a list of all the links on the wp site
01:43:46 <jbrooks> and I think dave hooked up the redirectage
01:44:05 <jbrooks> that trailing slash just needs to be trimmed
01:44:52 <quaid> ic
01:47:46 <quaid> right, forgot I have to use the webui to add an sshkey
01:47:52 <quaid> couldn't get the cli to work before
01:48:39 <quaid> jbrooks: your key is added
01:48:42 <quaid> ssh://847edb45aea84198838f915be6faa066@wiki-ovirt.rhcloud.com/~/git/wiki.git/
01:48:52 <jbrooks> quaid, thanks, cloning
02:08:18 <digisign> good nite hat-droids. looks like quite a shift to the Shift. plis keep an eye for nov28th nightly as its the One that seems to work fine. at least for me. all the best.
02:24:30 <jbrooks> quaid, ok, it appears that all the wp links actually ended in /
02:24:33 <jbrooks> like http://www.ovirt.org/2012/08/08/ovirt-3-1-release/
02:25:14 <jbrooks> dave didn't specify the / in the redirects, though -- I just added the / for that 3.1 release one, and it worked
02:25:52 <jbrooks> So I figure I'll do that for all the WP redirects...
02:27:06 <jbrooks> Hmm, or add a * to all of them maybe, in case some people have the links w/o the trailing slash
02:37:53 <quaid> jbrooks: ah, ok
02:38:18 * quaid back from helping with algebra
02:38:42 <jbrooks> So what works for both with and w/o the slash is changing Redirect 301 to RedirectMatch 301 and appending .* to the end of the old link
02:39:10 <jbrooks> I just did it for one, http://www.ovirt.org/2012/08/08/ovirt-3-1-release/, I can do the rest a bit later, or you can -- my wife's currently yelling at me to get to the table :)
02:39:11 <quaid> ah, ok
02:39:15 <quaid> word
02:39:24 <quaid> I'll pull and fix all of them, I think
03:11:50 <quaid> pushiing the fix
03:12:12 <quaid> whoops, merge conflict, fixing
03:20:30 <quaid> jbrooks: things that used to be /wiki/Foo are coming through as /Wiki/Foo
03:21:02 <jbrooks> hmm
03:21:26 <jbrooks> like what?
03:22:52 <quaid> one sec, I am getting inconsistent results in Chromium, probably caching
03:23:29 <quaid> wiki.ovirt.org/wiki/OVirt_3.1_release_notes
03:23:38 <quaid> ends up at http://www.ovirt.org/Wiki/OVirt_3.1_release_notes
03:24:59 <jbrooks> Ok, and that's not from our last change, right?
03:27:01 <quaid> sheesh, I dunno, sorry
03:27:20 <quaid> well, maybe it is ...
03:27:32 * quaid tried to think and thought he'd tested /wiki URL's before
03:27:45 <quaid> I had to do a merge of .htaccess but I don't think I lost anything
03:28:54 <quaid> huh, should we have a rule that calls out /wiki
03:31:10 <quaid> why are the permanent redirects ... _after_ the blocks with [L]
03:33:58 <quaid> jbrooks: can you diff against HEAD?
03:34:04 <quaid> I might have lost something
03:34:22 <jbrooks> I don't know how to do it
03:34:40 <quaid> I'm not seeing your commits to .htaccess in 'git log'
03:35:17 <quaid> git diff php/.htaccess
03:35:48 <jbrooks> doesn't show anything
03:35:59 <jbrooks> I pulled already
03:36:13 <quaid> weird
03:36:14 <jbrooks> What's the last change you see in git log befre your last
03:36:25 <jbrooks> I do see mine in git log
03:36:42 <quaid> woah, I don't see one for you at all
03:37:48 <quaid> you can do 'git diff 9d9e11a4d54f4dbe011853aff4e46b290ad0f8fd (your string)'
03:37:57 <quaid> that is my latest
03:38:13 <jbrooks> and my string is one of my changes?
03:39:44 <jbrooks> Ok, that works
03:39:56 <jbrooks> But the changes are all what I'd expect
03:41:26 <jbrooks> quaid, try this: http://en.wikipedia.org/wiki/foo
03:41:50 <jbrooks> mw appears to do that automatically
03:42:08 <jbrooks> oh., hmm
03:42:29 <jbrooks> maybe this has something to do with getting rid of the /wiki
03:45:02 <jbrooks> It seems to want to capitalize the first url element after the root of the site
03:45:40 <jbrooks> what's the mechanism that gets rid of the /wiki root?
03:54:52 <jbrooks> quaid, unless this is being dealt with elsewhere, I don't see why we'd expect the /wiki links to work
03:54:58 <jbrooks> There's nothing to redirect them
03:56:42 <jbrooks> We need something to strip out any /wiki/[rest of link] elements, replaced with /[rest of link]
03:56:49 <quaid> it used to work
03:56:56 <jbrooks> hmm
03:57:04 <jbrooks> Before we made these last changes?
03:57:15 <quaid> darn, I thought so
03:57:16 <jbrooks> We can easily enough roll them back
03:57:30 <jbrooks> But I don't see anything in the .htaccess file that'd make them work
03:57:33 <quaid> well, the fix you suggested worked for everything else
03:57:47 <quaid> I thought the third stanza caught anything after / and sent it to index.php
03:58:13 <quaid> but should we have a matching one that catches ....
03:58:15 <quaid> like this:
03:58:18 <jbrooks> so it'd just go to home?
03:58:27 <quaid> RewriteRule ^(wiki.*)$ %{DOCUMENT_ROOT}/index.php [L]
03:58:28 <quaid> ?
03:58:32 * quaid doesn't think that is right
03:58:56 <quaid> no, it's supposed to take it and feed it to index.php which then outputs the [Article name]]
03:58:57 <jbrooks> but it's not the wiki. part
03:59:01 <jbrooks> it's the /wiki part
03:59:17 <jbrooks> or
03:59:29 <jbrooks> hmm
04:00:16 <quaid> RedirectMatch ^/wiki/(.*) %{DOCUMENT_ROOT}/index.php [L]
04:00:17 <quaid> ?
04:00:53 * quaid puts on the Latryx radio to drown out the rom-com that is driving him nuts
04:01:35 <jbrooks> http://www.mediawiki.org/wiki/Manual:Short_URL/Apache
04:01:36 <quaid> jbrooks: I'm confused as to why I'm not seeing your commit in my git log, but ... should one of us test out that idea?
04:01:49 * quaid knows that page well
04:02:12 <jbrooks> quaid, maybe you pushed before pulling my changes
04:02:16 <quaid> yes
04:02:22 <jbrooks> but we should test that
04:02:22 <quaid> I thought I had them, thought I had pulled
04:02:38 <quaid> in fact, I did have some changes from you, but must have missed a second changeset
04:02:55 <quaid> ah, that's the RewriteRule I was looking for
04:02:56 <jbrooks> all my changes were to that one line
04:03:01 <quaid> huh
04:03:06 <quaid> I had that, dunno why I broke
04:03:23 <quaid> ok, who tries?
04:03:40 <quaid> RewriteRule ^/?wiki(/.*)?$ %{DOCUMENT_ROOT}/index.php [L]
04:03:46 <quaid> note the s/\/w//
04:04:05 <jbrooks> yeah, I can -- so is this in addition to what's there now?
04:04:10 <jbrooks> or instead
04:04:15 <quaid> addition?
04:04:29 <quaid> I see the other one is used to redirect /
04:04:56 * quaid thinks he'll see jbrooks changes if jbrooks does the next push that he can pull from
04:05:00 <quaid> the past changes, I mean
04:05:01 <jbrooks> Ok, I'll try it -- put it right after the one that's there now?
04:05:13 <quaid> problem is
04:05:28 <quaid> that rule there is not for /
04:05:32 <quaid> it's for everything and it should work
04:05:36 <quaid> and it has [L]
04:05:50 * quaid parsing the regexp incorrectly possibly?
04:06:38 <jbrooks> maybe another redirectmatch
04:07:05 <jbrooks> RedirectMatch 301 ^/wiki/(.*)$ /$1
04:07:20 <quaid> actually yea
04:07:28 <jbrooks> I'm trying it
04:07:38 <quaid> because the first one does catch things coming in with /wiki not there
04:07:53 <quaid> but it's the one sending "wiki/Foo" to the MW engine
04:08:00 <quaid> (which makes Wiki/Foo)
04:08:13 <quaid> I think the rule might need to be before, we'll see
04:10:02 <jbrooks> quaid, appears to work...
04:10:28 <quaid> seems to work here too
04:10:28 <quaid> nice
04:10:29 <jbrooks> www.ovirt.org/wiki/Quantum_and_oVirt
04:10:41 <jbrooks> high five dude
04:10:46 * quaid ^5s jbrooks
04:11:02 <jbrooks> yea, I forgot that syntax :)
04:11:08 <quaid> got it from lh
04:11:31 * quaid sees a missing ASL logo
04:11:35 <jbrooks> yep
04:11:41 <jbrooks> That was missing on the old site, too
04:11:55 <quaid> we need to populate the About page, that content isn't there
04:13:40 <quaid> I suppose I should setup oldwiki and oldwww on reousrces.o.org
04:16:28 <jbrooks> quaid, can you access ovirt.org right now?
04:19:14 <quaid> via ssh?
04:19:20 <quaid> yes, linode01.ovirt.org works
04:19:22 <quaid> I'm already shelled in
04:20:10 <jbrooks> No, the wiki -- it's not responding for me right now
04:20:58 <jbrooks> it's really slow
04:21:19 <quaid> huh
04:21:28 <quaid> the new wiki?
04:21:42 * quaid pokes
04:22:12 <quaid> probably something across OpenShift - I see stuff, but it's a bit wonky in response
04:24:35 <jbrooks> yeah, same here
04:30:18 <jbrooks> quaid, aight, I sent a msg to Dave telling him about the changes
04:30:36 <jbrooks> I'm going to go play video games or something ;)
04:35:26 <quaid> good
04:35:35 <quaid> I'll send updating emails and stuff
04:35:42 <quaid> and work on oldwiki and oldwww
04:42:21 <quaid> ooh, this is going to be a challenge
04:42:31 <quaid> wordpress doesn't like to respond outside of it's favorite fqdn
06:21:09 <quaid> I just realized, ovirtbot relies upon running on the same host as the wiki
07:50:37 <quaid> #endmeeting