15:00:17 <quaid> #startmeeting oVirt Infra weekly
15:00:17 <ovirtbot> Meeting started Mon Nov 26 15:00:17 2012 UTC. The chair is quaid. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:17 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:19 <adrian15> dneary: Thank you. I have a support question I'll ask it in an hour or so then. Thank you.
15:00:25 <quaid> #chair dneary
15:00:25 <ovirtbot> Current chairs: dneary quaid
15:00:34 <dneary> adrian15, Ask away
15:00:46 <dneary> adrian15, Some people may be able to help you
15:00:47 * eedri here
15:01:09 * garrett_ is here
15:02:24 <quaid> #topic Agenda
15:02:43 <quaid> ''Agenda''
15:02:43 <quaid> * MediaWiki & www
15:02:43 <quaid> * MediaWiki backup script
15:02:43 <quaid> * Hosting
15:02:43 <quaid> * Trac review
15:02:45 <quaid> * Puppet
15:02:48 <quaid> * Jenkins
15:02:50 <quaid> * Gerrit
15:02:53 <quaid> * Other business?
15:02:55 <quaid> Anything to add to that agenda?
15:03:13 <eedri> process of adding new admins to infra?
15:03:21 <quaid> ok
15:03:24 <eedri> i want to introduce a new candidate
15:04:08 <quaid> ok, let's move on then
15:04:16 <quaid> #topic MediaWiki & www
15:05:03 * sgordon is belatedly here
15:05:04 <quaid> #info Remaining problem of a mod_rewrite rule to get the logo visible
15:05:19 <quaid> does anybody know mod_rewrite enough to help me troubleshoot this?
15:05:36 <dcaro> I have some knowledge, I can try
15:06:19 <quaid> dcaro: great, thanks can I show you what's up right after the meeting?
15:07:39 <quaid> dcaro: actually, here it is:
15:07:42 <quaid> http://fpaste.org/NEgP/
15:07:44 <quaid> that's the .htaccess
15:07:55 <garrett_> quaid: (it does work on my instance too fwiw, so we can get it working somehow)
15:08:04 <quaid> and the problem is this:
15:08:06 <quaid> http://wiki-ovirt.rhcloud.com/skins/common/images/oVirt-logo.png
15:08:34 <quaid> that gets read as an article, so the s/skins/Skins/ is changed (and then not found)
15:08:44 <quaid> garrett_: right, thanks for reminding of that :)
15:08:52 <garrett_> quaid: it might be in the LocalSettings.php file too
15:09:06 <garrett_> not sure if Apache or MW handles that
15:09:10 <garrett_> (for the logo)
15:09:38 <quaid> Apache should be finding it as a file
15:11:10 <quaid> that's all I know of that is not working
15:11:20 <quaid> ... but I haven't gone looking through every page for images, etc. :)
15:11:20 <ovirtbot> quaid: Error: ".." is not a valid command.
15:11:27 <quaid> I'll look again later, use the fresh perspective thin
15:11:36 <quaid> whoops, mis-paste on ^^^^^
15:12:57 <quaid> #info process to transfer sites should take 45 to 90 minutes
15:13:18 <quaid> #action quaid to arrange DNS cutover timing based on the idea that we'll have this working within 2 days
15:13:37 <quaid> anything more on this topic?
15:13:57 <quaid> we can work on fixing it here in channel after the meeting/as the day progresses
15:14:18 <dneary> quaid, I'm thinking those duplicate RewriteConds are redundant...
15:14:28 <dneary> quaid, Let me dig around, make a suggestion
15:15:28 <quaid> dneary: I added the fourth rule block
15:15:41 <quaid> the first three are what garrett_ passed over that should work
15:15:43 <dcaro> quaid, dneary:I think that the first one should be the last...
15:16:12 <dneary> dcaro, Yes, I think that's the issue
15:16:44 <dneary> quaid, Apache's processing the rewrite rules from top to bottom, and MediaWiki is taking care of all URLs since the redirect to index.php gets added first
15:17:21 <quaid> anyone know of any pages that have images on them to see if the regular images are showing up?
15:18:07 <quaid> dneary: dcaro ah but ...
15:18:24 <quaid> I thought that the first two rule conditions say, "if it's not already a folder or file, then redirect to index.php"
15:18:30 <quaid> and that image is a file in a folder
15:18:44 <quaid> the rule there works for e.g. robots.txt
15:19:01 <quaid> ok, sorry, I don't want to get caught up here in fixing this
15:19:02 <quaid> we
15:19:21 <quaid> don't stop if you want to keep looking, but I'll move the agenda along now
15:19:31 <dneary> quaid, Yes, you're right, I think
15:19:41 <dneary> So the same rules are not applying to skins/...
15:19:45 <quaid> #info need to make sure wiki images are showing up in pages
15:19:53 <dneary> (also preceded with -f -d
15:19:56 <quaid> #topic MediaWiki backup script
15:20:32 <quaid> #info I forgot to remove this topic but I think we're covered with this because we'll need a new backup procedure for the new OpenShift based tool
15:20:48 <quaid> #info of course if I write that script it may have the same problem, so I'll be coming back later for help on that :)
15:20:56 <quaid> #topic Hosting
15:21:23 <quaid> #info My Red Hat IT contact told me last week he is provisioning two servers at RackSpace for us, bare metal to use as we wish
15:21:44 <quaid> #info RackSpace servers should be available this week or next, depending on how fast the paper churns
15:23:24 <dneary> quaid, The back-up script, as annoying as a daily email is, is low priority
15:23:28 <quaid> #info We're also proceeding with plans for Alter Way work, and may start installing & such but not switchover data until paper churns there
15:23:34 <dneary> We should just let people know that on the list
15:23:44 <quaid> oh, ok
15:23:56 <quaid> is the problem the broken part or the daily email?
15:24:08 <dneary> quaid, re Alter Way, it remains to be seen if we'll need paper at all :-)
15:24:15 <dneary> quaid, The daily email
15:24:19 <quaid> I'd considered having it send "I'm done" email, but maybe it could just trigger the logwatch email instead
15:24:30 <dneary> quaid, Ppl are asking just to have the email stopped
15:24:47 <quaid> I seem not to have seen this thread, I'll look and reply
15:24:54 <dneary> Personally I don't care that much. One email more or less very day...
15:25:06 <quaid> #action quaid to tell people status of 'broken' script & to please hang on
15:25:23 <quaid> ok, moving along ..
15:25:30 <dneary> quaid, It's come up several times - typically when someone replies to the "mediawiki backup script" error messages
15:25:33 <quaid> dneary: if you are done with hosting?
15:25:37 <dneary> Done
15:25:51 <dneary> No news to report beyond mailing list & last week's meetings
15:27:01 <quaid> word
15:27:15 <quaid> #topic Trac review
15:27:43 <quaid> #info I'm moving this topic to the end of the meeting, as it's a bit of administrivia that we don't need to do in the middle - often it's covered by other open items anyway, so putting it at the end will make it faster
15:27:55 <quaid> #action quaid to move this topic to the end of the agenda permanently
15:27:58 <quaid> make sense?
15:28:03 <eedri> +1
15:28:20 <quaid> cool
15:28:30 <quaid> #topic Puppet
15:28:42 <quaid> if ewoud isn't available, I can update on this one
15:30:45 <quaid> #info ewoud has a proof of concept (POC) Foreman install running:
15:30:57 <quaid> https://foreman.ekohl.nl
15:31:25 <quaid> #info ewoud is working on the initial Puppet manifests
15:31:51 <quaid> hmm, I forget who else volunteered to help learn & write those? was that dneary ?
15:32:04 <dneary> quaid, I did
15:32:10 <dneary> Haven't had any time for that this week
15:32:57 <dcaro> I can help too, I have some experience with foreman-puppet
15:33:39 <quaid> no worries
15:33:44 <quaid> dcaro: +1
15:34:02 <eedri> i can say dcaro has experience in jenkins,puppet,foreman
15:34:06 <quaid> #action quaid, dcaro, dneary will help ewoud with Puppet manifests
15:34:19 <eedri> he's part of the team that manage those services in rhevm
15:34:28 <eedri> so +1
15:34:51 <quaid> #info Puppet manifest discussion to happen on infra@ovirt.org ASAP
15:34:54 <quaid> great
15:35:06 <dcaro> yep :), proud of it
15:35:40 <quaid> dcaro: we have two new hosting situations starting with 2 servers at each facility, and we're going to do all the provisioning for them using Foreman/Puppet - so nothing in the new infrastructure is hand-built :)
15:36:00 <quaid> we can discuss the rest of the details on list - what is going to be where, etc.
15:36:20 <dcaro> sure
15:36:26 <eedri> dcaro, current evironemnt mainly consists of amazon ec2 vms
15:36:36 <eedri> dcaro, running all our services (gerrit/jenkins/wiki/etc..)
15:36:39 <quaid> & linode01 :)
15:36:43 <eedri> yap..
15:36:48 <eedri> the kitchen sink
15:36:53 <quaid> wiki is on linode (with mailman) = the kitchen sink :)
15:37:06 <quaid> rest is on EC2
15:37:24 <quaid> but soon - all KVM, all the time!
15:38:06 * quaid ready to move on?
15:38:33 <eedri> yes
15:38:57 <dcaro> yes
15:39:54 <quaid> #topic Jenkins
15:40:36 <eedri> jenkins.ovirt.org was upgraded during the weekend to latest LTS version
15:40:50 <eedri> this was important due to latest security issues
15:41:06 <quaid> #info jenkins.ovirt.org updated to latest for security fix
15:41:14 <quaid> eedri++
15:41:36 <eedri> also, we have some new power users
15:41:58 <eedri> recently we started delegating powerusers to handle specific jobs on jenkins.ovirt.org
15:42:30 <eedri> this reduce load on the infra team and gives an oppertunity to users with experience and will to enhance ovirt sub projects in jenkins
15:43:04 <eedri> #action we should consider using openid auth in new jenkins server
15:43:18 <quaid> #info we've been adding new power users, who offest the load on the Infra tream by enabling people with experience to enhance sub projects in Jenkins
15:43:28 * ewoud here now
15:43:38 <ewoud> sorry, meeting ran a bit late
15:43:40 <quaid> #idea we should consider using openid auth in new Jenkins server
15:43:57 <quaid> eedri: do you want to work on that idea/proposal/activity?
15:44:00 * Rydekull is on a train right now, and about to change to a bus, so he'll be cut off, but wonders if there is something that the infra team needs help with
15:44:23 <quaid> ewoud: no worries, look back on what we wrote above, we can go back to PUppet after this if you have more to add
15:44:39 <eedri> quaid, yes, we'll test it once the new server is ready
15:44:46 <eedri> quaid, shouldn't be too complicated
15:45:15 <quaid> Rydekull: definitely, we can use help across the board - we'll be talking about how to bring in new people in a few minutes, but if you want to come chat with me here later when you're back connected, I can fill you in
15:45:32 <quaid> #action eedri will work on OpenID for Jenkins
15:45:45 <quaid> eedri: sounds like a great idea
15:45:58 <eedri> quaid, i asked theforeman guys, the don't support it yet
15:46:11 <quaid> I wonder if OpenID can be used with MediaWiki - it will still want to associate with a user account, but maybe it can create and keep the association or something
15:46:13 <eedri> quaid, but they promised that if we open a feature request, they will :)
15:46:30 <quaid> #action oVirt Infra to make a Foreman feature request to have OpenID
15:46:39 <quaid> #action quaid to look in to MediaWiki and OpenID
15:46:51 <quaid> anything more on Jenkins?
15:47:00 <quaid> ewoud: do you want to return to Puppet/Foreman for a few minutes?
15:47:11 <ewoud> quaid: please
15:47:12 <eedri> ewoud, +1
15:48:26 <eedri> btw, new jenkins will have both fedora 17 & 18 slaves?
15:48:27 <ewoud> change the topic for the minutes?
15:48:47 <quaid> #topic Puppet/Foreman
15:49:03 <ewoud> so last weekend I set up a PoC foreman instance on http://foreman.ekohl.nl
15:49:27 <ewoud> I've been keeping some documentation on https://github.com/ekohl/foreman-howto so it should be easy to reproduce
15:49:40 <ohadlevy> ewoud: but i dont have permissions to play with your instance ;)
15:50:00 <ewoud> ohadlevy: I can make an account
15:50:18 <ohadlevy> ewoud: lol, I got enough foreman instances ;)
15:50:20 <ewoud> so can eedri
15:50:22 <ewoud> ohadlevy: :)
15:50:49 <ewoud> I've also written some puppet classes for my jenkins slave which are available on https://github.com/ekohl/ovirt-infra-puppet
15:51:30 <ewoud> I'm currently working on making it easy to install new hosts so you can place with the provisioning, but haven't had time to finish that
15:52:09 <ewoud> sadly there's no foreman - ganeti integration, so there has to be some manual work
15:52:18 <ewoud> but it's a PoC ;)
15:52:37 <ohadlevy> eedri: well,, patches are welcomed, I'm sure fog users would appreciate it
15:53:04 <ewoud> ohadlevy: I should learn ruby, but first I'm going to focus on the foreman-installer patches
15:53:50 <quaid> ewoud: did you see above that dcaro has experience with Foreman & Puppet and is interesting in helping, and dneary and I don't have experience and will be learning-while-helping? :)
15:54:23 <ewoud> quaid: yes
15:54:26 <quaid> great
15:54:47 <quaid> ok, anything more on foreman/puppet?
15:54:50 <ewoud> but now we have machines coming we can focus on what we want to automate
15:55:15 <ewoud> we've already said jenkins and gerrit I think
15:55:40 <ewoud> maybe try to work those out? also a bit of base system such as how do we manage accounts
15:56:22 <ewoud> those are things you can also think about without puppet knowledge :)
15:56:41 <eedri> quaid, we're going to have seperate git repos?
15:56:49 <eedri> quaid, one for puppet and one for forman?
15:57:16 <quaid> I think ewoud said yes?
15:57:41 <ewoud> not sure what you want in the foreman repo
15:58:30 <eedri> ewoud, if we're using the rpms, then i guess we don't need
15:58:50 <ewoud> I'm strongly in favor of RPMs
15:59:00 <eedri> ewoud, i agree
15:59:03 <quaid> ok, I want to see if we can hit the last topics without going much over an hour
15:59:08 <eedri> ewoud, as long as foreman supports upgrades
15:59:30 <quaid> #agreed it's better to package scripts and stuff in RPMs than to have a git repo for scripts < Foreman
15:59:34 <quaid> is that a correct agreed?
16:00:12 <eedri> quaid, it's better to say that using foreman rpms deployments is better than using the foreman git repo
16:00:22 <ewoud> yes, and any system specific script we can deploy using puppet with files/templates if needed
16:00:29 <karimb> when you runonce a VM with certain parameters and reboot, i noticed that VM still uses those given parameters...isnt that a bug...?
16:00:51 <ewoud> karimb: the run means run in terms of the KVM process living
16:01:14 <ewoud> karimb: so a guest reboot doens't count because KVM stays alive, you really need to shut down and boot again to lose run once
16:01:29 <quaid> #undo
16:01:29 <ovirtbot> Removing item from minutes: <MeetBot.items.Agreed object at 0x8dc1cec>
16:01:30 <dcaro> eedri, ewoud, quaid: I agree, rpms better than repos
16:01:30 <karimb> ewoud, so is there a way to prevent this behaviour?
16:01:53 <quaid> #agreed using foreman rpms deployments is better than using the foreman git repo
16:01:59 <karimb> ewoud, cos it makes useless booting from kernel+initrd+cmdline and forget about VM s installation....
16:02:06 <quaid> #topic Gerrit
16:02:12 <ewoud> karimb: not afaik, but been a while since I really looked at it
16:02:13 <quaid> anything on this topic?
16:02:26 <quaid> #info I think the Infra git repo is available, but I haven't put anything in it
16:03:50 <quaid> moving on ...
16:04:15 <quaid> #topic Process for bringing in new people to INfra
16:04:21 <karimb> ewoud, allright ...will use poweroff in my kickstart and a script running on manager to boot VMS tagged with first_install
16:04:32 <quaid> #info we need a discussion on list where everyone can be involved
16:04:51 <quaid> #action quaid to start new thread ASAP
16:05:49 <quaid> we'll just discuss in that thread, get it figured out in the next day or so
16:05:59 <quaid> as we have a few people right now in that position
16:06:02 <quaid> #topic Trac review
16:06:11 <quaid> https://fedorahosted.org/ovirt/report/1
16:06:27 <ewoud> I should update my foreman/puppet ticket
16:06:32 <quaid> great
16:06:42 <quaid> I'll just run through the tickets we didn't discuss otherside in this meeting
16:06:47 <quaid> https://fedorahosted.org/ovirt/ticket/10
16:07:16 <quaid> #info renaming of mailing list arch > devel is happening after the www/wiki transfer is all worked out, priority-wise
16:07:37 <quaid> #action quaid needs to put together a migration plan, so people are warned to fix mail filter rules, etc.
16:07:55 <quaid> https://fedorahosted.org/ovirt/ticket/11
16:08:11 <quaid> #info slow mailing list show resolve when we move it to Alter Way, leaving this open for now so we can be sure it is better
16:08:46 <quaid> https://fedorahosted.org/ovirt/ticket/13
16:09:06 <quaid> #info Is this an Infra task?
16:09:15 <quaid> #action quaid to find out if this is an Infra ticket or now
16:09:43 <quaid> https://fedorahosted.org/ovirt/ticket/5
16:10:09 <ewoud> priority wise this has fallen below puppet/foreman
16:10:18 <quaid> #info We'll need to have a how to file a ticket process in place one before doing all the hosting switching
16:10:34 <quaid> ewoud: I can takeover this ticket, since my big hard work has mostly completed :)
16:10:46 <ewoud> quaid: feel free to take it
16:10:53 <quaid> #action quaid to takeover this ticket
16:11:07 <quaid> besides, docs is what I know how to do the best anyway :)
16:11:20 <quaid> https://fedorahosted.org/ovirt/ticket/12
16:11:59 <quaid> #action quaid to revive the thread on this, get it fixed or lined up to change with new hosting
16:13:05 <quaid> ok, that's it
16:13:11 <quaid> closing meeting in 30 seconds
16:14:21 <dneary> adrian15, You're up :)
16:14:54 <quaid> #endmeeting