15:00:34 <mburns> #startmeeting oVirt Weekly Sync
15:00:34 <ovirtbot> Meeting started Wed Nov 21 15:00:34 2012 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:34 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:43 <mburns> #topic agenda and roll call
15:00:51 * garrett_ is here
15:00:58 <mburns> Release Status
15:01:03 <mburns> Sub Project Reports
15:01:05 <mburns> Workshop updates
15:01:11 <dneary> Afternoon all
15:01:34 * mgoldboi here
15:01:35 * oschreib_ here
15:01:45 * dneary here
15:01:45 * sgordon here
15:01:59 <mgoldboi> i would like to add 3.1.0.4 to the agenda
15:02:12 <mgoldboi> as well as bump the version to 3.2
15:02:34 * quaid is here
15:02:42 <mburns> mgoldboi: sure, we can add those to the agenda
15:03:00 <val0x00ff> sgordon: thank you. So in my case it's not necessary as I have one host only.
15:03:03 <mburns> #chair mgoldboi oschreib_ quaid
15:03:03 <ovirtbot> Current chairs: mburns mgoldboi oschreib_ quaid
15:03:33 <mburns> #topic Release Status
15:03:36 <mburns> #link http://wiki.ovirt.org/wiki/OVirt_3.2_release-management
15:03:57 <oschreib_> mgoldboi: ^^ I guess that's enough to bump the version
15:04:19 <oschreib_> (3.2 is already decided as the next release version iiuc)
15:04:28 <mburns> feature freeze is in 1 week
15:04:51 <mburns> mgoldboi: i have no objection to updating to 3.2 for the version
15:05:18 <mburns> it's only ovirt-engine rpms that follow that version info, so not a big issue, IMO
15:05:41 <mgoldboi> mburns: we need to start with nightly builds and people to start testing official 3.2...
15:06:08 <oschreib_> mgoldboi: I'll make sure Juan's patch is pushed.
15:06:16 <mgoldboi> oschreib_: thanks
15:06:47 <mburns> mgoldboi: anything that needs to be done with nightly builds other than change the version in the source?
15:07:08 <mburns> and get them building on F18...
15:07:20 <mgoldboi> mburns: need to see that infra is ok in terms of repo etc.
15:07:34 <oschreib_> mburns: does mock have f18 env?
15:07:46 <mburns> oschreib_: pretty sure it does, but let me check
15:08:14 <mburns> yes, on F17, there are fedora-18-*.cfg
15:08:14 <mgoldboi> mburns: we can definitely build for f17, f18 needs some workaround and patches - i'll make sure those are in asap
15:08:26 <mburns> mgoldboi: ack, thanks
15:08:53 <mburns> our primary target OS for this release is F18, so having that available is pretty critical
15:09:30 <mburns> any updates on where we are with vdsm and engine supporting F18?
15:09:45 <mburns> node is actively being worked on and close to being fully functional
15:10:07 <mgoldboi> mburns: we have a working instnaces - but it needed to be tested more
15:10:21 <mburns> mgoldboi: for both engine and vdsm?
15:10:25 <mgoldboi> mburns: workarounds/tweaks/patches needs to be commited
15:10:28 <mgoldboi> mburns: yes
15:10:42 <mburns> #info node F18 support is very close, should be ready by feature freeze
15:10:58 <mburns> #info working instances of engine and vdsm on F18, just need to be pushed
15:11:10 <mburns> mgoldboi: excellent news
15:11:38 <mgoldboi> mburns: still optimistic somehow, not "very" close...
15:11:45 <oschreib_> :)
15:11:56 <mburns> what about the other packages -- mom, sdk/cli, reports, etc?
15:12:10 <ovirtbot> 14[[07Template:Developer documentation14]]4 10 02http://wiki.ovirt.org/w/index.php?diff=5772&oldid=4975&rcid=5896 5* 03DNeary 5* (-6) 10/* Developer documentation */ Remove old TODO
15:12:14 <mburns> mgoldboi: having something running is better than where we were last week
15:12:35 <mburns> #info engine and vdsm close, but need additional testing
15:12:37 <mgoldboi> mburns: you're right..., sdk/cli - afaik no issues
15:12:50 <oschreib_> mburns: I'd be surprised if sdk/cli will need big work.
15:13:02 <mburns> #info sdk/cli should be good to go on F18
15:13:44 <mburns> doronf: aglitke: is mom ready for F18?
15:14:00 * mburns not sure who does reports....
15:14:08 <oschreib_> mburns: ydary
15:14:37 <mburns> oschreib_: thanks
15:14:39 <ydary> oschreib_: pong
15:14:49 <mburns> ydary: any issues with reports working on F18?
15:14:49 <ovirtbot> 14[[07User:DNeary/Develop14]]4 10 02http://wiki.ovirt.org/w/index.php?diff=5773&oldid=5720&rcid=5897 5* 03DNeary 5* (+60) 10/* Projects */ Link to [[subprojects]]
15:15:53 <mburns> am i missing any other components that we need to check for f18 compat?
15:18:05 <mgoldboi> mburns: tools - log collector/iso uploader/imageuploader
15:18:05 <mgoldboi> mburns: not tested yet afaik
15:18:06 <mburns> #info tools not tested on F18 yet
15:18:06 <mburns> what about guest agent?
15:18:22 <mburns> anyone who can volunteer to look at tools and/or guest agent on F18?
15:18:45 <mgoldboi> mburns: put it on me as well
15:19:01 <mburns> #action mgoldboi to look at tools and guest-agent on F18
15:19:30 <mgoldboi> mburns: where do we stand with ovirt-node?
15:19:44 <mburns> mgoldboi: a couple minor things have come up, but nothing major
15:19:54 <mburns> should be good to go with dev freeze
15:20:15 <mgoldboi> mburns: we need an f18 wiki to track all relevant issues/commits etc. there
15:20:17 <mburns> we're a little tighter on one of our target features, but i'm hopeful
15:22:22 <mburns> mgoldboi: yes, a wiki (or etherpad) to track would be good
15:23:20 <mgoldboi> mburns: should have each component / status/ bugs / workarounds/ priority /etc
15:23:20 <mburns> mgoldboi: do you want to take ownership of creating it?
15:23:20 * mburns unlikely to have time today, and am out on holiday until next week after today
15:23:20 <mgoldboi> mburns: ok, only today...
15:23:20 <mgoldboi> :)
15:23:20 <mburns> mgoldboi: ;-) thanks
15:23:20 <mburns> #action mgoldboi to create an F18 status wiki or etherpad
15:23:44 * mgoldboi will make sure it happens... :)
15:23:46 <mburns> any other issues to bring up for 3.2 release?
15:25:02 <mburns> ok, guess not
15:25:21 <mburns> #topic oVirt 3.1.0.4 update
15:25:43 <mburns> mgoldboi: what needs to be discussed here?
15:26:54 <ovirtbot> 14[[07New website tasks14]]4 10 02http://wiki.ovirt.org/w/index.php?diff=5774&oldid=4795&rcid=5898 5* 03DNeary 5* (+2) 10/* Links needed in new wiki pages */ 
15:27:06 <mgoldboi> mburns: we need a release of 3.1.0.4 - new package of sdk on fedora channel breaks allInOne
15:27:06 <mgoldboi> mburns: patch is ready
15:27:06 <mgoldboi> mburns: we need build +comunication
15:27:06 <mgoldboi> oschreib_: can you take care of build process?
15:27:31 <oschreib_> Sure I can
15:27:31 <mburns> #info new sdk package in fedora breaks allinone
15:27:31 <mburns> #info need new build and communication of new release
15:27:39 <mburns> #action oschreib_ to handle build of 3.1.0.4 update
15:27:51 <oschreib_> mgoldboi: deadline?
15:28:12 <mburns> once it's built and verified to fix the issue, we send an announcement to the mailing lists
15:28:21 <mburns> #info once it's built and verified to fix the issue, we can send an announcement to the mailing lists
15:28:26 <mgoldboi> oschreib_: it's pretty much ready form where i see it - as soon as you can handle it
15:28:46 <oschreib_> mburns: we need verification it's works
15:28:51 <oschreib_> mgoldboi: ^^
15:29:02 <oschreib_> ok, I'll handle it fast
15:29:13 <oschreib_> who takes care of communication?
15:29:31 <mburns> i can put something together on an etherpad
15:29:43 <mgoldboi> oschreib_: verified by Juan
15:29:47 <mburns> and if we post the new build in the next couple days, someone else can send it out
15:30:01 <mburns> otherwise, i can send it out next week
15:30:05 <ovirtbot> 14[[07User:DNeary/Community14]]4 10 02http://wiki.ovirt.org/w/index.php?diff=5775&oldid=5664&rcid=5899 5* 03DNeary 5* (+83) 10/* Community governance & structure */ 
15:30:23 <oschreib_> mburns: cool
15:31:08 <oschreib_> mgoldboi: did we pushed the fix to allinone into 3.1 upstream branch?
15:31:39 <mgoldboi> oschreib_: need to make sure
15:31:55 <oschreib_> mgoldboi: OK, lets handle this offline
15:32:44 <mburns> ok, so i think we're all set here
15:32:55 <mburns> #topic sub-project reports
15:33:07 <mburns> #info covered code-based projects in Release status section
15:33:11 <mburns> #topic sub-project reports -- Infra
15:33:30 <mburns> quaid: dneary:  any updates from the infra team?
15:33:45 <dneary> mburns, Quick one:
15:34:02 <dneary> We're ready to go with Alter Way
15:34:27 <dneary> Kévin Mazière is signed up to the infra@ mailing list, waiting for people to ask him to do stuff
15:34:37 <mburns> #info ready to go with Alter Way for hosting
15:34:42 <dneary> I started a thread last week about what we need from them which needs reviving
15:35:02 <dneary> We don't have an agreement signed with them (yet) but we don't need one to get started, we have decided
15:35:32 <dneary> We're working through some final issues with the new website also
15:35:38 <mburns> dneary: we're using Alter Way for Jenkins and Gerrit
15:35:43 <mburns> was there anything else going there?
15:35:58 <dneary> You can test out the new theme on the old wiki already - in the user preferences, "Appearance", choose "Strapping"
15:36:00 <mburns> #info working through plan for migrating to OpenShift and Alter Way
15:36:22 <mburns> #info working through final issues on the new web site
15:36:22 <dneary> mburns, Itamar requested that we not move Gerrit yet
15:36:37 <quaid> actually, I think we discussed on list a few weeks ago,f wiw
15:36:47 <mburns> #info theme is available on current wiki now  -- in the user preferences, "Appearance", choose "Strapping"
15:36:49 <dneary> We're starting with Jenkins and (quaid can correct me if I'm wrong) mailman & postfix
15:37:00 <quaid> i.e. he requested, we approved going in stages with Gerrit last
15:37:03 <quaid> right
15:37:20 <dneary> I'm working through the content polish (see those ovirtbot messages that have been going during the meeting)
15:37:53 <mburns> #info moving things in stages, gerrit moving last
15:38:07 <mburns> #info dneary working on polishing content for site cutover
15:38:17 <mburns> dneary: do we have a timeframe for the new site being live?
15:38:34 <dneary> Happy to have some help - a list of tasks is at http://wiki.ovirt.org/wiki/New_website_tasks and a list of "gaps" I've identified is at http://wiki.ovirt.org/wiki/Gap_analysis
15:38:40 <garrett_> dneary: the theme is just partially on the live site (it needs some more tweaks to be proper)
15:38:44 <dneary> mburns, quaid would be able to give a better idea than I can
15:39:23 <dneary> I'm missing a few extensions I think are important before switching over, related to embedding video, generating RSS, and we need to migrate over content from the old wiki to the new at some point
15:39:32 <dneary> Once we're happy with the new site, it's a DNS switch
15:39:46 <dneary> I want to have it switched over before the end of the month
15:39:59 <dneary> garrett_, Thanks for the prevision
15:40:02 <dneary> precision
15:40:07 <mburns> #info target for site switchover is end of November
15:40:07 <dneary> In any case, it looks good to me
15:40:28 <mburns> ok, anything else going on with the infra team?
15:41:42 <mburns> ok, then we can move on to
15:41:43 <dneary> mburns, Beyond what was in the minutes of the infra meeting on Monday, no
15:41:54 <mburns> #info Workshops
15:42:01 <mburns> #undo
15:42:01 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x8e59a2c>
15:42:07 <mburns> #topic Workshops
15:42:10 <ovirtbot> 14[[07Features/Design/HostBiosInfo14]]4 !N10 02http://wiki.ovirt.org/w/index.php?oldid=5776&rcid=5900 5* 03Ybronhei 5* (+2746) 10Created page with "<!-- {{autolang|base=yes}} -->  == Host's Bios Information ==  === Summary === When assigning new host to RHEV-M the engine gets general information about the host. This infor..."
15:42:31 <dneary> #info lh is on vacation this week
15:42:36 <mburns> quaid: you're organizing the NetApp workshop, right?
15:43:08 <quaid> in a manner of speaking, yes :)
15:43:27 <quaid> with Jon Benedict, Jason Brooks, and Leslie
15:43:32 <mburns> quaid: ok
15:43:40 <mburns> quaid: anything we need to bring up here?
15:43:47 <dneary> #info #info Presentations from Bangalore and Barcelona workshops are now online: http://wiki.ovirt.org/wiki/Bangalore_oVirt_Workshop and http://wiki.ovirt.org/wiki/LinuxCon_Europe_workshop_schedule
15:43:57 <dneary> #undo
15:44:02 <dneary> #info Presentations from Bangalore and Barcelona workshops are now online: http://wiki.ovirt.org/wiki/Bangalore_oVirt_Workshop and http://wiki.ovirt.org/wiki/LinuxCon_Europe_workshop_schedule
15:44:05 <dneary> Hmmm
15:44:05 <mburns> #chair dneary
15:44:05 <ovirtbot> Current chairs: dneary mburns mgoldboi oschreib_ quaid
15:44:10 <dneary> #info lh is on vacation this week
15:44:13 <mburns> dneary: should work now
15:44:13 <dneary> #info Presentations from Bangalore and Barcelona workshops are now online: http://wiki.ovirt.org/wiki/Bangalore_oVirt_Workshop and http://wiki.ovirt.org/wiki/LinuxCon_Europe_workshop_schedule
15:44:18 <dneary> Thanks mburns
15:44:31 <dneary> mburns, How do you know it's working?
15:44:51 <quaid> #info Nothing new about workshop at NetApp, team to provide an update early Dec
15:44:58 <dneary> quaid, Do you know how plans are coming along for a board meeting during that workshop?
15:45:16 <dneary> quaid, It's been proposed for the last few, and I think it'd be good to have one
15:45:19 <mburns> quaid: ok, thanks
15:45:31 <quaid> nope, I've heard it proposed but not really planned
15:46:01 <quaid> #action someone needs to talk to board@ and individual members about making the NetApp-based workshop
15:46:13 <quaid> we'll sort out "someone", might be a few of us
15:46:39 * mburns can start a thread on board@ to see about interest
15:47:09 <mburns> #action mburns to mail board@ to discuss board meeting at NetApp Workshop
15:47:20 <mburns> anything else to discuss w.r.t. workshops?
15:48:18 <mburns> ok
15:48:22 <mburns> #topic Other Topics
15:48:23 <ovirtbot> 14[[07Features/Design/DetailedExternalEvents14]]4 !10 02http://wiki.ovirt.org/w/index.php?diff=5777&oldid=5769&rcid=5901 5* 03Emesika 5* (-7) 10/* Flow */ 
15:48:31 <mburns> anything else anyone wants to bring up to discuss?
15:48:56 <mburns> if not, /me will close this meeting in ~1 minute
15:50:27 <mburns> ok, thanks all
15:50:31 <mburns> #endmeeting