15:02:34 <dneary> #startmeeting
15:02:34 <ovirtbot> Meeting started Mon Nov 19 15:02:34 2012 UTC.  The chair is dneary. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:34 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:02:40 <dneary> Hi all
15:02:56 <dneary> while waiting for quaid, we can get started, I think
15:03:05 <dneary> ewoud, Still here?
15:03:13 <ewoud> dneary: yes, was trying to link the agenda
15:03:42 <ewoud> #link http://wiki.ovirt.org/wiki/Infrastructure_team_meetings#2012-11-19
15:04:00 <quaid_> yep, you can do that :)
15:04:01 <dneary> ewoud, Thanks
15:04:14 <dneary> quaid_, Thanks :)
15:04:21 <dneary> #chair ewoud quaid_
15:04:21 <ovirtbot> Current chairs: dneary ewoud quaid_
15:04:29 <dneary> #link http://wiki.ovirt.org/wiki/Infrastructure_team_meetings#2012-11-19
15:04:41 <dneary> Sorry ewoud - should have chaired you earlier
15:04:44 <quaid_> (fyi you don't need to lead with #link)
15:04:46 <ewoud> no problem
15:04:53 <ewoud> quaid_: but I want to ;)
15:04:58 <quaid_> :D
15:05:22 * eedri here
15:05:28 <dneary> Hi eedri
15:05:31 <eedri> hi
15:05:39 * garrett_ is here
15:05:40 <dneary> quaid_, Want to take over chairing now?
15:05:51 <ewoud> #chair eedri garrett_
15:05:51 <ovirtbot> Current chairs: dneary eedri ewoud garrett_ quaid_
15:05:52 <quaid_> sure, just getting my stuff together here
15:06:44 <ewoud> I do have another meeting now so maybe a bit afk
15:06:48 <dneary> Let me just start the first topic, then...
15:06:57 <ewoud> I did add the mediawiki backup script to the agenda
15:07:05 <dneary> #topic MediaWiki and www
15:07:19 <dneary> ewoud, Also my request for admin access?
15:07:23 <ewoud> ~afk for a bit
15:07:52 <ovirtbot> 14[[07Infrastructure team meetings14]]4 10 02http://wiki.ovirt.org/w/index.php?diff=5677&oldid=5612&rcid=5805 5* 03DNeary 5* (+35) 10/* 2012-11-19 */ 
15:08:12 <dneary> I just added my request after the other MediaWiki topics - seems to make the most sense there
15:08:46 <quaid_> #info I still have about 3 hours of work to do to get the alpha state there
15:08:52 <dneary> quaid_, Status on MediaWiki, theme & website mogration?
15:09:01 * quaid_ didn't get his other prioroties done until late last night
15:09:12 <dneary> Forget that - was slow in typing
15:09:30 <quaid_> #info process includes working up the how-to for the final cutover
15:09:38 <YamakasY> gobbe thaks
15:09:42 <YamakasY> thanks
15:09:59 <quaid_> #info so we'll know by the end of my today what it will take to do the switchover on the server side
15:10:15 <quaid_> so, just a tiny bit off schedule still
15:10:20 <quaid_> anything else here? questions?
15:10:57 <quaid_> ok, moving along
15:11:05 <quaid_> #topic MediaWiki backup script
15:11:08 <dneary> quaid_, Anything I can do to help?
15:11:12 <quaid_> what's the nature of this one?
15:11:25 * quaid_ hasn't seen his email yet
15:11:30 <YamakasY> gobbe: Please enter your authentication name: ??
15:11:46 <dneary> quaid_, We've been getting a daily nag from MediaWiki back-up about leading /s being stripped, and there have been a number of suggestions about suppressing the warning
15:12:12 <dneary> I suggested using -C / and passing the list of filenames without the leading /s
15:12:41 <dneary> But I have not found the back-up script in source control, so not sure if that is even needed or if there's a better way
15:13:11 <quaid_> we don't have an INfra source going, although we should
15:13:17 <dneary> #info We've been getting a daily nag from MediaWiki back-up about leading /s being stripped to infra@, and there have been a number of suggestions about suppressing the warning
15:13:28 <gobbe> YamakasY: so you are not trying it on plain kvm, but ovirt?
15:13:49 <dneary> #info A number of suggestions have been made about suppressing them
15:13:51 <YamakasY> gobbe: no, a box installed with ovirt
15:14:06 <quaid_> ah, ok
15:14:12 <quaid_> I hadn't seen the discussion on that
15:14:26 <YamakasY> damn, I have a host that cannot add a storage domain... why again!!
15:15:14 <quaid_> one sec
15:15:35 <gobbe> YamakasY: then you need to check password from /etc/pki/vdsm/keys/ and use admin@rhevm
15:17:04 <quaid_> http://fpaste.org/g07g/
15:17:07 <quaid_> there is the script itself
15:17:25 <quaid_> I'll work on the Infra git repo idea later - we may have a repo already on git.ovirt.org but I forget
15:17:52 <dneary> quaid_, Ah, OK
15:17:52 <quaid_> dneary: if -C etc. works that's fine
15:18:08 <quaid_> I always forget to care about that warning
15:18:26 <dneary> quaid_, It should do.
15:18:42 <ovirtbot> 14[[07Infrastructure team meetings14]]4 !10 02http://wiki.ovirt.org/w/index.php?diff=5678&oldid=5677&rcid=5806 5* 03Quaid 5* (+0) 10fixing date command to call the non-DST
15:18:58 <dneary> It's not major, the main point was getting the file published, and ensuring that this discussion was on the agenda (I think it's low priority)
15:19:26 <quaid_> yeah, and I don't know off-hand what backup means when on OpenShift, so this may go away soon of that accord
15:19:37 <quaid_> ok, settled?
15:19:48 <dneary> eedri, ?
15:20:01 <eedri> sorry, i was away for min
15:20:03 <dneary> eedri was the one who added that to the agenda this week
15:20:11 <eedri> what are we talking here?
15:20:16 <dneary> Ah, no - not eedri, ewoud
15:20:19 <dneary> Sorry :)
15:20:21 <eedri> :D
15:20:57 <dneary> I think we can move on
15:21:03 <quaid_> ok then
15:21:22 <quaid_> #topic Admin for dneary
15:21:29 <quaid_> ok, I just read your email
15:21:44 <quaid_> and the sitch is, on the current server admin == root
15:22:05 <dneary> quaid_, I know it's still early for you - when I wrote it, I thought the infra meeting would be later in the week
15:22:27 <dneary> I hope I can be trusted to touch nothing I don't have permission to touch
15:22:28 <quaid_> so, yes, one of the advantages of going with OpenShift is we can give root-type access to the service in a granular fashion
15:23:08 <dneary> but I accept that I shouldn't have access if I can't :-(
15:23:44 <quaid_> well, it's more that we have a semi-used process, that is, we have only started to use it - for adding new trusted Infra people
15:24:09 <dneary> I understand. I guess I'm a test case, then.
15:24:17 <quaid_> off hand, I think we'd have to do some fast track through that process, not sure if it matters to do that right now since we're moving the service
15:24:24 <dneary> I really do want to help get things going ASAP, and I have the skills to do so
15:24:42 <YamakasY> gobbe, ok thanks
15:24:43 <dneary> I'm happy if it goes through an on-list voting process
15:25:06 <quaid_> right, I don't have any objections as an Infra person
15:25:46 <quaid_> as the person doing the work, though, I'm having that resistance to the risk of being derailled by what it would take to work together to completion
15:25:55 <YamakasY> gobbe: nope, doesn't work
15:26:18 <dneary> quaid_, I am happy to co-ordinate to ensure we're not stepping on each other's toes, and leave the lead up to you
15:27:30 <dneary> I'm also happy for this lot to be decided right now - take some time to put thoughts together & we can continue on the mailing list
15:27:37 <quaid_> I think there isn't enough work left on this task to make it specifically worthwhile to bring you up to speed on it, etc.
15:27:42 <dneary> s/"lot"/"not"
15:27:55 <quaid_> but in general, if you want to join the Infra team formally, that's a great thing :)
15:28:21 <gobbe> YamakasY: ah, sorry, my fault
15:28:33 <gobbe> YamakasY: password from libvirt_password file and username is vdsm@rhevh
15:28:56 <YamakasY> gobbe, yes I was going to try vdsm because I need that too on my storage :D
15:28:57 <dneary> quaid_, The specific thing which I could do today s fix the strapping theme - I have worked with several themes before & know what's involved in that
15:29:07 <quaid_> #info Team needs to review "joining" process to include dneary
15:29:14 <garrett_> dneary, I don't think it's the theme that's broken
15:29:15 <dneary> That would also free you up to concentrate on OpenShift
15:29:19 <quaid_> dneary: why should we fix the theme on the current wiki?
15:29:24 <dneary> But I also fully get your arguments
15:29:38 <dneary> quaid_, So that I can test the content layout before migration
15:29:41 <garrett_> dneary, it works perfectly fine on my dev setup, and it's a basic php error
15:29:47 <YamakasY> gobbe: what can be a reason that a host cannot mount a stroage domain, when i can from the commandline ?
15:29:58 <dneary> I copied all of the content which had been written in Garrett's sandbox to the main wiki this morning
15:30:00 <garrett_> but, help to figure out what's going wrong is great
15:30:15 <gobbe> YamakasY: check from logs
15:30:23 <quaid_> dneary: ok, but where we really want to test the layout is in the new version on OpenShift?
15:30:31 <dneary> garrett_, I agree. It's a straightforward integration issue, probably
15:30:37 <dneary> quaid_, Yes
15:30:48 <quaid_> I guess I can see some value in diving in to that before final migration, but isn't it a bit of a time sink right now?
15:30:54 <garrett_> dneary, yeah, first thing is to check the version of php, etc., as this is an error in a foreach
15:30:56 <YamakasY> gobbe: yes OK, but I have seen this more times
15:30:58 <dneary> quaid_, But, in theory, if the layout works in the old one with the new theme, it will work in the new one with the new theme
15:31:07 <dneary> It just enables me to get moving forward again
15:31:11 <dneary> with content
15:31:12 <garrett_> (or perhaps the function call isn't returning content?)
15:31:51 <quaid_> dneary: hmm, I don't see how you are barred from working on content (until the freeze, that is)?
15:32:15 <quaid_> am I missing something about how the new theme affects the content?
15:32:30 <garrett_> quaid_, content can be worked on, but layout can't really, until it's using the theme
15:32:33 <quaid_> I think the next big hurdle is going to the  be Apache redirects
15:32:39 <dneary> quaid_, I don't want to create new content in the sandbox, and I want to test the lay-out of the existing content with the new theme, to ensure we can migrate as quickly as possible once OpenShift is online
15:33:01 <dneary> quaid_, Otherwise, I will be spending several days tweaking content to the new theme after the OpenShift wiki is online
15:33:05 <quaid_> but the theme doesn't affect the layout of the content except how it's skinned on the page?
15:33:13 <dneary> Those are days we could be working in parallel
15:33:14 <quaid_> why?
15:33:22 <garrett_> quaid_, not entirely
15:33:28 <dneary> The theme includes a layout component
15:33:33 <garrett_> quaid_, without the theme, no bootstrap-based layout can be used
15:34:05 <dneary> That's the main reason I wanted it
15:34:12 <quaid_> ok, I'm missing something, I don't have to fully understand that right now
15:34:37 <quaid_> #info server is running php-5.3.3-3.el6_2.8.i686
15:34:39 <garrett_> quaid_, the skin provides more than just a look and feel
15:34:40 <dneary> quaid_, The key point is, we can't start laying out the old content until we have the new theme working somewhere
15:35:02 <garrett_> there are two modes to it, too... the default mediawiki layout, and then manual bootstrap layout
15:35:04 <quaid_> what are the chances we can get the PHP error fixed?
15:35:13 <dneary> So if I can have it as a theme option on wiki.ovirt.org, I'm happy and can ensure we have a quicker "go live" once OpenShift is ready
15:35:14 <garrett_> if you don't use bootstrap layout, then it defaults to mediawiki layout
15:35:24 <quaid_> without having to add a new sudoer :) (although we could)
15:35:33 <dneary> quaid_, I'll get it fixed if I have access
15:35:33 <garrett_> quaid_, well, we have to get it fixed one way or another (;
15:35:36 <quaid_> dneary: right, let's get the theme option fixed
15:35:41 <ewoud> back
15:35:42 <garrett_> oddly, it's in a basic foreach loop...
15:36:05 <quaid_> dneary: without bucking the Infra process, though, can you help by going through me? I.e.,help me solve it?
15:36:11 <quaid_> we could do that right after this meeting, for example
15:37:00 <dneary> garrett_, Have you checked that the list is not emplty before passing it to foreach?
15:37:04 <dneary> quaid_, Yes
15:37:10 <dneary> Don't want to derail meeting further
15:37:10 <garrett_> dneary, the list should never be empty, but no
15:37:42 <garrett_> that's what I was thinking previously as a fix/work-around
15:37:42 <quaid_> #agreed We'll fix the theme problem together right after the meeting, and continue the dneary-in-Infra discussion on-list
15:37:50 <garrett_> perhaps the oVirt wiki is doing something odd
15:39:17 <quaid_> ok, we'll tackle this outside of the meeting
15:39:26 <quaid_> about to move on ...
15:39:37 <quaid_> #topic Hosting
15:40:41 <dneary> Without going into internal Red Hat details, it is taking me longer than expected getting a hosting agreement approved
15:40:48 <dneary> It is slowly moving in the right direction
15:41:00 <dneary> #info Without going into internal Red Hat details, it is taking me longer than expected getting a hosting agreement approved
15:41:07 <dneary> #info It is slowly moving in the right direction
15:41:19 <quaid_> thx
15:41:41 <quaid_> #info No news right now about the Red Hat IT hosting offer, something is in the works
15:41:49 <quaid_> I haven't been pushing on that one, to be honest
15:41:51 <dneary> #info Kevin Mazière from Alter Way is now a member of infra@ and has posted several times already, and he is awaiting a revival of the thread re our requirements for the server
15:42:03 <quaid_> since it doesn't get us forward on the specific goals of Jenkins master move or www refresh
15:42:27 <dneary> #info I have talked to Stéphane Vincent, and we agree that we can get going preparing the hosting while sorting out the details of the agreement
15:42:36 <quaid_> +1
15:42:54 <quaid_> we really don't need the agreement in place until we actually cutover services
15:43:19 <quaid_> #agreed we can work on the pre-cutover while doing the agreement paperwork, in parallel
15:43:59 <dneary> So - last time this came up, there was talk of network requirements
15:44:06 <dneary> We should revive that discussion on the list
15:44:22 <dneary> Kévin wasn't a member last time (I did poke in that direction last week on-list)
15:44:35 <ewoud> dneary: if you can revive it I'll reply
15:44:48 <quaid_> +1
15:45:05 <quaid_> #action dneary to revive network requirements discussion re. Alter Way
15:45:57 <dneary> quaid_, Can I give you tyhat action?
15:46:04 <quaid_> #undo
15:46:04 <ovirtbot> Removing item from minutes: <MeetBot.items.Action object at 0x8f10b0c>
15:46:12 <dneary> I really don't know what requirements you had, and can't remember the details
15:46:22 <quaid_> #action quaid to revive the network requirements discussion re: Alter Way
15:46:30 <dneary> Or ewoud?
15:46:35 <quaid_> heh, neither do I but I think I know where to look up enough to start, and ewoud will reply
15:46:55 <ewoud> dneary: I said if you revive it I'll supply some content
15:47:38 <ewoud> so if someone will state the goals it's good enough
15:47:48 <dneary> ewoud, Responding to the email with subject "Moving Jenkins to Alter Way Hosting" would be an excellent place to revive
15:47:55 <dneary> (thread I started last week, 14/10
15:48:02 <quaid_> ooh
15:48:04 <quaid_> how about that
15:48:08 <quaid_> #undo
15:48:08 <ovirtbot> Removing item from minutes: <MeetBot.items.Action object at 0x8f10b8c>
15:48:23 <ewoud> dneary: ah yes, that's still in my inbox (and thus todo list)
15:48:30 <dneary> Thanks ewoud!
15:48:32 <quaid_> #action ewoud to reply to existing thread "Moving Jenkins to Alter Way Hosting" with details about the networking needs
15:49:00 <quaid_> #action quaid to get an update on Red Hat offer by next meeting
15:49:51 <quaid_> ok, ready to move on?
15:50:08 <dneary> Yup
15:50:13 * dneary is happy to step out
15:50:43 <dneary> I think none of the rest concerns me (but ping me if I'm needed)
15:51:01 <YamakasY> gobbe: I cannt find a thing using google, but this is what happens: failed because of error code 477 and error message is: 477
15:51:34 <quaid_> I'm going to jump to something that involved ewoud, as you are here
15:51:41 <quaid_> #topic Puppet
15:51:51 <quaid_> #topic Puppet/Foreman
15:52:15 <ewoud> right
15:52:26 <quaid_> ewoud: would it help if you had someone else on Infra to work with?
15:52:43 <quaid_> we're not imminent on anything active happening until we get new hosting
15:52:44 <ewoud> I think it would
15:53:18 <quaid_> dneary: would you like to help? I reckon you'd like to learn some about Puppet, too
15:53:19 <ewoud> I'll commit myself to building a poc before the next weekend so we can play around
15:53:35 <quaid_> I also want to help, as I want to get the same education :D
15:53:45 <ewoud> so you can at least play with foreman and a test VM
15:53:53 <ewoud> I think my own server has sufficient resources for that
15:53:53 <quaid_> #action ewoud to build a POC for playing around with Foreman
15:53:56 <quaid_> excellent
15:54:10 <quaid_> great, that will move us forward without waiting on something else
15:54:50 <ewoud> it won't feature creating new VMs from foreman, but it will give us the option to play with puppet
15:55:12 <quaid_> good
15:55:42 <dneary> quaid_, what is needed?
15:56:34 <quaid_> dneary: learning Puppet, learning Foreman, collaborating on a plan of how we'll use them
15:56:41 <dneary> ah
15:57:01 <dneary> I will be looking at the Foreman more closely this week as a side project
15:57:07 <quaid_> I'm in the same boat, those services I want to learn but haven't had a real infrastructure to learn them on before :)
15:57:11 <quaid_> +1
15:57:26 * ewoud has set it up at $employer
15:57:31 <ewoud> so had some paid time to play with it
15:57:37 <quaid_> dneary: if you want share your research as you go on infra@, I'd like to learn too (later in the week for me)
15:57:45 <dneary> quaid_, OK
15:58:09 <quaid_> #action dneary (and quaid) to help and learn Puppet/Foreman
15:58:31 * quaid_ is just making sure he doesn't give himself too much to do so is only promising to lurk-help right now
15:58:52 <ewoud> there are plenty of links in the last minutes (or the one before that)
15:59:03 <ewoud> maybe start a wiki page with our puppet/foreman project?
15:59:38 <quaid_> dneary: can you do that? start a wiki page that tracks your reserch, and we'll start putting content in there about how we'll be using them?
16:00:10 <dneary> quaid_, It'll be the basics of what I learn - not likely to be anything insightful, but happy to share
16:00:24 <quaid_> +1
16:00:35 <quaid_> #action dneary to start the basics Puppet/Foreman wiki page
16:00:46 <quaid_> #action team to help populate the wiki page as we proceed
16:01:07 <quaid_> ok, I just had to shoot my web browser so lost the agenda
16:01:13 <quaid_> but I think we could possible be done and close here?
16:01:16 <quaid_> anything more on this topic?
16:01:21 <quaid_> or any other topic?
16:01:36 <ewoud> we should start the project for the sponsorship
16:01:54 <ewoud> jenkins.ekohl.nl which I need to rename as well
16:02:09 <ewoud> but that's something we can do outside this meeting
16:02:16 <quaid_> +1ok
16:02:39 <ewoud> and I was wondering if anyone else has plans to visit FOSDEM
16:02:57 <dneary> I'll be in FOSDEM
16:03:11 <quaid_> ooh, Infra meetup?
16:03:26 * quaid_ won't  be there but encourages the drinking of beer together
16:03:34 <quaid_> I'll even offer to have dneary pay for the a few rounds
16:03:35 * quaid_ ducks
16:03:41 * garrett_ is planning on going to FOSDEM too
16:03:54 <dneary> quaid_, "rounds"?
16:04:02 <dneary> What are these? Like circles?
16:04:46 <quaid_> dneary: what do you call it when you order a set of drinks for a table?
16:05:06 <dneary> Oh *that* round
16:05:16 * dneary was being funny
16:05:19 <quaid_> *whew*
16:05:22 <dneary> s/being/trying to be/
16:05:27 * quaid_ was being his usual obtuse
16:05:38 <quaid_> I forget, we have a workshop at FOSDEM?
16:06:15 <ewoud> not sure, last year I did meet a few oVirt devs at FOSDEM
16:06:20 <quaid_> dneary: if you look in an American dictionary under 'gullible', you'll find a picture of me there
16:06:45 <dneary> quaid_, Did you know that the word "gullible" isn't included in most dictionaries?
16:07:15 <quaid_> really?!?
16:07:23 * quaid_ rushes to go check
16:07:27 <dneary> Check for yourself!
16:07:30 <dneary> :-)
16:07:30 <quaid_> shoot, you're right!
16:07:37 <ewoud> did you know that 89% of all statistics are made up?
16:07:55 <quaid_> ok, that is a sign of this meeting achieving
16:07:57 <quaid_> "done"
16:08:01 <ewoud> +1
16:08:22 <quaid_> ok, doing so in ...
16:08:24 <quaid_> 5
16:08:25 <quaid_> 4
16:08:26 <quaid_> 3
16:08:27 <quaid_> 2
16:08:29 <quaid_> 1
16:08:32 <quaid_> #endmeeting