15:01:15 <quaid> #startmeeting oVirt Infra weekly
15:01:15 <ovirtbot> Meeting started Mon Nov 12 15:01:15 2012 UTC.  The chair is quaid. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:15 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:18 <yuner_> ok,i will see it
15:01:32 <val0x00ff> btw does not mean this is the right way, but helps to troubleshoot the problem.
15:01:52 <quaid> #topic Agenda & rollcall
15:02:48 <quaid> http://wiki.ovirt.org/wiki/Infrastructure_team_meetings#2012-11-12
15:03:07 <quaid> ''Agenda''
15:03:07 <quaid> * MediaWiki & www
15:03:07 <quaid> * Hosting
15:03:07 <quaid> * Trac review
15:03:07 <quaid> * Puppet
15:03:09 <quaid> * Jenkins
15:03:12 <quaid> * Gerrit
15:03:14 <quaid> * Other business?
15:03:41 <quaid> ok, not sure if there is anyone else around
15:03:48 * sgordon is here
15:03:49 <quaid> so I'll proceed and we'll see :)
15:03:54 <sgordon> bit kind of split with another call
15:03:56 <sgordon> *but
15:04:24 * eedri_ is at another meeting currently.. party attentive
15:05:10 <quaid> yeah, I forgot to remind us about how the daylight savings change would affect this meeting
15:05:21 <quaid> #chair eedri_ sgordon garrett_
15:05:21 <ovirtbot> Current chairs: eedri_ garrett_ quaid sgordon
15:05:32 <quaid> #topic MediaWiki & www
15:06:01 <quaid> http://lists.ovirt.org/pipermail/infra/2012-November/001338.html
15:06:13 <quaid> I started working on the move to OpenShift last week
15:06:34 <val0x00ff> http://fpaste.org/2dU2/  < Is this normal when a virtual disk is being created?  Seems too slow to me.
15:06:38 * ewoud is also partly here
15:07:05 <quaid> #chair ewoud
15:07:05 <ovirtbot> Current chairs: eedri_ ewoud garrett_ quaid sgordon
15:07:31 <quaid> so there are some open discussion points, which I think we need to resolve on-list
15:07:42 <quaid> for example, the "/wiki or not" question
15:08:11 <garrett_> I'd say not, as the entire website is going to be a wiki
15:08:27 <sgordon> isnt the issue that mediawiki becomes a bit harder to manage?
15:08:28 <garrett_> and we'd use sub-domains for any non-wiki parts
15:08:34 <sgordon> or was that just a furphy?
15:08:40 <ewoud> still, mediawiki doesn't recommend removing it
15:08:42 <garrett_> sgordon, in which ways? I haven't noticed any
15:08:51 <sgordon> what ewoud said
15:08:58 <garrett_> right, but why?
15:09:00 <quaid> I think it comes down to MW not recommending for it, meaning they don't really test it
15:09:18 <garrett_> but it does work, and people do run it that way
15:09:23 <quaid> for example, it means you need to do something about ovirt.org/robots.txt - MW thinks that's an article request
15:09:32 <garrett_> if you're running it alongside something else, then I could see some issues perhaps
15:09:50 <quaid> we also don't have access to Apache directly, so we need to do all this in .htaccess
15:09:51 <sgordon> i dont see the issue with having /wiki in the URL anyway if we can redirect properly
15:09:55 <garrett_> quaid, that should be possible to do
15:10:26 <garrett_> sgordon, it's ugly to have /wiki in the URL, and we don't need to advertise the fact that the site is powered by a wiki
15:10:33 <quaid> I have a few open questions (that's just one of them) in the infra@ thread
15:11:01 <sgordon> ugly is relative, i dont see it as that big a deal
15:11:13 <quaid> garrett_: I think we'll want a way to get people at the start of "our wiki" - a wiki is a thing people look for
15:11:22 <garrett_> are we going to have www. in front too?
15:11:27 <garrett_> and :80 in the URL also?
15:11:44 <sgordon> dont see your point really?
15:11:47 <quaid> www.ovirt.org:80/wiki < yehaw!
15:11:53 <sgordon> ovirt.org can redirect to www.ovirt.org/wiki
15:11:56 <sgordon> etc
15:12:09 <garrett_> www.ovirt.org:80/wiki/Content instead of ovirt.org/Content
15:12:18 <garrett_> no, it shouldn't redirect
15:12:22 <garrett_> it shouldn't be like that
15:12:35 <garrett_> one should NEVER expose technical implementations in a URL
15:12:43 <sgordon> yeah, doesnt seem to work for wikipedia
15:12:44 <sgordon> ;)
15:12:55 <sgordon> im just saying if there are issues with removing /wiki
15:13:04 <garrett_> wikipedia is supposed to be a wiki, and I don't agree with the way they do everything
15:13:07 <sgordon> then it doesnt seem like it should be a big deal to leave /wiki in there
15:13:16 <garrett_> yeah, I would love to know any issues there may be with removing /wiki
15:13:20 <ewoud> I'd say we currently work towards just moving wordpress to the wiki
15:13:30 <ewoud> and when we've done that we can look at removing the wiki from the URL
15:13:39 <garrett_> just some hand-waving that it could be a bad idea, especially when it may not even apply to us, is not a reason
15:13:42 <sgordon> is ovirt.org not supposed to be a wiki?
15:14:02 <garrett_> ovirt.org is supposed to be a website
15:14:06 <garrett_> with content
15:14:19 <ewoud> garrett_: I recall trying it and had some issues, which is why I'm not so happy about it
15:14:29 <garrett_> and we're enabling people to edit it, and we happened to choose a wiki, as that's best for what we want
15:14:44 <garrett_> currently, wordpress powers some of it, and mediawiki others
15:14:51 <garrett_> and it's not clear what goes where or why
15:15:03 <ewoud> garrett_: I'm all for removing /wiki, but for technical reasons and implementation speed I'd choose not te remove it right now
15:15:04 <garrett_> and MW looks like an awkward wiki on the live site
15:15:20 <garrett_> ewoud, it certainly works flawlessly in my testing
15:15:37 <garrett_> my point is this: I haven't had a single issue whatsoever with removing /wiki from my sandbox
15:15:39 <quaid> I know we could do this in stages, but I sort-of feel that we want to do the URL change at the same time
15:15:46 <garrett_> and there isn't a reason listed anywhere that I can find
15:16:07 <garrett_> I've only seen one comment that says it might be a bad idea, and doesn't say why or under what circumstances
15:16:07 <quaid> http://www.mediawiki.org/wiki/Manual:Wiki_in_site_root_directory
15:16:30 <quaid> there are 3 bullets there, which I think we've discussed at various times
15:16:45 <quaid> #info special rules for favicon.ico, robots.txt are needed
15:16:59 <quaid> #info periodic bugs because it's not the expected configuration
15:17:12 <quaid> #info not supported by MW developers
15:17:18 <garrett_> first one, for favicon.ico and robots.txt can be handled fine
15:17:38 <garrett_> periodic bugs? but there are periodic bugs in all software
15:18:10 <sgordon> pretty sure the implication is they dont test such configurations at all
15:19:16 <garrett_> some major wiki sites do run it in root
15:19:37 <garrett_> isn't wikia powered by mediawiki?
15:19:59 <garrett_> for one example
15:20:20 <quaid> ok, I'll take each of the open points in the thread and make sure they get addressed
15:20:29 <garrett_> sure, thanks
15:20:52 <garrett_> (just checked: yes, Wikia does use MW (+ extensions + custom theme), and runs it without /wiki/ in the URL)
15:21:01 <quaid> I know we could do this in stages, but I sort-of feel that we want to do the URL change at the same time
15:21:02 <garrett_> I'm sure there are others too
15:21:04 <quaid> oops
15:21:12 * quaid kicks his touchpad
15:21:26 <garrett_> quaid, yes, agreed; URL change should be handled at the same time
15:21:44 <quaid> #agreed We need to resolve this on-list ultimately, moving discussion back there
15:22:19 <quaid> anyone who wants to work on the MW instance in OpenShift can send me a public sshkey to upload
15:22:32 * ewoud is afk now because of another meeting
15:22:46 <dneary> garrett_, while I have seen mediawiki installs that didn't use the /wiki (or /w) it's not recommended by MW developers...
15:23:18 <garrett_> dneary, but the reasons are mostly FUD
15:23:56 <quaid> garrett_: let's get the theme named and posted, too, so I can load it in the instance
15:24:02 <dneary> FUD = Fear, Uncertainty & Doubt... don't agree that they're FUD
15:24:11 <sgordon> when the developers themselves are spreading it
15:24:12 <dneary> Certaibnly, they can be worked around
15:24:13 <garrett_> if there are problems, we can fix them when we get to them, and submit patches if there are really issues
15:24:16 <sgordon> im not sure it qualifies as FUD
15:24:44 <garrett_> it does, at least to some degree
15:24:52 <quaid> sgordon: I see garrett's point - the language I've seen is mainly "Don't do it, bad things might happen, and we won't support it when they do"
15:25:02 <sgordon> yeah but if we put that warning in
15:25:10 <sgordon> and someone did it with our software and something happened
15:25:18 <sgordon> our response would probably be too bad so sad :P
15:25:34 <garrett_> developers also usually put in messages that their software might eat kittens and puppies or trash a hard drive too
15:25:38 <sgordon> (granted with ovirt if we put a warning in that generally means you could be looking at data loss)
15:25:52 <dneary> One practical issue for us - it'll require either a site-wide RewriteRule and will potentially cause issues for Google indexing, because all old /wiki/Page_name pages will now need to be /Page_name
15:25:53 <quaid> for me the point is, there are scant reasons NOT to - the main reason not to is that it's unsupported, there are no other solid technical arguments
15:26:06 <dneary> Is there a potential data migration issue also?
15:26:24 <garrett_> dneary, yes, but we can make that work
15:26:48 <garrett_> whatever known issues there might be, we can fix and/or work around
15:27:51 <ovirtbot> 14[[07Infrastructure team meetings14]]4 !10 02http://wiki.ovirt.org/w/index.php?diff=5386&oldid=5385&rcid=5510 5* 03Quaid 5* (+0) 10fixing the date -d call to match what it's supposed to - 10 am US Eastern
15:28:30 <quaid> does anyone think we can reach a consensus here?
15:28:38 <quaid> regardless, I think we need to decide on-list
15:29:29 <sgordon> yup
15:29:35 <garrett_> quaid, there are possible issues listed, such as making sure robots.txt and favicon.ico are accounted for — we should simply try for the best option (not having /wiki/ or /w/) and see if we can get it working, addressing whatever issue there might be
15:29:54 <garrett_> if it doesn't work then we can fall back, but the the minor issues brought up are completely solvable
15:31:27 <garrett_> for example, we should try to abide by this: http://www.w3.org/Provider/Style/URI
15:31:47 <dneary> garrett_, quaid: I have some time this week to do this, if needs be
15:31:58 <dneary> But we need to avoid holding things up unnecessarily
15:32:05 <garrett_> that's why we should just do it
15:32:11 <sgordon> i think the MW cites that same page as why not to do it
15:32:12 <sgordon> fwi
15:32:14 <sgordon> *fyi
15:32:21 <garrett_> and if there are problems with it, then we can either solve them — or if we cannot, then fall back
15:32:39 <garrett_> sgordon, that page also lists reasons why to do it too
15:32:39 <quaid> ok, let's move this discussion back to the list
15:32:52 <quaid> I don't want to put a bunch of time in a solution without all of us agreeing we can/should try
15:33:01 <garrett_> again, we are working on a different server, so we should try to do the right thing and have cleaner URLs
15:33:08 <garrett_> and if that doesn't work, we fall back
15:33:13 <quaid> +1
15:33:27 <quaid> I'd like to see it cleaner and done one time, if we can
15:33:41 <garrett_> agreed
15:34:25 <garrett_> if we start by not trying, then we accept mediocrity by default. if we try and discover we cannot, then we can work toward a compromise.
15:34:50 <quaid> ok, moving on for now
15:34:53 <garrett_> ok
15:34:56 <quaid> #topic Hosting
15:35:20 <quaid> #info No update from Red Hat IT
15:35:29 <quaid> more my fault for forgetting to get an update
15:35:34 <quaid> #action quaid to get a RHT IT update
15:35:46 <quaid> #info OpenShift hosting is in the works for the new MediaWiki instance
15:36:06 <quaid> dneary: anything for AlterWay today?
15:36:21 <dneary> quaid, Not today. An update since the last time, however
15:36:45 <dneary> quaid, Turns out it's not as straightforward as "ask the CEO of Red Hat France to sign it"
15:37:18 <dneary> quaid, I am at the start of the process of submitting the terms & conditions of AlterWay's hosting to Red Hat legal to get it approved
15:37:33 <dneary> Still figuring out the right way to do that, but I'm talking to our EMEA counsel
15:38:03 <dneary> In the meantime, I have asked Stéphane to join infra@ so as to work on requirements and preparatory work so that we can get started ASAP
15:38:13 <dneary> I'll be following up with him by phone this week
15:38:15 <quaid> #info dneary is working the T&Cs with Red Hat France
15:38:36 <quaid> #info Stephane invited to work out requirements and prep on infra@
15:38:58 <quaid> #action dneary to follow up with Stephane this week
15:39:14 <quaid> anything more?
15:39:52 <quaid> #topic Trac review
15:40:27 <quaid> https://fedorahosted.org/ovirt/report/1
15:40:37 <dneary> quaid, That's it
15:41:20 <dneary> quaid, They're as impatient as us. Two weeks travel plus two weeks last minute planning in the last month has unfortunately made me the SPOF for that, and I'm eager to remedy that
15:41:35 <quaid> #info Ticket #4 is in progress and been discussed today (updating www) - garrett has the theme done but unnammed, ready to use https://fedorahosted.org/ovirt/ticket/4
15:42:00 <quaid> dneary: cool, we'll get it
15:42:33 <quaid> #info Ticket #6 is an open thread on the mailing list, ewoud is not available right now to discuss https://fedorahosted.org/ovirt/ticket/6
15:42:46 <quaid> #undo
15:42:46 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x8efb88c>
15:43:01 <quaid> #info Ticket #6 is an open thread on the mailing list (foreman/puppet), ewoud is not available right now to discuss https://fedorahosted.org/ovirt/ticket/6
15:43:58 <quaid> #info Ticket #10 (arch@ => devel@) is unchanged, I'm just prioritizing doing it after we get the www done https://fedorahosted.org/ovirt/ticket/10
15:45:44 <dneary> quaid, For ticket 11, it seems that the slowness is periodic, I'm not experiencing it now
15:46:12 <quaid> #info Ticket #11 (slow mailman response), I'm supposing it will resolve when we move the list server or take load off the server it is on https://fedorahosted.org/ovirt/ticket/11
15:46:22 <dneary> Could be load related, or related to some kind of resource leak
15:46:43 <dneary> Or any of a dozen other things, but those are the most probable :)
15:46:59 <quaid> the VM doesn't have a lot of RAM & the disk IO gets slammed all the time with stuff
15:47:35 <val0x00ff> another problem solved: when strating a vm the image is assigned to nobody:nobody with 660 permissions. This seems not to suffice, resulting in Permission Denied.  So this image needs 666 permissions.
15:47:43 <quaid> #info Ticket #5 (how-to use Trac) is low priority but will eventually get done :) https://fedorahosted.org/ovirt/ticket/5
15:47:44 <val0x00ff> s/strating/starting*
15:47:58 <quaid> and that's ticket review :)
15:48:25 <quaid> for the rest of the agenda:
15:48:35 <quaid> anyone here who has updates for Jenkins, Gerritt, or Puppet?
15:48:51 <quaid> I'm going to open those topics and give a minute for each
15:49:03 <quaid> #topic Puppet
15:49:35 <quaid> #info ongoing discussion on list about how to handle this, is tied in to hosting changes
15:50:51 <quaid> #topic Jenkins
15:51:26 <quaid> RobertM: did you see the question about Jenkins backups?
15:51:39 <quaid> it happened on infra@ over the weekend
15:52:45 <val0x00ff> RobertM: can you approve my wiki account? Or mburns if one of you around? Thanks in advance.
15:53:29 <RobertM> quaid, I don't see anything with the subject as backup
15:53:45 <dneary> val0x00ff, I'll do it
15:54:00 <dneary> quaid, The notification emails aren't getting sent, and I don't see notifications in the wiki either
15:54:27 <quaid> RobertM: http://lists.ovirt.org/pipermail/infra/2012-November/001343.html
15:54:50 <ovirtbot> 14[[07Special:Log/newusers14]]4 create210 02 5* 03Rmiddle 5*  10Rmiddle created a user account Val0x00ff
15:54:50 <val0x00ff> dneary: Thanks. I'll try and do my best to contribute to the wiki as I'm doing all day nothing else than oVirt
15:54:51 <ovirtbot> 14[[07User:Val0x00ff14]]4 !N10 02http://wiki.ovirt.org/w/index.php?oldid=5387&rcid=5512 5* 03Rmiddle 5* (+700) 10Creating user page for new user.
15:54:51 <quaid> dneary: which notification emails?
15:54:52 <ovirtbot> 14[[07User talk:Val0x00ff14]]4 !N10 02http://wiki.ovirt.org/w/index.php?oldid=5388&rcid=5513 5* 03Rmiddle 5* (+252) 10Welcome!
15:55:04 <RobertM> val0x00ff, Confirmed
15:55:12 <dneary> quaid, "User XXX requested a wiki account"
15:55:18 <quaid> ah, those
15:55:22 <dneary> RobertM, Thanks! Beat me to it
15:56:47 <quaid> ok, moving along
15:57:19 <val0x00ff> RobertM: Thank you. Just got the confirmation email and changed the password already. Going to hang around there a bit.
15:57:34 <quaid> #topic Gerrit
15:57:56 <quaid> #info no update for this topic, may remove from standing agenda for now or until move planned
15:58:30 <quaid> #topic Any other business?
15:59:05 <ovirtbot> 14[[07OVirt 3.1 release notes14]]4 !10 02http://wiki.ovirt.org/w/index.php?diff=5389&oldid=4879&rcid=5514 5* 03Val0x00ff 5* (+7) 10/* Fedora */ 
16:01:23 <quaid> ok closing mtg
16:01:32 <quaid> #endmeeting