14:00:13 <mburns> #startmeeting oVirt Weekly Meeting
14:00:14 <ovirtbot> Meeting started Wed Oct 31 14:00:13 2012 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:14 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:25 <mburns> #topic Agenda and Roll Call
14:00:34 * quaid is here
14:00:39 <mburns> Status of Next Release (Feature Status, F17/F18 support)
14:00:40 <mburns> Sub-project reports (engine, vdsm, node, infra)
14:00:40 <mburns> Workshop Report
14:00:48 * jb_netapp is here
14:00:53 <mburns> #chair quaid oschreib mgoldboi
14:00:53 <ovirtbot> Current chairs: mburns mgoldboi oschreib quaid
14:02:57 * itamar here
14:03:06 * mgoldboi herer
14:03:36 <mburns> #topic Next Release
14:03:49 <mburns> #info 2 weeks until Dev Freeze
14:04:06 <mburns> #info 6 weeks until estimated GA
14:05:01 <mburns> #link http://wiki.ovirt.org/wiki/OVirt_3.2_release-management
14:06:43 <mburns> itamar: any updates on F18?
14:06:52 <mburns> danken: ^^
14:07:08 <itamar> yes, some updates.
14:07:11 <dneary> mburns, F18 has been pushed out past our predicted GA
14:07:16 <dneary> I think
14:07:51 <mburns> dneary: they're before, but just barely, according to our wiki...
14:07:56 <mburns> err...their wiki
14:07:59 <itamar> f18 doesn't work at this point for either engine (postgres changes) or vdsm (bridge changes)
14:08:08 <mburns> they ga 2012-12-11
14:09:10 <itamar> we could focus on fedora 17 still for 3.2, *but* that would mean fedora 18 will be going out with totaly broken ovirt/vdsm (which are part of fedora). so i think we should actually focus on fixing all the issues we have for fedora 18 as a gating item for 3.2.
14:09:34 * eedri here
14:09:47 <mburns> itamar: maybe not gating on 3.2, but ship a 3.2.1 shortly afterwards...
14:09:51 <itamar> another f18 issue: both vdsm and engine need to move from iptables to firewalld, maybe we can go disable these and go with release notes till it is fixed
14:10:27 <itamar> that means fedora 18 goes longer without vdsm/ovirt working in them at all.
14:11:28 <dneary> itamar, So if F18 ends up releasing late(r), you think we should push oVirt 3.2 too?
14:11:30 <itamar> it also means supporting 3.2 for two entirely different versions of fedora. i think we need to improve our support/bug fixes for ovirt, but we need to focus on specific versions
14:12:02 <mburns> itamar: problem with focusing on a specific release is that it kills all upgrades...
14:12:30 <mburns> itamar: is iptables deprecated? or is it there, but firewalld is the default?
14:12:40 <itamar> not sure on firewalld/iptables
14:13:51 <dneary> mburns, Fedora is the only major distro moving to firewalld at this time
14:13:53 <itamar> and upgrade must be resolved (i use the unofficial upgrade path for fedora)
14:15:00 <itamar> dneary, it is the only major distro we currently support as well... though i assume we'll want to keep backward compatibility for iptables in both engine and host
14:15:24 <itamar> mburns, so what's the upgrade path for fedora users when fedora 19 comes out and 17 is deprecated?
14:16:37 <mburns> itamar: i think you can upgrade from 17->19, but i'm not sure
14:17:02 <mburns> itamar: we need backward compat for iptables, yes
14:17:35 <mburns> we have people running on el6 today
14:17:49 <mburns> mostly centos6
14:17:55 <itamar> so you can upgrade from f17 to f18 as well, which i prefer would be needed for ovirt 3.2, so we can focus on supporting less combinations per version.
14:18:14 <mburns> and that's not going to firewalld at all
14:18:14 <dneary> itamar, Yes, I think we should
14:18:27 <dneary> For F17 and also to make it easier to port to other OSes
14:18:39 <mburns> itamar: but will 3.1 continue running on f18?
14:18:43 <mburns> sounds like it won't...
14:18:59 <itamar> yes, we have .el6, and would be nice if they check 3.2 setup and upgrade, since that repo is maintained by backporting various patches which upgrade may or may not work with the official ovirt 3.2 release.
14:20:09 <itamar> ovirt 3.1 won't run on f18, hence my main concern of focusing on f18 to rapidly have a vdsm/ovirt for f18 instead of the current versions we have there which will be broken (we may choose to fix them, but we first need to understand/resolve these issues, which would be via 3.2 on f18.
14:20:54 <mburns> itamar: agreed that we should focus on F18 and make sure things are going to work correctly there
14:21:06 <mburns> itamar: but i think we need 3.2 to also work on f17
14:21:22 <mburns> that way, people upgrade oVirt from 3.1 -> 3.2
14:21:35 <mburns> and then can gradually upgrade hosts/engine to F18
14:22:01 <quaid> the EL users need to be first class, too
14:23:26 <itamar> quaid, the EL users are using kind of a forked version of ovirt via a separate repo/patches. i don't know if they made any changes which wouldn't work for an upgrade to 3.2, they need to test it and send patches/etc.
14:24:14 <mburns> yes, we need to get any patches in the forked repo included in out builds
14:24:19 <mburns> and start shipping them on ovirt.org
14:25:12 <quaid> yeah, it's just that with the Fedora versions being rocky for months, EL (re)builds are popular  - which we tend to see with these type of projects - so we want to plan for EL users, yes
14:25:25 <itamar> mburns, I'm assuming the forked build has been backporting patches from master mostly. I'm just saying upgrade are tricky, and require a lot of testing. if any assumptions were broken (say, they backported patches changing db-scheme), it may cause problems.
14:25:41 <itamar> i agree we should do .el6 builds of ovirt btw.
14:27:16 <quaid> +1
14:27:31 <mburns> an argument could be made that we don't need to make upgrade work for el6 since it was a forked version, though i think we should make best effort to make it work
14:27:32 <itamar> maybe we can define it as a goal for post 3.2
14:27:54 <itamar> i agree, i'm just saying the forked version should own the responsibility of testing/patches/etc.
14:28:02 <mburns> itamar: agreed
14:28:25 <itamar> but not sure we should block 3.2 on an upgrade issue of a forked version (which could be fixed in a forked version of 3.2, etc.).
14:28:30 <mburns> itamar: i think we should try to make 3.2 rpms available for el6
14:28:38 <itamar> we do need to resolve any issues preventing using ovirt on .el6
14:28:45 <mburns> even if it doesn't work correctly for the forked version
14:29:17 <itamar> actually, the only thing i know for sure is needed is changing the emulation (-m) from pc to rhel, but maybe there are other things.
14:29:19 <mburns> and then for all future versions, we have upgrade paths for el6
14:30:34 <mburns> but regardless, we need to have and upgrade path that doesn't say "upgrade ovirt and OS in the same step and the server will be down while that is going on"
14:31:10 <itamar> mburns, going back to fedora versions - using your logic (which is good from an upgrade story perspective), it will mean we'll have to maintain 3.2 for both f17 and f18 - i want to improve support, so i'd rather focus on one (f18 in that case). also, i'm not sure upgrading fedora with a 3.2 installed would "just work". i think we should focus 3.2 on f18, and test an upgrade path of f17-->f18 + upgrade. btw, its only for engine. for hosts we'll be b
14:32:19 <mburns> itamar: i don't think we should be forcing OS upgrade in the same step
14:33:02 <mburns> and given the Fedora release dates, F18 very likely won't GA by our targeted release date
14:33:07 <itamar> what happens if f17+ovirt 3.1 upgrades to f18? i think we should focus on this flow, then they can upgrade to f18 (rather than 3.2 for f17)
14:33:56 <mburns> itamar: tbh, i'm fine either way, but we *know* 3.1 won't work on F18
14:33:57 <itamar> then we should consider changing it due to delays in f18
14:34:12 <mburns> so we need to have a 3.1.1 release?
14:34:21 <mburns> that works on F17 and F18?
14:34:24 <itamar> mburns, actually, we know installing ovirt on f18 won't work, not f17+ovirt ugraded to f18
14:35:23 <mburns> itamar: can you have someone try that?
14:35:24 <itamar> also, this is mostly around engine. for host/node, f17 will continue to work with current version of vdsm. so i'd focus on getting 3.2 version of vdsm working on f18.
14:35:46 <itamar> mburns, yes. assuming fedora upgrade is working by now (it's still pre-rc iirc)
14:36:36 <mburns> itamar: i think, if 17+ovirt 3.1 -> 18 doesn't work, then we should focus exclusively on 3.2 and making it work on both
14:37:44 <itamar> what is the upgrade path for ovirt-node and host?
14:38:53 <mburns> itamar: ovirt-node -- not 100% sure yet, but we should be able to handle bridge differences and iptables/firewalld easily enough
14:39:19 <mburns> we don't allow firewall changes at the moment, so not a big deal there
14:39:39 <mburns> bridging is bigger, but shouldn't be too bad
14:40:07 <mburns> as for host -- if we say vdsm only on F18, then host must be upgrade to f18 and install new vdsm at the same time
14:40:37 <itamar> ok, need to check upgrade path for host as well for f17+vdsm("3.1")-->f18
14:40:40 <mburns> #action itamar to have someone test F17 + oVirt 3.1 upgrade to F18 to see if it works
14:41:13 <mburns> #agreed we should target F18
14:41:19 <itamar> i'd rather focus on making minimal vdsm/engine changes so f17 upgrade to f18 will work with 3.1, and 3.2 for f18.
14:41:37 <itamar> (that was before last comment)
14:42:17 <mburns> itamar: 3.1 cluster level should work fine with 3.1 vdsm, right?
14:42:22 <quaid> I'm just wondering - are there parts of this discussion that need to (re)occur on arch@?
14:42:34 <mburns> and 3.2 vdsm should support working in a 3.1 environment
14:42:46 <mburns> quaid: yes, was about to say this needs to go to the mailing list
14:43:22 <mburns> #action mburns to take F17/F18 and upgrade discussion to arch@
14:44:05 * mburns goint to skip sub-project status reports for right now since Barcelona workshop is next week
14:44:16 <mburns> #topic Workshops
14:44:20 <mburns> dneary: any updates?
14:44:34 <dneary> mburns, OK - last things first
14:44:57 <dneary> Leslie excused herself - she is in London for Red Hat Developer Days this week, and couldn't attend
14:45:10 <dneary> She gave me an update for the NetApp workshop in January
14:45:24 <dneary> She is meeting Jon Benedict next week to discuss details
14:45:42 <mburns> #info lh and jb_netapp to meet next week to discuss NetApp workshop in January
14:46:06 <dneary> LinuxCon Europe workshop: I have asked LF to set the Rubi room (Thursday & Friday) for 50 people, in anticipation of smaller crowds for the more technical oVirt sessions.
14:46:33 <dneary> I also recommended running some BOFs on the post-3.2 roadmap and maybe an informal meeting of board members present
14:47:01 <dneary> We have a hand-out for the stand which I got printed today with all the oVirt related content in the conference
14:47:07 <mburns> #info room being setup for 50 people for Thursday/Friday
14:47:32 <mburns> #info BOFs for after hours for post-3.2 roadmap and informal board meeting
14:47:49 <mburns> #info hand out ready for the booth with oVirt related content
14:48:04 <dneary> We have some giveaways for the stand (left-overs from another conference), and we are expecting delivery of KVM Forum & oVirt workshop goodies (USB keys) on Monday in Barcelona
14:48:38 <dneary> I need volunteers to help burn in the latest oVirt Live image on the USB keys Monday evening or Tuesday evening :-}
14:48:55 <mburns> #info some giveaways from previous conferences are ready for the booth
14:49:04 <mburns> #info USB keys to arrive Monday
14:49:09 <dneary> Final details: several sessions abstracts need updating, I'll be sending on updated abstracts in a batch today to LF
14:49:29 <dneary> itamar, Have I missed anything?
14:50:17 <dneary> Some last-minute schedule changes need to be made too (oVirt/Quantum talk is cancelled)
14:50:49 <itamar> dneary, sounds about right.
14:50:56 <itamar> see you all next week :)
14:50:58 <dneary> The KVM Forum is now sold out. Unfortunately we have no way of knowing how many of the registered attendees will be in oVirt sessions
14:51:14 <dneary> And then just to wrap up the Bangalore workshop:
14:51:35 <mburns> #info some last minute schedule and abstract updates are getting sent to LF today
14:51:48 <mburns> #info Barcelona is Sold Out!
14:51:57 <mburns> #info Bangalore wrap up
14:52:03 <dneary> I have received 10 responses to my request for feedback of 50 Bangalore attendees
14:52:33 <dneary> Respondents rated the workshop at 4 on a scale of 5
14:52:37 <dneary> (on average)
14:52:55 <mburns> #info avg rating 4 out of 5 for the workshop
14:53:07 <dneary> The level of former oVirt knowledge pre-workshop was varied - from none to "some knowledge" - no-one called themselves an expert
14:53:11 <mburns> #info 10 respondents out of 50 people
14:53:45 <dneary> All the sessions were well received, and several attendees say they now intent to contribute.
14:53:57 <dneary> Many attendees requested that the slides be made available
14:55:36 <mburns> dneary: excellent
14:55:44 <mburns> dneary: anything else?
14:55:50 <dneary> I think I'm out
14:55:53 <mburns> ok
14:56:07 <mburns> #topic sub-project report infra
14:56:14 <mburns> quaid: updates here?
14:56:30 <mburns> i know at least the wiki upgrade is done
14:57:47 <mburns> #info Wiki upgrade complete
14:58:37 * mburns guesses we lost quaid...
14:58:44 <mburns> #topic other topics
14:59:10 <mburns> out of curiosity, is there interest in a meeting next week given that a large number of people are going to be in Barcelona?
14:59:26 * mburns leaning toward canceling...
15:00:14 * mburns will take that to the list as well...
15:00:29 <mburns> ok, /me waits 30 sec for additional topics
15:01:17 <mburns> Thanks all
15:01:19 <mburns> #endmeeting