14:00:27 <mburns> #startmeeting oVirt Weekly Meeting
14:00:27 <ovirtbot> Meeting started Wed Oct 24 14:00:27 2012 UTC. The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:27 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:30 * garrett_ is here
14:00:35 <mburns> oschreib_: sorry, was just getting off a call...
14:00:46 * quaid is here
14:00:47 <mburns> #topic agenda and roll call
14:00:54 <oschreib_> mburns: I wasn't sure if it's now or an hour from now
14:01:02 <mburns> oschreib_: ;-)
14:01:02 * oschreib_ here
14:01:09 <mburns> Agenda:
14:01:11 <mburns> Status of Next Release (Feature Status)
14:01:11 * doron here
14:01:11 <mburns> Sub-project reports (engine, vdsm, node, infra)
14:01:11 <mburns> Workshop Report
14:01:27 <mburns> #chair oschreib_ quaid
14:01:27 <ovirtbot> Current chairs: mburns oschreib_ quaid
14:02:09 * ofrenkel here
14:02:52 * sgordon is here but on a call as well
14:03:31 <mburns> ok, lets get started
14:03:39 <mburns> #topic Release Status
14:03:52 <mburns> #link http://wiki.ovirt.org/wiki/OVirt_3.2_release-management
14:04:32 <mburns> #info a few more feature pages updated
14:04:56 <mburns> #info still 7 features missing a feature page (or link)
14:05:15 <mburns> #info VM create using pre-defined profiles
14:05:22 <mburns> #info libvdsm preview
14:05:33 <mburns> #info column resizing and sorting in webadmin
14:05:38 <mburns> #info user level api
14:05:45 <mburns> #info automatic storage domain upgrade
14:05:54 <mburns> #info Japanese Localization
14:06:11 <mburns> #info full plugin support with example plugins (in Node)
14:06:22 <mburns> those are the feature pages missing currently
14:06:44 <mburns> itamar1: can you track down people for the engine related pages missing?
14:06:49 * lh is here but distracted
14:06:58 <ovirtbot> 14[[07Feature/NetworkMainTab14]]4 !10 02http://wiki.ovirt.org/w/index.php?diff=4908&oldid=4907&rcid=5025 5* 03Alkaplan 5* (-7) 10/* Sub-Tabs */
14:07:14 <mburns> #action mburns to follow up on missing node feature page
14:07:35 <oschreib_> mburns: I can get status on missing feature pages
14:07:43 <mburns> oschreib_: ok, thanks!
14:07:46 <oschreib_> np
14:07:47 <itamar1> mburns, i gave steve list of people per each.
14:07:57 <mburns> itamar1: excellent, thanks
14:08:13 * sgordon expenses a baseball bat and a one way ticket to tel aviv
14:08:22 <sgordon> ;)
14:08:31 <mburns> sgordon: one-way? you staying there?
14:08:50 <sgordon> depends how the baseball goes?
14:08:56 <mburns> #info 5 new features added around glusterfs support
14:09:00 <oschreib_> he'll be in jail :)
14:09:06 <sgordon> >:D
14:09:38 <sgordon> but yes that is fine, i will chase up individually over the next week or so on the remaining issues, which includes some of the gluster feature detail
14:10:20 <mburns> #info sgordon reviewed the feature pages and most of the existing ones are in good shape
14:10:42 <mburns> #action mburns to review feature pages for %complete for next weeks meeting
14:10:58 <mburns> other just informational notes
14:11:24 <mburns> #info Beta/Devel Freeze scheduled for Nov 14
14:11:41 <mburns> #info GA scheduled for Dec 12
14:12:01 <oschreib_> mburns: we're going to release it on Fedora17 or 18?
14:12:02 <aglitke_> #action aglitke will add libvdsm preview feature page
14:12:08 <mburns> a question was asked earlier today about our alignment with Fedora releases
14:12:17 <mburns> aglitke_: thanks
14:12:25 <mburns> oschreib_: yes, that's a good question
14:12:40 <mburns> we should try to make it run on both, if possible
14:12:51 <itamar1> i think we should aim to f18
14:13:08 <oschreib_> I think it should be clear in the release page (as a must)
14:13:37 <oschreib_> mburns: being compatible with both f17 and f18 might be difficult
14:14:13 <mburns> oschreib_: how will upgrade work?
14:14:18 <oschreib_> and also, a feature page for F18 compatibility is a good idea (handling setup and JBoss changes)
14:14:18 <mburns> we currently have: MUST: Upgrade from previous release
14:14:54 <oschreib_> mburns: if we support F18, so some sort of manuall upgrade as we had in 3.0 ->3.1 might be good
14:15:08 <oschreib_> s/good/working/
14:15:21 <mburns> oschreib_: itamar1: has anyone looked at F18 and engine?
14:15:59 <oschreib_> mburns: also, what about node? f18 or f17 based?
14:16:39 <mburns> oschreib_: we've looked at it a bit, but not a lot yet
14:16:40 <oschreib_> mburns: I'm not sure the *engine* is going to be the issue, probably setup/Jboss/VDSM changes are needed.
14:17:09 <mburns> also worth noting that F18 GA is currently at 2012-12-11
14:17:25 <aglitke> that seems to answer it for me right there :)
14:17:26 <mburns> oschreib_: we'll probably attempt to support both F17 and F18 nodes
14:18:13 <mburns> oschreib_: though an f18 based image may have to lag a bit given that we need to build based on the f18 GA
14:18:39 <oschreib_> feature freeze is 3 weeks from now
14:19:05 <oschreib_> I guess we should take the next week to think/check/estimate the possibility of moving to f18 in 3.1 timeframe
14:19:15 <oschreib_> and decide in the next meeting.
14:19:20 <mburns> oschreib_: i think that's the best choice
14:19:46 <oschreib_> we need VDSM commitment also
14:20:02 <itamar1> mburns, yes, we started testing with fedora 18 and already opened a few bugs to clean
14:20:13 <mburns> #action each team needs to review support options for F18 in 3.2 (mburns, oschreib_ danken )
14:20:53 <mburns> #info will revisit F18 support next week
14:20:55 <itamar1> I know by next week may be hard for my team
14:22:03 <mburns> itamar1: ok, let's still revisit next week and we can defer a decision again if we need
14:22:49 <mburns> we can also make a decision like: "node/vdsm can run on either f17/f18, engine runs on f17 only"
14:23:14 <mburns> and then do a 3.2.1 later that adds ability to run engine on f18
14:24:31 <mburns> ok, anything else for release status?
14:27:00 <mburns> #topic Sub Project Status (Node)
14:27:13 <mburns> #info actively working on features for 3.2
14:27:42 <mburns> #info Node automation work mostly done, some refactoring still pending, but nothing critical or blocking
14:27:45 <ovirtbot> 14[[07OVirt 3.2 release-management14]]4 !10 02http://wiki.ovirt.org/w/index.php?diff=4909&oldid=4873&rcid=5026 5* 03Jboggs 5* (+22) 10/* Features */
14:28:10 <mburns> #info TUI redesign UI work done, backend functionality being worked on
14:28:19 <mburns> #info glusterfs client support complete
14:28:40 <mburns> #info full plugin support done, example snmp plugin complete, example cim plugin in progress)
14:28:43 <mburns> #undo
14:28:43 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x8f0b64c>
14:28:45 <mburns> #info full plugin support done, example snmp plugin complete, example cim plugin in progress
14:29:16 <mburns> and questions/comments/concerns?
14:30:30 <mburns> #topic Sub Project Status (VDSM)
14:30:49 <mburns> danken dougsland: any updates for vdsm for 3.2?
14:30:53 <mburns> feature status updates?
14:32:21 <mburns> #info no updates
14:32:29 <dougsland> mburns, not from my side
14:32:35 <mburns> #topic Sub Project Status (Engine)
14:33:00 <mburns> itamar1: doron: any updates for engine?
14:33:24 <doron> mburns: nothing new. work in progress for 3.2
14:33:37 <mburns> #info work in progress for 3.2
14:33:43 <mburns> doron: ok, thanks
14:33:48 <doron> sure
14:34:06 <mburns> #topic Sub Project Status (MOM)
14:34:13 <mburns> aglitke: any updates on MOM for 3.2?
14:34:20 <mburns> or doron ^
14:34:23 <aglitke> mburns, yes,
14:34:45 <aglitke> We just released packages for f17, f18, and epel6. Everything for the initial support is there.
14:35:05 <aglitke> We may want to stretch a bit and add support for ballooning if possible.
14:35:08 <aglitke> What I need:
14:35:17 <mburns> #info new MOM packages for F17, F18, epel6
14:35:26 <aglitke> information on how to get mom built as part of the nightly ovirt build process.
14:35:33 <mburns> #info everything needed for initial support is included in those builds
14:35:45 <mburns> eedri: ping, can you help aglitke get going with jenkins? ^^
14:35:46 <aglitke> And subsequently, how to produce packages for the release.
14:36:19 <doron> mburns: please note that mom is missing from bgzilla. Just emailed infra about it, but we should follow up.
14:36:36 <mburns> aglitke: packages for the release -- currently we don't have a centralized build system for official releases
14:37:03 <aglitke> mburns, ok, so those are manually uploaded by the package maintainer?
14:37:05 <mburns> aglitke: so it's probably just a process of building the packages, then getting them to oschreib_ or me to post
14:37:11 <aglitke> ok.
14:37:25 <mburns> aglitke: unless we get jenkins building the official packages
14:37:47 <mburns> #info still need to add mom component to bugzilla
14:37:53 <aglitke> I'd like to get those nightlies working and then we need to test that ksm is still working as expected in our regular testing.
14:38:12 <oschreib_> aglitke: and always build with mock locally
14:38:14 <mburns> aglitke: is mom in ovirt gerrit?
14:38:15 <aglitke> mom will take over the responsibility for tuning ksm now.
14:38:21 <aglitke> mburns, yes.
14:38:30 <aglitke> oschreib, ok.
14:38:31 <mburns> ok, good
14:39:02 <mburns> aglitke: if you don't hear from eedri, let me know and i'll get you access to configure a job in jenkins
14:39:12 <aglitke> ok. great thanks.
14:39:20 <mburns> #action mburns or eedri to get aglitke access to create mom build in jenkins
14:39:52 <eedri> mburns, afaik mom build needs physical server
14:39:58 <eedri> mburns, we don't have it on jenkins yet
14:40:12 <aglitke> eedri, why is it any different from the rest of the packages?
14:40:28 <doron> eedri: you need to differ build from tests.
14:40:28 <aglitke> the build is much less intensive than the engine build.
14:40:30 <eedri> aglitke, you're talking about just building it? or running tests
14:40:37 <aglitke> eedri, only building
14:40:42 <eedri> aglitke, which os?
14:40:51 <aglitke> same as for the rest of the packages.
14:40:58 <mburns> eedri: fedora and el6
14:40:58 <aglitke> it builds great on anything.
14:41:01 <eedri> aglitke, ok. fedora 17 should be an issue
14:41:06 <eedri> shoudn't
14:41:10 <aglitke> ok, great
14:41:23 <eedri> you can also open a ticket on infra trac instance
14:41:31 <aglitke> link?
14:41:40 <mburns> eedri: once it's running, we just need to include it in the nightly rpm publish
14:41:42 <oschreib_> eedri: if you need to build the package, just use mock, and you can build for every OS you want
14:42:01 <eedri> aglitke, https://fedorahosted.org/ovirt/
14:42:12 <eedri> mburns, shouldn't be a problem
14:42:33 <eedri> oschreib, we'll start with f17 like other pkg
14:42:33 <aglitke> eedri, thanks. I will open a ticket
14:42:43 <eedri> oschreib, if we'll need other os, we'll consider using mock
14:42:55 <mburns> #info eedri and aglitke working together to get jenkins mom build running
14:44:07 <mburns> anything else for mom?
14:44:43 <aglitke> nope. Thanks for all of the help.
14:45:01 <mburns> #topic Sub Project Status (infra)
14:45:11 <mburns> quaid: any updates?
14:45:18 * mburns missed the infra meeting this week...
14:47:08 <aglitke> eedri, https://fedorahosted.org/ovirt/ticket/9
14:47:21 <eedri> aglitke, thanks
14:47:28 <quaid> let's see
14:47:28 <mburns> #info no update from infra team
14:47:32 <mburns> #undo
14:47:32 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x8dedeec>
14:47:36 <quaid> it was short, but ..
14:48:00 <quaid> #info talking with Red Hat IT about getting 2 bare metal servers in our PHX2 datacenter within the month, in addition to Alter Way
14:48:15 <quaid> #info we'll be able to split services and duplicate to different networks, so we can have better availability and recovery
14:48:36 <quaid> #info website update is in the works, will report back status as it happens to arch@
14:48:49 <quaid> #info still need to rename arch@ to devel@ - reminder that will be happening
14:49:37 <quaid> #info Gerrit running more smoothly now that Itamar did some tweaks that solved (apparently) the jetty issue
14:50:16 <quaid> #info current plan is to migrate Jenkins first, then Mailman to Alter Way; holding back carefully with Gerrit due to crucial position in dev process
14:50:43 <quaid> #info working on infra@ on plan to use Foreman/Puppet to do these rollouts and manage machines from here on out
14:50:48 <quaid> <eoreport>
14:50:55 <mburns> thanks quaid
14:51:27 <mburns> #topic Workshop - Barcelona
14:51:40 <mburns> lh: any updates?
14:51:49 <mburns> dneary: ^
14:51:54 <lh> mburns, dneary has this one
14:52:39 <jbrooks> I've pitched a handful of news sites that've covered ovirt in the past on the workshop
14:52:59 <itamar1> dneary: any update on publihsing the schedule to get more attendees, and a poll of attendees on interest (not sure how many of attendees are interested in which session, since most are for both kvm and ovirt)?
14:53:02 <aglitke> #link https://events.linuxfoundation.org/events/kvm-forum/schedule
14:53:44 <mburns> #info schedule post to kvm-forum web-site
14:54:04 <quaid> dneary is giving training atm, I think
14:54:19 <mburns> #info working with various outlets to promote the workshop
14:55:31 <mburns> anything else on workshops (since dneary is unavailable?)
14:55:43 <doron> mburns: afair from previous workshop, we were missing someone to be the host in the workshop. Can you please verify we have a volenteer in Barcelona?
14:55:45 <dneary> I'm available for 2 mins
14:55:52 <mburns> doron: /me
14:56:06 <doron> mburns: awesome :)
14:56:17 <mburns> dneary: can you give a quick update on the barcelona?
14:56:28 <dneary> itamar1, mburns, The schedule is online now
14:56:31 <mburns> doron: or itamar1 or acathrow could handle that
14:56:42 <doron> ?
14:56:51 <mburns> but i'll be there and can handle the host role
14:57:02 <dneary> http://kvmforumovirtworkshop2012.sched.org/
14:57:04 <doron> mburns: that's prefect.
14:57:10 <mburns> if itamar and/or acathrow want to handle it, then i don't mind
14:57:12 <itamar1> mburns, wednesday has both booth and workshop, so need to make sure booth is covered.
14:57:24 <mburns> itamar1: i think booth is mon/tue only...
14:57:25 <itamar1> mburns, we can alternate on the different days?
14:57:46 <itamar1> mburns, really, but linuxcon is on wednesday as well? (I don't mind no wednesday)
14:57:51 <dneary> lh, do you know if ppl will pick up their KVM Forum packs on Monday or on Wednesday?
14:58:45 <mburns> #link http://kvmforumovirtworkshop2012.sched.org/
14:58:52 <dneary> I'm in the process of getting merchandising, but I'm travelling this week (in .cz) and giving a training course, so not online very much
14:59:05 <dneary> in fact, ppl are waiting for me to start again :-)
14:59:12 <mburns> #info mburns has volunteered to be host for Barcelona
14:59:18 <mburns> dneary: ok, thanks
14:59:26 <SirDerigo> s
14:59:26 <SirDerigo> sorry!
14:59:41 <lh> dneary, unknown, this can be handled later
14:59:44 <mburns> #info dneary working on merchandising, but delayed due to travel this week
15:00:11 * lh is in two other meetings, sorry
15:00:27 <dneary> lh, Noted
15:00:41 <mburns> lh: do you know the times that the booths are open?
15:00:46 <lh> mburns, yes one moment
15:00:55 <lh> mburns, http://go.linuxfoundation.org/lceu_elce12_sponsor_guide
15:00:57 * mburns had that but can't find it...
15:01:00 <dneary> mburns, Yes, delayed and hopefully I'm not in panic mode now... need to take care of ordering stuff today
15:01:03 <lh> Monday, November 5th: 10:30am - 7:00pm
15:01:04 <lh> Tuesday, November 6th:10:30am - 4:30pm
15:01:09 <dneary> OK - away
15:01:15 <lh> mburns, scroll down on that page to technology showcase hours
15:01:24 <mburns> #info booth hours are monday and tuesday
15:01:26 <mburns> lh: thanks
15:01:28 <mburns> dneary: thanks
15:01:31 <lh> mburns, np
15:01:37 <mburns> itamar1: booth hours ^^
15:01:42 <mburns> no need to cover wednesday
15:02:26 <mburns> #topic Other Topics
15:02:31 <mburns> anything else to cover today?
15:02:43 <doron> is there a list of people fotr the booth?
15:03:08 <doron> ie- booth duty.
15:03:19 <mburns> doron: i think there is a private email thread going around about who is available for booth duty
15:03:45 <doron> mburns: I hope it includes the relevant ppl... I havn't seen it....
15:03:47 <mburns> and the plan was to map it out on the first day there
15:04:14 <doron> very well.
15:04:34 <mburns> doron: yes, i'll make sure we reach out to the relevant people
15:05:01 <doron> thanks.
15:05:08 <lh> doron, afaik, dneary is prepping booth duty schedule but i will make sure one exists before you arrive
15:05:34 <mburns> lh: are we getting booth/sponsor passes for people?
15:06:19 <lh> mburns, if you are a registered speaker for KVM Forum + oVirt, you have free access to LCE which would also allow you to exhibit in the booth.
15:06:25 <lh> do we have any non-speakers attending?
15:06:29 <doron> lh not urgent. Just wanted to know this is being handled.
15:06:58 <mburns> doron: yes, we've discussed this and i'll follow up with people later this week
15:07:25 <mburns> if no other topics, i'll end the meeting in 30 sec
15:08:57 <mburns> ok, thanks everyone
15:09:00 <mburns> #endmeeting