14:13:08 <quaid> #startmeeting oVirt Infra weekly sync
14:13:08 <ovirtbot> Meeting started Tue Sep 18 14:13:08 2012 UTC. The chair is quaid. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:13:08 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:13:19 <quaid> #topic rollcall, agenda call
14:13:20 * RobertM here
14:13:26 <sgordon> probably would be less confusion without an open discussion about canceling it on the list
14:13:28 * sgordon here
14:13:45 <quaid> oh, sorry
14:13:52 * quaid didn't see a discussion about cancelling
14:14:18 * RobertM doesn't see it either
14:14:19 <quaid> oh, I think that was about cancelling the regular meeting
14:14:25 <quaid> the one tomorrow
14:14:50 <quaid> I'll read that thread, but I don't think it applies here?!?
14:15:58 <quaid> ok, I'm getting the agenda page updated
14:16:18 <quaid> proposal: we talk about hosting solutions today
14:18:09 <ovirtbot> 14[[07Infrastructure team meetings14]]4 !10 02http://wiki.ovirt.org/w/index.php?diff=4479&oldid=4452&rcid=4589 5* 03Quaid 5* (+82) 10How about that for an agenda?
14:18:11 <quaid> * Task tracking update
14:18:11 <quaid> * Hosting
14:18:12 <quaid> * Jenkins check-in
14:18:18 <quaid> <eoagenda>
14:18:33 <quaid> I'll wait a moment for additions, then move on
14:19:27 <quaid> ok then
14:19:33 <quaid> #topic Task tracking update
14:19:38 <quaid> this is quick
14:19:50 <quaid> last week mburns and I got me Admin access to the Trac instance at
14:19:54 <quaid> http://fedorahosted.org/ovirt
14:20:09 <quaid> and I'm going to tweak it to be an Infra team task tracker - adjust the fields, etc.
14:20:32 <quaid> when I get the first round of changes done, I'll post about it to the list for comments, then finalize and we can write-up how to use the tool
14:20:48 <quaid> it does require a Fedora account system (FAS) account to use
14:20:59 <quaid> https://admin.fedoraproject.org/accounts/
14:21:40 * dneary is here
14:21:43 <RobertM> quaid, I think most people with have a FAS account. I know I do
14:22:19 <quaid> well, I wouldn't presume very far there, but it's not really a barrier beyond any other "need an account" situation
14:22:30 <quaid> ok, that's all I have on that right now
14:22:41 <quaid> #action quaid to adjust fields in oVirt Trac to be useful to Infra team
14:23:13 <quaid> #action quaid to post about initial Trac changes to infra@ovirt.org for feedback and finalization
14:23:23 <quaid> ready to move on
14:23:30 <quaid> #topic Hosting
14:23:40 <quaid> RobertM: I've been distracted and haven'
14:23:45 <quaid> haven't gone back to this topic
14:23:50 <quaid> where do you think we are with it?
14:24:54 <RobertM> I am at a point where it isn't really workable. To find a server the meets are needs we are looking at $400 a month.
14:25:06 <RobertM> are=our
14:25:31 <RobertM> For that kind of money we could almost buy something used an colo it some place.
14:26:13 <dneary> quaid, re FAS, it is only potentially an issue with a strong identification to another distro.
14:26:43 <sgordon> FAS is just a type of openid though right, really
14:27:07 <sgordon> but i guess the only openid accepted for trac
14:27:13 <quaid> RobertM: that's capex and an ongoing hassle, I'd rather do the short term hosting
14:27:16 <sgordon> do we accept FAS in the gerrit openid login?
14:27:31 <RobertM> sgordon, Yes
14:27:40 <RobertM> That is why I have a FAS account.
14:28:06 <dneary> sgordon: I know - just pointing out that in the same way that some GNOME people had an issue needing to create an account on identity.kde.org to register for the Desktop Summit a couple of years ago, some Ubuntu/OpenSuse/Debian people might have an issue creating an identity on a Fedora service to contribute to a project that's supposed to be distro agnostic
14:28:11 <sgordon> yeah
14:28:18 <sgordon> but if this is only for tracking infra workflow
14:28:22 <sgordon> i dont see it as a huge blocker
14:28:23 <quaid> dneary: yeah, but fedorahosted is a temporary solution & we've certainly used e.g. Launchpad for oVirt already with similar results
14:28:29 <dneary> Yeah - I'm not making a big thing of it
14:28:47 <sgordon> if we were requiring it for the mediawiki instance that would be different
14:28:49 <dneary> re hosting...
14:28:55 <quaid> sgordon: we may need to direct people to file tickets there, though, so it's more than just workflow - or we can choose not to use it that way
14:29:08 <RobertM> quaid, On the topic of hosting we are looking at 400 or more a month for deciated servers just for jenkins if you can get a budget like that approved I know of at least 1 hosting provider and I remember seeing 2 others in around the same price range.
14:29:09 <sgordon> do you need to login to file tickets
14:29:12 <sgordon> i thought it accept anon?
14:29:15 <dneary> RobertM, Define what you mean by "hosting" for me, please?
14:29:15 <sgordon> *accepted
14:30:01 <dneary> RobertM, To me, I thought it meant either leasing a server or leasing a VM
14:30:03 <quaid> RobertM: ok, I can check in on that
14:30:42 <RobertM> dneary, Leasing a server with high IO aka raid 10 file system.
14:30:51 <dneary> OK
14:32:02 <quaid> so we have a weekly meeting that just moved back to this timeslot
14:32:15 <quaid> and I didn't realize that until 15 min ago, meaning I'm a bit distracted all of a sudden
14:32:19 <quaid> dneary too
14:32:26 <quaid> (we = internal team @RHT)
14:32:37 <RobertM> You can get hosting much cheaper but it really falls apart with the need for good IO most Dedicated hosts want to give you a sata2 drive a small number will give you software raid but those with true hardware raid a few and far between with big price tags per month attached.
14:32:42 <quaid> sgordon: I'll see if I can set tickets to anon, but we'll need email
14:32:58 <quaid> RobertM: here's the question then
14:33:13 <quaid> RobertM: if we're talking about e.g. 3 months max we'll need this host
14:33:30 <quaid> RobertM: how much of a difference is RAID 10 here - could we make do well enough with just more CPU and RAM?
14:33:39 <quaid> RobertM: if it's a big enough difference, I'll push for the budget
14:34:18 <quaid> #info quaid talked with RHT IT last week about VMs for oVirt (and other projects); there are things happening very soon; am seeing if there is a box we can reuse for Jenkins soonest
14:35:48 <RobertM> My system at home is just sata2 and it was getting overwelmed with IO request on master just running the patch jobs. A better host would help with general Jenkins but running both the patch jobs and the build jobs will likely swamp anything less.
14:37:10 <quaid> RobertM: ok
14:37:38 <quaid> RobertM: did you send me direct URLs with the provider(s)? anything new to that list?
14:38:07 <RobertM> As for CPU and Ram. quad core with 8G of ram would be fine for a master. The bottle neck is all about the IO.
14:38:44 <RobertM> Something EC2 really sucks at.
14:39:35 <quaid> RobertM: can you paste here some specific provider(s) solution pages? I'll use that in my budget-ask.
14:39:41 <RobertM> So moving a any dedicated host will see a major speed up. Just not sure a dedicated host with sata can handle adding the patch jobs
14:40:06 <RobertM> quaid, Let me check my notes. I will email something to infra
14:41:17 <RobertM> quaid, We might want to think about moving Gerrit sooner and that I would bet would be fine on straight sata.
14:42:26 <quaid> RobertM: ok, cool
14:43:39 <RobertM> That can be had for around a hundred a month and that effect more people.
14:43:55 <quaid> RobertM: ok, can you also include some solutions for that in the email?
14:44:07 <RobertM> quaid, Ok
14:44:36 <quaid> RobertM: I'm fairly certain that we'll be able to move off to e.g. RHT provided hosts in a few months, so I am more comfortable asking for ~$2K to get us there than if it were open-ended
14:45:52 <RobertM> quaid, I think the really import low hanging fruit is gerrit since that box seems to be having the most issues and a lot more people are using it.
14:50:15 <quaid> RobertM: ok, we can pick that hosting solution and move forward immediately, I think; we'll do that under the existing budget approval, then get the larger amount OK'd
14:51:29 <RobertM> quaid, How many quoto's do we need?
14:58:48 <quaid> RobertM: 2 or 3?
14:59:28 <RobertM> quaid, OK I will try and slice out some time to get that finished. Day Job has been sucking up a lot of my time that last few weeks.
15:04:13 <quaid> RobertM: I hear ya
15:04:26 <quaid> ok, I'm going to close the meeting unless you want to say anything about Jenkins?
15:04:33 <quaid> #topic Jenkins anything
15:04:44 <RobertM> Nope nothing has changed regarding Jenkins :(
15:21:12 * ewoud reads backlog
15:27:44 <ewoud> quaid: hetzner seems to have no minimum contract period and a 30 day cancellation period; not that expensive either
15:28:19 <ewoud> and some friends have a server there and happy
15:29:32 <quaid> ewoud: ok, can you reply to RobertM's thread with that?
15:29:36 * quaid closes this overdue closing
15:29:39 <quaid> #endmeeting