14:00:46 <mburns> #startmeeting oVirt Weekly Sync
14:00:46 <ovirtbot> Meeting started Wed Sep 12 14:00:46 2012 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:46 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:53 <mburns> #chair quaid RobertM
14:00:53 <ovirtbot> Current chairs: RobertM mburns quaid
14:01:00 <mburns> #topic agenda and roll call
14:01:14 * lh is here
14:01:19 <mburns> Status of Next Release (Release Criteria, Target GA date)
14:01:19 * garrett_ is here
14:01:19 <mburns> Sub-project reports (engine, vdsm, node, infra)
14:01:19 <mburns> Workshops
14:01:19 <mburns> Project Manager Election
14:02:59 * mburns hoping more than just lh and garrett_ are here...
14:02:59 <itamar> itamar here (for next 20 minutes)
14:03:05 * quaid is here too
14:03:40 <mburns> ok, the lets see what we can get done in the next 20
14:03:56 <mburns> #topic Next Release
14:04:18 <dneary> Me here too
14:04:27 <mburns> can we set a release date for Wednesday November 14?
14:04:37 <mburns> at least an initial release date?
14:04:40 * RobertM here
14:05:12 <itamar> mburns, from what i see on where we are now, and list of featutes i expect people to still push, I think later a few weeks would be good.
14:05:30 <itamar> to have some feature content in the version
14:05:49 <mburns> itamar: Dec 5?
14:05:49 <itamar> most of my team will be on holidays till mid october
14:06:22 <itamar> well, i'm not bound by december holidays, not sure how they affect others though for a freeze on dec 5th
14:06:25 <dneary> mburns, Nov 5th is KVM Forum
14:06:33 <itamar> (oh, i'm talking freeze date, not ga date)
14:06:45 <itamar> dneary - that's december vs. november
14:06:47 <mburns> itamar: yes, ga date
14:06:50 <dneary> itamar, Do we have a list of features we expect people to push somewhere?
14:07:01 <mburns> dneary: let's get a date first...
14:07:06 <itamar> dneary - will probably have in a week, yes.
14:07:13 <dneary> itamar, Yes - I was supporting your suggestion to do it later than Nov 14
14:07:40 * mburns was hoping for close to the workshop so we can demo latest and greatest...
14:07:59 <mburns> but that's more a hope than a requirement
14:08:23 <itamar> we'll need some features for that to happen, and i expect people could demo the features they have on master as well if needed
14:08:40 <itamar> we just don't have working days for next month...
14:09:26 <mburns> itamar: ok, so lets talk feature freeze
14:09:34 <mburns> when do you think we can feature freeze
14:09:38 <mburns> realistically
14:10:03 <dneary> mburns, I don't mind picking a date first, but then the features to go in has to be flexible
14:10:10 <mburns> dneary: yes
14:10:29 <itamar> denary - I think in any case we need to work that way unless a feature is decided as a blocker/critical.
14:10:30 <lhornyak> I am getting the usual error at git push to gerrit, could someone restart it?
14:10:32 <mburns> dneary: just looking to keep conversation on track without diving off into tangents
14:10:39 <dneary> mburns, I understand
14:10:57 <mburns> itamar: can we say Nov 14 for feature freeze?
14:11:03 <mburns> is that realistic?
14:11:05 <itamar> i'm just suggesting we need some time to develop features, regardless of which ones...
14:11:07 * rharper is here
14:11:30 <itamar> mburns, it's only one month to develop them - we usually need more since we need to integrate vdm, engine, ui, api/sdk/cli, etc.
14:11:44 <itamar> dec 15th is more reasonable i think
14:11:59 <mburns> itamar: that puts us at GA in mid January
14:12:04 <itamar> then bug fixes only for a couple of weeks, then beta
14:12:59 <itamar> i just don't see enough content that can be pushed in 4 weeks time of development - last few months were heavy on bug fixes, but not on features.
14:13:26 <mburns> itamar: we can make 3.2 a primarily bug fix release if we have to
14:13:41 <mburns> my concern is our tendency to slip the release date
14:13:52 <dneary> itamar, A couple of weeks post-feature freeze does not sound realistic, given what I saw for 3.1
14:13:54 <mburns> and setting it now for January would put us at risk for hitting F19 dates
14:14:11 <itamar> indeed, we can do 3.2 a bug fix one, but then i'd pull it earlier maybe.
14:14:29 <itamar> dneary - 3.1 was a huge version, 7 months of development. i'm talking about a 2 months one.
14:14:32 <dneary> I think a 3.2 in Fedora 18 is a good target - and we work backwards to see what we can get in during that timeframe
14:14:37 <mburns> how about feature freeze mid November
14:14:44 <mburns> then GA mid december
14:14:59 <mburns> then we move to a 6 month cycle
14:15:31 <mburns> dneary: it won't be done for GA
14:15:32 <dneary> itamar, I realise that. My point was more related to the release date slippage, and the fact that any new features need some integration time
14:15:44 <itamar> mburns - from what i saw with 3.1, i'm hesitant about a 6 months cycle. i think it made the version too big. i'd rather keep them smaller and more stable
14:15:50 <mburns> F18 ga is october, iirc
14:16:13 <rbergeron> mburns: it's now late november
14:16:13 <mburns> itamar: right, but we can discuss that when we start planning next release after 3.2
14:16:19 <mburns> rbergeron: ahh, thanks
14:16:25 <mburns> rbergeron: won't hit that either though
14:16:26 <itamar> mburns - yes, was just commenting about that.
14:16:29 <rbergeron> mburns: and it will likely be december by the time it gets out the door - already had 3 alphas
14:17:21 <mburns> itamar: can we agree to target maybe 1 or 2 small features into 3.2 (so we have something net new)
14:17:35 <mburns> and settle on mid november freeze and mid december release?
14:19:11 <itamar> mburns, i'd like more than 1-2 features to show, but if you feel strongly about the dates, i can live with them.
14:19:38 <dneary> mburns, OK - then we should not target F18.
14:19:42 <dneary> Hi rbergeron
14:20:09 <mburns> itamar: dneary:  i think we want to target f19 to get this in as a feature
14:20:16 <dneary> I tend to agree with mburns on shipping 3.2 this year
14:20:42 <mburns> any objections or other comments on November freeze and December GA?
14:20:46 <itamar> what's the beta date of f19?
14:21:04 <dneary> itamar, F18's beta date + 6 months (approx.)
14:21:21 <dneary> itamar, So, roughly mid March
14:21:27 <dneary> rbergeron, Is that correct?
14:21:32 <itamar> we can do a 3.3 by then :)
14:21:34 <mburns> itamar: not sure that's defined yet, but feature freeze would probably be early february
14:21:45 <itamar> (by march, not by feb)
14:21:54 <itamar> i see f18 feature freeze was october
14:22:32 <rbergeron> beta change for F19 should be approx. March 12 2013
14:23:30 <itamar> mburns - sorry, i have to drop now.
14:23:57 <mburns> itamar: ok
14:24:02 <rbergeron> give or take a week - and beta release should be approx. 3/26
14:24:08 <mburns> rbergeron: ok, thanks
14:24:27 <mburns> ok, so we've set general dates for freeze and GA for 3.2
14:24:45 <mburns> #agreed feature freeze in mid november
14:24:54 <mburns> #agreed target ga in mid december
14:25:08 <mburns> #info itamar will provide feature list for 3.2 next week
14:25:25 <mburns> anything else for release status?
14:25:47 <mburns> ok, moving on then
14:26:12 <mburns> #topic sub-project report - node
14:26:24 <mburns> #info still waiting on fix/solution for nfs kernel issue
14:27:06 <dneary> mburns, Any idea whose job it is to fix it?
14:27:08 <mburns> #info 2.5.2 packages released but no iso (some slight packaging and spec file changes to improve distro support)
14:27:14 <dneary> Can we at least get it to the right person?
14:27:19 <mburns> dneary: we have questions out to the assignee
14:27:32 <mburns> dneary: we're trying to push this along as much as we can
14:27:38 <dneary> And the assignee is a kernel guy?
14:27:43 <dneary> Or NFS guy?
14:27:46 <mburns> no, i think it's still on vdsm...
14:28:01 <dneary> I heard yesterday that it's a kernel bug
14:28:13 <mburns> need clarity on what vdsm can fix and workaround and what we need to push to kernel
14:28:15 <dneary> That there's a workaround, but no real fix for VDSM
14:28:17 <mburns> and i don't have that info
14:28:54 <dneary> #link https://bugzilla.redhat.com/show_bug.cgi?id=845660
14:29:02 <jclift> Can we build a node using earlier kernel - even though its a pita - because that'll solve the problem for the immediate future?
14:29:05 <dneary> MeetBot doesn't like me :(
14:29:13 <jclift> Building a kernel is something _we can do now_.
14:29:18 <jclift> Just saying. ;)
14:29:53 <mburns> fsimonce: any direction you can give on https://bugzilla.redhat.com/show_bug.cgi?id=845660
14:29:54 <garrett_> jclift, yep, I agree about that
14:29:55 <mburns> #link https://bugzilla.redhat.com/show_bug.cgi?id=845660
14:30:09 <mburns> #chair dneary
14:30:09 <ovirtbot> Current chairs: RobertM dneary mburns quaid
14:30:26 <garrett_> (jclift, that's one of the reasons why I made the focus an all-in-one appliance to download & install in the original download page mockup)
14:30:30 <fsimonce> mburns, are you looking for a workaround?
14:30:56 <mburns> fsimonce: or just clarity on what the issue is in the kernel so we can move it or clone it there
14:31:07 <mburns> and start bugging the kernel guys to fix it
14:31:17 <dneary> fsimonce, We're looking to (a) figure out what the issue is, and (b) ensure that it gets fixed, and (c) get a fixed version of oVirt and Fedora out so that oVirt works for people who want to do NFS storage domains
14:31:37 <fsimonce> I'll comment on the bug
14:31:39 <dneary> In fact, c is what I care about
14:31:44 <jclift> ( c ) version is more urgent.
14:31:54 <jclift> If we get that done, the other bits become non-urgent.
14:32:07 <dneary> jclift, Those were "and"s not "or"s ;)
14:32:11 <mburns> jclift: garrett_:  it's not trivial to get a build done with an old kernel
14:32:14 <dneary> fsimonce, Thanks!
14:32:37 <dneary> fsimonce, It's a big bug for us, I'd just like to see solving it be someone's top priority
14:32:38 <mburns> jclift: garrett_:  and i don't want to have to maintain our own kernel package
14:33:01 <mburns> we don't have the bandwidth or expertise to do that
14:33:05 <mburns> fsimonce: thanks
14:33:10 <jclift> mburns: We should be able to use one of our own kernel packages, just an older one.
14:33:33 <jclift> mburns: I have a full F17 mirror local to me if that's helpful.  Can give you remote ssh to a box (any os) for building on manually if needed.
14:34:05 <garrett_> jclift, right, it wouldn't be full/real support of a custom kernel really
14:34:08 <mburns> jclift: ok, we can sync after the meeting and see what we can do
14:34:16 <jclift> mburns: np
14:34:30 <mburns> #info mburns and jclift to work on getting node build with an old kernel
14:34:58 <dneary> mburns, What would be needed to fix this in Node? A new release with a different kernel version?
14:35:20 <dneary> mburns, Presumably fixing this in Fedora requires a kernel fix to be released for Fedora
14:35:37 <mburns> dneary: a kernel with higher NVR than the current fedora kernel that does not have the NFS issue
14:35:53 <dneary> NVR?
14:36:00 <mburns> name-version-release
14:36:25 <jclift> That would be the proper fix, yeah.
14:36:36 <jclift> Not a half arsed one like we're proposing. ;)
14:37:17 <mburns> once we get the details in the bz, i'll walk over and talk to the kernel people and see if we can get this fixed...
14:37:25 <dneary> mburns, So it's been fixed in more recent kernels already?
14:37:36 <fsimonce> mburns, dneary, done
14:37:37 * dneary is kind of lost
14:37:46 <mburns> and if that doesn't help, then i'll look at the hacking something together
14:37:49 <jclift> dneary: I don't think it has.  That's the problem.
14:37:52 <mburns> fsimonce: thanks
14:38:09 <mburns> dneary: not fixed yet, but we *could* theoretically rebuild an older kernel with a higher NVR
14:38:20 <mburns> but that's ugly and hackish (and something i want to avoid)
14:38:53 <mburns> basically, the node iso build process pulls in the fedora repos and ovirt.org repos and uses yum depsolver to include the packages needed
14:39:09 <mburns> and depsolver always chooses the latest it needs
14:39:25 <jclift> As a way to build things, it's not at all difficult for me to screw around with my local F17 mirror.
14:39:26 <mburns> so it will always choose the latest fedora kernel
14:39:40 <mburns> jclift: it requires hacking on my side too...
14:39:51 <mburns> to point at your repo instead of the public fedora mirrors
14:39:53 <jclift> I can easily remove the kernel-* packages it has, then insert an older kernel, then do the createrepo on that.
14:40:10 <jclift> Ahh, cool.  Whichever.  I'm happy to help in order to get this result.
14:40:22 <mburns> but we can discuss if i can't get kernel to work on a fix
14:40:26 <jclift> Sure
14:40:44 <mburns> #topic sub-project report - infra
14:40:51 <mburns> quaid: RobertM:  anything here?
14:41:57 <RobertM> mburns, Not really we are looking at hosting providers right now to get jenkins and gerrit on a more stable platform.
14:42:08 <dneary> so, reading fsimonce's most recent comment, he seems to be saying that this is not a kernel bug, it's just slightly different kernel behaviour that's exposing a cpython or vdsm bug - is that correct?
14:42:22 <fsimonce> dneary, probably
14:42:26 <dneary> (sorry, I know I'm behind the times, we had a bust lip kid emergency)
14:42:36 <mburns> #info looking into hosting providers, not much else to report
14:42:54 <mburns> #topic sub-project report vdsm/engine
14:43:02 <mburns> #info mostly working on bug fixes
14:43:16 <mburns> #info many people out of office over the next month due to holidays
14:43:24 <mburns> #topic workshops
14:43:31 <mburns> lh: anything here?
14:44:04 <lh> mburns, ovirt CFP for KVM Forum + Ovirt concludes at the end of this week
14:44:24 <mburns> lh: did we ever get the problem with no oVirt Workshop option in the CFP solved?
14:44:37 <lh> so get those submissions coming in http://events.linuxfoundation.org/events/kvm-forum/cfp-ovirt
14:44:38 <mburns> #info CFP for oVirt Workshop in Barcelona closes at EOW
14:44:50 <mburns> #link http://events.linuxfoundation.org/events/kvm-forum/cfp-ovirt
14:45:00 <lh> mburns, i do not follow on the question re: no ovirt workshop option in the CFP. can you clarify for me?
14:45:32 <mburns> lh: when i looked yesterday, there was only an option to submit for KVM Forum and not for oVirt Workshop
14:45:38 * mburns looks now
14:45:57 <mburns> looks like it's fixed now
14:46:05 <mburns> so all set
14:46:07 <lh> We're also looking to expand the oVirt Bangalore workshop on 16 September 2012 to two days, one for users one for devs. this requires surveying potential attendees, which I'll be working on next week
14:46:11 <lh> mburns, excellent, glad to hear it
14:46:29 <mburns> #info looking to expand Bangalore Workshop to 2 days
14:46:40 <lh> We filled up registration slots in Bangalore within a few days of setting up the event page so looking forward to good audience and attendance
14:46:51 <mburns> #info lh will be surveying attendees about that
14:46:58 <lh> #link http://ovirtbangalore2012.eventbrite.com/
14:47:03 <mburns> #info Bangalore registration completely full within a few days
14:47:11 <lh> That page will change if we move to two day format but just so folks know where it is
14:47:45 <lh> And for folks tracking community submitted talks for Bangalore workshop, you can now find these details on the ovirt wiki
14:47:47 <lh> #link http://wiki.ovirt.org/wiki/Bangalore_Abstracts
14:48:23 <lh> If you've submitted a talk idea for oVirt Bangalore, please make sure to add additional details to the abstract page as documented on it.
14:49:03 <lh> And somewhat related to workshops, oVirt will have a booth at LinuxCon Europe, so we can direct folks at LCE to attend KVM Forum + oVirt workshop later that week.
14:49:09 <lh> mburns, that's all I have unless anyone has questions
14:49:13 <mburns> #info community submitted talks for bangalore now available on the wiki
14:49:39 <mburns> #info people who have submitted talks, please update info on the wiki page
14:49:56 <mburns> #info we will have a booth at LinuxCon Europe
14:49:59 <mburns> lh: ok, thanks
14:50:04 <lh> mburns, my pleasure
14:50:11 <mburns> #topic Project Manager Election
14:50:28 <mburns> I'm not sure we have enough people to really hold the election
14:50:41 <mburns> anyone have thoughts on this?
14:50:53 <mburns> there are currently 2 candidates
14:50:58 <mburns> #info there are currently 2 candidates
14:51:02 <mburns> #info Mike Burns (mburns)
14:51:21 <mburns> #info Moran Goldboim (mgoldboi)
14:51:49 <mburns> i'm hesitant to hold the election today given that we don't have many people here
14:52:24 <mburns> but i'm also hesitant to not hold the election since we really need someone to start coordinating thing with the project
14:52:29 <mburns> any thoughts?
14:53:01 <rbergeron> mburns: i'm happy to share my miniature bucket o'tricks with the lucky winner but beyond that :)
14:53:30 <mburns> rbergeron: talking to you in san diego helped convince me that we need someone to do this
14:53:56 <mburns> rbergeron: and your offer is very much appreciated
14:54:51 <mburns> ok, so instead of voting here, how about we post it to the board list and ask for votes before Friday
14:55:13 <mburns> and perhaps another list as well?
14:55:18 <RobertM> mburns, Just the board or board and arch?
14:55:20 <dneary> mburns, Let's say that everyone on arch@ gets a vote, and do the election there
14:55:39 <mburns> that's fine with me
14:55:52 * mburns just didn't want to appear to be a dictator
14:56:02 <rbergeron> tricky when you're one of the names :)
14:56:22 <mburns> (at least not until i'm voted in (if that happens))
14:56:33 <mburns> rbergeron: exactly
14:56:47 <mburns> rbergeron: i could just say vote now and you have to be in attendance to win...
14:56:48 * dneary is in general not a fan of electing ppl to technical roles in the project, I prefer giving titles to people who are already doing the job :)
14:57:15 * dneary has another call in 2 mins
14:57:31 <rbergeron> mburns: winning is a funny word sometimes ;) lol
14:57:51 <mburns> ok, i'll send it to arch and board
14:57:53 <dneary> Moving to lurk mode
14:57:53 <RobertM> I was about to say.  It sounds more like lossing to me :)
14:58:06 <dneary> Thanks everyone! Better meeting today.
14:58:40 <mburns> and i'll abstain from comments about winning and whether winning is actually losing...
14:58:50 <mburns> #topic other topics
14:58:57 <mburns> ok, anything else to discuss today?
15:00:21 <mburns> ok, thanks all
15:00:24 <mburns> #endmeeting