14:02:41 <quaid> #startmeeting oVirt Infra weekly sync
14:02:41 <ovirtbot> Meeting started Tue Sep  4 14:02:41 2012 UTC.  The chair is quaid. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:41 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:02:53 <dneary> Hi quaid
14:02:55 * dneary is here
14:02:59 <quaid> #topic Roll call & agenda chat
14:03:03 * quaid here too
14:03:04 <quaid> hey dneary
14:03:06 * garrett_ is here
14:03:18 <quaid> #chair garrett_ dneary mburns RobertM eedri
14:03:18 <ovirtbot> Current chairs: RobertM dneary eedri garrett_ mburns quaid
14:03:27 * quaid has learned, give chair early and often
14:03:59 * RobertM here
14:04:01 * sgordon 
14:04:08 <mburns> dneary: no 2.5 --> ovirt 3.1
14:04:12 * eedri here
14:04:25 * mburns here
14:04:40 <quaid> ok, I'm looking in to the agenda, give me a moment ...
14:04:47 <dneary> mburns, And master -> 3.2 I suppose
14:04:52 <mburns> dneary: yes
14:04:53 * quaid took actual days off this long weekend
14:05:38 <mburns> quaid: days off?  what are those?
14:05:41 <quaid> ok, in no particular order I think we have:
14:05:44 <quaid> * Hosting
14:06:11 <quaid> * Task tracking
14:06:36 <quaid> last week:
14:06:38 <quaid> http://ovirt.org/meetings/ovirt/2012/ovirt.2012-08-28-14.00.html
14:06:58 <quaid> * Puppet (w/o ewoud)
14:07:08 <quaid> * Jenkins for a fun ending?
14:07:15 <quaid> anything else on anyone's mind?
14:07:19 <quaid> how are folks doing?
14:08:13 <garrett_> I'd like some more feedback on the designs & ideas I sent to the list, but I'm not sure if today's meeting is the place for that.
14:08:38 <ovirtbot> 14[[07Infrastructure team meetings14]]4 !10 02http://wiki.ovirt.org/w/index.php?diff=4356&oldid=4229&rcid=4457 5* 03Quaid 5* (+94) 10opening agenda for the day
14:09:04 <dneary> garrett_, Tomorrow's might be more appropriate, and we can perhaps ask that it be added to the agenda?
14:09:06 <quaid> garrett_: we'll want to talk back-end details about that - I know you have some ideas/concerns about the multiple content systems, etc.
14:09:15 <garrett_> dneary, yeah, that sounds good
14:09:24 <quaid> but yeah, Infra is more about implementing what the overall project wants
14:09:31 * mburns will add it to the agenda for tomorrow
14:09:35 <dneary> garrett_, And yes, back-end discussions (particularly around fixing search) are relevant here
14:09:46 <garrett_> okay, great
14:09:58 <quaid> garrett_: how about a section where you fill us in on the problems, I'll put it in the middle of the agenda
14:10:13 <garrett_> quaid, for tomorrow? sure. sounds great.
14:10:34 <ovirtbot> 14[[07Infrastructure team meetings14]]4 !10 02http://wiki.ovirt.org/w/index.php?diff=4357&oldid=4356&rcid=4458 5* 03Quaid 5* (+39) 10/* 2012-09-04 */ adding garrett's topics
14:10:45 <quaid> garrett_: I mean for today, those are relevant here I think
14:10:51 <garrett_> oh ok
14:10:58 <quaid> and it's good to talk about stuff multiple times, so it sinks in. OK?
14:11:01 <ovirtbot> 14[[07Meetings14]]4 !10 02http://wiki.ovirt.org/w/index.php?diff=4358&oldid=4287&rcid=4459 5* 03Mburns 5* (+13) 10/* Weekly project sync meeting */ 
14:11:03 <garrett_> sure
14:11:08 <quaid> ok then
14:11:17 <quaid> #topic Hosting ...
14:11:47 <quaid> my short take is, I'm overwhelmed by the options out there & am researching entirely from scratch
14:12:12 <quaid> RobertM & I still have to schedule a time this week to research together
14:13:01 <quaid> #idea get a BIG server to do Jenkins, and a not-so-BIG server to host VMs so we can split services to different hosts (e.g. wiki, lists, etc.)
14:13:24 <quaid> #info try to do that to start with $200/mon and see where that gets us
14:13:26 <RobertM> quaid, We also have gerrit
14:13:40 <quaid> RobertM: I was wondering if that could live on one of the VMs?
14:15:07 <RobertM> quaid, Might be able to if the 2nd box had decent IO gerrit biggest issue seems to be IO just like jenkins
14:15:07 <eedri> RobertM, quaid gerrit has periodic issues (stuck/non-responsive)
14:15:23 <eedri> RobertM, quaid maybe it's a good idea to understand if it related to performance issues
14:15:33 <eedri> RobertM, quaid before moving it to a new server
14:16:19 <eedri> RobertM, you believe its IO related ?
14:17:07 <quaid> #info Gerritt may need a good IO, cf. Jenkins
14:17:07 <RobertM> eedri, The speed issue I think are.
14:18:28 <RobertM> The completely Stuck / Non-responsive issue I am not as sure about since I haven't been able to log into gerrit well it is happening
14:19:05 <eedri> itamar, ^^
14:19:28 <eedri> itamar, do we know why gerrit is periodicly stuck? it might help deciding on new vm/hardware to migrate it to
14:20:46 <itamar> gerrit is peridically stuck due to a jetty bug on heavy load. a stronger/faster machine makes this less of an issue.
14:21:20 <itamar> if it won't solve it, we can do a tomcat container instead of jetty, but it doesn't seem to be a very common deployment, and i prefer KISS
14:21:28 <itamar> so we can go with stronger/faster.
14:21:45 <quaid> ok
14:21:48 <itamar> then we can add the cron job other people added which checks if the log contains the jetty error and recycles the service
14:22:28 <quaid> #info Gerritt occasional sticking problem due to jetty bug on heavy load; stronger/faster machine will help make this less of an issue; an alternate is to run the less common configuration of Tomcat as a container
14:22:59 <quaid> #idea add cron job that checks if the log contains the jetty error, then recycles the service
14:23:09 <quaid> ok, I think that gives us a fair architecture to consider
14:24:57 <itamar> I'd also consider a cron that restarts the service every saturday for good measure
14:25:21 <quaid> #idea weekly cronjob to restart jetty (on Saturday) just in case
14:25:40 <itamar> btw, it was just down now, unrelated to the jetty issue (first time in a few months i see a hang not related to the jetty issue)
14:25:48 <quaid> ok, I'll schedule some time with RobertM to see if we can narrow down options for hosting - KVM based, etc.
14:25:50 <itamar> restart solve the issue.
14:26:14 <eedri> itamar, jenkins info queue is big, might be it affects gerrit service?
14:26:23 <itamar> info queue?
14:26:29 <eedri> itamar, we seem to have a long backlog that current vm can't handle
14:26:41 <eedri> itamar, i mean jenkins.ovirt.info that runs all the patch jobs
14:27:20 <itamar> git pull will be heavy till we move to a new server, but the hang didn't seem related to that.
14:27:49 <itamar> also - maybe allow a jenkins jobs to a few people to restart gerrit on these hangs (limited permission to jenkins, limited permission to the job to more people) - so resatrting the gerrit service won't need permissions to the gerrit server itself
14:28:33 <eedri> itamar, we could add sudo access to 'service' and 'jenkins' user
14:28:38 <eedri> itamar, on gerrit server
14:29:00 <itamar> that's what i meant, or to a script which does 'service gerrit restart'
14:29:28 <itamar> then you can schedule the restart on saturdays from jenkins, plus, allow selected people a permission to run it manually on a gerrit hang
14:29:57 <eedri> #action add jenkins job to run remote cmd on gerrit.ovirt.org that will restart gerrit service. requires sudo access for jenkins user on gerrit
14:30:04 <quaid> +1
14:30:23 <quaid> anything more on hosting?
14:30:42 <quaid> #action quaid and RobertM to meet on IRC to narrow down & pick some hosting options
14:30:47 <quaid> kind-of a carryover from last week :)
14:32:09 <quaid> ok, moving to the next topic ...
14:32:28 <quaid> #topic Infra task trackers
14:33:09 <dneary> quaid, On task trackers: Is it possible to re-use something we use already, instead of adding Yet Another Tool?
14:33:27 <dneary> quaid, I lose track of all the bugzillas, redmines, tracs, wikis, ...
14:33:57 <eedri> i think we should start with what we have, i.e Trac
14:34:23 <eedri> unless someone is volunteering to install a new server :)
14:35:04 * quaid reads the thread on the list, is back
14:35:26 <quaid> right, easiest is to use the oVirt Trac instance on fedorahosted.org
14:35:49 <quaid> this is about giving this team a place to track it's work, and secondarily giving people a way to file requests instead of "email the list"
14:36:25 <agwells0714> RobertM: yt?
14:37:19 <quaid> there is some risk in switching around later, but as this is not a project wide service with lots of interactions (such as the bug tracker) ...
14:38:18 <quaid> I'll reply to RobertM's comments on list, so we don't have to drag on here
14:38:41 <quaid> #action decide on task trackers on the infra list
14:38:55 <quaid> #topic Website, CMS, broken search
14:39:15 <quaid> garrett_: I read a bit about this from yesterday, but can you fill us in on what is broken about search and how we are managing content on *.ovirt.org?
14:39:34 <garrett_> right now, if you search for pretty much anything, you will not find what you're looking for
14:39:52 <garrett_> part of the reason is because the most useful documentation is hosted on the wiki, and in PDFs
14:40:07 <RobertM> The two ways other projects have seem to do it is 1) override internal search and simple use goggle
14:40:10 <quaid> so search on the WordPress side then?
14:40:10 <garrett_> however, we do also have some useful content on the WordPress hosted site too, but not nearly as much
14:40:14 <quaid> as opposed to the wiki search?
14:40:24 <garrett_> right now, the search is on the WP side, not the MW side of things
14:40:35 <quaid> there is a MW search, just on the wiki.o.org side
14:40:46 <garrett_> I think it's pretty confusing to have more than one project website
14:40:51 <garrett_> and no order between the two of them
14:41:16 <garrett_> the more I work on these mockups, the more I think we should seriously consider switching to a wiki-powered site so everything's in one place
14:41:25 <garrett_> it shouldn't look wiki-ish
14:41:33 <garrett_> but can be powered by MediaWiki
14:42:09 <garrett_> there are a few reasons for considering switching everything to the wiki, too
14:42:18 <garrett_> 1) content is all in one place
14:42:39 <garrett_> 2) because the content is in one place, we can have search work ourselves, without relying on external parties (such as google)
14:42:52 <garrett_> 3) the new site design can be implemented once, not multiple times
14:43:10 <garrett_> 4) we can make the navigation a bit more clear for users of the site
14:43:35 <garrett_> 5) there's no question where the content belongs (right now we have to ask if it should go to WP or MW)
14:43:42 <quaid> MW is as extensible as WP, I'm just less familiar with what is out there
14:43:48 <garrett_> 6) it enables more people to edit the pages
14:44:22 <garrett_> quaid, yes, I'm more familiar with WP than MW too, but have set up sites using both before in the past
14:44:31 <RobertM> #6 can be consider a con as well.
14:44:34 <garrett_> and also, yes, MW is very extensible too
14:44:56 <garrett_> RobertM, we wouldn't want just anyone messing with the front-facing pages, naturally, so those should be locked down
14:45:04 <garrett_> like top-section-level
14:45:09 <cctrieloff> garrett_: If we can make it look slick, then that seems a good way to go.
14:45:15 <quaid> RobertM: generally, we want content editing barriers as low as we can make them, in a FOSS project that is :)
14:45:20 <garrett_> front page, and first page for the navigation (with the exception of docs and/or development)
14:45:38 <garrett_> cctrieloff, we definitely can make it look slick
14:45:50 <garrett_> quaid, totally
14:45:54 <cctrieloff> I know there is also a trend to put teh full site in GIT, and then have it generated. both work, with the key being everyone can edit / work on it and have it look really good
14:45:59 <quaid> garrett_: my biggest concern is going to be, can we extend the website based on MW without having to bring a PHP hacker in to Infra just for that :)
14:46:10 <RobertM> I haven't really seen main project based entirely on mediawiki look slick.
14:46:13 <garrett_> I agree: having a git-based site is another valid approach
14:46:26 <quaid> cctrieloff: so folks have to check in /out of git to edit the site? sounds like a high barrier, though
14:46:34 <garrett_> whatever we do, we should have 1 way of doing things, and it should be consistent and simple for people to contribute
14:46:48 <garrett_> there are git-based wikis
14:46:56 <quaid> for content, we want to be sure *users* can edit
14:46:57 <garrett_> github uses one, and it's open source too
14:47:01 <quaid> ok, I see
14:47:07 <quaid> back to the extensible part - plugins, etc.
14:47:11 <garrett_> it uses markdown, so it's plain text for editing
14:47:16 <cctrieloff> having the project show well I needs to be a large consideration..
14:47:29 <garrett_> https://github.com/github/gollum
14:47:48 <quaid> unless gollum has a nice ecosystem we can pull from ...
14:48:08 <garrett_> quaid, we should define what we want from any ecosystem
14:48:18 <quaid> ok
14:48:40 <garrett_> I think we can probably get away with a minimum of extensions/plugins/add-ons/etc.
14:48:55 <garrett_> and still have a very compelling, useful website
14:48:56 <quaid> #idea Popular enough so the pool of Infra hackers is wide and deep
14:49:50 <quaid> #idea Pool of extensions that we can draw from so we have to invent little to none
14:50:03 <RobertM> Personally I think what we have works just needs some cleanup.  There are a few ways to combine search between the sites.
14:50:24 <quaid> RobertM: there are a few things not addressed with that, though
14:50:44 <quaid> RobertM: for example, where do you put content? WP or MW? How do you know when you've got something to post where it goes?
14:51:27 <quaid> RobertM: there is also #3, not having to implement a new design in two different theming systems (WP, MW)
14:51:33 <clag> hi all, can someone confirm that dns SRV port is 389 for using ovirt with rhds ?
14:52:12 <quaid> #idea Github's gollum is a git-backed wiki that is growing in popularity, may work
14:52:37 <garrett_> for oVirt, I think having a wiki of some sort makes a lot of sense, and that's why I'm suggesting to transition to a wiki-only site
14:52:52 <garrett_> since it can do everything WordPress is doing for us right now
14:53:05 <garrett_> later on, we can tack on a blog too, if we desire
14:53:21 <garrett_> rather than tacking on a wiki for content on top of a content site powered by a blog engine
14:53:57 <dyasny> quaid, ping
14:54:00 <quaid> +1 on wiki being a great lowest-common tool
14:54:04 <quaid> dyasny: pong
14:54:11 <RobertM> garrett_, quaid I agree having a wiki is a good idea but maybe I have never seen it done right but every site I have seen based entirely on a wiki looks poorly done
14:54:17 <dyasny> quaid, you're in a meetting? or can I bug you a bit?
14:54:24 <garrett_> RobertM, then let's do it right
14:54:24 <quaid> dyasny: just replied that plugins.ovirt.org DNS entry is there
14:54:43 <quaid> dyasny: this is OK, but we're going to wrap up the meeting in a few minutes, if you want to wait until then
14:54:46 <garrett_> I'm pretty certain we can implement it correctly
14:54:51 <dyasny> quaid, sure, I'll wait
14:55:05 <quaid> garrett_: do you have any good examples of MW used this way?
14:55:34 <garrett_> quaid, I don't know of any off the top of my head anymore, but we did set up some years back this way when I worked at Novell
14:55:47 <garrett_> and I have seen it done this way before too
14:55:59 <garrett_> and, if they're done correctly, then you wouldn't notice anyway
14:56:31 <quaid> right!
14:56:41 <quaid> let's see if we can find a few, might help that part of the discussion
14:56:41 <garrett_> for example, we wouldn't have edit links by default — only when you have an account, are logged in, and have access to edit a page (which is by default, except for special pages)
14:56:46 <RobertM> I am not sold on wordpress either.  I just feel that the front page needs to be well defined with fairly static content that leads to other area's like the wiki
14:56:59 <garrett_> RobertM, like my mockups, for example?
14:57:00 <quaid> RobertM: I think that is something we all agree on :)
14:57:20 <garrett_> I can make a wiki look like that, or whatever else we agree upon
14:57:26 <garrett_> that's not a problem
14:57:46 <quaid> garrett_: OT, but the point I want to see get worked on is your ideas around a single download - the rest of the stuff you suggest is not very controversial (except to a WordPress nerd like me)
14:58:02 <garrett_> there are probably clean enough themes to use as a starting point these days (as opposed to starting completely from scratch)
14:58:03 <quaid> ok, I didn't want us to come to a decision here
14:58:18 <quaid> just to open the discussions so we understand more what we have to discuss with the entire project
14:58:19 <garrett_> quaid, yes, I agree
14:58:31 <garrett_> quaid, on the OT part... we should talk about that too
14:58:54 <garrett_> it's important for the project in a few ways
14:59:01 <quaid> this topic is going to be in the main meeting tomorrow, and we are trying to keep the arch@ discussion going
14:59:07 <garrett_> and should probably be a bit controversial (:
14:59:26 <RobertM> There are other consideration as well.
14:59:53 <garrett_> quaid, although not controversial, I would like to move forward with the logo tweak, the color, and overall site design in general too
15:00:25 <RobertM> garrett_, What I saw of your new design I liked
15:00:28 <quaid> garrett_: I totally get your desire to pick one theme system, though, so let's see if we can get that decision by tomorrow?
15:00:47 <garrett_> quaid, that sounds great
15:02:01 <quaid> garrett_: ok, let's wrap up here, we've got a call to distract us
15:02:19 <quaid> shall we close?
15:02:28 <quaid> or continue with remaining topics, the famous Puppet and Jenkins?
15:02:46 * eedri is about to leave soon..
15:03:01 <garrett_> quaid, sounds good to me
15:03:05 * quaid is distracted now
15:08:30 <quaid> ok, I'm going to close the meeting with the close of interest :)
15:09:14 <quaid> #endmeeting