14:00:39 <mburns> #startmeeting oVirt Infra weekly meeting
14:00:39 <ovirtbot> Meeting started Tue Aug 28 14:00:39 2012 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:39 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:44 <mburns> #chair eedri RobertM
14:00:44 <ovirtbot> Current chairs: RobertM eedri mburns
14:00:58 * RobertM here
14:01:00 * mburns has no idea what topics/agenda items we have
14:02:01 * eedri here
14:03:25 * ewoud here
14:03:42 <ewoud> think quaid said he was on a plane
14:03:43 <RobertM> Last over items are, New hosting for Gerrit / Jenkins, and Generally Jenkins fun
14:03:58 <RobertM> quaid, is around
14:04:07 <RobertM> But he is on airplane wifi
14:04:15 <RobertM> Last=Left
14:04:25 <mburns> ok
14:04:31 <mburns> #topic Hosting
14:04:38 <mburns> who owns this particular topic?
14:05:08 <RobertM> quaid, I believe but he was looking for input on hosting providers from the group
14:05:14 <ewoud> I think the problem with hosting is now that nobody really owns it
14:05:19 <ewoud> if anyone quaid indeed
14:06:02 * ewoud recalls something about a proposal
14:06:05 <ovirtbot> 14[[07Special:Log/upload14]]4 upload10 02 5* 03Mburns 5*  10uploaded "[[02File:Ovirt-node-2012-08-28.odp10]]": Presentation for oVirt Node at LinuxCon North America oVirt Workshop 2012-08-28
14:06:21 <RobertM> Part of the problem is everyone has there own pet ISP and we have very limited budget for the hosting.
14:06:49 * mburns has no opinion...
14:06:57 <mburns> i've never really worked with any hosting providers
14:07:33 <ewoud> I only have worked with my employer and another local one
14:07:35 <RobertM> I think as a group we were suppose to find options for getting 2 dedicated boxes and a few VPS for around $150.
14:07:42 <ewoud> and a university
14:07:57 <RobertM> Preferably in the EU or US.
14:08:17 <RobertM> But it would be paid in use Dollars
14:08:44 <ewoud> first I think we should choose if we want to hire boxes or buy boxes and colocate
14:09:42 <ewoud> RobertM: according to http://ovirt.org/meetings/ovirt/2012/ovirt.2012-08-14-14.00.html you would kick off the hosting proposal on the ML
14:09:51 <ovirtbot> 14[[07Special:Log/upload14]]4 upload10 02 5* 03Mburns 5*  10uploaded "[[02File:Ovirt-node-2012-08-28.pdf10]]": Presentation for oVirt Node at LinuxCon North America oVirt Workshop 2012-08-28
14:09:58 <RobertM> ewoud, It has to be rental boxes as the bugget is pretty small.
14:10:06 <ovirtbot> 14[[07Category:Node14]]4 !10 02http://wiki.ovirt.org/w/index.php?diff=4336&oldid=4115&rcid=4436 5* 03Mburns 5* (+69) 10/* Presentations */ 
14:10:29 <RobertM> ewoud, It was kicked off and went pretty much no where.
14:10:39 <ovirtbot> 14[[07Category:Node14]]4 !10 02http://wiki.ovirt.org/w/index.php?diff=4337&oldid=4336&rcid=4437 5* 03Mburns 5* (+4) 10/* Presentations */ 
14:10:48 <ewoud> RobertM: true
14:11:30 <RobertM> I don't think we are ready to make a call on this we need more options.
14:11:52 <mburns> #info not enough information or options to make a decision here yet
14:12:09 <RobertM> #action RobertM to try and find 3 hosts that will fit the budget and needed spec's before next week.
14:12:26 <mburns> anything else for hosting?
14:12:34 <RobertM> I think not.
14:12:59 <mburns> anything else to discuss before going to jenkins?
14:13:07 <ewoud> mediawiki upgrade?
14:13:19 <mburns> #topic medawiki upgrade
14:13:37 <ewoud> I think we don't run special plugins
14:13:42 <ewoud> see http://wiki.ovirt.org/wiki/Special:Version
14:14:16 <ewoud> didn't see any objects, but I don't have access
14:14:22 <ewoud> objections*
14:14:56 * mburns hasn't read the thread yet...
14:14:59 <RobertM> My only concern is downtime and what might break when we upgrade.
14:15:19 <ewoud> RobertM: we can manage that by announcing downtime and a backup
14:15:44 * mburns agrees on announcing downtime/backup
14:15:58 <mburns> though next week at the earliest for the actual upgrade
14:16:12 <RobertM> ewoud, It is more how long vs the process.
14:16:27 <ewoud> RobertM: not long, my colleague did it for our internal wiki as well
14:16:52 <ewoud> I'll poke on the ML and try to pick a date
14:17:27 <RobertM> #action ewoud to work with quaid and RobertM to pick a date for upgrade.
14:17:55 <RobertM> Ok next topic? Anything else before Jenkins?
14:18:16 <mburns> #topic Jenkins
14:18:37 * mburns puts hard stop at 7:40
14:18:47 <mburns> currently it's 7:18
14:19:37 <ewoud> RobertM: eedri these are your points usually
14:19:52 <RobertM> Jenkins is still dual brain. Ovirt.org does the master branch and jenkins.ovirt.info does patches.  There have been a few issues with the patch process in part because of a copy and paste mistake on my part when I brought 3 new slaves online.
14:20:20 <eedri> ewoud, were there open issues on jenkins from last meetings? i can't remmeber
14:20:52 <eedri> ewoud, i think next thing we can push forward is running automation test on an hypervisor
14:20:53 <ewoud> eedri: I wasn't really attending the last meeting, but I'll check the minutes
14:21:09 <eedri> ewoud, as long as we have a physical server to run it on
14:21:34 <eedri> ewoud, meaning a test that install install rhevm + add host + run rest api/cli/sdk tests
14:21:36 <ewoud> eedri: but that depends on the hosting
14:21:36 <RobertM> jenkins.ovirt.info has 2 physical and 3 virtual servers.
14:21:54 <eedri> ewoud, we can start using ovirt.info hosts
14:21:58 <ewoud> true
14:22:24 <RobertM> Even if we merge the 2 once on hosting those 2 boxes could become slaves.
14:23:23 <eedri> RobertM, we'll need a phsyical host that won't be slave in jenkins
14:23:40 <eedri> RobertM, since the hypervisor might reboot during install,etc..
14:23:53 <ewoud> eedri: any chance of using KVM nested virtualisation?
14:24:04 <RobertM> but the per patch processing is kicking jenkins.ovirt.info butt.  Even with the 3 new VM's The jobs run an hour or more behind in the Morning hours in EST timezone
14:24:33 * eedri thinks of using my server jenkins-upstream-f16-host01
14:24:54 <eedri> its a test physical server i've added
14:25:18 <eedri> RobertM, we can connect it to ovirt.info instead if it will be faster
14:25:51 <eedri> ewoud, never tested nested virtualization
14:26:24 <RobertM> I am not sure what is needed I am getting some more Hardware at the end of the year what do we need?
14:27:02 <eedri> RobertM, does ovirt.org specify min req for a hypervisor?
14:27:06 <RobertM> Ebay hardware can be found cheap for less then $200 you can get a pretty decent piece of hardware.
14:27:18 <mburns> nested virt is questionable...
14:27:23 <mburns> it's pretty slow in general
14:28:29 <eedri> i think we can start with the current host, i'm not using it at the moment
14:29:09 <RobertM> eedri, Do we know how we are going to manage these hosts? PXE?  Etherboot?
14:30:02 <RobertM> We need something that will allow us a lot of control over the OS so we can install what is need and clean up failures.
14:31:03 <RobertM> or is it something that we just need ssh access to a base f17 build?  And we can just install unistall software on a static host.
14:32:12 <eedri> RobertM, well
14:32:34 <eedri> RobertM, once we'll have foreman+puppet we'll be able to provision and reinstall hosts
14:32:57 <eedri> RobertM, but, if we have a static host, f17 for example. we don't need to pxe install it all the time
14:33:24 <eedri> RobertM, the test will run vdsm-bootstrap and install vdsm/libvirt/etc... but not the OS
14:33:45 <mburns> you're talking about running vm's on a base host and how to manage the vms, right?
14:34:18 <mburns> base os should not ever be reprovisioned
14:34:21 <eedri> mburns, i'm talking about running automatic tests via restapi/cli/sdk
14:34:27 <RobertM> mburns, That is what I am asking?  It sounds like they want raw hardware because of the virtual needs.
14:34:30 <eedri> mburns, exactly
14:34:36 <mburns> eedri: right
14:34:50 <eedri> mburns, it will need to reprovision only if we want to use the host for other os, like rhel
14:35:03 <eedri> mburns, if we want to test ovirt for rhel hypervisors
14:35:10 <mburns> two options for the vms:  run local pxe server on the machine, or have a set of base disk images that you always reset to
14:35:24 <eedri> we're using cobbler
14:35:41 <eedri> for rhevm, i guess we can install a cobber server for ovirt
14:35:52 <mburns> start your vms against copies the base images, then after the test, reset back to base images
14:35:59 <RobertM> does cobber support WAN?
14:35:59 <mburns> then no need for cobbler
14:36:06 <mburns> we don't want cobbler
14:36:22 <mburns> we want puppet/foreman eventually
14:36:47 <mburns> but short term using either base disk images that are pre-installed with the os we want or using a simple local tftpboot server should be sufficient
14:37:05 <eedri> mburns, yes, that is ideally, though haven't had the chance to use it yet for installing vms in a test
14:37:10 <RobertM> mburns, eedri Unless we are planing to get a colo so place how do we pxe boot systems at remote locations unless I am missing something pxe can do.
14:37:35 <mburns> RobertM: networking is completely internal to the machine (libvirt network)
14:37:53 * ewoud back
14:38:08 <mburns> run tftpboot services on real hardware and have libvirt network pxe boot from physical host
14:38:12 <mburns> never leaves the machine
14:38:13 * RobertM is missing something
14:38:32 * mburns misses having a whiteboard to explain...
14:38:47 <eedri> etherpad?
14:38:50 <mburns> RobertM: 1 physical host running any OS (rhel, fedora, whatever)
14:39:06 <RobertM> mburns, Maybe you can explain it this afternoon in person.
14:39:09 <mburns> on top of that machine you run vms for engine and vdsm hosts
14:39:21 <mburns> you also run a tftp server
14:39:50 <RobertM> I have do those kind of setups inside a LAN but I don't know how we could do that over a WAN
14:39:52 <mburns> the network definition of the vms tells it to pxe from the physical server
14:39:56 <RobertM> do=done
14:40:13 <mburns> RobertM: yeah, we can discuss this afternoon if you want
14:40:16 * eedri also doesn't have experience over WAN
14:40:31 <mburns> but basically, there is no WAN, you run the test completely within 1 physical host
14:41:20 <RobertM> If we want to get like 10 core-duo and stack them in someone basement / a colo I can it being done pretty easyly but tiring to do it over the WAN I am having trouble.
14:41:43 <mburns> RobertM: ok, lets discuss later today, then we'll summarize for people on the list
14:41:52 <RobertM> mburns, That works for me.
14:41:52 <mburns> we have to run anyway
14:41:55 <RobertM> Yep
14:41:59 <eedri> +1 for contining this issue on the list
14:42:07 <mburns> ok anything else?
14:42:16 <eedri> puppet status?
14:42:31 <mburns> can we defer that? or take it on list?
14:42:36 <eedri> sure
14:42:49 <mburns> thanks
14:43:09 <mburns> #action mburns and RobertM to discuss jenkins test deployment and report back to list
14:43:19 <mburns> #action take puppet status to list
14:43:23 <mburns> ok, thanks all
14:43:25 * mburns has to run
14:43:28 <mburns> #endmeeting