15:06:23 <quaid> #startmeeting vdsm-hooks - scope and plans
15:06:23 <ovirtbot> Meeting started Fri Aug 24 15:06:23 2012 UTC.  The chair is quaid. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:06:23 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:06:24 <gestahlt> re
15:06:32 <quaid> #chair dyasny
15:06:32 <ovirtbot> Current chairs: dyasny quaid
15:06:49 <quaid> all: go ahead and talk around us, we're just using the meetbot to log a discussion, etc.
15:06:53 <dyasny> quaid, ok, so I've had a call with acathrow and we decided we need to think another step ahead, and create a top level domain/portal section called "plugins"
15:07:31 <dyasny> quaid, so it's going to be plugins.ovirt.org and ovirt.org/plugins under which we can place all the pluggable stuff, uncluding vdsm-hooks
15:07:37 <dyasny> quaid, make sense?
15:08:20 <quaid> it does to me
15:08:41 <dyasny> quaid, cool. so hat's AI #1
15:08:41 <quaid> perhaps we should check the scheme with arch@ before we make any more changes or work, though
15:08:58 <dyasny> quaid, I thought it was an Infra thing?
15:09:03 <quaid> that is, once we work out here all the details we can think of, we take it to the main list for input
15:09:08 <quaid> doing the work is an Infra thing, sure
15:09:14 <quaid> but you see what has happened already?
15:09:14 <dyasny> ah ok
15:09:36 <quaid> I got asked to urgently make hooks.ovirt.org, but that wasn't really the full scope needed
15:10:00 <quaid> you and andy got further ideas, etc. - so before we do more work, perhaps we want to be sure there isn't something else?
15:10:41 <dyasny> quaid, you're right. so lets define what we want. I say we need a top level locations for everything pluggable, under which, that which currently concerns me most- a location for vdsm hooks
15:10:41 <quaid> but fwiw :) it makes sense to me to have a generic subdomain that has specifics under it
15:11:24 <quaid> ok plugins.ovirt.org/vdsm-hooks/... makes sense
15:11:36 <dyasny> +1
15:11:48 <RobertM> +1
15:12:26 <dyasny> ok, in vdsm-hooks (probably not the case for every type of pluggable content) we need some kind of standard engine that will display the available hooks in a specific format
15:13:17 <dyasny> quaid, not to get into the actual design, but there's got to be something premade we can install, that will look like the sites I've emailed you about - extensions.gnome and gallery.zimbra and marketplace.redhat
15:13:35 <quaid> +1 agree there must be something we can mostly Just Use
15:13:54 <dyasny> quaid, any ideas as to what? I'd really hate to dirty my hands with php :)
15:14:23 <quaid> (yet that's what the rest of the web properties run)
15:14:31 * dyasny looks at opensourcecms.org
15:14:49 <quaid> right, I'm more scared with the 10,000 options
15:15:10 <quaid> we can probably use WordPress with some extensions
15:15:24 <dyasny> right, I'll look for a usable extension
15:15:30 <MTecknology> RobertM: :)
15:15:50 <dyasny> quaid, what version of WP do we have?
15:16:03 <RobertM> Don't forgot you have me and I large live in a php world.
15:16:04 <quaid> perhaps each hook is a post, and the post has comments, a ranking system, tags, and categores -- only ranking isn't built in yet
15:16:36 <quaid> dyasny: usually the latest WP
15:17:06 <RobertM> How do some of the other projects handle it?
15:17:10 <quaid> 3.3.2
15:17:18 <quaid> #info WordPress version is 3.3.2
15:17:29 <dyasny> quaid, lets define what we want, and then try to adapt the CMS to that. So, we have a hook, and it has a bunch of properties - version, compatibility, rating, download count, links to the RPM, comments...
15:17:32 <quaid> #agreed plugins.ovirt.org/sub-dir-per-project-need makes sense
15:18:04 <quaid> tags, categories
15:18:16 <quaid> links to other downloadable formats
15:18:31 <quaid> link to the RPM that makes all this a yum repo :)
15:18:57 <dyasny> quaid, something like pkgs.org
15:21:24 <quaid> dneary: I have no problem adjusting the length of the bio if 50 words is too long; I don't like when people try to skip it like it doesn't matter, though. Perhaps 25 words is a good compromise there?
15:21:46 <quaid> dyasny: cool
15:22:11 <dyasny> quaid, ok, so I'll look for a suitable plugin for WP. How long does it take to test and install one?
15:22:18 <dneary> quaid, What's the point of the bio?
15:22:35 <dneary> If it's to introduce yourself on your User: page, then I think maybe 10 words is enough
15:22:50 <dneary> I OKed one account today where there were 37 "Test" words :)
15:23:17 <dneary> It was something like "I work on oVirt Node and VDSM for PPC Test test test test...."
15:28:09 <quaid> dneary: yes, it automatically populates the User: page
15:29:59 <quaid> dneary: I dunno, I don't particularly care personally, but I do think it's a nice thing to have _something_ on one's user page, and otherwise people usually put nothing; I guess 10 words is better than nothing, but if it's what you just wrote as an example, it's barely better than nothing (from a human perspective.)
15:30:41 <quaid> dyasny: install is instantaneous - drop in place and it goes, usually, although some have additional requirements for install
15:31:19 <quaid> dyasny: we could test things using an OpenShift WordPress quickstart, especially if it changes the main WP install significantly
15:32:17 <dyasny> quaid, ok, I'll start looking into the plugin, and we'll move on from there. now about the actual RPMs - they are built for fedora and fsimonce is going to push them into EPEL next week, so we'll have both f17 and el6 versions
15:32:21 <quaid> #agreed Plugin system should include: version, compatibility, rating, download count, links to the RPM/package formats, comments, tags, categories, link to the RPM that makes an 'ovirt-plugins' repo
15:32:46 <quaid> are they both going to be downloadable directly from Fedora then?
15:33:11 <dyasny> quaid, I've heard several suggestions, from building them locally, to linking to fedora nad epel repos
15:33:32 <dneary> quaid, I agree
15:33:42 <dneary> It's not nice to have User pages be dead links
15:33:43 <dyasny> quaid, problem is, with every build of vdsm, the hook version will also move on, so keeping track of the links to the actual RPMs is going to need to be automated somehow
15:33:53 <dneary> But I think that 10 words as a minimum should be enough.
15:35:32 <quaid> dyasny: right, I was hoping there would be some automation - perhaps the links can be to a symlink, and a cronjob can rewrite the symlink on the file system?
15:35:45 <quaid> oh, but then what would the eventual file name be - the versioned one or the non-versioned symlink?
15:36:17 <dyasny> quaid, exactly, we need to find out how other sites do it
15:36:19 <quaid> #info Every build of VDSM will reversion the hook, keeping track of the links to the RPMs needs to be automated
15:37:06 <quaid> #info WordPress may have an extension we can use, something that is about a catalog of goods, software collection would be best
15:42:11 <RobertM> Jenkins / scripting could be use to update symlinks
15:42:42 <RobertM> aka hook-xxx-latest -> hook-xxx-version
15:44:06 <dyasny> quaid, ^^ this is a good idea
15:45:11 <quaid> but then the file name downloaded doesn't have the version in the name, right?
15:45:41 <quaid> #idea Jenkins & scripting could be used to update symlinks
15:46:06 * quaid meant to use #idea for a few others, oh well
15:46:44 <dyasny> quaid, why? it'll be the current RPM, links in WP updated by the build engine
15:49:10 <quaid> dyasny: won't it be "hook-xxx-latest.rpm" rather than "hook-xxx-version.rpm" when downloaded?
15:49:15 <MTecknology> RobertM: could i pm?
15:50:34 <dyasny> quaid, in yum search they all look the same - vdsm-hook-<name>.noarch
15:51:54 <quaid> k
15:54:05 <gestahlt> Meeting finished?
15:55:35 <MTecknology> I need to edit pom.xml and change ${project.parent.basedir} and ${project.build.directory} to .. or else I get this...      [echo] *** Copying configuration file from ${project.parent.basedir}/backend/manager/conf/standalone.xml to /opt/jboss/standalone/configuration
15:55:51 <quaid> gestahlt: most likely :)
15:55:52 <MTecknology> I don't know if that's a bug or something I did wrong
15:56:01 <quaid> dyasny: did we get all that you wanted down about the service?
15:57:33 <dyasny> quaid, yup, I'd like to lay down a roadmap with some approximate dates out of this
15:57:50 <gestahlt> Okay, im missing the ovirtmgmt bridge in the all in one solution
15:57:56 <gestahlt> How do i create it ideally?
16:01:16 <quaid> dyasny: that's fine, I guess it should mainly be dates where you have resources to make it happen
16:01:32 <quaid> dyasny: if we need PHP hacking help, we can ask
16:02:04 <dyasny> quaid, ok then
16:02:18 * dyasny off to the next meeting
16:03:28 <RobertM> MTecknology, Good thing to note for when I begin packaging
16:03:39 <quaid> #endmeeting