14:01:39 <mburns> #startmeeting ovirt weekly meeting
14:01:39 <ovirtbot> Meeting started Wed Aug 15 14:01:39 2012 UTC. The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:39 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:52 * RobertM here
14:01:55 * lh is here
14:01:56 <mburns> #topic agenda and roll call
14:02:04 * dustins here
14:02:14 <mburns> Status of Next Release
14:02:14 <mburns> Sub-project reports (engine, vdsm, node, infra)
14:02:15 <mburns> Upcoming workshops
14:02:15 <mburns> Backup for Release Manager
14:02:32 * quaid is lurking, distracted
14:02:36 * garrett_ is here
14:02:57 * dougsland here
14:04:37 <mburns> #topic Release status
14:04:43 <mburns> #info 3.1 is released
14:04:46 * eedri here partially
14:04:51 <mburns> #info time to start planning for 3.2 release
14:06:39 <mburns> according to the wiki, we should be discussing release criteria for the 3.2 release
14:06:45 <mburns> #link http://wiki.ovirt.org/wiki/Release_Process
14:07:32 <mburns> i think for this meeting, i'll simply say: think about release criteria and we can discuss next week
14:08:03 <mburns> i'll send out a mail asking for release criteria input before the next meeting
14:10:05 <mburns> any objections to having that discussion next week?
14:10:27 <RobertM> mburns, +1
14:11:09 <mburns> #action mburns to send out mail on release criteria for 3.2
14:11:22 <mburns> #info responses to be discussed on next week's meeting
14:11:43 <mburns> #topic Sub-Project reports -- node
14:11:48 <mburns> #info nothing new to report
14:12:05 <mburns> #info waiting on new kernel for a new ovirt-node iso build
14:12:33 <mburns> #topic Sub-Project reports -- vdsm
14:12:42 <mburns> dougsland: anything new to report on vdsm?
14:13:06 <dougsland> mburns, afaik, nothing new as well
14:13:26 <mburns> #info nothing new for vdsm
14:13:32 <mburns> #topic Sub-Project reports -- engine
14:13:45 <mburns> doron: anything new on the engine front?
14:14:27 <doron> mburns: sorry, was otp
14:15:13 <mburns> doron: anything new for engine? issues that came up in 3.1 release that need fixing? etc...
14:16:00 <doron> mburns: Not that I'm aware of, but I'd like to verify before making this final.
14:16:08 <mburns> doron: ok
14:16:16 <mburns> #info nothing new to report
14:16:34 <mburns> doron: let me know if there is something we should be aware of
14:16:41 <mburns> #topic Sub-Project reports -- infra
14:16:45 <doron> mburns: very well.
14:16:46 <mburns> RobertM: quaid: ?
14:17:55 <RobertM> Infra enabled per patch review of the engine over the weekend.
14:18:15 <mburns> #info per patch review of engine patches enabled
14:18:15 <RobertM> That means all the major projects have per patch coverage.
14:18:52 <mburns> #info all major projects are now building with each patch submission
14:19:06 <eedri> i have a query about make rpm that related to infra
14:20:01 <eedri> in order to allow nighly builds, we need to enable 'make rpm' in all projects to create rpm names with the git sha included
14:20:13 <mburns> eedri: yes, we do
14:20:14 <eedri> it is done for some projects (vdsm/ovirt-node) but not all of them
14:20:31 <mburns> eedri: can you get a list of the projects that are not doing this?
14:20:40 <eedri> ovirt-engine for starts
14:20:45 <mburns> we'll ping the maintainers directly (or we can submit patches)
14:21:02 <eedri> ovirt-cli/ovirt-sdk
14:21:23 <mburns> eedri: should be a simple process
14:21:41 <eedri> mburns, patch to the makefile i assume
14:22:45 <mburns> eedri: might be able to do it with just a spec file change
14:23:04 <mburns> and then a tweak of the build scripts in jenkins
14:23:07 <mburns> but i'd need to look
14:25:03 <mburns> eedri: probably a small Makefile change as well actually
14:25:26 <mburns> eedri: i'll take a look at engine and cli/sdk
14:25:33 <eedri> mburns, thanks
14:25:35 <mburns> probably simple to fix in both cases
14:26:05 <mburns> #action mburns to look at engine and cli/sdk for building with some hash (git, date) in jenkins
14:26:21 <mburns> #topic upcoming workshops
14:26:26 <mburns> lh: you're up
14:26:45 <lh> mburns, thanks
14:27:16 <lh> We're doing wonderfully with registration at the upcoming workshop at LinuxCon North America. If I remember correctly we're at ~90 attendees.
14:27:30 <lh> Finishing touches needed: assign speakers to sessions, finalize AV, that sort of thing.
14:27:42 <lh> http://wiki.ovirt.org/wiki/OVirt_Global_Workshops
14:28:10 <lh> Attendees can still register free of charge using the link here http://wiki.ovirt.org/wiki/OVirt_Global_Workshops#LinuxCon_North_America_2012
14:28:14 <mburns> #info LC NA is at ~90 out of 100 attendees
14:28:26 <mburns> #link http://wiki.ovirt.org/wiki/OVirt_Global_Workshops
14:28:37 <lh> The oVirt portion of the KVM Forum + oVirt workshop CFP just opened
14:28:57 <lh> Relevant details were sent to the mailing lists, but I will also update the global workshops wiki page with the data
14:28:58 <mburns> #info still finalizing speakers for each session, AV, etc...
14:29:20 <mburns> #info CFP for oVirt Workshop in Barcelona just opened
14:29:29 <lh> You can also find the CFP details at https://events.linuxfoundation.org/events/kvm-forum/cfp-ovirt
14:29:40 <mburns> #info wiki and mailing lists have additional data
14:29:46 <mburns> #link https://events.linuxfoundation.org/events/kvm-forum/cfp-ovirt
14:30:00 <lh> Please share the CFP widely. I'll be asking the OVA to help us market the CFP, as well as asking Board Member companies to help.
14:30:06 <mburns> lh: are there details on how many slots we have?
14:30:08 <lh> We still need a reviewer or two for the papers committee.
14:30:48 <mburns> #info OVA will be helping with marketing the CFP, looking for board member companies to help as well
14:30:57 <lh> mburns, at this time, I am not certain. I believe Chris Wright, one of the KVM Forum organizers, and a few other folks are wrangling that to determine what sessions should be for attendees of both streams and that will help to determine how many ovirt specific slots there are
14:30:59 <mburns> #info still need a couple reviewers for CFP
14:31:09 <mburns> lh: ok
14:31:25 <lh> and last but not least, we have the Bangalore workshop on October 16 and we are still asking for folks to let us know if they'd like to present there.
14:31:46 <lh> mburns, that's all i have unless anyone has questions
14:31:55 <mburns> #info Bangalore workshop is October 16 -- still looking for people to present there
14:32:04 <mburns> lh: ok, thanks
14:32:21 <mburns> lh: i can help with paper reviews if needed
14:32:33 <mburns> for Barcelona
14:32:54 <mburns> unless you have a red hat heavy presence already...
14:32:56 <lh> mburns, excellent, thanks. we can get you added to the reviewers email list and other resources. the CFP review process goes through the Linux Foundation's CFP tool
14:33:05 <mburns> lh, ok
14:33:09 <lh> mburns, so far we have Itamar Heim, Jon Benedict, Kyle Mestery
14:33:25 <mburns> ok, so 3 different companies so far
14:33:27 <lh> mburns, I am sure you would be welcome, but I am hoping more Board Companies volunteer a reviewer
14:33:38 <lh> mburns, correct, Cisco, NetApp and Red Hat
14:33:54 * mburns thinks aliguori (or someone he delegates) should be on that as well...
14:34:22 * mburns whistles innocently for volunteering someone...
14:35:16 <mburns> #info currently have 3 reviewers -- jb_netapp itamar kmestery
14:35:30 <mburns> ok, moving on
14:35:37 <mburns> #topic backup release manager
14:35:50 <mburns> #info Ofer is on long term vacation (~ 2 months)
14:36:03 <mburns> need someone to fill his role during that time frame
14:36:12 <mburns> no volunteers (that I saw) on the email list
14:36:30 <mburns> any nominees? volunteers?
14:36:56 <mburns> otherwise, it looks like it's me and RobertM doing the job...
14:37:04 <mburns> but part time at best...
14:37:55 * mburns guesses no one is interested...
14:38:18 <RobertM> mburns, It might be no one is sure what the job entails.
14:38:27 <mburns> RobertM: true
14:38:31 <mburns> even i don't know completely
14:38:44 <mburns> mostly, it should be making sure that we're following the release process
14:39:14 <mburns> organizing the sub-project maintainers in posting builds, etc...
14:39:25 <mburns> maintaining release criteria
14:39:49 <mburns> things like that
14:40:37 <mburns> i don't see the responsibilities wiki page yet..
14:41:21 <mburns> #info no real interest apparently
14:41:33 <mburns> #info mburns and RobertM will make best effort...
14:41:40 <quaid> I wonder if this is the sort of thing that a sponsoring organization might want to pursue as a way to get someone up to speed on $everything
14:41:49 <quaid> it's as much about organization as anything, right?
14:42:47 <mburns> quaid: i think so
14:42:54 <mburns> though Ofer did more than that, i think
14:42:55 <RobertM> oschreib Are you going to have a change to write the wiki page this week?
14:43:08 <aliguori> mburns, we'll (IBM) volunteer someone, i'll get back to you in a little bit as to who
14:43:19 <mburns> he did builds as well...
14:43:20 * quaid looks around for itamar
14:43:23 <mburns> aliguori: thanks!
14:43:47 <mburns> quaid: RobertM and i can cover short term while we try to get additional people
14:44:33 <mburns> ok, moving on
14:44:40 <RobertM> mburns, We both with be at the event on the 28th why don't we review the process then.
14:44:49 <mburns> RobertM: sure
14:44:59 <mburns> #topic site re-design
14:45:07 <mburns> late topic -- garrett_ you're on
14:45:14 <garrett_> hi everyone!
14:45:29 <garrett_> I've been lurking around a little bit, and introduced myself to the lists just a bit ago
14:45:43 <garrett_> and I'm currently working on some designs for the oVirt website
14:45:53 <garrett_> I wanted to have something to show, to ask for feedback
14:45:53 <mburns> #link http://people.redhat.com/glesage/oVirt/website/mockup-1/
14:46:27 <garrett_> I've also worked with Dave Neary with the sitemap, and came up with a proposed one based on his suggestion
14:46:31 <garrett_> #link http://people.redhat.com/glesage/oVirt/website/ovirt-sitemap.txt
14:47:12 <garrett_> I integrated the green used from the current oVirt.org website
14:47:16 <garrett_> for a highlight color
14:47:22 <garrett_> and slightly tweaked the logo
14:47:53 <garrett_> and am trying to make something that looks elegant and professional, yet still community-based
14:48:28 <garrett_> the target audience is sysadmins and programmers, so there's a bit more information still on the front page
14:48:50 <mburns> garrett_: we certainly need board ack before making any changes like this
14:48:51 <garrett_> anyway, I put a lot of thought into it and would like to hear back impressions
14:49:00 <garrett_> I'll send it to the list for more feedback
14:49:01 <mburns> especially with the logo change
14:49:18 <garrett_> it's a minor change; I basically made the "o" a little more round
14:49:39 <mburns> and color change ;-)
14:49:39 <garrett_> okay, I'll send it to board@ first, as you suggest
14:49:52 <garrett_> well, the color is already used on the current website (:
14:49:57 <garrett_> but yes, for the logo
14:50:01 <mburns> garrett_: personally, i like the layout you're proposing
14:50:08 <garrett_> thanks!
14:50:19 <ewoud> +1 on better layout
14:50:36 <mburns> changing logo and color scheme though -- there's other stuff to consider there
14:50:39 <garrett_> this is just the first draft to send off; I want to work with you all to iterate and make it what you want
14:50:42 <ewoud> I'm wondering if it would be useful to have a mailing list for this
14:50:58 <mburns> ewoud: arch@ or infra@
14:51:06 <mburns> with cc to board@
14:51:11 <cctrieloff> I think it is a huge improvement, just looked at it
14:51:12 * lh has often wondered if there should be a marketing@ovirt list for folks who wanted to work on marketing tasks, maybe we are not there yet.....
14:51:31 <RobertM> mburns, I would think infra would be a better choice since arch is more about the code.
14:51:39 <garrett_> I'm also proposing a lot of text changes. It's mostly based on what's there, but cleaned up a little.
14:51:40 <mburns> lh: send a request to infra@
14:51:41 <ewoud> mburns: I also mean more in-depth details
14:51:42 <quaid> garrett_: btw, we started doing some of the wiki tweaks last week, such as fixing up the sidebar - if you get a nice sitemap for the wiki, let me know
14:51:51 <lh> mburns, shall do
14:51:52 <garrett_> quaid, excellent!
14:52:06 <ewoud> quaid: I think we should also upgrade to a newer mediawiki
14:52:13 <mburns> #info new site design -- looking for feedback
14:52:14 <quaid> +1
14:52:30 <mburns> #action garrett_ to send to infra@ and board@ looking for feedback
14:52:39 <quaid> ewoud: we can schedule that this week via infra@ I guess, but we might want to talk about RPM v. ZIP :)
14:52:54 <ewoud> quaid: I'll add it to the agenda
14:53:26 <quaid> garrett_: ok, that's a very clean look that I think will appeal to the target audience; I like the layout; the page is muy inviting, and matches up with current expectations for what a FOSS project site should have
14:53:51 <lh> quaid, +1
14:53:56 <quaid> garrett_: btw, still working on the activity stuff with Heiko, something we can chat about with him
14:54:16 <garrett_> okay
14:54:19 <ovirtbot> 14[[07Infrastructure team meetings14]]4 !10 02http://wiki.ovirt.org/w/index.php?diff=4229&oldid=4227&rcid=4330 5* 03Ekohl 5* (+74) 10start 2012-08-21 agenda
14:54:26 <mburns> #info general agreement with people on meeting on the new layout being better
14:54:46 <mburns> #info need acks from board on logo and color scheme changes
14:55:14 <mburns> #info need acks on wording as well
14:55:29 <mburns> ok, anything else to discuss with the site design?
14:55:38 <ovirtbot> 14[[07Features/Design/Network/NetworkFiltering14]]4 !10 02http://wiki.ovirt.org/w/index.php?diff=4230&oldid=4228&rcid=4331 5* 03Moti 5* (+259) 10/* VDSM */
14:55:48 <mburns> #topics other topics
14:55:53 <mburns> #topic other topics
14:56:01 <mburns> anything else to discuss?
14:56:09 <mburns> otherwise, /me will end in 1 minute
14:57:10 <mburns> going once...
14:57:28 * RobertM lets end the meeting
14:57:32 <mburns> going twice..
14:57:41 <mburns> gone
14:57:45 <mburns> thanks all!
14:57:48 <mburns> #endmeeting