14:00:45 <mburns> #startmeeting ovirt weekly sync
14:00:45 <ovirtbot> Meeting started Wed Jul 18 14:00:45 2012 UTC. The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:45 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:55 <mburns> #topic agenda and roll call
14:01:06 * aglitke is here
14:01:21 <mburns> Status of Next Release
14:01:22 <mburns> Sub-project reports (engine, vdsm, node, infra)
14:01:22 <mburns> Upcoming workshops
14:01:22 <mburns> wiki organization (dneary)
14:01:31 <oschreib> hitvx: please talk to me about setup after the meeting
14:01:54 * dustins here
14:01:56 * lh here
14:02:01 * rickyh here
14:02:08 <hitvx> oschreib: thnx will do
14:02:13 * oschreib here
14:02:14 * rharper is here
14:02:39 <rharper> mburns: I wanted to poke on getting the upstream gerrit changes for posting changeset patches to the patches mailing list
14:02:53 * quaid is here
14:03:05 <mburns> rharper: sure, we can discuss after other topics
14:03:09 <rharper> thanks
14:03:35 <mburns> #topic Release Status
14:03:40 <mburns> oschreib: you're show
14:03:58 <oschreib> OK, first - I didn't manage to rebuild ovirt-engine rpm with the right releases
14:04:08 <oschreib> something doesn't work here with maven/mock
14:04:26 <oschreib> I'll try to do it today, but I guess I'll need help.
14:05:11 <oschreib> mburns: any chance you can help with the build in mock?
14:05:37 * ofrenkel here
14:05:51 <mburns> oschreib: unlikely to be able to help with the build today
14:05:58 <mburns> i have to get node built and tested
14:06:12 <oschreib> mburns: ok. I'll find a way
14:06:14 <mburns> i can handle posting to ovirt.org
14:06:29 * sgordon is here
14:06:38 <oschreib> mburns: that I can do too. just the maven build doesn't work here.
14:06:47 <oschreib> lets do the blocker review
14:07:01 <oschreib> #info Release Blockers review
14:07:29 <oschreib> #info 5 blockers still open
14:08:15 <mburns> oschreib: i'd like to propose a new blocker as well
14:08:16 <mburns> https://bugzilla.redhat.com/show_bug.cgi?id=832227
14:08:26 <oschreib> lets talk about it in the end I guess
14:08:34 * mburns thought it was a blocker already, but just noticed it isn't
14:08:45 <oschreib> #info ovirt-node fails to register with ovirt-engine (vdsm, POST)
14:08:52 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=837443
14:09:11 <oschreib> dougsland: what about a new vdsm build with it? it blocks two node bugs
14:09:30 <mburns> latest koji build should have that fixed, iiuc
14:09:42 <mburns> http://koji.fedoraproject.org/koji/buildinfo?buildID=330964
14:09:43 <dougsland> oschreib, http://koji.fedoraproject.org/koji/buildinfo?buildID=330964 for the bridge bugs
14:10:04 <mburns> we need to get that posted to beta repos for me to include it
14:10:10 <mburns> it's only in updates testing...
14:10:16 <oschreib> ok, so it should be moved to ON_QA
14:10:38 <oschreib> mburns: care to handle the beta repo? or want me to do it?
14:10:55 * mburns will do it now while you handle the meeting
14:11:12 <oschreib> ack
14:11:21 * RobertM here
14:11:24 <oschreib> dougsland: please move it to ON_QA
14:11:39 <dougsland> oschreib, sure.
14:11:46 <oschreib> #action mburns to upload vdsm-4.10.0-5.fc17 into beta repo
14:11:57 <oschreib> #info new vdsm build available vdsm-4.10.0-5.fc17
14:11:59 <oschreib> next bug
14:12:38 * mgoldboi late but here
14:12:49 <oschreib> #info ovirtmgmt network issue when registering a host in 3.1 (vdsm, POST)
14:12:56 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=838097
14:13:04 <gestahlt> Ah that bridge bug
14:13:07 <oschreib> dougsland: status?
14:13:15 <gestahlt> thats my current problem now
14:13:53 <dougsland> oschreib, the patch is merged, the reporter didn't reply. I should move to ON_QA
14:14:22 <oschreib> dougsland: I bet gestahlt will be glad to help you verify it
14:14:38 <oschreib> it's in the same VDSM build? (vdsm-4.10.0-5.fc17)
14:14:52 <gestahlt> lemme check
14:16:09 <oschreib> dougsland: ?
14:16:55 <dougsland> oschreib, let me double check
14:17:06 <dougsland> oschreib, yes, it's
14:17:15 <oschreib> #info fixed in vdsm-4.10.0-5.fc17
14:17:18 <oschreib> next
14:17:54 <oschreib> #info 3.1: sshd daemon is not starting correctly after complete the installation of oVirt Node (node, MODIFIED)
14:18:02 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=832517
14:18:15 <oschreib> mburns: I know it was blocked on vdsm
14:18:51 <mburns> oschreib: once i have the new vdsm, i'll spin a new build and post it today
14:18:53 <mburns> then move to ON_QA
14:19:45 <oschreib> #info vdsm dependency bug fixed, new node build today
14:19:56 <oschreib> #action mburns to build and post new node
14:20:19 <oschreib> #info 3.1: iptables blocking communication between node and engine (node, MODIFIED)
14:20:27 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=832539
14:20:33 <oschreib> mburns: I guess it's the same
14:20:42 <gestahlt> Guys, i got to hit the road
14:20:47 <gestahlt> See you tomorrow
14:21:28 <mburns> oschreib: yes
14:21:40 <oschreib> gestahlt: chao
14:21:51 <oschreib> #info same as previous bug
14:22:36 <oschreib> #info Fedora 16 and 17 guests hang during boot (qemu, NEW)
14:22:42 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=837925
14:22:53 <oschreib> I'm not sure it should block our release
14:23:03 <oschreib> we should put some pressure there.
14:23:11 <oschreib> mburns: any idea who can help us?
14:23:22 <mburns> aliguori: READ10: ping -- can you put pressure on the right people for ^^
14:23:34 <mburns> 837925
14:23:56 * aliguori looks
14:24:54 * mburns wonders if that is crobinso 's domain now...
14:25:11 <jbrooks> I applied the change mentioned in comment #11 to my copy of qemu, and it worked. No F16 or F17 guests on 3.1 stands out...
14:25:32 <aliguori> mburns, looks like it's all taken care of, no?
14:26:23 <mburns> aliguori: appears there is a fix, but no build in f17 yet, iiuc
14:26:26 <aliguori> amit's on OFTC, let's see if we can pull him in here
14:27:04 <crobinso> mburns: aliguori: I'll push a build for that today, provided it's a simple backport
14:27:06 <oschreib> question- do we want to blocker 3.1 release on that?
14:27:10 <aliguori> ah, okay
14:27:18 <mburns> crobinso: thanks!
14:27:27 <aliguori> oschreib, it's already fixed in upstream qemu
14:27:27 <oschreib> crobinso: thanks +1
14:27:32 <aliguori> this is strictly a fedora 17 issue
14:27:38 <oschreib> aliguori: I understand.
14:27:41 <mburns> oschreib: i vote no -- with caveat that we release updated node asap after qemu build is done
14:27:54 <aliguori> hopefully ovirt 3.1 doesn't block on distro problems...
14:28:13 <mburns> aliguori: only if they're horribly bad
14:28:32 <mburns> aliguori: we really only have 1 distro at the moment
14:28:42 <mburns> less of an issue later when we support multiple
14:30:04 <oschreib> #info not a clear oVirt blocker, not removing this from the tracker just in order to track it
14:30:12 <oschreib> #info should be fixed soon
14:30:17 <aliguori> mburns, understood, but if you want to get more than 1 distro, being agnostic from the beginning will help that cause :-)
14:30:32 <oschreib> mburns: you wanted to discuses another bug?
14:30:46 <mburns> aliguori: agreed, it takes a very big issue to cause problems
14:30:46 <cctrieloff> at some point in the meeting, would like to give update on workshops.
14:30:58 <mburns> cctrieloff: yep, thats #3 on the agenda
14:31:00 <lh> cctrieloff, we're on the agenda a bit later
14:31:02 <mburns> oschreib: yes
14:31:09 <mburns> oschreib: https://bugzilla.redhat.com/show_bug.cgi?id=832227
14:31:28 <mburns> oschreib: my reasoning for it being a blocker is in the latest comment
14:32:08 <oschreib> can it get into today's build
14:32:09 <oschreib> ?
14:32:29 <dougsland> oschreib, I will prepare a new pach, based on the last comments in gerrit
14:32:31 <mburns> oschreib: according to dougsland, a new patch is coming
14:32:33 <dougsland> then, need ack
14:32:38 <dougsland> from reviewers
14:33:15 <dougsland> and new build by Federico or Dan
14:33:39 <oschreib> sounds like a blocker to me
14:34:59 <oschreib> the thing is - current release date is a week from now
14:35:08 <oschreib> I guess we will have to delay it
14:35:13 <oschreib> or release it like this
14:35:22 <oschreib> and respin vdsm/node afterwards
14:35:46 <mburns> oschreib: we can release like this, then have vdsm spin async
14:35:56 <dougsland> oschreib, mburns agreed
14:35:58 <mburns> and i'll include async when i build fix with new qemu
14:36:16 <mburns> it doesn't affect fedora+vdsm
14:36:19 <mburns> just ovirt-node
14:36:47 <dougsland> and it register the node anyway, since jboss is listening 8443 and 443
14:37:28 <oschreib> dougsland: ovirt-engine doesn't open 8443 and 8080 by default
14:37:33 <oschreib> in the FW I mean
14:38:06 <oschreib> #agreed https://bugzilla.redhat.com/show_bug.cgi?id=832227 is critical, not a release blocker. we can respin node later on.
14:38:11 <dougsland> oschreib, yes, /me nod
14:38:36 <oschreib> I'm adding it to the tracker (so we will track it
14:39:17 <oschreib> anything else on release?
14:39:25 <oschreib> oh, one more thing
14:39:34 <oschreib> actually, two
14:39:45 <oschreib> 1. do we feel comfortable with next week release?
14:40:54 <RobertM> oschreib, It is 7 Days out from release and we have at least 3 bugs who's fixes aren't in repo yet.
14:41:12 <oschreib> 2. I want to start writing the release announce, any recommendation for a good place?
14:41:27 <oschreib> RobertM: all bugs should be fixed and published today
14:41:32 <jbrooks> oschreib, how about the wiki
14:41:33 <oschreib> so we're on the edge here.
14:41:42 <oschreib> jbrooks: ovirt.org?
14:42:00 <jbrooks> oschreib, yes, for writing the release announcement
14:42:26 <oschreib> jbrooks: I like etherpad more
14:42:31 <RobertM> How close are we on oVirt 3.1 install doc's to replace the 3.0 doc's?
14:42:55 <oschreib> RobertM: that's a question to sgordon
14:43:08 <RobertM> sgordon, You around?
14:43:11 <dougsland> oschreib, 1. yes 2. wiki :)
14:44:20 <oschreib> jbrooks: don't we prefer http://openetherpad.org/ovirt-3-1 ?
14:44:40 * mburns ok with release next week (assuming we get new builds posted without git hashes or RC tags)
14:44:43 <jbrooks> jbrooks, that works, etherpad is nicer to write in
14:44:55 <jbrooks> heh
14:44:56 <mburns> and no other issues come up in the next week
14:45:14 <oschreib> should we do a release go/no go on Monday/Tuesday?
14:45:26 <sgordon> RobertM, oschreib yes sorry
14:45:29 <sgordon> so
14:45:32 <mburns> oschreib: how about 10 min at the start of wednesday's call
14:45:39 <sgordon> not much movement on http://www.ovirt.org/w/index.php?title=Release_Notes_Draft
14:45:48 <mburns> then action after that will be to move things to new location?
14:45:56 <sgordon> in particular need to fill out installation instructions down the bottom
14:46:08 <sgordon> contributors welcome etc
14:46:39 <sgordon> i have what i believe to be a relatively functional guide for RHEV 3.1 downstream that i am still working on, i need to get it into ovirt git and do a lot of find and replace ;)
14:46:39 <jbrooks> sgordon, I'd like to see confirmation on the rel notes items need to check if it's in 3.1
14:46:46 <oschreib> sgordon: If you need any help on installation, you know where to find me
14:46:54 <sgordon> jbrooks, the list is what itamar gave me
14:47:02 <sgordon> there are some exceptions where he wasnt sure, they are noted
14:47:22 <RobertM> sgordon, Do you think you will be ready by the 25th?
14:47:28 <oschreib> #info Release Announcement will be in http://openetherpad.org/ovirt-3-1
14:47:30 <sgordon> if you can get such confirmation from someone, feel free to edit
14:47:46 <sgordon> RobertM, i would say so, i have to hand them off internally for something else shortly
14:48:18 <mburns> ok, so we're still on track for July 25 release
14:48:19 <RobertM> Because lack of doc should be a release blocker.
14:48:32 <mburns> can we move on?
14:48:35 <sgordon> as the only docs contributor, i feel that would be a tad unfair right now
14:48:50 <sgordon> maybe something to consider for a later release
14:48:55 <oschreib> RobertM: I agree
14:49:15 <oschreib> sgordon: and with you too.
14:49:49 <oschreib> sgordon: the fact you're to only contributor doesn't mean it's not important
14:50:15 <RobertM> sgordon, I understand that but if the doc's aren't ready then the release should be held up until they are ready. Not saying you are doing a bad job just that it is release blocker.
14:50:37 <mburns> ok, lets review next week in go/no go
14:50:39 <quaid> RobertM: which docs do you mean, though?
14:51:07 <quaid> RobertM: the release announcement can be sufficient, if it points to a few useful wiki pages, and can move people along - basic get started, etc.
14:51:19 <sgordon> from my pov the best solution would be for someone to provide the sections in that release notes wiki
14:51:24 <sgordon> for installation
14:51:32 <RobertM> http://www.ovirt.org/get-ovirt/
14:51:36 <sgordon> then i can quickly incorporate that into the ovirt branded install guide
14:51:42 <mburns> #action for all maintainers -- add sections in releases notes
14:51:55 <sgordon> (the main differences between up/downstream other than the names are how you get the packages)
14:52:18 <sgordon> (speaking solely from an install guide pov of course)
14:52:30 <mburns> sgordon: can you hound the maintainers for release notes?
14:52:57 <mburns> danken, bazulay, lpeer / doron_afk , and me
14:53:05 <RobertM> quaid, There is a linked installation guide on www.ovirt.org/get-ovirt/ We are going to need to update that. It would be good to have a 3.1 guide ready.
14:53:50 <mburns> ok, we need some form of documentation
14:53:54 <mburns> i think we all agree
14:54:06 <mburns> maintainers need to work with sgordon to get release notes
14:54:14 <mburns> and oschreib is going to make sure installation is covered
14:54:29 <mburns> we'll assess status on wednesday next week in go/no og
14:54:32 <mburns> no go
14:54:40 <mburns> agreed?
14:54:49 <dneary> hi
14:54:54 * RobertM mburns +1
14:54:58 <oschreib> +1
14:55:02 <dougsland> +1
14:55:03 <dneary> sorry to be late, wake-up call didn't happen
14:55:05 <mburns> ok, then lets move on quickly
14:55:12 <mburns> #topic workshops
14:55:19 <mburns> lh: cctrieloff: go ahead
14:55:24 <lh> Update on Linux Con North America first
14:55:33 <mburns> dneary: can you take the wiki stuff to the list?
14:55:51 <lh> Spoke to Angela Brown from Linux Foundation yesterday, we are almost at full capacity for ovirt at LCNA (50 people) with only 25% of conference registrations in
14:55:56 <dneary> mburns, Which list?
14:56:07 <lh> We can easily add more seats and be billed later. Good problem to have. :)
14:56:13 <lh> cctrieloff, did you want to address that ^^
14:56:24 <mburns> dneary: hmm...
14:56:26 <dneary> mburns, which list? arch, users, vdsm-devel, engine-devel?
14:56:37 <mburns> dneary: probably arch
14:56:39 <mburns> and infra
14:56:56 <dneary> I did email arch and users yesterday about the most time-critical part
14:57:02 <dneary> The screencasts
14:57:15 <mburns> users is helpful if you want to reach user base as well
14:58:17 <cctrieloff> lh: yes
14:58:20 <mburns> lh: cool that we're almost at capacity
14:58:27 <lh> mburns, agreed
14:58:45 <mburns> are there cross-registrations with gluster this time?
14:58:46 <cctrieloff> I think we should open it up, and see how many people we get,
14:58:48 * lh will provide update on KVM Forum + oVirt after cctrieloff addresses north america
14:59:01 <lh> mburns, no that issue was eliminated by separating regs
14:59:18 <mburns> ok
14:59:27 <cctrieloff> in addition I believe it is a great opportunity to allow board members or any corps that want to sponsor the event.
14:59:54 <RobertM> dneary, Yesterday was my bday so I haven't had a change to look at the screen cast stuff.
15:00:05 <cctrieloff> Should be opportunity for both LinuxCon NA and KVM Forum/oVirt in Europe
15:00:07 <lh> RobertM, happy birthday
15:00:57 <mburns> ack on opening to as many people as want to register for it
15:01:30 <cctrieloff> lh: do you want to send such a mail to the board list with costs for additional 50 people for NA, and costs for extra 100 people for Europe...
15:01:38 <lh> cctrieloff, shall do
15:01:54 <lh> will take me until tomorrow to get firm data, angela brown is traveling today
15:02:10 <cctrieloff> that should be fine.
15:02:15 <lh> k
15:02:33 <mburns> #info almost at capacity for NA workshop, will get data for expanding for both NA and Europe
15:02:49 <lh> So for KVM Forum + oVirt, Angela Brown and I will be putting together a rough schedule so all the organizers can review and make sure it works given this is the first time the two events are co-located.
15:03:05 <lh> That should be prepped next week assuming she is not swamped prepping for LC North America.
15:03:32 <lh> mburns, that's all i have
15:03:53 <mburns> lh: ok
15:03:58 <mburns> lh: thanks!
15:04:07 <dneary> mburns, want to talk for 1 or 2 mins re wiki stuff?
15:04:26 <mburns> #info information on layout and schedule for workshop during kvm forum/linuxcon europe will be coming next week
15:04:30 <mburns> #topic wiki
15:04:32 <mburns> dneary: please do
15:05:49 <dneary> mburns, OK
15:06:56 <dustins> cd
15:07:08 <hitvx> oschreib: sorry can't wait any longer, have to go, will try tomorrow again (btw problem was about CPU dectection failure)
15:07:11 * dustins wrong terminal, whoops
15:07:16 <dneary> mburns, The first objective I have is to figure out everything that's there, and propose a structure for the wiki so that we can have a more informative front page
15:07:23 <oschreib> hitvx: just drop me an email
15:07:38 <oschreib> hitvx: ofer@redhat.com
15:07:53 <hitvx> oschreib: thnx will do
15:08:03 <dneary> mburns, The main concern for me at this point is, I would like to grow a stewardship team for the wiki, people who are going to be doing this on a continuous basis
15:08:36 <mburns> dneary: ok
15:08:53 <dneary> I also want to make page naming more consistent, and compliment categorisation with an actual designed structure, so that pages are almost all mlinked to from other related pages
15:08:54 <mburns> dneary: and you sent initial email on what you're looking to do to users?
15:09:57 <mburns> dneary: no, that was only for sceencasts
15:10:17 <mburns> #info dneary looking for help with restructuring/organizing the wiki
15:10:18 <dneary> For example, for features pages, rather than have the information for a release only categorised under "Category:oVirt 3.1" (a hypothetical example), I'd like to see an oVirt 3.1 release page that fills the gaps and organises the pages categorised there
15:10:26 <dneary> mburns, Ah
15:10:44 <mburns> dneary: sure
15:10:48 <quaid> dneary: I recommend we use the MediaWiki/Wikipedia article norms as a starting point for Wiki Best Practices
15:10:49 <dneary> I suppose the email to infra@ yesterday giving the pre-meeting update was what I was thinking of
15:10:58 <dneary> quaid, I agree
15:11:21 <mburns> dneary: i think getting an initial draft of the best practices is a good first step
15:11:35 <mburns> and then working that through email (much like we did for the infra mission statement)
15:11:50 <dneary> quaid, Also, in MeeGo, I came up with a very short and actionable wiki guidelines which may be useful: http://wiki.meego.com/Wiki_contribution_guidelines
15:12:33 <dneary> quaid, The good thing about the MeeGo one is that it didn't focus so much on the "what" as the "how" and "why"
15:12:53 <mburns> dneary: ok, can you drive this through users and arch mailing lists?
15:13:18 <dneary> mburns, I actually thought I might be erring on the side of being too present in the lists - your feedback that I need to be more proactive on the user and arch lists is useful, thank you
15:13:34 <dneary> mburns, I wanted to avoid being over-powering
15:13:47 <mburns> dneary: i'm just thinking that this meeting really isn't the right forum to get that done
15:14:00 <mburns> good for announcing the intention, but not for designing and setting the goals
15:14:45 <mburns> #info please watch for info on users@ and arch@ lists for more details on wiki organization
15:14:53 <mburns> #topic other topics
15:14:59 <mburns> anyone have other topics?
15:15:17 <mburns> #info skipped subproject status due to time constraints
15:15:24 <quaid> +1 :)
15:15:28 <dougsland> not from my side
15:15:31 <RobertM> +1
15:17:42 <mburns> ok, thanks all
15:17:47 <mburns> #endmeeting