14:00:12 <mburns> #startmeeting ovirt weekly meeting
14:00:12 <ovirtbot> Meeting started Wed Jul 11 14:00:12 2012 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:12 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:24 <mburns> #topic agenda and roll call
14:00:27 <mburns> Agenda:
14:00:28 * sgordon_ 
14:00:36 <mburns> Status of Next Release
14:00:36 <mburns> Sub-project reports (engine, vdsm, node, infra)
14:00:36 <mburns> Upcoming workshops
14:00:36 <mburns> wiki organization (dneary)
14:00:52 * ofrenkel here
14:00:58 * jb_netapp here
14:00:59 * dustins here
14:01:00 * oschreib here
14:01:02 * eedri here
14:01:05 * rickyh here
14:01:08 * quaid is here
14:01:26 * lh is here
14:02:17 <mburns> #topic Status of next release
14:02:23 <mburns> oschreib: all yours
14:02:30 <mburns> #info Scheduled for July 25
14:02:34 <oschreib> Current release date is 25th July
14:03:05 <oschreib> 5 open issues
14:03:17 <oschreib> #info Blocker tree - https://bugzilla.redhat.com/showdependencytree.cgi?id=822145&hide_resolved=1
14:03:21 <oschreib> #link https://bugzilla.redhat.com/showdependencytree.cgi?id=822145&hide_resolved=1
14:03:27 <oschreib> #info 5 open issues
14:04:00 <oschreib> lets have a quick review of the open bugs
14:05:09 <dneary> Hi mburns
14:05:17 * dneary is here
14:05:20 <oschreib> #info 3.1: sshd daemon is not starting correctly after complete the installation of oVirt Node (node, MODIFIED)
14:05:36 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=832517
14:05:59 <mburns> oschreib: ready to go, just awaiting official vdsm package with patches from 837443
14:06:04 * rharper is here
14:06:23 <mburns> oschreib: i've manually pulled those patches into a test build
14:06:29 <mburns> and i posted the test build to nightly
14:06:33 <oschreib> #info waiting for vdsm fix for BZ#837443
14:06:48 <mburns> http://ovirt.org/releases/nightly/binary/ovirt-node-iso-2.4.0-999.mburns201207102007.fc17.iso
14:08:16 <mburns> oschreib: same story for next bug -- 832539
14:08:19 <oschreib> #info ovirt-node fails to register with ovirt-engine (vdsm, POST)
14:08:26 <mburns> #chair oschreib quaid
14:08:26 <ovirtbot> Current chairs: mburns oschreib quaid
14:08:28 * RobertM here
14:08:54 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=837443
14:09:11 <oschreib> danken: dougsland updates?
14:09:50 <oschreib> mburns: since you're blocking on this one, I'd like to review this one first
14:09:59 <mburns> sure
14:10:35 <dougsland> oschreib, the node is already registering with the new patches, but danken shared a vlan improvement
14:10:49 <oschreib> ?
14:10:50 <dougsland> I am sending a new version right now based on his comments
14:11:14 <mburns> oschreib: need these patches merged:  http://gerrit.ovirt.org/#/c/6016/ http://gerrit.ovirt.org/#/c/6090/
14:11:59 <oschreib> dougsland: any estimation? it was in the same status last week AFAIK
14:12:49 <oschreib> #info still in review process
14:13:01 <dougsland> oschreib, yes, thanks
14:13:37 <oschreib> #info 3.1: iptables blocking communication between node and engine (vdsm, MODIFIED)
14:13:51 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=832539
14:14:14 <oschreib> dougsland: ?
14:14:37 <dougsland> oschreib, it's in the same status, review.
14:14:53 <oschreib> it's MODIFIED
14:15:33 <oschreib> dougsland: ^^
14:15:35 <dougsland> oschreib, are you asking about the iptables ?
14:15:39 <dougsland> or the registering ?
14:15:48 <oschreib> iptables
14:16:13 <mburns> oschreib: that was ovirt-node
14:16:32 <oschreib> sorry
14:16:34 <mburns> same story as earlier one, test build is available, but it's not official until vdsm pushes a new build for 837443
14:16:37 <oschreib> my mistake
14:16:55 <oschreib> #info bug is on ovirt-node, not vdsm
14:17:29 <oschreib> #info blocks on BZ#837443 as well
14:17:47 <oschreib> next
14:18:25 <oschreib> #info Fedora 16 and 17 guests hang during boot (vdsm, NEW)
14:18:37 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=837925
14:18:42 <oschreib> danken: dougsland?
14:20:03 <dougsland> oschreib, I didn't dig this bug yet, danken ?
14:21:32 <dougsland> oschreib, according with the last comment, looks like there is a fix
14:21:40 <ilvovsky> here
14:21:45 <ovirtbot> 14[[07Special:Log/upload14]]4 upload10 02 5* 03Sming 5*  10uploaded "[[02File:Libvdsm.JPG10]]": libvdsm proposal
14:21:45 <dougsland> oschreib, we need to check that
14:21:52 <oschreib> dougsland: I trust you to push it forward :)
14:21:58 <oschreib> #info still in work
14:22:12 <mburns> oschreib: you can #action too...
14:22:59 <oschreib> #action dougsland to push and update the bug
14:23:02 <oschreib> last
14:23:33 <oschreib> #info  ovirtmgmt network issue when registering a host in 3.1 (vdsm, POST)
14:23:49 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=838097
14:23:56 <oschreib> danken: dougsland?
14:24:55 <danken> oschreib: pls excuse me, I was not really here
14:25:17 <dougsland> oschreib, looks like a backport resolved the bug
14:25:53 <danken> dougsland: is there a build with this patch?
14:26:21 <dougsland> danken, I am not aware of it.
14:27:20 <danken> yep, indeed. that's quite an #action for federico/saggi
14:27:52 <oschreib> #action danken to make sure Saggi/Federico handles this quickly
14:27:59 <oschreib> #info still in work
14:28:23 <oschreib> bottom line, we have 3 VDSM bugs blocking the release, node bugs depends on VDMS
14:28:25 <oschreib> VDSM*
14:28:38 <mburns> danken: can we try to get the 837443 patches into whatever the next build is?
14:31:20 <mburns> oschreib: anything else for release status?
14:32:02 <oschreib> mburns: not really
14:32:14 <oschreib> I hope next status will be better
14:32:31 <mburns> oschreib: then i have a question about release status that came up on irc a couple times recently
14:32:37 <mburns> do we have any story around upgrade?
14:33:03 <ovirtbot> 14[[07Special:Log/upload14]]4 overwrite10 02 5* 03Sming 5*  10uploaded a new version of "[[02File:Libvdsm.JPG10]]"
14:33:10 <oschreib> define story
14:33:13 <danken> mburns: Bug 837443 -      ovirt-node fails to register with ovirt-engine
14:33:13 <danken> is under review. Douglas works pretty hard on that
14:33:27 <danken> when it is solved, we will backport it to ovirt-3.1 breanch.
14:33:51 <mburns> danken: yes, he has, but it would be nice if we could hold off building a new vdsm until that gets solved and backported
14:33:59 <RobertM> oschreib, Does it work or not?  Any known issues?
14:34:07 <oschreib> mburns: I didn't see any bug about it
14:34:09 <mburns> oschreib: something that says how to upgrade
14:34:20 <mburns> and what steps to take
14:34:25 <oschreib> engine-upgrade is the right way to do it
14:34:37 <oschreib> Didn't test it actaully
14:34:53 <oschreib> either way, if we have any issue
14:34:57 <RobertM> oschreib, Do you uninstall 3.0 upgrade to Fedora 17 install ovirt 3.1 then run engine-upgrade?
14:35:04 <ovirtbot> 14[[07Special:Log/upload14]]4 overwrite10 02 5* 03Sming 5*  10uploaded a new version of "[[02File:Libvdsm.JPG10]]"
14:35:29 <oschreib> RobertM: I thogout you're talking in-beta upgrades
14:35:50 <oschreib> RobertM: In case you want to upgrade 3.0 (F16 to F17 actually)
14:35:50 <sgordon_> oschreib, no people want to know how to upgrade 3.0->3.1
14:36:11 <oschreib> sgordon_: it might be problematic due to the platform chabge
14:36:12 <danken> mburns: understood - the build is quite meaningless without it.
14:36:22 <mburns> danken: thanks!
14:36:32 <oschreib> the best solution will be to remove ovirt-engine (but preserve DB and /etc/pki/ovirt-engine)
14:36:46 <oschreib> and run engine-setup once again after Fedora upgrade
14:36:52 <mburns> oschreib: basically, we need someone to figure out steps
14:37:04 <mburns> even if the steps are fairly ugly
14:37:10 <sgordon_> yeah...if we have steps i can provide them in the release notes
14:37:22 <oschreib> RobertM: if you can test it, I'll be very happy to debug/document
14:37:35 <mburns> and we'll make upgrade a more pleasant, or at least less painful, process in the next version
14:38:08 <oschreib> mburns: I hope so, but we will have the same issue in every major platform change (F17->F18)
14:38:09 <RobertM> oschreib, I don't have a 3.0 install running but I am sure I can run though the process.
14:38:20 <oschreib> RobertM: Cool!
14:38:56 <mburns> oschreib: perhaps, but there are ways to mitigate it
14:39:05 <oschreib> mburns: indeed
14:39:15 <RobertM> Well if we were to have F17/F18 builds for 3.2 it would make the process smother.  The fact that you can keep 3.0 around well you upgrade to F17 makes the upgrade harder.
14:39:19 <mburns> we could put in a patch to 3.1 later (3.1.1) that will allow it to run on F18
14:39:26 <oschreib> so RobertM, can I action you and myself to document the upgrade?
14:39:26 <mburns> then run engine upgrade to 3.2
14:39:47 <RobertM> oschreib, Yes.
14:40:04 <RobertM> mburns, Exactly
14:40:04 <oschreib> #action RobertM and oschreib to document 3.0->3.1 upgrade
14:40:21 <mburns> ok, so we have an action plan for upgrade
14:40:26 <mburns> now we can move on
14:40:39 <mburns> #topic project status -- Engine
14:40:48 <mburns> #info covered primarily in release status
14:40:56 <mburns> #info no real bugs outstanding on the engine
14:41:02 <mburns> oschreib: are there new rpms coming soon?
14:41:17 <mburns> or are the ones out there to be considered final
14:41:46 <oschreib> no bugfixes in engine AFAIK
14:42:05 <mburns> oschreib: i think we need another build just for version numbers
14:42:22 <RobertM> I though I had a bug fix in engine that was after the last builds?
14:42:22 <oschreib> mburns: sure, I'll do it once we will feel comfortable with it.
14:42:23 <mburns> oschreib: having a version number like:  ovirt-engine-3.1.0-0.2.20120704git1df1ba.fc17.noarch.rpm
14:42:30 <mburns> is ugly
14:42:35 <oschreib> mburns: agreed
14:42:48 <oschreib> RobertM: which one? was it cherry-picked into 3.1?
14:43:01 <RobertM> oschreib, Will need to look.
14:43:03 <oschreib> RobertM: not all bugs are cherry-picked, just important one,
14:43:03 <mburns> oschreib: maybe have RC versions of engine built and posted by EOD tomorrow?
14:43:14 <mburns> with good versions
14:43:26 <mburns> like ovirt-engine-3.1.0-1.fc17.noarch.rpm
14:43:46 <oschreib> mburns: sounds like a good action to me (3.1.0-0.3RC sounds better)
14:43:53 <oschreib> since we might have a new build
14:43:56 <mburns> oschreib: no RC
14:44:10 <mburns> oschreib: if we rebuild RC, then it become 3.1.0-2.fc17
14:44:22 <oschreib> mburns: I prefer changing the version next week
14:44:38 <mburns> goal would be to take the actual RC and just move it from beta to stable repo
14:44:44 <oschreib> mburns: indeed
14:44:48 <mburns> and we don't want to GA a version with RC in it
14:44:54 <mburns> oschreib: next week is fine for posting
14:44:59 <mburns> though early in the week i think
14:45:16 <RobertM> There were like 10 diff bugs related to this issue.  https://bugzilla.redhat.com/show_bug.cgi?id=835920
14:45:19 <mburns> so the full RC version is out at least a week prior to GA
14:45:37 <RobertM> Maybe not 10 but several
14:46:40 <mburns> RobertM: that's actually against vdsm
14:46:46 <oschreib> RobertM: the posixfs?
14:46:53 <RobertM> Yes
14:47:04 <RobertM> ok
14:47:07 <mburns> should that be a blocker for the release
14:47:08 <mburns> ?
14:47:15 <oschreib> I'm not sure
14:47:23 <oschreib> I'm not against fixing at while we can
14:47:42 <RobertM> It depends on if you want posix fs to be listed as a new feature.
14:47:43 <mburns> but anyway, not an engine bug
14:47:48 <oschreib> posixfs is a new feature, and not in the release critetia
14:47:58 <mburns> #topic project status -- vdsm
14:48:23 <mburns> #info A couple blocking bugs -- 837443 838097 837925
14:48:29 <mburns> #info possibly 835920
14:48:41 <mburns> new build should be coming soon with patches
14:49:03 <mburns> oschreib: posixfs is not a new feature if this bug blocks usage of it...
14:49:15 <mburns> and we don't fix this bug
14:49:23 <mburns> danken: dougsland:  any info on 835920 ?
14:49:37 <danken> I think we have enough blockers already...
14:49:38 <danken> sec
14:49:51 <oschreib> mburns: lets say like this - I agree vdsm should try to fix it for Fedora, I'm not sure it should block the version
14:50:09 <mburns> oschreib: so fix it in an async update?
14:50:52 <oschreib> mburns: well, we didn't release anything yet
14:50:58 <oschreib> mburns: but yes, why not.
14:51:00 <danken> mburns: I do not know much about 835920, I'm afraid
14:51:17 <danken> better ask Saggi, or amureini .
14:51:31 <dougsland> the same from my side
14:51:32 <danken> I wouldn't list it as a  blocker
14:51:34 <mburns> oschreib: danken:  ok, not a blocker for release, though if we can get it in, that's good
14:52:06 <mburns> #info 835920 not a blocker, but very much a desired fix
14:52:16 <mburns> #topic project status -- node
14:52:28 <mburns> #info all blockers fixed, just awaiting fixed vdsm
14:52:44 <mburns> #info temporary scratch build uploaded to nightly area on ovirt.org for testing
14:52:46 <danken> #action get an ack for 835920 from abaron or someone
14:53:11 <mburns> #topic project status -- infra
14:53:25 <mburns> RobertM: quaid: quick dump of infra project status?
14:53:47 <mburns> #info mission statement seems to be agreed upon
14:53:56 <RobertM> Infra now has a mission statement and is finalizing a list of members.
14:54:19 <mburns> #info now finalizing a list of initial members
14:54:26 <RobertM> Biggest issue is storage limits on linode01 since it is down to a few hundred megs.
14:54:48 <RobertM> It will require some downtime to upgrade the storage on the VM>
14:54:58 <mburns> #info biggest issue is storage on ovirt.org host, will require downtime
14:55:27 <mburns> RobertM: criteria for joining infra team is also a major task right now
14:55:39 <RobertM> mburns, Correct
14:55:46 <mburns> #info finalize criteria for how new people join infra team
14:55:52 <mburns> #undo
14:55:52 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x9c924cc>
14:56:01 <mburns> #info another major task: finalize criteria for how new people join infra team
14:56:30 <mburns> #info other topics being actively worked:  jenkins, wiki cleanup, etc...
14:57:09 <mburns> #info all discussions are held on IRC or in email, all decisions are published to infra@
14:57:14 <RobertM> Also converting to use puppet to manage configs and allowing more transparent access to the config so people outside the team can help.
14:57:26 <mburns> #info also exploring puppet
14:57:37 <mburns> ok, moving on since we're running late...
14:57:48 <mburns> #topic workshops and conferences
14:57:52 <mburns> lh: you're up
14:58:07 <lh> So, all information about workshops continues to reside here
14:58:15 <lh> http://www.ovirt.org/wiki/OVirt_Global_Workshops
14:58:27 <lh> We are on track for LinuxCon North America, which is next upcoming workshop
14:58:44 <mburns> #link http://www.ovirt.org/wiki/OVirt_Global_Workshops
14:58:50 <lh> Tuesday, August 28th for those who'd like the date
14:59:08 <lh> The Red Hat Bangalore office has offered to host an oVirt workshop on Tuesday, October 16th
14:59:34 <lh> I was talking to dneary and we were hoping to do an open call for papers for the Bangalore workshop. Gets more folks involved.
15:00:11 <lh> But we'd need more data from the community, specifically: target audience for CFP, deadline for submissions, where to advertise, etc.
15:00:22 <lh> We can take that topic up on list but wanted to raise it here now
15:00:30 <lh> anyone have thoughts on the above?
15:00:35 <mburns> #info on track for LinuxCon North America August 28
15:00:53 <mburns> #info Red Hat Bangalore has offered to host a workshop on October 16
15:00:59 <dneary> mburns, I'm up next, but have a phone call now
15:01:11 <joncox> anyone got a minute to help me out with an issue I'm having?
15:01:15 <dneary> Can we bump me to next week? Or take it to the list?
15:01:22 <lh> mburns, i can take the cfp question to the ovirt lists
15:01:30 <lh> mburns, and that is all i have for now
15:01:30 <dneary> Or leave Qs for me here and I'll answer them when I'm off the phone
15:01:31 <pmyers> mburns: hey just as a heads up, I can't make it to LinuxCon NA anymore... personal conflict came up
15:01:35 <mburns> #info hope is to have call for papers for bangalore workshop
15:01:41 <pmyers> I updated Wiki accordingly
15:02:01 <pmyers> still might be able to make Barcelona though, and it looks like that will be a bigger workshop for us anyhow
15:02:03 <mburns> lh: i think having call for papers is a good idea, but probably best to take to the mailing list
15:02:24 <lh> mburns, sounds good, will follow up there
15:02:27 <mburns> dneary: up to you if you want to take it to the list or leave it on agenda
15:02:35 <mburns> #topic other topics
15:02:45 <mburns> joncox: will get back to you shortly...
15:02:53 <mburns> pmyers: ok, thanks for the update
15:02:56 <joncox> thanks
15:03:02 <mburns> anyone have other topics to discuss?
15:03:15 <mburns> #info dneary has a conflict, so deferring his discussion on wiki cleanup
15:03:58 <RobertM> mburns, I had 1 thing.  What are people thoughs on creating an ISO for the allinone install?
15:04:22 <mburns> RobertM: as a kind of appliance?
15:04:43 <RobertM> mburns, Yes.
15:04:57 <jbrooks> RobertM, I've been playing with that a bit
15:04:58 <mburns> RobertM: sounds like a good idea to me
15:05:19 <oschreib> good idea
15:05:39 <RobertM> Most people who use ovirt start with an all in one box to get a feel for it.  The lower the bearer the more likely they are to try out the software.
15:05:52 <mburns> absolutely
15:06:10 <mburns> #info proposed idea:  appliance with allinone
15:06:26 <mburns> #agreed it's a good idea
15:06:49 <mburns> RobertM: jbrooks can we take this to the list?
15:06:59 <mburns> to work out how to go about creating it?
15:07:05 <jbrooks> certainly
15:07:06 <RobertM> mburns, Witch list?
15:07:11 <RobertM> User?
15:07:24 <RobertM> Or arch?
15:07:38 <mburns> probably arch, i think
15:08:03 <mburns> maybe separate emails to both?
15:08:23 <mburns> on users to see if there is interest with a pointer to the discussion on how to do it on arch@
15:08:28 <RobertM> ok.  jbrooks to you want to drive this thread or should I?
15:08:43 <mburns> i'd rather keep technical discussion of how to implement off the users list
15:08:49 <jbrooks> RobertM, why don't you kick it off? I'll comment on the thread
15:08:53 <mburns> it's supposed to be more for support rather than development
15:09:42 <RobertM> Yea there doesn't seem to be an ovirt development list.  There is an engine and vdsm but there doesn't seem to be a list for ovirt as a hole.
15:09:54 <mburns> #action RobertM to kick off thread on arch about allinone appliance
15:09:55 <RobertM> jbrooks, Ok.
15:10:03 <mburns> ok, anything else?
15:10:58 <mburns> going once...
15:12:15 <RobertM> SOLD I couldn't resist :)
15:12:26 <mburns> RobertM: that's my line...
15:12:34 <mburns> thanks all
15:12:37 <mburns> #endmeeting