14:00:49 <mburns> #startmeeting ovirt weekly sync
14:00:49 <ovirtbot> Meeting started Thu Jul  5 14:00:49 2012 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:49 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:55 <mburns> #chair oschreib
14:00:55 <ovirtbot> Current chairs: mburns oschreib
14:01:10 <mburns> #topic roll call and agenda
14:01:30 * oschreib here
14:01:34 <mburns> Agenda:  Status of Next Release
14:01:34 <mburns> Sub-project reports (engine, vdsm, node)
14:01:34 <mburns> Upcoming workshops
14:02:08 <dneary> Hi everyone
14:03:05 <ilvovsky> here
14:03:13 * mburns waits a couple min for everyone to join
14:04:44 <dougsland> dougsland, here
14:06:00 <mburns> #topic Release Status
14:06:12 <mburns> oschreib: it's your show
14:07:09 <oschreib> OK
14:07:42 <oschreib> Current release date is July 9th
14:08:04 <oschreib> We have currently 9 blockers
14:08:14 <oschreib> 5 of them ON_QA
14:08:26 <oschreib> 2 MODIFIED and 2 POST
14:08:37 <oschreib> #info Current release date is July 9th
14:09:11 <oschreib> #info 9 blocker currently for 3.1 release, 5 ON_QA, 2 MODIFIED and 2 POST
14:09:16 <oschreib> #link https://bugzilla.redhat.com/showdependencytree.cgi?id=822145&hide_resolved=1
14:10:06 <oschreib> we should talk about delaying the release probably.
14:10:24 <oschreib> or maybe review the blockers first
14:10:42 <mburns> let's see where we are with blockers first...
14:10:48 <oschreib> ack
14:11:00 <oschreib> #info Blockers review
14:11:16 <oschreib> #info vdsmd init script times out due to lengthy semanage operation (vdsm, POST)
14:11:24 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=832199
14:11:30 <oschreib> dougsland: it's assigned to you
14:11:37 <oschreib> dougsland: thoughts?
14:12:04 <dougsland> oschreib, I should send a new patch version today
14:12:20 <oschreib> dougsland: will it solve the issue?
14:12:56 <dougsland> oschreib, yes
14:12:58 <oschreib> dougsland: or more accurate, how much time till a Fedora build with it?
14:13:26 <dougsland> oschreib, the fedora build I don't know, usually federico does the build for Fedora.
14:13:40 <dougsland> or Dan
14:13:49 <oschreib> estimation? we need to decide on a new release date probably
14:14:07 <dougsland> ilvovsky, any ideas ^ ?
14:14:32 <dougsland> ( for the fedora build )
14:14:33 <ilvovsky> oschreib: I know that Saggi or Dan should replace Federico for builds
14:14:59 <oschreib> #info new patch should be reviewed soon
14:15:13 <ilvovsky> oschreib: looks like we need one of them here
14:15:24 <oschreib> ilvovsky: +1
14:15:33 <oschreib> ok, next bug
14:15:46 <oschreib> #info 3.1: sshd daemon is not starting correctly after complete the installation of oVirt Node (ovirt-node, MODIFIED)
14:15:53 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=832517
14:15:54 <mburns> oschreib: we just need builds on ovirt.org, not actually in fedora, right?
14:16:19 <oschreib> mburns: well, yah, but vdsm guys builds it in koji
14:16:21 <mburns> oschreib: that bug is fixed, but new build failed acceptance testing due to another bug on the block list...
14:16:40 * jclift points out that once you have a working build in Fedora, you'd _better_ not put a newer release into the same Fedora.
14:16:56 <jclift> i.e. if 3.1 goes into F17, 3.2 won't be.
14:17:13 <mburns> 837443
14:17:23 <oschreib> jclift: that's fine, but lets finish 3.1 first :)
14:17:41 <oschreib> #info verification blocks on BZ#837443
14:17:51 <jclift> Of course.  It's something the Aeolus team recently realised. ;)
14:18:03 <dneary> jclift, I'd aim for F18 for 3.2 anyway, I think
14:18:11 <jclift> All good.  :)
14:18:35 <oschreib> jclift: actually, there's no reason not to update vdsm in Fedora17 in 3.2, if we keep it compatible
14:18:52 <oschreib> #info ovirt-node fails to register with ovirt-engine (vdsm, POST)
14:18:57 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=837443
14:19:08 <oschreib> dougsland: info, time estimation, etc?
14:19:31 <dougsland> oschreib, I will send a new patch today as well. I have just finished a talk with ilvovsky about it and we figure out how the best approach to solve it
14:19:56 <oschreib> dougsland: this one is actually morwe critical as it blocks ovirt-node
14:20:09 <dougsland> oschreib, I know.
14:20:12 <oschreib> dougsland: please try to hurry with it
14:20:25 <dougsland> oschreib, sure, after the meeting I will prepare a patch, test and send to gerrit
14:21:05 <ilvovsky> dougsland: let's hope Danken will ACK it :)
14:21:24 <dougsland> :-)
14:21:24 <oschreib> #info patch in review
14:21:56 <oschreib> #info 3.1: iptables blocking communication between node and engine (ovirt-node, MODIFIED)
14:22:06 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=832539
14:22:34 <ovirtbot> 14[[07Features/ReloadableConfiguration/keys table14]]4 !10 02http://www.ovirt.org/w/index.php?diff=3784&oldid=2934&rcid=3880 5* 03Msalem 5* (+6281) 10
14:22:38 <oschreib> mburns: guilty or not guilty?
14:23:09 <mburns> oschreib: should be fixed, but same story as the previous one, we need to get node and engine talking before we can really test it
14:23:23 <mburns> but appears fixed in our testing
14:23:34 <oschreib> mburns: any reason not to put a "depends" flag in BZ?
14:24:16 <mburns> oschreib: no real reason not to
14:24:26 <oschreib> mburns: sounds like a good idea to me
14:24:29 <mburns> ok
14:24:33 * mburns will add
14:24:48 <oschreib> #info blocks on BZ 837443 as well
14:24:57 <oschreib> ok, we have 5 on_qa bugs
14:25:10 <oschreib> I'll try to contact the reported in order to verify them
14:25:10 <mburns> done
14:25:56 <oschreib> so, sounds like a bit of a progress, but we don't have a working build (and according to the release process, we gotta have one for at least a week)
14:26:16 <oschreib> two/three weeks delay?
14:27:23 <oschreib> those re-accruing delays looks bad, and quite annoying. I don't want to delay it once more.
14:27:58 <mburns> oschreib: so july 23?
14:28:40 <oschreib> or July 30
14:29:46 <mburns> how about July 25 (wednesday)?
14:30:07 <mburns> that gives 3 weeks from yesterday to finish
14:30:19 <oschreib> sounds good to me
14:32:21 <oschreib> anyone elses?
14:32:33 <dougsland> that's ok for me
14:34:46 <mburns> #agreed release date will slip to 25 July
14:35:17 <mburns> oschreib: anything else for release status?
14:35:30 <oschreib> nope
14:35:33 * mburns thinks we covered things for project status as well
14:35:45 <mburns> so moving on to conferences/workshops
14:36:02 <mburns> #topic Workshops and Conferences
14:36:22 <mburns> i don't think there is anything new to cover here
14:36:27 <mburns> and lh isn't online
14:36:41 <oschreib> indeed
14:36:54 <mburns> next workshop is August 28 in San Diego
14:36:57 <mburns> #info next workshop is August 28 in San Diego
14:37:08 <dougsland> oschreib, mburns actually
14:37:20 <mburns> i think most of the planning is being done over email, so i think we're good there
14:37:25 <dougsland> there is FISL and lh is aware about that.
14:37:59 <dneary> Sorry - missed my opportunity
14:38:13 <dneary> concerning the 3.1 release, who is taking care of announcements and press?
14:38:16 <mburns> dougsland: ahh, that's just a presentation, iirc...
14:38:25 <dneary> I saw that sgordon is writing the release notes
14:38:56 <oschreib> dneary: last time, I sent the announcement to @ovirt lists
14:39:03 <mburns> dneary: generally it's either oschreib or me who sends out updates on the mailing lists
14:39:06 <oschreib> and I think quaid handled press and so
14:39:14 <dneary> oschreib, mburns: Would you like some help?
14:39:20 <mburns> yes!
14:39:23 <dougsland> mburns, we will have a booth there with oVirt demo and talks about oVirt
14:39:34 <mburns> dougsland: ahh, excellent
14:39:40 <dneary> oschreib, mburns: jbrooks is available to help with release announcements, if you'd like
14:39:58 <dneary> mburns, Great! Is there a list where it's better to co-ordinate?
14:40:02 <oschreib> any help is welcome
14:40:06 <dneary> Or just use the wiki?
14:40:27 * mburns is flexible
14:40:32 <mburns> wiki or mailing lists are fine
14:40:39 <dneary> list*s*?
14:40:43 <dneary> which ones? :)
14:41:07 <mburns> i'd think arch would be most appropriate for getting things together, then announcements sent to announce@
14:41:33 <jclift> Hmmm, which meeting topic should "Screencasts" go in?
14:41:53 * jclift wants to ask who's lined up for doing screencasts for 3.1, preferably for release time
14:42:14 <mburns> #topic release announcements
14:42:20 <jclift> ie. press release -> here are screencasts of the new features in action
14:42:21 <jclift> k
14:42:53 <mburns> #info oschreib mburns to work with jbrooks to coordinate release announcements
14:43:22 <mburns> jclift: not sure who is responsible for that
14:43:30 <oschreib> jclift: anyone can install and do it
14:43:34 <dneary> ok
14:43:36 <mburns> i would think someone from the engine team is the most likely candidate...
14:43:38 <oschreib> if anyone needs help, I'm here
14:43:55 <oschreib> and installs ovirt-engine twice a day
14:43:55 <jclift> mburns: yeah, just bringing it up as a point, as it's probably a good idea to get done
14:43:57 <dneary> jclift, I'm happy to do voice-overs, but someone else should do videos
14:44:17 <jclift> Good opportunity to get community people involved.  RobertM maybe if we ask him? :)
14:44:34 <dneary> jclift, Yes, sure - why not?
14:44:45 * mburns agrees that it should be non-Red Hat people ;-)
14:44:49 <oschreib> +1
14:44:51 <oschreib> :)
14:44:54 <jclift> dneary: You good to ask him? :)
14:44:57 <dneary> We could break it down into 3 steps: 1. Come up with feature stories we want to tell
14:45:06 <dneary> 2. Record the video that shows the feature
14:45:10 <dneary> 3. Do the voice-over
14:45:20 <dneary> RobertM, ping?
14:45:25 <jclift> Yep, sounds workable.
14:45:43 <mburns> #action jclift to recruit RobertM to do feature screencasts
14:45:49 <dneary> jclift, OK - so the user stories & scripts we can come up with on the Users list and commit them to the wiki
14:46:00 <jclift> mburns: s/jclift to/dneary to/ ?
14:46:06 * dneary thanks mburns for getting him out of a tight spot
14:46:13 <mburns> #undo
14:46:13 <ovirtbot> Removing item from minutes: <MeetBot.items.Action object at 0x9c92b6c>
14:46:15 <dneary> jclift, Your idea ;-)
14:46:22 <mburns> #action jclift and/or dneary to recruit RobertM to do feature screencasts
14:46:22 * jclift is an idea person.  Not someone to assign actions to. :p
14:47:21 <mburns> ok, anything else to cover today?
14:47:46 <mburns> going once...
14:48:18 <mburns> twice...
14:48:32 <mburns> done
14:48:38 <mburns> err..gone
14:48:41 <mburns> thanks all
14:48:44 <mburns> #endmeeting