14:00:23 <mburns> #startmeeting oVirt Weekly Sync
14:00:23 <ovirtbot> Meeting started Wed May 23 14:00:23 2012 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:23 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:30 <mburns> #chair oschreib
14:00:30 <ovirtbot> Current chairs: mburns oschreib
14:00:41 <mburns> #topic agenda and roll call
14:00:46 * oschreib here
14:01:03 <mburns> Status of Next Release
14:01:03 <mburns> Sub-project reports (engine, vdsm, node)
14:01:03 <mburns> Review decision on Java 7 and Fedora jboss rpms in oVirt Engine
14:01:03 <mburns> Upcoming workshops
14:01:06 * dustins here
14:01:22 * lh here
14:01:34 <mburns> oschreib: we can cover deferring the freeze date in release status
14:01:58 <oschreib> sure we can
14:02:07 * rickyh here
14:02:11 * RobertMdroid here
14:02:11 * mestery_ here
14:02:34 * mburns waits a minute for roll call
14:02:58 <oschreib> I'm really bothered by the lack of engine/vdsm representative...
14:03:19 * doronf here
14:03:41 * doronf (was a silent observer so far ;)
14:04:34 * sgordon is here
14:04:41 <sgordon> oschreib, +1
14:05:17 <mburns> #topic Status of next release
14:05:29 <mburns> #link https://bugzilla.redhat.com/show_bug.cgi?id=822145
14:05:57 <oschreib> We have ~4 blockers, three of them are major ones
14:06:00 <mburns> proposal, slip freeze date by 1 week to June 7
14:06:20 <mburns> oschreib: which one *isn't* major?
14:06:33 <mburns> #4 i just added about 20 min ago
14:06:38 <oschreib> Official JBoss rpm support, we ~can live without it
14:06:46 <mburns> ok
14:07:08 <oschreib> Any one disagree with the 1 week slip?
14:07:16 <oschreib> I don't see any other option.
14:07:23 <mburns> oschreib: are we just shortening the beta period?
14:07:29 <mburns> or are we slipping the GA date as well?
14:07:58 <oschreib> I think we can start with shortening the beta period
14:08:18 <oschreib> 3 weeks is something I can live with
14:09:00 <doronf> guys, I think this change should be sent to the list, since many are missing. Although I agree there's no real alternative.
14:09:29 <oschreib> doronf: If we can't take action in this meeting, I suggest cancel it
14:09:55 <mburns> oschreib: all major sub-projects are supposed to represented here
14:10:02 <oschreib> also, there's no other real option IMO
14:10:18 <doronf> oschreib: d you have rep's here from all projects?
14:10:37 <mburns> we should send to the list as an announcement, but the point of this meeting is to make decisions like this
14:10:51 <RobertMdroid> if someone objects they sould have been  at the meeting
14:11:21 <oschreib> doronf: once again, do you suggest to cancel this today's meeting?
14:11:26 <mburns> ack on delaying 1 week
14:11:57 <doronf> oschreib: convinced by RobertMdroid's claim. +1 on postponing.
14:12:33 <mburns> #agreed freeze date and beta release delayed by 1 week to 2012-06-07
14:12:35 <oschreib> RobertMdroid: thanks.
14:12:51 <oschreib> GA date should be reviwed next week
14:12:57 <cctrieloff> here
14:12:57 <mburns> ack
14:12:58 <oschreib> reviewed
14:13:13 <mburns> oschreib: anything else for release status?
14:13:18 <mburns> or should we move to project status?
14:13:22 <sgordon> umm brief one
14:13:29 <mburns> sgordon: sure
14:13:46 <sgordon> just a reminder once we freeze we should be trying to use the release notes flag where required
14:14:06 <sgordon> it will make life easier for you guys too if we actually do it, because i wont have to hassle you all to write your own release notes directly in the page
14:14:19 <sgordon> (i will be able to query for the bugs and write/collate myself)
14:14:21 <mburns> #info post freeze, release notes flag needs to be used where required
14:14:43 <sgordon> i cant remember the exact flag but from memory it is pretty obvious, ovirt_requires_release_note or something like that
14:15:02 <sgordon> unfortunately from memory we still have the issue only redhat contributors can set it (maybe partners too?) =/
14:15:03 <oschreib> sgordon: it's easy, we have only two flags iirc
14:15:05 <mburns> 760304 782711 791107 797405 807042
14:15:10 <mburns> argh...
14:15:19 <mburns> ovirt_requires_release_note
14:15:48 <oschreib> should we review the blocker bugs now?
14:15:50 <mburns> we can have people set needinfo on a maintainer asking them to set the flag if needed
14:15:55 <mburns> oschreib: sure
14:16:08 <oschreib> ok
14:16:10 <oschreib> we have https://bugzilla.redhat.com/show_bug.cgi?id=821867
14:16:35 <oschreib> VDSM corrupts libvirt config
14:17:11 <oschreib> unfortunately, no VDSM rep here to update about it.
14:17:27 <oschreib> #info https://bugzilla.redhat.com/show_bug.cgi?id=821867 is a VDSM blocker for 3.1
14:17:36 <mburns> dougsland: any info on ^^
14:18:32 <dougsland> oschreib, mburns I am about to open a BZ to libvirt guys as Daniel requested
14:18:49 <dougsland> I meant, about their config working with augeas
14:19:00 <oschreib> dougsland: please do so, set it as Urgent, and add it to the tracker.
14:19:47 <oschreib> dougsland: iirc, we never worked with auges, why start it now (and block the release) instead of removing the # comment now
14:19:48 <dougsland> oschreib, correct.
14:20:17 <oschreib> dougsland: and do it with augeas as a new feature/bug/whatever
14:20:27 <dougsland> oschreib, remove the comment is enough for me.
14:20:31 <mburns> i agree, for this release, just remove comment
14:20:35 <dougsland> oschreib, I will send a patch
14:20:38 <mburns> but file bug and get it fixed for next version
14:20:42 <dougsland> alright
14:20:46 <oschreib> dougsland: thanks
14:20:50 <mburns> oschreib: we do use augeas in ovirt-node extensively though
14:21:07 <mburns> but that's not going to block us here since we don't touch libvirt config
14:21:15 <oschreib> mburns: thats fine, but don't block my release :)
14:21:22 <dougsland> oschreib, :)
14:21:44 <oschreib> #action dougsland to fix upstream vdsm right now, and open a bug on libvirt augeas
14:21:53 <mburns> #action dougsland to provide patch removing comments for 821867
14:21:58 <oschreib> dougsland: keep me posted on this
14:22:01 <mburns> #undo
14:22:01 <ovirtbot> Removing item from minutes: <MeetBot.items.Action object at 0x8e136cc>
14:22:23 <oschreib> next bug: https://bugzilla.redhat.com/show_bug.cgi?id=822158
14:22:36 <oschreib> doronf: any update on that?
14:23:39 <mburns> #link https://bugzilla.redhat.com/show_bug.cgi?id=822158
14:23:51 <doronf> oschreib: there's a bz opened on yair. We'll need to get updates tomorrow.
14:24:59 <mburns> #info assignee not available, update to come tomorrow
14:25:00 <oschreib> I'm wondering wheather we should revert the VDSM patch broke it, until engine will know how to deal with it
14:25:29 <oschreib> #action oschreib to make sure BZ#822158 is handled quickly
14:25:29 <ofrenkel> oschreib, +1 for that
14:26:03 <oschreib> ofrenkel: but you SHOULD know how to deal with it, preferably, in the upcoming build.
14:26:35 <ofrenkel> oschreib, i agree, it should be coordinated and checked all the way
14:26:55 <oschreib> ofrenkel: I completely agree
14:26:57 <oschreib> next bug: https://bugzilla.redhat.com/show_bug.cgi?id=824397
14:27:06 <oschreib> Juan is working on that.
14:27:10 <mburns> if we think this should be fixed in the next engine build, why spend time reverting in vdsm?
14:27:31 <oschreib> ofrenkel: how much time will it take to fix it?
14:28:22 <ofrenkel> don't know, the time consuming task is to understand what to do there
14:28:43 <oschreib> ok, I'll try to coordinate that with both maintainers.
14:28:47 <mburns> ack
14:28:55 <mburns> #link https://bugzilla.redhat.com/show_bug.cgi?id=824397
14:29:00 <ofrenkel> mburns, in case this blocks/delays the build then revert
14:29:06 <mburns> ofrenkel: ack
14:29:13 <oschreib> I expect bug BZ#824397  to be merged before next week's meeting
14:29:19 <oschreib> no promise
14:29:45 <mburns> #info 824397 expected to be merged prior next week's meeting
14:29:55 <oschreib> mburns: next bug is yours
14:30:15 <mburns> #link https://bugzilla.redhat.com/show_bug.cgi?id=824420
14:30:28 <mburns> #info tracker for node based on F17
14:30:40 <mburns> #info blocked by util-linux bug currently
14:30:55 <mburns> #info new build expected from util-linux maintainer in next couple days
14:31:26 <mburns> that's it for that bug at the moment
14:31:47 <mburns> oschreib: anything else for release status?
14:32:24 <oschreib> no
14:32:31 <oschreib> 30min is enough for me
14:32:41 <mburns> ;-)
14:32:49 <mburns> #topic sub-project status -- engine
14:33:05 <mburns> doronf: anything to report outside of what is ^^?
14:33:33 <doronf> mburns: not really. some issues beying checked
14:33:40 <doronf> but nothing crucial.
14:33:46 <mburns> doronf: ok
14:34:00 <mburns> #info nothing to report outside of blockers discussed above
14:34:09 <mburns> #topic sub-project status -- vdsm
14:34:28 <mburns> dougsland: anything to report?
14:35:21 <dougsland> not really
14:35:36 <mburns> #info nothing outside of blockers above
14:35:43 <mburns> #topic sub-project status -- node
14:35:58 <mburns> #info working on f17 migration, but blocked by util-linux bug
14:36:23 <mburns> #info should be ready for freeze deadline
14:36:43 <mburns> #topic Review decision on Java 7 and Fedora jboss rpms in oVirt Engine
14:37:02 <oschreib> Java7 is basically working (compilation wize)
14:37:11 <oschreib> and from some short tests I made
14:37:19 <mburns> #info Java7 basically working
14:37:27 <oschreib> doronf: any more info on that?
14:37:42 <mburns> so can we agree that we'll run on java 7 and drop that from the agenda?
14:37:47 <doronf> oschreib: I wasn't monitoring it, so can't update.
14:38:25 <mburns> if it's basically working, would make sense to me to just say the decision is made
14:38:27 <oschreib> ok, I need update from engine on that, to be sure we have no other risk there
14:38:41 <mburns> oschreib: ok, want to take it offline then?
14:38:48 <mburns> and get an update for next week?
14:39:02 <oschreib> I think engine should give ack on that next build
14:39:08 <mburns> ok
14:39:11 <doronf> oschreib: I beleive this may need to be verified with DWH  / reporting as well.
14:39:18 <mburns> and fedora jboss rpm status?
14:39:25 <mburns> still pending?
14:39:27 <oschreib> mburns: patch is in review
14:39:35 <oschreib> http://gerrit.ovirt.org/#change,4416
14:39:45 <oschreib> short tests worked fine
14:39:49 <mburns> #info engine will make ack/nack statement next week
14:40:04 <mburns> #info fedora jboss rpms patch is in review, short tests passed
14:40:12 <doronf> mburns: this is reporting as well. not just engine.
14:40:34 <oschreib> ydary: any issues with dwh on Java7?
14:41:07 <ydary> no
14:41:27 <oschreib> ydary: it just work?
14:42:30 <yzaslavs> doronf: ping
14:42:32 <doronf> oschreib: sec
14:43:05 <ydary> While Talend don't officially support openjdk, we have been testing with openJDK 1.7.0 for a while now and had no issues.
14:43:41 <mburns> ok, so it's just engine ack on fedora jboss rpms and java7
14:43:45 <mburns> that we need
14:44:25 <oschreib> indeed
14:44:47 <mburns> #info engine ack on fedora jboss rpms and java7 needed next week
14:44:55 <mburns> ok, moving on unless someone has something else?
14:45:11 <mburns> #topic Upcoming Workshops
14:45:21 <mburns> lh: anything to report here?
14:45:40 <lh> Visit to NetApp HQ in Sunnyvale, California, US went well last week.
14:46:01 <lh> We have nailed down the January 22nd - 24th 2013 dates for the workshop, more details forthcoming
14:46:39 <mburns> #info NetApp workshop set for Jan 22-24 2012
14:46:52 <lh> For nearer term workshops, we are at half capacity for LinuxCon Japan and we're confident that we'll fill all 50 seats, but it would still be wonderful for folks to promote the event
14:47:07 <lh> mburns, s/2012/2013 for #info
14:47:14 <mburns> #undo
14:47:14 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x8e5afcc>
14:47:16 <mburns> #info NetApp workshop set for Jan 22-24 2013
14:47:34 <lh> I will also raise this on list, but it has been proposed that we have board meetings at all large workshops
14:47:37 <mburns> #info already at half capacity for Workshop at LinuxCon Japan
14:47:49 <mburns> #info please continue to promite it
14:48:16 <mburns> #undo
14:48:16 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x8db976c>
14:48:19 <mburns> #info please continue to promote it
14:48:25 <lh> I believe there is not sufficient time to organize such a meeting for LC Japan, but LinuxCon North America, KVM Forum and the NetApp workshop would all be good venues for a board meeting
14:48:43 <mburns> #info proposal:  board meeting to be held at all major workshops
14:48:47 <lh> Want to get that on everyone's radar for now so we can begin planning board meetings where they make sense
14:49:02 <lh> Other than these items, nothing new to report out.
14:49:14 <mburns> lh: definitely bring up board meetings thing on the list
14:49:18 <lh> Details will continue to be added to http://www.ovirt.org/wiki/OVirt_Global_Workshops
14:49:23 <mburns> i'm not sure if there are even any board members here today
14:49:30 <mburns> #link http://www.ovirt.org/wiki/OVirt_Global_Workshops
14:49:32 <lh> mburns, ack
14:49:47 <mburns> lh: agree that it's not possible for LC Japan
14:49:50 <mburns> just too close
14:50:12 <mburns> #topic Open Discussion
14:50:18 <mburns> anyone have other topics?
14:50:43 <mburns> #info oVirt/Quantum integration discussion will be held separately
14:50:58 * mburns waits 2 min for other topics
14:52:12 <cestila> hi sale
14:52:19 <cestila> i'm is new
14:52:44 <mburns> Thanks all
14:52:47 <mburns> #endmeeting