14:00:55 <mburns> #startmeeting oVirt Weekly Sync
14:00:55 <ovirtbot> Meeting started Wed May  9 14:00:55 2012 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:55 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:02 <mburns> #chair oschreib
14:01:02 <ovirtbot> Current chairs: mburns oschreib
14:01:10 <mburns> #topic agenda and roll call
14:01:18 * jb_netapp is here
14:01:23 <dustins> *here
14:01:31 <mburns> #link http://www.ovirt.org/wiki/Meetings#Weekly_project_sync_meeting
14:01:32 * oschreib here
14:01:34 <mburns> agenda is ^^
14:01:42 <ykaul> here
14:01:44 * aglitke here
14:01:45 * mburns waits 2 min for people to say they're here
14:01:56 * lh is here
14:03:58 <mburns> ok
14:04:03 <mburns> #topic Release status
14:04:05 * doron here
14:04:12 <mburns> oschreib: any updates?
14:04:45 <oschreib> Nothing much
14:04:55 <oschreib> lots of patches every day in the engine
14:05:17 * eedri here
14:05:22 <oschreib> Java7 and JBoss  are a major concern
14:05:31 * ofrenkel here
14:06:22 <mburns> oschreib: ok, we have a separate topic for java 7 and jboss
14:06:48 <oschreib> we separated some RPMS from our spec
14:06:53 <oschreib> thanks to kroberts
14:07:09 <mburns> #info not much new with release status
14:07:13 <oschreib> iso-uploader, log-collector and image-uploader are a separate components now
14:07:21 <oschreib> and soon will be in Fedora
14:07:22 <mburns> #info concerns with java 7 and jboss
14:08:12 <mburns> #info iso-uploader, log-collector, image-uploader are separate components and going into Fedora
14:08:31 <mburns> just as a reminder:
14:08:44 <mburns> #info Devel Freeze and branching:  May 31
14:08:58 <mburns> #info Release date:  June 27
14:09:11 <mburns> oschreib: how are we looking for alpha release next week sometime?
14:09:14 <oschreib> you actually read my command line
14:09:27 <mburns> :)
14:09:38 <oschreib> I'll send a mail to the maintainers to provide builds
14:09:43 <mburns> oschreib: ok
14:09:45 <oschreib> so we will put them in the nightly dir
14:09:58 <mburns> sounds good
14:10:04 <oschreib> but I guess it will be for F16
14:10:16 <mburns> we can get project maintainers to give updates in sub-project status
14:10:25 <mburns> oschreib: engine on f16, right?
14:10:35 <mburns> b/c vdsm requires f17, iiuc
14:10:39 <oschreib> mburns: sure
14:11:01 <mburns> #action oschreib to follow up with maintainers to get builds done for alpha next week (hopefully)
14:11:14 <mburns> #info engine likely to have alpha on f16
14:11:29 <mburns> #info vdsm requirements will put node and other hosts on f17
14:11:33 * lpeer_ here
14:11:35 <ykaul> mburns: so all-in-one feature is not going to make it, if VDSM requires F17 and engine (and webadmin) F16.
14:11:53 <mburns> ykaul: this is for alpha only
14:12:10 <mburns> by the time we get to branching, i expect that we'll have engine working on f17
14:12:13 <kroberts> oschreib: what did I do?
14:12:22 <ykaul> mburns: no, it's until we solve the issues with F17, Java 7, etc. Is there a commitment to solve it to beta?
14:12:27 <oschreib> kroberts: separated rpms
14:12:33 <kroberts> oschreib: ah.
14:12:50 <kroberts> oschreib: yw. sorry it took so long
14:13:11 <oschreib> kroberts: np
14:13:14 <oschreib> ykaul: indeed
14:13:25 <oschreib> ykaul: we're aiming for F17
14:13:32 <mburns> ykaul: imo, its a blocker for beta, but we can discuss in the next section
14:14:13 <kroberts> oschreib: question... I'm assuming I do *not* need separate RPMs in time for F17's release on 5/22
14:14:19 <kroberts> oschreib: or do I?
14:14:28 <oschreib> kroberts: no, we don't
14:14:43 <oschreib> kroberts: we will provide our own rpms for F17
14:14:48 <mburns> ok, anything else for release status?
14:15:00 <oschreib> kroberts: but you can push them into Fedora, it be quick
14:15:18 <mburns> i think fedora for f17 is locked down now
14:15:48 <mburns> so it can only go as an update post-release
14:16:07 <mburns> ok, moving on
14:16:24 <mburns> #topic sub-project status -- Node
14:16:44 <kroberts> oschreib: ok, I have to get all of the FAS stuff set up.  I think I need to be in the "Packager" group
14:17:06 <mburns> #info we've started looking at f17 builds, but not a lot of progress there yet
14:17:07 <kroberts> oschreib: An I need to be sponsored or something
14:17:08 <oschreib> kroberts: lets take it offline, we're in the weekly sync meeting now :)
14:17:15 <mburns> #info plan to get on this in the next week
14:17:16 <kroberts> oschreib: k
14:17:33 <mburns> #topic sub-project status -- Engine
14:17:46 <mburns> lpeer_: updates?
14:17:57 <lpeer_> mburns: we sent a patch to work
14:18:03 <lpeer_> mburns: with jdk 7
14:18:24 <lpeer_> mburns: now it is not working with GWT other than that nothing new
14:18:54 <mburns> #info patch send to work with jdk 7, but that broke gwt
14:18:59 <mburns> #undo
14:18:59 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x96ffc8c>
14:19:05 <mburns> #info patch sent to work with jdk 7, but that broke gwt
14:19:19 <mburns> #topic sub-project status -- VDSM
14:19:28 <mburns> danken: any updates on vdsm?
14:19:32 <lpeer_> mburns:  it did not break the GWT only exposed the problem that was there
14:19:44 <mburns> #undo
14:19:44 <ovirtbot> Removing item from minutes: <MeetBot.items.Topic object at 0x96ffdec>
14:19:46 <mburns> #undo
14:19:46 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x96ffdac>
14:20:01 <mburns> #info patch sent to work with jdk 7, but that exposed issue with GWT
14:20:09 * RobertM here
14:20:12 <mburns> #topic sub-project status -- VDSM
14:20:31 <mburns> #info no vdsm representative here to give update
14:21:00 <mburns> #topic Java7 and distro versions of jboss
14:21:37 <mburns> lpeer_: can we consider this a blocker? or still too early to decide?
14:23:58 <mburns> #info we're deferring decision on whether java 7 and jboss from fedora are blockers, will keep on agenda for next week
14:24:20 <mburns> #topic upcoming workshops
14:24:23 <ykaul> mburns: blocker for ... alpha? beta?
14:24:39 <mburns> ykaul: not alpha, since we know it won't be ready for that
14:24:45 * lh waits for convo on blocker to finish
14:24:47 <mburns> but we need call on beta/GA
14:25:02 <mburns> i'll force decision next week
14:25:11 <mburns> lh: all yours
14:25:15 <ykaul> mburns: unless we postpone the alpha, of course.
14:25:16 <lh> great.
14:25:19 <eedri> can we add maven/jenkins status to the topic?
14:25:32 <mburns> eedri: sure, we can add that after workshops
14:25:56 <lh> Next upcoming workshop is LinuxCon Japan, June 8th in Yokohama
14:26:06 <lh> Agenda has been published to the LC Japan site https://events.linuxfoundation.org/events/linuxcon-japan/ovirt-gluster-workshops
14:26:21 <lh> And registration is now available at http://www.regonline.com/Register/Checkin.aspx?EventID=1099949
14:26:39 <lh> A summary of all this information will be sent out to the various oVirt lists following this meeting
14:26:43 <lh> but for the benefit of those here
14:27:08 <lh> Please invite folks to the workshop you feel would benefit from it
14:27:12 <mburns> #info next workshop is LinuxCon Japan -- June 8
14:27:20 <mburns> #link https://events.linuxfoundation.org/events/linuxcon-japan/ovirt-gluster-workshops
14:27:26 <mburns> #link http://www.regonline.com/Register/Checkin.aspx?EventID=1099949
14:27:37 <mburns> #info please invite people who would benefit
14:27:46 <lh> Those attendees who sign up using the oVirt workshop registration link receive discounted registration to LC Japan
14:28:09 <lh> And those who have already registered may amend their existing registration to add in the workshop
14:28:26 <lh> The Linux Foundation will be promoting on behalf of the oVirt project
14:28:42 <lh> If anyone would like details on our promotion strategy, I can share them now or contact me offline
14:28:48 <mburns> excellent
14:29:03 <mburns> for those interested, the workshop will be led by bazulay and me
14:29:18 <lh> Only other topic is that we're making progress on NetApp workshop to be held in San Francisco Bay Area for late January 2013
14:29:22 <mburns> though if someone else wants to help out, we probably won't say no
14:29:28 <lh> And the lists will be notified when that is confirmed
14:29:41 <mburns> jb_netapp: any updates on ^^
14:30:05 <mburns> lh: what about linuxcon NA and linuxcon Europe?
14:30:05 <lh> mburns, I'll be visiting NetApp campus next week, so assume we'll be driving to completion then
14:30:12 <mburns> lh: ok
14:30:20 <lh> workshops are confirmed for LC North America and Europe
14:30:31 <lh> dates not yet nailed down, nor agenda, nor instructors
14:30:36 <lh> but that is on the collective radar
14:30:37 <mburns> #info lh will work out details during visit to netapp next week
14:31:10 <mburns> #info confirmed for linuxcon NA (August) and Europe (November), agendas/instructors/dates not finalized yet
14:31:33 <lh> mburns, that's all i have regarding workshops
14:31:38 <mburns> excellent
14:31:40 <mburns> thanks lh
14:31:48 <lh> my pleasure
14:31:59 <mburns> #topic maven/jenkins status
14:32:03 <mburns> eedri: all you
14:32:07 <eedri> few issues
14:32:19 <eedri> 1st - we are still failing on clean mvn install using mvn 3.0.x
14:32:36 <mburns> eedri: bug filed?
14:32:54 <eedri> not sure if it's a bug or maven issue
14:33:12 <eedri> needs to investigated
14:33:56 <eedri> mburns, i will open a bug on it
14:34:14 <mburns> eedri: thanks
14:34:25 <mburns> if it turns out to be maven, we can move or close the bug
14:34:29 <mburns> or clone it
14:34:36 <eedri> 2nd issue - lately gwt build started failing on error "too many open files"
14:34:53 <mburns> eedri: sounds like a config issue on the build host
14:34:56 <eedri> wondering if a code change triggerd this, of lack of resources from jenkins VM
14:35:22 <mburns> eedri: my guess would be that it's vm limitation
14:35:32 <mburns> that we can work around
14:35:40 * mburns trying to remember option that needs to be set
14:35:45 <sgordon> yeah
14:35:53 <eedri> mburns, option was set to fs.max=2048
14:35:59 <eedri> mburns, or 4096..
14:36:04 <sgordon> /etc/sysctl.conf i think
14:36:10 <eedri> mburns, default was 1024
14:36:26 <mburns> eedri: is that not helping?
14:36:34 <mburns> ulimit sets it, i think
14:36:38 <eedri> mburns, sometimes, let's take it offline and see
14:36:44 <mburns> eedri: ok
14:36:49 <eedri> mburns, ulimit only helps current shell
14:37:12 <eedri> 3rd issue - email alerts from jenins have been updated to contain more info
14:37:29 <mburns> sysctl -w fs.file-max=100000
14:37:32 <eedri> any remakrs on that ? should it include additional info / less info
14:37:57 <eedri> mburns, ok, i will set it on all jenkins slaves and we'll monitor it
14:38:13 <mburns> eedri: i've generally found that the level of info is sufficient
14:38:25 <mburns> and as long as the link is in there, i'm fine
14:38:48 <mburns> eedri: for file limits, i found this link:  http://www.cyberciti.biz/faq/linux-increase-the-maximum-number-of-open-files/
14:38:58 <eedri> mburns, there is still the annoying issue of empty emails sent ocasionally, probably bug in email plugin
14:39:03 <eedri> mburns, checking into it
14:39:24 <mburns> eedri: that must affect engine builds, i've not seen that with node stuff
14:39:43 <eedri> mburns, you might not used the "ext-email" pluging
14:39:51 <mburns> right, i don't
14:40:36 <mburns> #info clean mvn install using 3.0.x is failing
14:40:44 <mburns> #action eedri to file bug to investigate issue
14:41:02 <mburns> #info builds failing due to too many open files
14:41:14 <akio> I have everything working except storage, it doesn't look like you can create pools from FC luns with the webadmin.
14:41:33 <akio> It says that it isn't implemented.
14:41:36 <mburns> #info try increasing limit and see if that helps, if not, bring up again in this meeting
14:42:03 * akio realizes his rudeness, sorry
14:42:07 <mburns> #info email alerts updated to include more info
14:42:22 <mburns> #info feedback on level of detail would be appreciated
14:42:39 <mburns> #info this affects only engine builds, node builds use a different email method
14:42:45 <mburns> eedri: anything else?
14:42:53 <mburns> akio: no worries, should be done shortly
14:43:13 <eedri> mburns, waiting to see when we can start using stronger jenkins slaves
14:43:47 <eedri> mburns, just a reminder to check status on that
14:43:59 <mburns> eedri: i think we can followup on that on the infra list
14:44:07 <mburns> there were comments from quaid and itamar there
14:44:13 <eedri> mburns, sure
14:44:37 <mburns> eedri: is that all for jenkins stuff?
14:44:46 <eedri> mburns, for now :)
14:44:55 <mburns> eedri: thanks
14:45:01 <mburns> #topic Other Topics
14:45:06 <mburns> anyone have anything else to bring up?
14:45:29 * mburns thinks we can leave forum/mailing list discussion on the mailing list for now
14:46:00 <oschreib> probably
14:46:40 <mburns> ok, starting countdown to ending the meeting
14:47:10 <mburns> #info discussion about forums vs. mailing lists on infra@ovirt.org -- feedback welcome
14:47:43 <mburns> meeting ending in 1 minute unless we have other topics
14:49:32 <mburns> Thanks all
14:49:34 <mburns> #endmeeting