13:00:21 <mburns> #startmeeting oVirt Node Weekly Sync
13:00:21 <ovirtbot> Meeting started Tue Mar 27 13:00:21 2012 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:21 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:00:31 <mburns> #chair mburns jboggs pmyers fabiand
13:00:31 <ovirtbot> Current chairs: fabiand jboggs mburns pmyers
13:00:37 * pmyers here
13:00:38 <mburns> #topic Roll Call and Agenda
13:00:41 * jboggs here
13:00:46 * fabiand here
13:00:49 <mburns> 1.  Action Item Review
13:00:54 <mburns> 2.  Release Status
13:00:59 <mburns> 3.  Stateless status and update
13:01:04 <mburns> 4.  CIM status and update
13:01:10 <mburns> 5.  Other topics
13:01:30 <mburns> anyone have other topics?
13:01:46 <mburns> #topic action item review
13:01:58 <mburns> #link http://ovirt.org/meetings/ovirt/2012/ovirt.2012-03-20-13.02.html
13:02:23 <mburns> #info systemd patches posted
13:02:37 <mburns> #info systemd patches reviewed and merged
13:02:53 <mburns> #info bugs updated for 2.3.0 release
13:03:31 <mburns> #info mburns still hasn't looking into stateless yet
13:03:38 <mburns> but we'll discuss that later
13:03:45 <mburns> #topic release status
13:04:02 <mburns> #info oVirt Node 2.3.0 Released 2012-03-26
13:04:26 <mburns> #link http://www.ovirt.org/wiki/Node_Backlog
13:04:48 <mburns> i updated the 2.3.0 link there, added a 2.5.0 link and an untargeted link
13:05:31 <mburns> oVirt Project release is targeting May for their next release
13:05:59 <mburns> we should target 2.4.0 for end of April, then do 2.4.1, 2.4.2 as needed during that next month
13:06:07 <mburns> thoughts?
13:06:22 <jboggs> sounds ok to me
13:06:32 <fabiand> to me too
13:06:47 <ovirtbot> 14[[07Node Backlog14]]4 !10 02http://www.ovirt.org/w/index.php?diff=2961&oldid=2960&rcid=3045 5* 03Mburns 5* (+7) 10
13:06:56 <mburns> ok, updated backlog page with that date
13:07:12 <mburns> #agreed 2.4.0 targeted for 2012/04/30
13:07:50 <mburns> given that, we need to review the bug list for 2.4.0 and move out bugs that we can't get done
13:08:19 <mburns> jboggs: fabiand:  can you see what's assigned to you and what you think you can reasonably get done for that date?
13:09:02 <mburns> jboggs: fabiand:  also taking into account other responsibilities you have beyond just ovirt-node
13:09:34 <jboggs> mburns, mine are obscure ones that are probably going to be pushed anyways, can possibly take on some you guys want to push
13:09:35 <mburns> #action jboggs fabiand mburns to review bugs assigned and move to 2.5.0 where appropriate
13:10:00 <mburns> jboggs: i expect most of your time will be spent on plugin development
13:10:13 <mburns> i'd like to get that and stateless in for 2.4.0
13:10:24 <jboggs> ok that works
13:10:25 <fabiand> mburns, we'll have to talk about where else I could be working on
13:10:39 <pmyers> network manager conversion?
13:10:42 <pmyers> that's probably important
13:10:42 <fabiand> :)
13:10:43 <ovirtbot> 14[[07Vdsm TODO14]]4 !10 02http://www.ovirt.org/w/index.php?diff=2962&oldid=2676&rcid=3046 5* 03Danken 5* (+241) 10/* What Can You Do for Vdsm */ 
13:10:50 <mburns> fabiand: yes, you've done a good job grabbing bz's
13:11:07 <mburns> fabiand: i'd like to get automation stuff going a bit as well
13:11:07 <fabiand> :)
13:11:13 <fabiand> mburns, definetly!
13:11:19 <fabiand> I'd also like to get some automated testing
13:12:09 <hitvx> suggestion, one should not 'feature freeze' on 2012-04-31 (http://www.ovirt.org/wiki/Second_Release)  ;)
13:12:12 <xTs_w> mburns: :)
13:12:19 <xTs_w> mburns: how's the stateless node coming?
13:12:46 <mburns> #action mburns to work with fabiand on mapping out automation plan
13:13:40 <mburns> hitvx: yeah, hard to freeze on a day that doesn't exist
13:14:32 <mburns> we'll target 2012/04/30 for our 2.4.0 and that will allow us to meet the 2012/05/31 release date for the overall project
13:14:40 <mburns> xTs_w: stateless is the next topic
13:16:00 <ovirtbot> 14[[07Second Release14]]4 !10 02http://www.ovirt.org/w/index.php?diff=2963&oldid=2795&rcid=3047 5* 03Mburns 5* (+0) 10/* Timeline */ change feature freeze to 30-April since 31-April doesn't exist
13:16:11 <mburns> ok, anything else for releases?
13:16:34 <mburns> #info oVirt 3.1 release targeted for 2012-31-05
13:16:49 <mburns> #info oVirt 3.1 feature freeze 2012-04-30
13:16:56 <mburns> ok, on to stateless
13:17:01 <mburns> #topic Stateless
13:17:21 <mburns> #link http://www.ovirt.org/wiki/Node_Stateless
13:18:01 <mburns> #action mburns to update wiki page
13:18:10 <mburns> #undo
13:18:10 <ovirtbot> Removing item from minutes: <MeetBot.items.Action object at 0x96af44c>
13:18:15 <mburns> #action mburns to update wiki page for stateless
13:18:44 <mburns> i've been using stateless locally to test images
13:18:52 <mburns> it seems to be fairly stable
13:19:09 <mburns> but we're still limited by the lack of support for stateless nodes by vdsm and engine
13:19:15 <pmyers> xTs_w: speaking of stateless, any chance you can help push that along re: some patches?  If we had some more folks helping in the community we could make a lot more progress here :)
13:19:23 <fabiand> mburns, would be nice if you added your notes how to do this to the wiki
13:19:33 <mburns> fabiand: how to run stateless?
13:19:40 <fabiand> mburns, yes
13:19:57 <pmyers> mburns: stateless for vdsm/oVirt Engine is outside the scope of oVirt Node project... we'll do what we can to make Node stateless (as much as possible) and then leave the rest to vdsm team
13:20:05 <xTs_w> pmyers: I'd like to help, but recently had to kill my whole testing equipment, because we needed the parts somewhere else :(
13:20:15 <pmyers> that's a bummer :(
13:20:16 <mburns> fabiand: ok, i'll put up a quick wiki page, but in short, add "stateless" to the kernel command line
13:20:16 <xTs_w> I've currently got no stuff to test
13:20:26 <pmyers> you can do dev work on Node in a VM though
13:20:35 <pmyers> so even if you have a single box with kvm on it, it's good enough :)
13:20:35 <fabiand> mburns, right - I can go trough the scripts to see what's happening :)
13:20:55 <mburns> yes, i do most install testing in vms first, and develop on a vm
13:21:03 <mburns> then move to real hardware once i work out bugs there
13:21:35 * mburns has even been known to run test installs on vms running inside ovirt-engine on ovirt-node
13:21:54 <fabiand> mburns, nesting?
13:21:59 <mburns> overall, most of the basic steps for stateless are done
13:22:02 <mburns> fabiand: mostly
13:22:18 <mburns> you can't run vms on the nested or virtualized ovirt-nodes
13:22:21 <fabiand> mburns, nesting would be nice for testing - but later more on this
13:22:34 <mburns> but you can do most of the rest
13:22:49 <fabiand> at least it would be nice to allow virtualized nodes to be registered with engine - for testing
13:23:25 <mburns> #action mburns to review current stateless state and get a todo list together
13:23:57 <mburns> fabiand: yes, registration should actually work with virtualized nodes
13:24:06 <mburns> they should just come up non-operational
13:24:26 <mburns> ok, anything else to cover on stateless?
13:24:31 <fabiand> right
13:25:05 <mburns> ok, moving on to cim
13:25:10 <mburns> #topic CIM Status
13:25:47 <mburns> #info sblim-sfcb service starts, firewall port is opened, cim password can be set correctly
13:25:58 <mburns> #info remote systems cannot query however
13:26:38 <mburns> DV gave me some pointers on node-devel@ earlier and looking through the logs he suggested, i found that it's failing to load the libcmpiutil.so library
13:26:50 <mburns> this is because we blacklisted that package
13:27:13 * mburns will have a patch soon to un-blacklist it and re-test cim
13:27:45 <pmyers> cool
13:28:18 <mburns> #other topics
13:28:42 <mburns> #action mburns to patch missing libcmpiutil package and retest cim
13:28:46 <mburns> #topic Other Topics
13:29:01 <mburns> Automation
13:29:21 <mburns> fabiand: we can work up a high level plan for automation, then we can send it to node-devel@
13:29:31 <fabiand> sounds good
13:29:47 <mburns> makes more sense to do that off line to me rather than in a meeting like this
13:30:02 <mburns> Network Manager conversion
13:30:12 <mburns> pmyers: i didn't completely ignore your comment earlier
13:30:37 <mburns> we're going to need to move toward supporting the network manager api in the near future
13:30:39 <fabiand> I'd say we should start this early ..
13:30:51 <mburns> fabiand: yes, i agree
13:31:08 <pmyers> mburns: I know you didn't which is why I didn't poke you a second time :)
13:31:16 <jboggs> using NM api should hopefully clear up alot of the networking scenarios from potential failures
13:31:31 <mburns> it appears that vdsm is going to eventually make NM their default interface for network management, so at the very least we need to start including it
13:31:40 <mburns> jboggs: i hope so as well
13:32:14 <mburns> i think what we'll do is have jboggs focus on the plugins
13:32:28 <mburns> fabiand: on the automation stuff
13:32:40 <mburns> mburns: on the stateless
13:32:43 <mburns> all of us fixing bugs
13:33:05 <mburns> and whoever gets through the big ticket stuff first takes the first pass at designing the NM changes
13:33:50 <fabiand> Maybe the last one getting thourgh should get NM? ;)
13:33:58 <jboggs> haha
13:33:58 <mburns> i'll try to get a wiki feature page up for NM this week
13:34:01 <mburns> fabiand: ;-)
13:34:12 <mburns> #action mburns to post wiki page for NM feature
13:34:32 <mburns> anything else for NM?
13:34:41 <mburns> not sure there is much to talk about at the moment here
13:34:53 <mburns> ok, one other thing from me then
13:34:57 <mburns> #link http://ovirt.org/wiki/Node_Troubleshooting
13:35:05 <mburns> i threw this together yesterday
13:35:18 <mburns> so it's really just a dump of stuff off the top of my head
13:35:26 <mburns> feel free to add anything else you've found
13:35:38 <mburns> or add additional topics
13:36:04 <mburns> or even erase what i wrote as being horribly wrong...
13:36:30 <mburns> that's all i have for today
13:36:32 <fabiand> Don't know if it's relevant for the meeting, but the /data-not-beeing-mounted bug seems quite important to me
13:36:43 <fabiand> because it will make updates difficult, afaiu
13:36:54 <mburns> sure we can cover it briefly
13:37:01 <mburns> #topic mountpoints not getting mounted
13:37:15 <mburns> #link https://bugzilla.redhat.com/show_bug.cgi?id=806349
13:37:38 <mburns> background -- /data is not getting mounted correctly on reboot
13:37:51 <mburns> and i've heard that /var/log isn't either
13:37:55 <fabiand> yep
13:37:59 <fabiand> just Config
13:38:26 <fabiand> thus, logging and data as well as bind-mounting  /data/images to the libvirt path doesn't happen
13:38:47 <mburns> fabiand: has investigated and found that this is due to a systemd bug where it recognizes that the unit file that does the /etc/fstab mounting was updated, but doesn't reload
13:39:03 <fabiand> I wouldn't say it's a bug ..
13:39:06 <mburns> he's posted a workaround fix already and filed a systemd bug on this
13:40:00 <fabiand> (swap is also affected)
13:40:38 <fabiand> At least: A couple of paths are not mounted correctly, including the images path and that ain't to good in my eyes
13:41:07 <mburns> /data/images is only a problem if the user wants to upgrade from engine or run a "local" storage domain
13:41:42 <mburns> HostVG-Logging and Swap not working right are larger concerns for me
13:41:53 <fabiand> ah okay - I thought that /data/images is the "main entry point"
13:41:59 <fabiand> (for storing images)
13:42:39 <mburns> i'm pretty sure vdsm manages that in another location, though the actual location escapes me atm
13:43:11 <fabiand> I  believe it will be libvirts default location (~ /var/lib/libvirt/images)
13:43:36 <mburns> no, it's something like /engine/data-center or something like that
13:43:44 <fabiand> oh that one. ok
13:43:54 <mburns> they do whatever mounting they need there
13:44:12 <mburns> anything else to discuss on this?
13:44:18 <mburns> i think it's well in hand currently
13:44:29 <mburns> we have a workaround and bug filed for the original problem
13:44:35 <mburns> and a separate bug to revert the fix
13:44:44 <mburns> err...revert the workaround
13:45:10 <mburns> ok, thenk
13:45:14 <mburns> #topic Other Topics
13:45:23 <mburns> anything else to bring up today?
13:45:50 <mburns> going once...
13:46:05 <mburns> twice..
13:46:16 <mburns> gone
13:46:22 <mburns> thanks everyone
13:46:25 <mburns> #endmeeting