14:01:14 <mburns> #startmeeting oVirt Node weekly sync
14:01:14 <ovirtbot> Meeting started Tue Feb 28 14:01:14 2012 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:14 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:29 <mburns> #topic agenda and roll call
14:01:33 <mburns> who's here?
14:01:36 <mburns> Agenda:
14:01:41 <mburns> 1.  Action Item Review
14:01:45 <mburns> 2.  Release Status
14:01:49 <mburns> 3.  Other topics
14:02:33 <mburns> pmyers: jboggs:  here?
14:02:36 <jboggs> here
14:03:07 <mburns> #topic Action item review
14:03:19 <mburns> #link http://ovirt.org/meetings/ovirt/2012/ovirt.2012-02-21-14.03.html
14:04:27 <mburns> #info gerrit status:  6 patches posted, 4 need review by mburns, others need re-work by mburns
14:05:13 <ovirtbot> 14[[07Development/Introducing Entity Search14]]4 !10 02http://www.ovirt.org/w/index.php?diff=2543&oldid=2539&rcid=2619 5* 03Lhornyak 5* (+90) 10/* Introduce the Entity in Database */ 
14:05:24 <mburns> #info node builds now running correctly in jenkins.ovirt.org
14:05:44 <mburns> #info ovirt-node-iso is close, but not quite there yet, should be done EOW
14:05:55 <mburns> #action mburns to finish patch reviews by EOW
14:06:07 <mburns> #action mburns to post ovirt-node-iso by EOW
14:06:28 <mburns> #action mburns to get jenkins builds running based on gerrit posts
14:06:52 <mburns> jboggs: any luck getting info from dnaori on the install issue?
14:07:05 <mburns> #info initial plugin patch posted for review
14:07:20 <jboggs> same issue still after updating the bios just awaiting ssh access to take a closer look
14:07:29 <mburns> jboggs: ok
14:07:33 <jboggs> updated the bz last night
14:07:43 <mburns> #info install issue still pending resolution
14:08:02 <mburns> #topic release status
14:08:20 <mburns> #info Targeting ovirt-node 2.3.0 for March 15
14:08:46 * pmyers in late
14:08:47 <mburns> #info 15 bugs still outstanding
14:09:00 <mburns> #link http://goo.gl/xb410
14:09:44 <mburns> oVirt project release targeting late May for next coordinated release
14:10:04 <mburns> that will likely be with either 2.4.0 or 2.3.1 of ovirt-node
14:10:22 <mburns> #info oVirt project release targeting late May for next coordinated release
14:10:25 <mburns> #info that will likely be with either 2.4.0 or 2.3.1 of ovirt-node
14:11:07 <mburns> pmyers: jboggs:  not sure we can hit the Mar 15 date with 15 open bugs
14:11:19 <mburns> especially since i'm on vacation next week...
14:11:35 <pmyers> bite off as many as we can
14:11:36 <jboggs> ill see what i can push through
14:11:44 <pmyers> and we'll do a 2.4.0 release with a subset of the bugs fixed
14:11:52 <mburns> ack
14:12:21 <mburns> #agreed make best effort for March 15 and push other bugs to future release
14:12:22 <pmyers> fabiand_ should be able to help out more I think as well :)
14:13:41 <mburns> fabiand_: let me know what type of bandwidth you have to pick some of these up
14:14:26 <mburns> #action mburns to coordinate with fabiand_
14:14:41 <mburns> #topic other topics
14:15:03 * mburns doesn't have other topics to cover today
14:15:07 <fabiand_> pmyers: yep I'll be working on some of the bugs, not yet at full speed though
14:15:18 <pmyers> whatever you can contribute will be appreciated :)
14:15:37 <fabiand_> mburns: I've already started on the systemd migration, I'll push my branch somewhere in the next couple of days
14:15:37 <pmyers> mburns: stateless debate?
14:16:02 <mburns> fabiand_: feel free to just post the patches to gerrit
14:16:08 <pmyers> assume you guys have been following the thread with doronf_ abaron and I?
14:16:35 <mburns> fabiand_: just include RFC or something in the commit header so we don't push something pre-maturely
14:16:57 <fabiand_> mburns, right
14:17:09 <mburns> iirc, there is an option in the git-review tool that does drafts, though i haven't used it
14:17:37 <mburns> pmyers: i followed up to the weekend, but i'm behind on the thread
14:17:41 <pmyers> k
14:17:59 <pmyers> I don't think there's any question as to whether or not oVirt Node general purpose should support stateless
14:18:03 <pmyers> I mean we already do for Archipel
14:18:04 <pmyers> however
14:18:15 <pmyers> there seems to be some debate as to whether anyone cares for oVirt Engine specifically
14:18:28 <pmyers> which may mean that oVirt Node just implements the basic stateless stuff as we have already planned
14:18:36 <mburns> pmyers: lid is definitely interested
14:18:39 <pmyers> and if vdsm/oVirt Engine decides not to worry about it, that's their call
14:18:49 <pmyers> what's lid
14:18:52 <pmyers> lid's role/
14:19:18 <pmyers> i.e. working on oVirt in general or working like the archipel folks?
14:19:22 <mburns> he's been working on a stateless node with engine for the past couple weeks
14:19:35 <pmyers> ah
14:19:53 <mburns> he's been a bit unclear on how much he's going to rely on engine
14:19:57 <pmyers> k
14:20:10 <mburns> but my impression is that he's interested in it
14:20:16 <pmyers> well, imo, we know what _we_ need to implement from the pure Node side
14:21:17 <mburns> pmyers: yes
14:21:20 <xTs_w> (I'm very interested in the stateless node btw. But no time atm to do any work :(
14:21:40 <mburns> looks like i'm only a couple messages behind on that thread
14:21:47 <pmyers> xTs_w: even if not contributing patches, weigh in on the discussion :)
14:22:23 <xTs_w> pmyers: well, I can't follow the discussion either. Somebody screwed up the backup here and I've got to fix it :(
14:22:29 <pmyers> ah
14:22:40 <mburns> #action mburns to follow up on the stateless email thread
14:22:49 <pmyers> ok, other topic... how's UEFI doing?
14:22:51 <mburns> and get other who are interested to weigh in as well
14:23:06 <pmyers> i saw some 'boot/install' issue threads and am curioius to know if there are still outstanding issues being triaged?
14:23:36 <mburns> jboggs: ^^
14:23:40 <jboggs> pmyers, havent heard anything back on uefi, its needinfo still
14:23:50 <mburns> pmyers: 2 issues that i'm aware of
14:23:53 <jboggs> ill add another comment
14:23:55 <pmyers> bz#s?
14:24:11 <mburns> dnaori's issue installing, which we thought was bios and/or dmraid related
14:24:18 <mburns> and the one just filed yesterday
14:24:30 <pmyers> upstream bzs or RHEV product bzs?
14:24:35 <jboggs> upstream
14:24:45 <mburns> https://bugzilla.redhat.com/show_bug.cgi?id=785728 <-- dnaori's issue
14:25:21 <mburns> https://bugzilla.redhat.com/show_bug.cgi?id=798030 <-- issue filed yesterday
14:25:41 <mburns> #link https://bugzilla.redhat.com/show_bug.cgi?id=785728
14:25:47 <mburns> #link https://bugzilla.redhat.com/show_bug.cgi?id=798030
14:26:02 <pmyers> FiV for each of those is 2.3.0
14:26:06 <pmyers> but isn't 2.3.0 already out?
14:26:13 <pmyers> so they should be retargeted to 2.3.1?
14:26:13 <mburns> no, 2.2.3 is out
14:26:16 <pmyers> ah
14:26:21 <mburns> 2.3.0 is March 15
14:26:22 <pmyers> too many numbers to keep track of ;)
14:26:28 <pmyers> ok I was mixing that up with 2.4.0
14:26:29 <pmyers> cheers
14:27:34 <mburns> IMO, it's unclear if either of these is UEFI or not
14:27:42 <jboggs> theyre not
14:27:58 <jboggs> theres a bad comment line in the log thats misleading
14:28:11 <mburns> ok
14:28:14 <mburns> good
14:29:08 <mburns> anything else today?
14:29:28 <apevec> jboggs, mburns in 798030 screenshot is clear: machine is not uefi
14:29:48 <apevec> in that case grub2 requires that bios partition for stage2
14:31:57 <mburns> apevec: ok
14:32:43 <mburns> anything else?
14:32:52 <pmyers> plugin work?
14:33:19 <jboggs> initial plugin patch posted, will continue pushing forward with it
14:33:21 <mburns> jboggs posted the initial "set password" plugin
14:33:30 <pmyers> right, was curious about the name 'plugin
14:33:32 <pmyers> for that
14:33:39 <pmyers> it's just a script that wraps edit-livecd, correct?
14:34:00 <mburns> yeah, it's probably more of a tool, than a plugin...
14:34:04 <pmyers> right
14:34:06 <jboggs> yeah, was iffy on what to call it, but can perhaps just modularize it to do the other plugin work
14:34:10 <pmyers> right
14:34:16 <pmyers> i think what we want here is something called
14:34:18 <pmyers> edit-node
14:34:22 <pmyers> that wraps edit-livecd
14:34:30 <pmyers> and then the plugins are 'things that edit-node can do'
14:34:44 <pmyers> and one of the plugins could be a plugin to allow edit-node to change the admin password, etc
14:34:49 <pmyers> jboggs: does that make sense?
14:34:56 <jboggs> yeah, so rename it
14:35:02 <pmyers> apevec had started work on a generic edit-node
14:35:14 <pmyers> apevec: do you have any initial work to transfer over to jboggs on that?
14:35:26 <mburns> i guess that works
14:35:38 <mburns> and another "plugin" will be to install packages
14:35:41 <pmyers> right
14:35:49 <apevec> no code, just requirements I gathered in wiki
14:35:53 <pmyers> k
14:35:57 <jboggs> apevec, that works
14:36:01 <mburns> and one to setup services
14:36:08 <mburns> firewall rules, etc...
14:36:25 <pmyers> what subpackage will this stuff be in?
14:36:28 <pmyers> ovirt-node-tools?
14:36:41 <mburns> pmyers: initially, that seems to work
14:36:46 <pmyers> k
14:36:55 <mburns> we can split out once we have more
14:38:39 <mburns> eedri: ping -- fyi, the jenkins server has about 50 ovirt_engine_maven_3 builds queued up
14:39:19 <eedri> mburns, yea i will disable that job, it's a test job to see how jenkins.ovirt.org handles gerrit patches
14:39:23 <eedri> mburns, it's on silent mode
14:39:31 <eedri> mburns, i suspect it might be too much for it
14:39:43 <mburns> pmyers: ok, so we have steps forward at least for each
14:39:52 <pmyers> ack
14:40:12 <mburns> eedri: there's an option to consolidate into a build, iirc
14:40:23 <mburns> pmyers: anything else we need to hit today?
14:40:25 <eedri> mburns, what do you mean?
14:40:29 <pmyers> jboggs: this is in POST, is it fixed then or still investigating? https://bugzilla.redhat.com/show_bug.cgi?id=750662
14:40:57 <pmyers> mburns: fabiand_ was handling this one right?  https://bugzilla.redhat.com/show_bug.cgi?id=751856  if so, needs to be reassigned in bz
14:41:05 <jboggs> pmyers, fixed
14:41:10 <mburns> eedri: a way to consolidate all requests to build into a single job if there is already one running
14:41:25 <pmyers> jboggs: so latest jenkins builds have that fix in it then?
14:41:28 <mburns> so at most, you only get one queued up at a time
14:41:31 <eedri> mburns, well.. you don't always want to do it
14:41:40 <eedri> mburns, you might wan to do it to a patch set
14:41:45 <mburns> eedri: true
14:41:53 <jboggs> pmyers, should, ive be using local builds for last few patches
14:41:57 <pmyers> k
14:41:58 <eedri> mburns, there is one plugin that can help, but still it won't be enough
14:42:04 <fabiand_> mburns: assigned the above bug to myself
14:42:12 <eedri> mburns, jenkins can run a single job in parallel
14:42:20 <pmyers> jboggs: testing out an autobuild should be part of how we make sure our patches work, so definitely do that
14:42:22 <eedri> mburns, and you can control how many will run and on which nodes
14:42:30 <mburns> pmyers: that bug should be in latest builds, so i'll move it to modified
14:42:34 <pmyers> k
14:42:36 <eedri> mburns, but still it cant handle this amount of patches sent
14:42:44 <mburns> fabiand_: thanks
14:42:52 <mburns> eedri: ok
14:42:58 <eedri> mburns, any ideas?
14:43:26 <mburns> eedri: i'll think about it and look through the plugin list to see if there is anything
14:43:30 <pmyers> mburns: ok big ticket items for 2.3.0 right now are: CIM, keyboard selection, SNMP UI, iSCSI boot, correct?
14:43:44 <mburns> maybe something like a "only trigger if it's gotten code review +1" or something
14:43:47 <eedri> mburns, the plugin i'm talking about is "throttle concurent jobs"
14:43:59 <mburns> pmyers: sounds right
14:44:11 <mburns> iscsi boot is done from our side, but waiting on dracut fix
14:44:19 <pmyers> k
14:44:29 <mburns> well, done as in posted, but i need to review still
14:44:35 <pmyers> bz is still ASSIGNED tho?
14:44:37 <mburns> eedri: will look
14:44:52 <pmyers> let's make sure we're practicing good bz hygiene :)
14:45:05 <mburns> pmyers: hmm, that's b/c we're still blocked by dracut bug, iirc
14:45:11 <pmyers> https://bugzilla.redhat.com/show_bug.cgi?id=753313 doesn't depend on any other bug?
14:45:16 <jboggs> i left in assigned to test before setting it post
14:45:37 <pmyers> jboggs: POST is fine if you think the code is complete and it's just blocked on another bug
14:45:47 <pmyers> but what is that other bug?
14:46:08 <jboggs> its a rhel bug finding it now
14:46:12 <jboggs> er rhevh
14:46:13 <mburns> 520111
14:46:26 <pmyers> needs to be cloned to fedora so it gets fixed upstream, no?
14:46:44 <mburns> wait, that's ovirt-node bug
14:46:58 <mburns> https://bugzilla.redhat.com/show_bug.cgi?id=794751
14:47:04 <mburns> that's upstream dracut bug
14:47:17 <pmyers> that's rhel6 dracut
14:47:35 <pmyers> https://bugzilla.redhat.com/show_bug.cgi?id=545148
14:47:37 <pmyers> is the upstream
14:47:37 <mburns> bad copy paste
14:50:49 <eedri> mburns, thanks
14:50:57 <mburns> ok, anything else to go over today?
14:51:02 <pmyers> nope
14:51:21 <mburns> pmyers: jboggs:  should i cancel meeting next week since i'm not here?
14:51:26 <mburns> or do you want to hold it anyway?
14:51:31 <pmyers> mburns: jboggs can run it
14:51:40 <jboggs> wfm
14:51:51 <mburns> #agreed jboggs to run meeting next week
14:52:12 <mburns> ok, ending the meeting then
14:52:16 <mburns> #endmeeting