14:00:42 <mburns> #startmeeting oVirt Node Weekly Sync
14:00:42 <ovirtbot> Meeting started Tue Feb 14 14:00:42 2012 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:42 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:50 <mburns> #topic Roll Call and Agenda
14:00:56 <mburns> who's here?
14:01:00 <mburns> Agends:
14:01:06 <mburns> Agenda:
14:01:11 <mburns> 1.  Action Item Review
14:01:16 <mburns> 2.  Release status
14:01:20 <mburns> 3.  Stateless
14:01:24 <mburns> 4.  Other Topics
14:01:51 <mburns> pmyers: _jboggs:  here?
14:01:54 * _jboggs here
14:01:58 * pmyers in
14:02:07 <mburns> #topic Action Items
14:02:16 <mburns> only 2 this week
14:02:31 <mburns> #info archipel stateless patches have been merged
14:02:46 <mburns> still need to clean up the stateless wiki, but we can cover that later in the meeting
14:03:04 <primalmotion> (yeay)
14:03:05 <apevec> mburns, did you merge the whole branch or cherry picked?
14:03:19 <mburns> _jboggs: any update on the install issue dnaori saw?
14:03:21 <_jboggs> followed up with dnaori, suggesting a bios update, since the version are way out of date, awaiting him to get back with me
14:03:43 <mburns> #info install issue for dnaori pending feedback from dnaori
14:04:02 <mburns> apevec: worked with primalmotion to solidify the patches
14:04:14 <mburns> and squashed them down to 1 patch that was pushed completely
14:04:18 <apevec> cool
14:04:51 <mburns> that was it for action items from last week
14:04:58 <mburns> #action mburns to update stateless wiki
14:05:08 <mburns> #topic release status
14:05:23 <mburns> 2.2.3 is scheduled to go out tomorrow
14:05:27 <mburns> #info 2.2.3 is scheduled to go out tomorrow
14:05:43 <mburns> #info 3 patches still pending in gerrit
14:06:25 <mburns> bz status:  1 new, 2 post, 1 modified
14:06:37 <mburns> new is the issue that dnaori saw, so i'll defer that to 2.3.0
14:06:52 <mburns> only thing left to do is get the patches in gerrit acked
14:07:03 <_jboggs> mburns, ill start looking
14:07:09 <mburns> _jboggs: thanks
14:07:19 <mburns> #action _jboggs to review gerrit patches
14:07:43 <mburns> #info next release after 2.2.3 is 2.3.0 -- tentatively scheduled for March 15
14:08:19 <mburns> anything else on releases?
14:08:45 <mburns> ok, moving on
14:08:50 <mburns> #topic Stateless
14:09:04 <mburns> #info archipel patches are merged
14:09:24 <mburns> #info some followup patches based on the archipel patches are still pending
14:09:45 <pmyers> mburns: can you briefly describe the approach being used and how it differs from our original conception of stateless?
14:10:31 <mburns> right now, it's pure stateless which won't really work with engine long term
14:10:47 <pmyers> they don't retrieve config dynamically?
14:11:03 <mburns> every time you boot, you will need to (at least) remove the old version of the host from engine, then re-add
14:11:14 <mburns> pmyers: no config bundle or anything at the moment
14:11:16 <pmyers> ah ok
14:11:27 <pmyers> so basically we need to make vdsm handle stateless properly
14:11:30 <pmyers> and once that is done we should be fine
14:11:40 <mburns> pmyers: that's one option
14:11:46 <pmyers> that's the better option I think
14:11:57 <pmyers> my new idea for stateless is 'just enough to boot and contact your mgmt server'
14:11:58 <pmyers> and
14:12:00 <mburns> the other is to add functionality to setup the config bundle and push it somewhere, then retrieve it
14:12:10 <pmyers> 'everything else is retrieved via the mgmt agent, in this case vdsm'
14:12:17 <pmyers> mburns: that's more compex than we need
14:12:19 <pmyers> see above :)
14:12:29 <mburns> pmyers: simpler solution for us is certainly to get vdsm/engine to handle it properly
14:12:32 <mburns> pmyers: ack on that
14:12:34 <pmyers> ok good
14:12:41 <pmyers> so we need to update wiki to reflect this change in scope
14:12:48 <pmyers> and then start looping in vdsm folks on what they need to do
14:12:51 <pmyers> and/or help them do it
14:12:52 <mburns> pmyers: yep, that's my #action from above
14:12:59 <pmyers> it is python after all, and we can do python :)
14:13:06 <mburns> yep
14:13:36 <mburns> but when the patches in gerrit get merged, we have a node that will start up correctly and run the setup tui
14:13:55 <pmyers> cool
14:14:11 <mburns> and the store and remove config functions are smart enough to do nothing if it's stateless
14:14:52 <mburns> ok, anything else for stateless?
14:15:16 <mburns> #topic Other Topics
14:15:24 <mburns> any other topics to cover today?
14:15:27 * mburns doesn't have any
14:16:00 <_jboggs> nothing from me
14:16:01 <mburns> #action mburns to release 2.2.3 tomorrow
14:16:07 <mburns> #undo
14:16:07 <ovirtbot> Removing item from minutes: <MeetBot.items.Action object at 0x9616b0c>
14:16:15 <mburns> #action mburns to release 2.2.3 on 15-Feb
14:16:32 <mburns> pmyers: apevec:  anything else to cover?
14:17:14 <mburns> going once....
14:17:23 <mburns> twice...
14:17:25 <pmyers> hmm
14:17:41 <pmyers> jboggs dropped off?
14:17:50 <mburns> _jboggs:
14:17:52 <pmyers> was going to ask about plugins and how that was looking lately
14:17:58 <_jboggs> im still here
14:18:01 <pmyers> ah, autocomplete failed me :)
14:18:07 <pmyers> change your nick :)
14:18:14 <mburns> that was to avoid namespace collision with jbrooks
14:18:20 <pmyers> lol
14:18:21 <_jboggs> pmyers, still crammed working on iscsi, ill be able to work on it this week
14:18:28 <pmyers> ah right
14:18:31 <pmyers> I just saw that move to ASSIGNED
14:18:32 <pmyers> that's good
14:18:41 <mburns> oh, right...jbrooks
14:18:46 <_jboggs> its been assigned, just forgot to move for tracking :)
14:18:51 <pmyers> np
14:19:11 <mburns> #action mburns to review/update workshop presentation for jbrooks to get translated for workshop in Beijing
14:19:12 <pmyers> and there's uefi issue with someone on list, but we need more logs
14:19:17 <pmyers> hopefully it's user errort
14:19:22 * pmyers really wants uefi to GO AWAY
14:19:25 <_jboggs> uefi is the devil :)
14:19:28 <mburns> +1
14:19:31 <mburns> +100
14:19:31 <pmyers> lol
14:20:22 <pmyers> ok that's all from me then
14:20:22 <mburns> #info _jboggs working on iscsi boot
14:20:34 <mburns> #info _jboggs to start with plugins later this month
14:20:47 <mburns> ok, if nothing else...
14:20:50 <mburns> going once...
14:21:06 <mburns> twice..
14:21:21 <mburns> sold to the person in the back ;-)
14:21:26 <mburns> #endmeeting