15:01:00 <quaid> #startmeeting
15:01:00 <ovirtbot> Meeting started Wed Feb  8 15:01:00 2012 UTC.  The chair is quaid. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:00 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:27 <quaid> rbergeron: what's the command to name the meeting?
15:01:50 <MTecknology> heh- i used to help out with meetbot :)
15:02:01 <quaid> #topic Hello, hello, hello - roll call for 5
15:02:14 <quaid> MTecknology: ooh, I <3 meetbot :)
15:02:20 * sgordon is here
15:02:22 * oschreib here
15:02:24 * mburns here
15:02:41 * MarkBaker Mark Baker is here
15:02:46 * mgoldboi here
15:02:47 <oschreib> sgordon: I guess not. (about rpm signing)
15:02:58 * MTecknology watches in 'here'
15:03:08 * pmyers in
15:03:11 <sgordon> oschreib, hmm ok
15:04:24 * jimjag is here
15:04:40 * ykaul here.
15:04:49 <mburns> quaid: #meetingname
15:05:04 <quaid> thanks
15:05:05 <mburns> quaid: fyi -- http://meetbot.debian.net/Manual.html
15:05:08 <MTecknology> xTs_w: care if I bug you in query?
15:05:12 <quaid> #meetingname oVirt Weekly Sync
15:05:12 <ovirtbot> The meeting name has been set to 'ovirt_weekly_sync'
15:05:23 <xTs_w> MTecknology: do it
15:05:41 <quaid> mburns: thanks, haven't seen the full manual!
15:05:56 <quaid> #topic Administrivia - the great hand-off
15:06:09 <quaid> just a quick note about this
15:06:46 <quaid> for those who haven't heard, rbergeron just accepted the role of Fedora Project Leader
15:07:07 <aglitke_> congrats rbergeron !
15:07:10 <oschreib> +1
15:07:13 <mburns> congrats!
15:07:13 <clarkee> rbergeron: congratulations!!!
15:07:17 <clarkee> g+1
15:07:45 <clarkee> MTecknology: rpm :)
15:07:52 <quaid> so I'm wrestling the reins of running this meeting from her from now, although she's welcome to to guest-run a meeting any time :)
15:08:18 <quaid> in a few weeks I'd like to see if anyone else wants to run (or learn how to run) this meeting
15:08:30 <quaid> otherwise, I figured I would just do it for now
15:08:41 <dreamreal> I will but next week :)
15:08:46 <quaid> cool
15:09:05 * mburns knows how, but doesn't really want another meeting to run...
15:09:20 <mburns> but i can in a pinch if no one is around
15:09:23 <quaid> mburns: yeah, this is more to encourage NEW meeting leaders :)
15:09:37 <quaid> mburns: thanks though, if I ever oversleep feel free to just start things :D
15:09:44 <quaid> ok, moving along ...
15:09:48 <dreamreal> then I'm out! Who needs the extra work?! (Sorry)
15:09:50 <mburns> ack
15:10:05 <quaid> because I'm slow at this, I didn't do up an agenda
15:10:15 <quaid> let's quickly set one and move on
15:10:20 <quaid> #topic Setting agenda
15:10:27 <quaid> I've got in mind:
15:10:29 <oschreib> First release, next release
15:10:35 <quaid> yep, that's the first one
15:10:39 <oschreib> :)
15:10:44 <quaid> * Update on Beijing workshop
15:11:02 <quaid> anyone want to add something now?
15:11:09 <quaid> otherwise, we'll save room at the end
15:11:20 <quaid> #topic First release
15:11:26 <quaid> oschreib: how is it going?
15:11:46 <oschreib> We discuessed yesterday about the go/no go
15:11:50 <oschreib> and GO it is.
15:12:12 <oschreib> everything is ready, rpms and tarball are ready in nightly (just sent a mail about it an hour ago)
15:12:29 <jimjag> this is great news
15:12:33 <jimjag> congrats to all
15:12:46 <oschreib> so if everything will go fine, we will release tomorrow, 15:00UTC (or something like that)
15:12:56 <quaid> have we written up a release announcement?
15:13:01 <oschreib> mburns: any update from the node perspective?
15:13:30 <oschreib> I didn't write any announcement.
15:13:30 <sgordon> quaid, i would say not really, the release notes as it stands are here: http://www.ovirt.org/wiki/Release_Notes
15:13:37 <mburns> oschreib: built the node this morning with new iscsi-initiator-utils
15:13:38 <quaid> #agreed oVirt first release 9 Feb ~1500 UTC
15:13:41 <mburns> will be testing this morning
15:13:56 <oschreib> superb.
15:14:06 <oschreib> some more good news - ovirt-engine-sdk is in Fedora 17!
15:14:21 <quaid> #action quaid will work-up an announcement with jbrooks
15:14:28 <quaid> oschreib: excellent
15:14:44 <oschreib> http://koji.fedoraproject.org/koji/packageinfo?packageID=13250
15:14:44 <quaid> #info ovirt-engine-sdk is in Fedora 17
15:14:45 <ykaul> oschreib: what is 'if everything will go fine' - what else is needed?
15:15:09 <oschreib> ykaul: If we won't fined any release blocker, and if the new rpms will pass smoketest
15:15:33 <oschreib> mgoldboi: yeylon: did you see the new rpms?
15:15:48 <mgoldboi> oschreib: please note that i have not touched it - and probably won't make it till tomorrow - arrived a bit late for me
15:15:51 <ykaul> oschreib: anyone looking for release blockers?
15:16:03 <oschreib> the community :)
15:16:33 <oschreib> mgoldboi: I'm sorry for the late arrival, we had some major issues this morning
15:17:15 <oschreib> quaid: so I'm leaving the formal announcement to you, right?
15:17:39 <quaid> oschreib: I'll write it up, you can send it :)
15:18:03 <oschreib> quaid: sounds good. I can translate them to hebrew. :-P
15:18:04 <quaid> we'll cook it up on a wiki page before today is done so you have it ready
15:18:10 <quaid> heh
15:18:22 * quaid is good at writing for l10n
15:18:38 <oschreib> sgordon: I've created a repo in stable
15:18:52 <sgordon> yeah i saw that, i am just dropping it in the install guide now
15:19:14 <oschreib> we should probably edit some wiki pages about it (so people will use the stable, not the nightly)
15:19:17 <quaid> #info oVirt first release is ready ... barring any last minute blockers
15:19:27 <quaid> oschreib: good point
15:19:31 <quaid> what pages do we need to change?
15:19:40 <quaid> #link http://ovirt.org/get-ovirt
15:19:43 <quaid> that's one
15:19:46 <oschreib> http://www.ovirt.org/wiki/Installing_ovirt_from_rpm
15:20:12 <oschreib> get-ovirt should contain a link to the tarball as well.
15:23:27 <quaid> #action quaid Add link to tarball on get-ovirt page, fix other pages so people use new stable
15:23:46 <quaid> #link http://www.ovirt.org/wiki/Installing_ovirt_from_rpm
15:23:57 <quaid> ok, I'll look around for anything else that needs changing
15:24:13 <quaid> anything else on first release?
15:24:24 <quaid> #link http://www.ovirt.org/wiki/Release_Notes
15:24:31 * quaid getting all the links we need in the notes :)
15:24:53 <ykaul> quaid: do we have an update-to-first-release policy of some sort? I assume for security issues, we'll release something. What else?
15:25:23 <quaid> how do you mean by policy? as in a recommendation to people to update?
15:26:01 <oschreib> Please note that upgrade is not supported (installer wise, mentioned in RN)
15:26:38 <sgordon> yeah i have taken all the bits about upgrade out
15:26:44 <sgordon> do we have engine-cleanup oschreib ?
15:26:52 <ovirtbot> 14[[07Features/Design/DetailedHotlugNic14]]4 !10 02http://www.ovirt.org/w/index.php?diff=2272&oldid=2152&rcid=2343 5* 03Roy 5* (+308) 10/* Engine - VDSM API */ 
15:27:01 <oschreib> sgordon: indeed, with few bugs :)
15:27:03 <mburns> engine-cleanup exists, but doesn't appear to work completely...
15:27:08 <sgordon> ok...
15:27:11 <ovirtbot> 14[[07Special:Log/upload14]]4 upload10 02 5* 03Fsimonce 5*  10uploaded "[[02File:StorageLiveMigration1.png10]]"
15:27:14 <mburns> it doesn't cleanup the jboss profile
15:27:29 <oschreib> we don't have JBoss profile in JBoss AS7 ....
15:27:44 <mburns> then something else is messed up in my install
15:27:52 <mburns> but i'll take that offline for now
15:28:05 <ovirtbot> 14[[07Features/Design/DetailedHotlugNic14]]4 !10 02http://www.ovirt.org/w/index.php?diff=2274&oldid=2272&rcid=2345 5* 03Roy 5* (-7) 10/* @EJB API = */ 
15:28:30 <ykaul> policy = some kind of rules by which we decide when to release an update. If a bug is a security bug, if it is warranted because of a platform change (Jboss changes, underlying Linux), if it's because of a data corruption bug we found, etc.
15:29:09 <sgordon> isn't that going to be problematic if we dont have ovirt-upgrade yet?
15:29:36 <mburns> with engine, yes, but that doesn't apply to vdsm and node
15:29:37 <sgordon> or are we going to attempt to make yum work for its dinner here?
15:30:26 <oschreib> sgordon: yum might work, the only issue is DB upgrade
15:30:35 <oschreib> we can add a manuall process for it
15:30:35 <yeylon> oschreib, y.
15:30:46 <ykaul> oschreib: and possibly configuration, if needed, but I think it can be a manual thing.
15:31:51 <oschreib> any volunteer for the upgrade documentation?
15:33:05 <quaid> is that needed for this release?
15:33:09 <sgordon> to clarify, are we talking about upgrade for first release
15:33:15 <oschreib> indeed
15:33:17 <sgordon> or for a potential future issue as yaniv was saying
15:33:19 <sgordon> heh
15:34:42 <oschreib> I don't think it's needed for the release, only if we will have updates...
15:34:59 <oschreib> I'll take care of it.
15:35:29 <sgordon> if you can put it in the wiki or somewhere i can try integrate it into the install guide where the upgrade stuff i had to drop is
15:35:40 <sgordon> but i think we need to make sure it actually works ;)
15:36:10 <oschreib> sgordon: I won't be able to finish this before next week
15:36:11 <quaid> +1
15:36:29 <quaid> ok, that's starting to sound like we're looking in to the next release now ...
15:36:38 <sgordon> well i think for the first release we stick with what we have been saying
15:36:43 <sgordon> which is no upgrades from nightlies
15:36:55 <sgordon> it's something we should have a solution for when it comes to the next release though
15:37:08 <ovirtbot> 14[[07Features/Design/StorageLiveMigration14]]4 !10 02http://ovirt.org/w/index.php?diff=2275&oldid=2249&rcid=2346 5* 03Fsimonce 5* (-373) 10
15:37:10 <oschreib> good
15:37:13 <sgordon> (and for anything that comes up in between...which i think is what ykaul was getting at)
15:39:57 <quaid> #topic Next release
15:40:10 <quaid> so I forget if we had discussed the release rhythm yet
15:40:20 <oschreib> we need to set a date (or to start a mailing list discussion)
15:42:42 <ykaul> and release criteria. Or we can stick to the one we've had for v1.
15:42:46 <sgordon> do we have any people from engine / vdsm floating around?
15:42:48 <quaid> #action oschreib to start a discussion on arch@ about release dates/timing for next release :)
15:43:00 <sgordon> otherwise yeah, mailing list
15:43:11 <quaid> yeah, we won't solve that one here today :)
15:43:17 <sgordon> would be nice to set some goals for it as well as tightening the release criteria
15:44:22 <quaid> +1
15:44:36 <oschreib> ykaul: I'm for raising the bar for next release, don't worry .
15:44:41 <oschreib> +1
15:47:24 <quaid> ok, enough on that topic
15:47:34 * quaid waits for 10 seconds just in case
15:47:34 <oschreib> +100 :)
15:47:45 <quaid> #topic oVirt workshop in Beijing
15:47:57 <quaid> #link http://www.ovirt.org/news-and-events/workshop/
15:48:14 <quaid> we started publicizing the next workshop, which is 21 March in Beijing
15:48:50 <quaid> the two days prior (19, 20 March) will be intensive sessions with some of the Red Hat team working with folks from IBM and Intel
15:48:59 <quaid> then the third day is an open workshop
15:49:27 <quaid> we're only 10% reserved so far, but we're on track to fill the workshop based on previous experience
15:49:38 <quaid> we'll have room for about 100 people for that
15:50:26 <quaid> so please spread the word
15:50:51 <quaid> any questions about the workshop? logistics? etc.
15:51:20 <aglitke_> Is it going to be a similar format to the California one?
15:51:28 <aglitke_> ie. the sessions?
15:53:45 <quaid> aglitke_: I think so, yes
15:53:57 <quaid> but shorter to meet one day
15:54:07 <aglitke_> Ok, yep.
15:54:15 <quaid> so I guess the deep sessions are the first two days
15:54:33 <quaid> then a day of overview that further helps integrate the IBM/Intel teams
15:54:52 <aglitke_> Sounds good.  I assume we'll be working on a more formalized agenda in the wiki?
15:54:56 <quaid> yes
15:55:14 <quaid> but if you've got anything you want to see etc.
15:55:22 <quaid> feel free to start that agenda thread on arch@
15:55:58 <aglitke_> Ok.  I think we should be okay with the streamlined SJC agenda.
15:56:11 <aglitke_> Thanks, that's all I have for now.
15:57:52 <quaid> ok, same for me
15:58:04 <quaid> #topic Open floor - anything from you?
15:58:13 <quaid> anything for our last few minutes?
15:59:21 <quaid> in that case :)
15:59:25 <quaid> #endmeeting