14:00:29 <mburns> #startmeeting oVirt Node Weekly Sync
14:00:29 <ovirtbot> Meeting started Tue Jan 31 14:00:29 2012 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:29 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:36 <mburns> #chair jboggs pmyers
14:00:36 <ovirtbot> Current chairs: jboggs mburns pmyers
14:00:41 * pmyers in
14:00:46 * jboggs in
14:00:49 <mburns> Agenda:
14:00:54 <mburns> 1.  Action Item Review
14:01:00 <mburns> 2.  Release Status
14:01:07 <mburns> 3.  Other Topics
14:01:23 <mburns> #topic Action Item Review
14:01:45 <mburns> #action apevec to incorporate virt-minimal comps group into node kickstart and send info to node-devel
14:01:59 <mburns> #action mburns to rework stateless plan based on archipel-node work
14:02:13 <mburns> ^^ still not done due to other issues that keep coming up
14:02:31 <mburns> #info 2.2.2 build and released
14:02:54 <mburns> that's it for action items from last week
14:03:01 <mburns> #topic release status
14:03:07 <jboggs> I tested the 2.2.2 build and everything seems to work fine
14:03:22 <jboggs> other than vdsm reg which is pending a release
14:03:33 <mburns> #info ovirt project release postponed due to blocking issues in multiple components
14:03:44 <pmyers> mburns: how's progress going on creating the virt minimal comps group in Fedora-land?
14:04:04 <mburns> jboggs: can you work with rgolan on testing the patch for engine with latest node?
14:04:22 <pmyers> #link http://lists.fedoraproject.org/pipermail/devel/2012-January/161475.html
14:04:25 <jboggs> which patch?
14:04:32 <jboggs> the rewrite?
14:04:41 <mburns> pmyers: i haven't seen anything on that thread on fedora-devel in about a week
14:04:46 <pmyers> yeah me neither
14:04:47 <mburns> jboggs: yes
14:04:53 <pmyers> apevec doesn't seem to be around
14:05:04 <mburns> pmyers: yeah, that's why i left it as an action item for now
14:05:20 <mburns> #action mburns to follow up on virt minimal with apevec
14:05:29 <pmyers> i'm giong to email notting and cc you guys
14:05:36 <pmyers> to see what his thoughts are on next steps
14:05:43 <mburns> jboggs: there was a thread on users@ that i cc'ed you on regarding the re-write patch
14:05:47 <mburns> pmyers: ok
14:06:14 <jboggs> mburns, got it
14:06:28 <mburns> jboggs: have you determined what the issue was with the failed installations?
14:06:33 <mburns> is it definitely dmraid?
14:07:13 <jboggs> have to check back in with danori, he's not online atm
14:07:31 <jboggs> didnt see dmraid loaded on an identical machine, but it wasnt running fedora
14:07:40 <mburns> jboggs: ok, please update the bz when you figure it out
14:08:16 <mburns> jboggs: i think it only loads if you have it configured
14:08:31 <mburns> so if the machine didn't have the raid configured, then it wouldn't load (iiuc)
14:08:49 <jboggs> i ran dmraid -r and it didnt report any disks with it on the other machine, but it could be configured differently so cant trust it until i get access to the exact machine
14:09:01 <mburns> jboggs: ack
14:09:22 <mburns> #action jboggs to follow up with rgolan on node registration to engine
14:09:47 <mburns> #action jboggs to follow up with dnaori on failed installation
14:10:14 <mburns> those are the only 2 blockers on ovirt-node for the ovirt-project release
14:10:31 <mburns> and if it's dmraid we should be ok to release without fixing it this time
14:11:08 <mburns> there are fixes in vdsm though, so a new ISO will be needed for the actual release
14:11:14 <ovirtbot> 14[[07Searchbackend14]]4 !10 02http://www.ovirt.org/w/index.php?diff=2097&oldid=2096&rcid=2165 5* 03Lhornyak 5* (+295) 10/* Generated SQL */ 
14:11:21 <mburns> oh, wait, jboggs you added a patch for EFI as well, right?
14:11:29 <jboggs> yeah one last one
14:11:30 <mburns> so i do need to rebuild the rpms as well
14:11:49 <mburns> 2.2.2-2 will be built and posted later today then
14:11:52 <mburns> acti
14:12:03 <mburns> #action mburns to build 2.2.2-2
14:12:31 <mburns> ok, i think that covers first release stuff
14:12:44 <mburns> #topic next release
14:13:03 <mburns> #info 2.2.3 planned for 15-Feb
14:14:05 <mburns> there are a number of rhel6 bugs that are marked for 2.2.3 that aren't cloned yet
14:14:14 <mburns> we should get them cloned
14:14:49 <jboggs> mburns, have a list already?
14:14:51 <mburns> #action mburns to clone rhel6 bugs to upstream and mark for 2.2.3/2.3.0/etc
14:15:13 <mburns> jboggs: the list we went through in our internal meeting last thursday
14:15:19 <jboggs> ok
14:15:37 <mburns> #topic Other Topics
14:16:21 <mburns> #info new plugin design writeup sent by pmyers to node-devel list
14:16:44 <pmyers> #link http://lists.ovirt.org/pipermail/node-devel/2012-January/000099.html
14:16:52 <mburns> looks like a good plan
14:17:11 <mburns> though i'm afraid of how people will abuse yum...
14:17:16 <pmyers> I'm not afraid
14:17:18 <pmyers> we'll lock it down
14:17:18 <jboggs> mburns, any interest in archipel becoming a plugin?
14:17:42 <pmyers> I had another thought re: plugins
14:17:50 <mburns> jboggs: eventually, yes
14:17:53 <pmyers> why not just use RPM as the packaging format rather than tarballs?
14:18:06 <mburns> but we need true stateless/diskless support before they will do that
14:18:09 <pmyers> this would make it so that plugins would literally be the same on Fedora vs. oVirt Node
14:18:31 <pmyers> the 'online plugins' that pull from repos are trivially done this way
14:18:41 <pmyers> the harder would be the ones that are self contained
14:18:54 <jboggs> pmyers, are you saying multiple rpms, or can we still stuff them in a tarball prior to injecting them for ease?
14:19:13 <pmyers> I think the self contained case is less and less interesting the more I think about it
14:19:23 <pmyers> and I wonder if it all could degenerate into using repos
14:19:38 <pmyers> whether the repos are on the local filesystem vs. remote via http is sort of a minor point
14:19:45 <jboggs> could be easier management really then
14:19:48 <pmyers> yes
14:19:48 <mburns> pmyers: i wonder if people would balk at RPM in the long run
14:19:55 <pmyers> why's that?
14:20:03 <mburns> if we ever get to the generic ovirt-node that's not fedora based
14:20:18 <pmyers> doesn't matter, in those cases they wuold use their native packaging format
14:20:27 <pmyers> even if we went with tarballs, it still _contains_ rpms
14:20:32 <mburns> though the lack of interest i've seen in generating one tells me that it's not a problem
14:20:37 <pmyers> there's that too
14:21:08 <pmyers> jboggs: basically if we just make this 'use yum, but only allow it to be used offline' plugins becomes really simpke
14:21:11 <pmyers> simple that is
14:21:29 <jboggs> yeah less overhead for package managment and dependency
14:21:32 <pmyers> right
14:21:41 <mburns> pmyers: the part to me that's interesting is configuration and management of what the plugins install
14:21:42 <pmyers> the tarball could literally be a tar of a directory which is a yum repo
14:21:50 <pmyers> yes
14:21:50 <mburns> not where it comes from and how it's packaged
14:21:53 <pmyers> yep
14:22:00 <pmyers> that's actually the meat of it
14:22:29 <pmyers> so basically the 'main' or top level RPM in a plugin (like vdsm for example)
14:22:39 <pmyers> would need to follow some guidelines in order to 'make it a plugin'
14:22:48 <pmyers> namely, installing some metadata that can be read by mgmt systems, etc
14:22:58 <pmyers> to identify that it IS a plugin
14:23:18 <pmyers> I wonder if that's just smth we can put in rpm metadata tho
14:23:33 <mburns> pmyers: the way i see it, the work we have to do is define the interface that plugins use to tell ovirt-node what it needs
14:23:52 <mburns> and then handle that interface on our side
14:23:52 <pmyers> examples of that?
14:23:59 <pmyers> ah
14:24:03 <pmyers> firewall port
14:24:04 <pmyers> etc
14:24:08 <mburns> what services to start, what TUI stuff we need to include
14:24:21 <pmyers> can't the main rpm like vdsm just do that in it's %post
14:24:22 <pmyers> ?
14:24:46 <pmyers> and from ovirt node perspective we need to make sure that the commands that would be used in %post work consistently across both normal Fedora and oVirt Node
14:25:15 <pmyers> i.e. if vdsm uses lokkit to manipulate firewalls, we just need to have a lokkit command equivalent that works the same way and tweaks the firewall appropriately
14:25:16 <mburns> it could, conceivably, but there are other ways to do it
14:25:27 <mburns> we need to define that
14:25:30 <pmyers> agreed
14:25:39 <jboggs> what about using puppet?
14:25:50 <pmyers> that might be overkill
14:25:54 <pmyers> augeas would make more sense
14:25:58 <pmyers> for the limited scope here
14:26:12 <jboggs> true
14:26:23 <pmyers> anyhow, I've derailed the meeting :)
14:26:51 <mburns> pmyers: it's appropriate, and we are in the "Other Topics" section...
14:27:24 <pmyers> true, though let's continue this discussion on list
14:27:29 <mburns> ok, any other topics to bring up?
14:27:31 <pmyers> CIM
14:27:33 <pmyers> hehe
14:27:40 * mburns disappears
14:27:50 * jboggs has to catch up on that thread
14:28:08 <pmyers> seems we got some good input coming in from some CIM experts
14:28:15 <pmyers> so maybe we can make heads or tails of this soon
14:28:31 <mburns> pmyers: yes, and i think lagarcia is going to be a good person to help
14:28:35 <pmyers> yep
14:29:01 <mburns> but i think i'd rather keep that discussion on list for now
14:29:13 <pmyers> agreed
14:29:17 <mburns> since we don't have all the parties interested on this meeting
14:29:41 <pmyers> mburns: btw you need to upadte backlog page
14:29:44 <pmyers> 2.2.2 is already out
14:29:50 <pmyers> #link http://ovirt.org/wiki/Node_Backlog
14:29:55 <mburns> pmyers: knew i was forgetting something
14:30:09 <mburns> i marked the bzs closed, but didn't update the text
14:30:13 <mburns> ok, i'll do that
14:30:16 <pmyers> and the query
14:30:19 <mburns> #action mburns to update backlog page
14:30:26 <pmyers> the query should move frmo showing all open, to showing all closed
14:30:37 <mburns> pmyers: ack
14:30:49 <pmyers> #link http://goo.gl/IAhNR
14:30:57 <pmyers> 2.2.3 bug list is only 2 items
14:31:12 <mburns> pmyers: right, but there are others we need to clone (see earlier action item)
14:31:16 <pmyers> yep
14:31:52 <mburns> ok, anything else?
14:32:01 <mburns> going once....
14:32:11 <mburns> twice...
14:32:17 <mburns> ...gone
14:32:17 <ovirtbot> mburns: Error: "..gone" is not a valid command.
14:32:25 <mburns> Thanks all
14:32:27 <mburns> #endmeeting