14:00:29 <mburns> #startmeeting ovirt node weekly sync
14:00:29 <ovirtbot> Meeting started Tue Jan 10 14:00:29 2012 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:29 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:50 <mburns> #topic Roll Call and Agenda
14:00:57 * pmyers in
14:01:01 <mburns> 1.  Action item review
14:01:09 <mburns> 2.  release status
14:01:41 <mburns> 3.  open discussion
14:01:45 <mburns> any other topics?
14:02:08 <mburns> jboggs: you here?
14:02:15 <jboggs> yep
14:02:35 <mburns> excellent
14:02:49 <mburns> ok, other topics can come up in open discussion
14:02:59 <mburns> #topic action item review
14:03:09 <mburns> #link http://ovirt.org/meetings/ovirt/2012/ovirt.2012-01-05-14.01.html
14:03:24 <mburns> my action items:
14:03:41 <mburns> #info mburns has not yet tested registration, will test in next day or 2
14:04:05 <mburns> #info parsing of rhel bugs is still in progress, but a couple have moved already
14:04:13 <mburns> #info builds are still pending for this week
14:04:30 <mburns> #info meeting time moved to Tuesday 9:00 ET (obviously)
14:04:56 <mburns> jboggs: your only AI was to send the status email to node-devel which i saw
14:05:03 <mburns> any updates on UEFI?
14:05:43 <jboggs> reverting efi config back to grub legacy and debugging
14:05:51 <jboggs> hopefully finished this morning
14:06:30 <mburns> #info efi -- reverting back to grub legacy, hopefully finished this morning
14:06:48 <mburns> that's it for action items from last week
14:06:55 <mburns> so moving on...
14:07:00 <mburns> #topic release status
14:07:15 <pmyers> jboggs: quick question
14:07:22 <pmyers> you're going to revert totally back to grub legacy then
14:07:32 <mburns> #undo
14:07:32 <ovirtbot> Removing item from minutes: <MeetBot.items.Topic object at 0x9a21cec>
14:07:34 <pmyers> and we'll move to grub2 only when ALL of the platforms are supported by grub2?
14:07:50 <jboggs> just the efi install portion essentially a config file and a prebuilt grub.efi
14:08:25 <pmyers> ok
14:08:28 <jboggs> grub legacy is obseleted, grub legacy grub.efi file is provided in a subpackage just because grub2-efi isnt fully functional
14:08:34 <pmyers> ah ok
14:08:35 <pmyers> got it
14:08:37 <mburns> #info revert is only for grub-efi not all of grub2
14:08:40 <jboggs> its messy :/
14:08:43 <pmyers> no kidding
14:08:44 <pmyers> :)
14:09:00 <mburns> #topic release status
14:09:08 <mburns> #link http://www.ovirt.org/wiki/Node_Backlog
14:09:28 <mburns> 2 bugs still new for 2.2.1
14:09:38 <mburns> one is uefi that is close
14:09:52 <mburns> the other is host name resolution
14:10:15 <mburns> i'll try to pick off the host name -> ip resolution today or tomorrow morning
14:10:26 <mburns> that should wrap up the 2.2.1 release for thursday's build
14:10:34 <pmyers> will the efi bug be done by then?
14:10:50 <mburns> jboggs said he hopes it will be done today
14:10:55 <pmyers> ah sry missed that :)
14:11:15 <jboggs> uefi works on usb on the plus side :)
14:12:01 <mburns> ok, anything else on this topic?
14:12:24 <mburns> ok, moving on then
14:12:24 <pmyers> will vdsm bug to remove RHEVM from plugin get fixed by 1/28?
14:12:28 <mburns> or not
14:12:31 <pmyers> :P
14:12:41 <mburns> pmyers: already posted if i read my bz email right
14:12:46 <pmyers> ah cool
14:12:51 <pmyers> if we can get a build done
14:12:54 <mburns> dougsland: did that get merged yet?
14:12:57 <pmyers> we can include in the 2.0.1 ISO
14:13:00 <pmyers> which would be good :)
14:13:10 <mburns> (rhevm plugin renaming)?
14:13:21 <apevec> jboggs, re. legacy grub-efi - will not that require you to generate old-style grub.conf ?
14:13:31 <mburns> #action jbogss to finish up efi today/tomorrow
14:13:33 <jboggs> apevec, yes
14:13:47 <mburns> #action mburns to pick up 768491
14:13:59 <apevec> hm, then you have to keep two templates around...
14:14:01 <mburns> #action mburns to follow up with vdsm team on rhevm plugin renaming to engine
14:14:14 <apevec> it might be clear to just revert completely to grub?
14:14:20 <apevec> s/clear/cleaner/
14:14:36 <mburns> #action mburns to build 2.2.1 rpms Jan 12 and iso Jan 13
14:14:50 <mburns> apevec: not sure we can with it being obsoleted
14:14:52 <apevec> e.g. we read grub.conf to generate backup boot entry
14:15:02 <apevec> what does it mean obsoleted?
14:15:05 <jboggs> apevec, grub is obseleted it pulls in grub2 no matter what
14:15:06 <apevec> it's in repos
14:15:13 <apevec> oh
14:15:26 <jboggs> needs a -idontcare option
14:15:33 <mburns> apevec: if you try to build with grub it fails currently
14:15:42 <mburns> saying that you need to use grub2
14:15:59 <apevec> during RPM install?
14:16:04 <mburns> apevec: yes
14:16:05 <pmyers> lol
14:16:08 <apevec> man...
14:16:15 <pmyers> way for fedora to push a new technology that isn't FREAKING READY YET
14:16:27 <mburns> fedora-- for obsoleting something before it's replacement works
14:16:27 <jboggs> if i could get grub2-efi-install working correctly it would be much simple it just doesnt handle /dev/mapper devices correctly
14:16:36 <pmyers> mburns: NetworkManager, systemd
14:16:41 <pmyers> examples abound
14:16:46 <mburns> yep
14:16:48 <apevec> price of progress I guess
14:17:03 <pmyers> maybe what we need is a 'stable Fedora to work on'
14:17:08 <pmyers> wait, isn't that sort of CentOS?
14:17:09 <pmyers> :)
14:17:13 <mburns> or RHEL
14:17:27 <mburns> ok, anyway....
14:17:30 <mburns> moving on
14:17:35 <apevec> yeah, sorry for getting OT
14:17:36 <mburns> #topic open discussion
14:17:40 <mburns> apevec: np
14:17:45 <mburns> you're input is always welcome
14:18:05 <apevec> question: anyone had a look at "Virt minimal" comps group we discussed at ovirt workshop?
14:18:05 <pmyers> mburns: review of 2.3.0 bugs and schedule?
14:18:20 <apevec> if not, I'll send proposal to node-devel
14:18:27 <mburns> apevec: nothing done yet
14:18:30 <pmyers> apevec: go ahead and send proposal
14:18:48 <apevec> also nothing from other distros?
14:18:55 <mburns> pmyers: i'd like to defer that a week
14:19:01 <pmyers> k
14:19:02 <apevec> idea was that such group would be available in other distros
14:19:06 <mburns> until we get 2.2.1 out and i get rhel bugs cloned
14:19:08 <apevec> to base ovirt-node recipe on
14:19:15 <mburns> apevec: nothing from other distros yet
14:20:01 <mburns> #action apevec to send proposal to node-devel re:  virt-minimal comps group
14:20:47 <mburns> #action mburns deferred 2.3.0 bug and schedule review to next week
14:21:02 <mburns> not really an action, but that will remind me to have it on the agenda for next week...
14:21:24 <mburns> only other open discussion item i have is related to archipel's use of ovirt-node
14:21:47 <mburns> they have a stateless node mostly up and running, though it took some hacking to get it there
14:21:47 <pmyers> very cool btw
14:21:53 <apevec> cool!
14:21:59 <apevec> where is the source repo?
14:22:13 <mburns> it's not stateless in the same concept that we want to use, but it's a step in that direction
14:22:21 <primalmotion> If I may interfere, it works great now
14:22:35 <mburns> primalmotion: can you point us to the source repo?
14:22:35 <apevec> mburns, how stateless is it then?
14:22:39 <mburns> apevec: totally
14:22:45 <mburns> no disk, no config bundle
14:22:51 <mburns> boot with commandline and run
14:22:54 <primalmotion> https://github.com/primalmotion/archipel-node
14:23:02 <primalmotion> archipel itself is at https://github.com/primalmotion/archipel
14:23:08 <mburns> #link https://github.com/primalmotion/archipel-node
14:23:29 <pmyers> mburns: I assume it requires things liek DHCP and DNS SRV?
14:23:33 <pmyers> or is it ALWAYS PXE boot?
14:23:42 <pmyers> in which case you can do LOTS of stuff over PXE args
14:23:53 * mburns defers to primalmotion for those questions
14:24:37 <primalmotion> pmyers: it's not required
14:25:19 <pmyers> PXE is not required, but what about smth like DNS SRV?
14:25:40 <primalmotion> not required too
14:25:41 <pmyers> if you have neither DNS SRV nor PXE, how do you configure the node, or do you set up manual kernel cmd line args in a USB stick that the node boots from?
14:25:41 <apevec> mburns, hm, what about making ovirt-node mirror on github?
14:26:06 <apevec> that way it would be easy to create forks, like archipel-node
14:26:09 <pmyers> mburns: maybe we should consider that as well
14:26:11 <mburns> apevec: this was discussed on the weekly board call
14:26:15 <pmyers> i.e. this 'config server' is not necessary
14:26:26 <mburns> apevec: and decided against
14:26:27 <pmyers> we can put everything you need to 'get minimal network up' in kernel args
14:26:30 <primalmotion> I've tried to be as generic as possible. there are few kernel args to pass to define a mount point and the solid state storage path and eventually a custom post init script
14:26:33 <pmyers> or PXE args
14:26:41 <pmyers> primalmotion: very cool
14:26:45 <pmyers> i like the direction that is going in
14:26:50 <apevec> mburns, like, to prevent forking? You can't prevent that :)
14:26:53 <pmyers> and think it should be folded in the base ovirt node
14:26:56 <apevec> mburns, really, what was the reason?
14:26:57 <pmyers> vs only in the archipel stuff
14:27:05 <mburns> apevec: i think it was something like brand dilution
14:27:07 <pmyers> eh
14:27:14 <pmyers> we have github for other parts of ovirt I thought
14:27:16 <pmyers> so let's do it
14:27:17 <apevec> mburns, bah
14:27:20 <pmyers> no reason not to
14:27:29 <mburns> pmyers: what's on github?
14:27:30 <apevec> so create 'ovirt' user on github
14:27:34 <mburns> i don't know of anything there
14:27:35 <primalmotion> I basically send hostname=test ip=dhcp ARCHIPEL_STORAGE_MOUNT_ADDRESS=//server/vm ARCHIPEL_STORAGE_MOUNT_POST_SCRIPT=/path/post.sh ARCHIPEL_STATELESS_PATH=/vm/stateless and archipe does the rest
14:27:35 <pmyers> i thought vdsm or smth was
14:27:39 <pmyers> cloned at least
14:27:48 <pmyers> primalmotion: right
14:27:54 <pmyers> primalmotion: we should genercize this tho
14:27:57 <mburns> pmyers: not that i had heard
14:28:01 * pmyers shrugs
14:28:12 <mburns> #action mburns to investigate creating ovirt-node mirror on github
14:28:14 <pmyers> in any case, I don't see a compelling reason not to clone
14:28:18 <pmyers> mirror
14:28:21 <apevec> https://github.com/openSUSE/vdsm
14:29:33 <mburns> pmyers: plan is for primalmotion to get everything working and stable, then submit the patches back and work them into ovirt-node
14:29:40 <pmyers> excellent :)
14:30:00 <pmyers> jboggs: thoughts on making the 'stateless' stuff more along these lines and removing the need for a special 'config server' ?
14:30:01 <mburns> some of the stuff he's using is a bit hackish (since i wrote a bit of it) but that's ok for now
14:30:36 <mburns> pmyers: it's not our problem, it's a vdsm/engine problem
14:30:41 <mburns> they require persistent storage
14:30:42 <pmyers> ?
14:30:47 <pmyers> right
14:30:57 <mburns> if they fix that, then we can go truly stateless
14:31:00 <pmyers> ah
14:31:07 <pmyers> yeah that's one way to look at it
14:31:21 <pmyers> but their fix might require us to develop this config server
14:31:21 <pmyers> etc
14:31:34 <pmyers> or we could say that vdsm needs to pull it's config from RHEVM
14:31:39 <pmyers> vs. a more generic config server
14:31:46 <pmyers> er ovirt engine that is
14:31:59 <mburns> pmyers: there's work to be done on both sides to make it work
14:32:12 <mburns> our flow currently requires install to disk
14:32:25 <pmyers> right, but we should be able to remove that w/o needing this 'config server' that is generic, right?
14:32:52 <pmyers> i.e. all we need to do in ovirt node is make sure that you can boot, get an IP and contact your mgmt server
14:33:01 <mburns> pmyers: yes, it's doeable
14:33:02 <pmyers> which we can do either via hardcoding stuff in kernel cmd line
14:33:03 <mburns> doable
14:33:05 <pmyers> or DNS SRV etc
14:33:07 <pmyers> ok
14:33:10 <pmyers> so we need to rework the wiki page
14:33:13 <pmyers> to simplify this
14:33:42 <mburns> pmyers: problem i see is that engine requires approving the node unless it's already registered
14:33:49 <mburns> and that's manual process
14:34:16 <pmyers> yep
14:34:28 <mburns> #action mburns to rework stateless plan to mimic archipel workflow
14:34:54 <mburns> pmyers: probably not going to happen this week, but i'll keep it on action items until i get to it
14:35:12 <pmyers> k
14:35:20 <mburns> ok, anything else people want to discuss?
14:36:25 <mburns> ok, then i think we'll end here
14:36:30 <mburns> thanks everyone!
14:36:33 <mburns> #endmeeting