14:00:43 <mburns> #startmeeting ovirt-node weekly sync
14:00:43 <ovirtbot> Meeting started Thu Dec 15 14:00:43 2011 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:43 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:00 <mburns> #topic roll call
14:01:05 <mburns> who's here?
14:01:15 * jboggs here
14:01:22 <xTs_w> acathrow: 0.6.1.2
14:01:26 * mestery is lurking too
14:01:34 * xTs_w is quit now until the meeting ends
14:01:38 <xTs_w> *quiet
14:01:46 <mburns> #info mburns jboggs mestery here
14:01:53 <mburns> #topic agenda
14:02:03 <mburns> 1.  Action Item review
14:02:12 <mburns> 2.  release status
14:02:21 <mburns> 3. stateless and plugin
14:02:33 <mburns> 4.  Open discussion
14:02:38 * pmyers in
14:02:40 <mburns> anyone have something else?
14:03:03 <mestery> The agenda looks good mburns.
14:03:17 <mburns> #info AI review, release status, stateless and plugin status, Open discussion
14:03:27 <mburns> #topic Action Item review
14:03:40 <mburns> #link http://ovirt.org/meetings/ovirt/2011/ovirt.2011-12-08-14.00.html
14:03:58 <mburns> my personal action items --
14:04:07 <mburns> # release notice sent for 2.2.0
14:04:20 <mburns> # info release notice sent for 2.2.0
14:04:24 <mburns> #info release notice sent for 2.2.0
14:05:10 <mburns> i haven't looked into branching policy yet, but did ping oschreib to see if there is a process we want to follow
14:05:17 <mburns> i believe there is a wiki page in the works
14:05:37 <mburns> #info ovirt release manager working on branching policy for ovirt projects
14:05:47 <oschreib> somebody said oschreib? :)
14:06:05 <pmyers> mburns: how's vdsm fixes coming along?
14:06:08 <mburns> oschreib: just saying i had pinged you on a process for branching etc...
14:06:09 <pmyers> are they committed yet?
14:06:32 <mburns> pmyers: i last checked earlier this week and they weren't yet
14:06:37 <pmyers> hm
14:06:43 <mburns> and i don't see dougsland around yet
14:06:50 <pmyers> abaron: you have any status on that?  ^^
14:07:07 <mburns> #action mburns to follow up with dougsland on vdsm fixes for node/engine interaction
14:07:41 <mburns> #info stateless design has not been updated since last sync meeting
14:07:54 <mburns> jboggs: any updates on plugin design?
14:08:02 <pmyers> you've been busy... more interested in how plugin design/impl is progress
14:08:03 <pmyers> ing
14:08:10 <pmyers> that's the higher prio of those two items
14:08:13 <jboggs> still no updates, was kinda hoping for comments to see where to go from there
14:08:25 <pmyers> jboggs: in absence of comments from community, start writing patches
14:08:33 <pmyers> folks may be more interested in evaluating prototypes
14:08:39 <pmyers> instead of just chatting on wikis
14:08:48 <mburns> pmyers: uefi is on jboggs' plate before plugins
14:08:52 <pmyers> ah right
14:08:54 <pmyers> forgot about that one
14:09:01 <jboggs> uefi is a pain :)
14:09:06 <pmyers> heh, I believe it :)
14:09:09 <mburns> jboggs: yes it is
14:09:21 <jboggs> ive got a grub prompt at least
14:09:26 <mburns> that covers action items from last week except for dougsland
14:09:48 <mburns> jboggs: thats better than nothing
14:10:10 <mburns> ok, moving on to release status
14:10:13 <mburns> #topic Release Status
14:10:20 <mburns> 2 things here
14:10:28 <mburns> 1.  oVirt Suite Release
14:10:35 <mburns> 2.  ovirt-node individual releases
14:10:50 <mburns> for the oVirt Suite, we're targeting end of January
14:10:57 <mburns> with a code freeze date of Jan 14
14:11:18 <mburns> we should have little issue hitting those dates
14:11:42 <mburns> #info oVirt Suite code freeze Jan 14, Release end of January
14:12:05 <mburns> we're going to target a 2.2.1 release of ovirt-node for the jan 14 date
14:12:20 <mburns> though we many not actually formally release until the end of january
14:12:23 <pmyers> that's just uefi and vdsm fixes right?
14:12:37 <mburns> pmyers: +1 issue that came up yesterday
14:12:50 <mburns> with failing installs on real hardware
14:13:26 <mburns> smoke testing was done originally on virtual machines, and it works fine there, but real hardware is failing
14:13:37 <jboggs> mburns, was that the space issue?
14:13:39 * mburns thought he ran on real hardware, but must have run the wrong iso
14:13:47 <mburns> jboggs: i had space issues, but that was a bad node build
14:14:12 <mburns> i'm going to run a new test today with a better build
14:14:25 <mburns> #action mburns to re-run smoketesting with new 2.2.0 iso build
14:14:57 <mburns> #info 3 issues for 2.2.1 -- vdsm fixes, uefi boot, real hardware installation failure
14:15:09 <mburns> #action jboggs working on uefi
14:15:16 <mburns> #action mburns on real hardware issues
14:15:32 <mburns> #action dougsland on vdsm issues with mburns following up
14:16:23 <mburns> #info F17 feature freeze is Feb 7
14:16:42 <mburns> we're targetting 2.3.0 for F17, so we need to jump on that as soon as possible
14:16:58 <mburns> main feature there is plugins
14:17:31 <mburns> anything else for release status?
14:18:20 <mburns> ok, moving on to status of stateless and plugins
14:18:27 <mburns> #topic Stateless and Plugins
14:18:39 <mburns> #info Stateless, no movement in the last week
14:18:51 <mburns> #info stateless targetted for 2.4.0
14:19:32 <mburns> for plugins, high level design is posted
14:19:45 <mburns> #link http://ovirt.org/wiki/Node_plugins
14:19:59 <mburns> #info patches yet to commence
14:20:21 <mburns> jboggs: can you jump on the implementation once you get the uefi stuff to work?
14:20:28 <jboggs> yeah np
14:20:53 <mburns> #action jboggs to start on implementing plugins after uefi is solved
14:21:18 <mburns> anything else on stateless and plugins?
14:21:45 <mburns> ok, on to open discussion
14:21:50 <mburns> #topic Open discussion
14:22:39 <mburns> first thing here:  there are a number of bugs filed on ovirt-node in RHEL 6 that need to be parsed and cloned to upstream ovirt-node component
14:22:51 <mburns> #action mburns to parse rhel 6 bugs for upstream inclusion
14:23:15 <mburns> #action mburns to review posted patches
14:23:29 <mburns> anyone have topics they want to bring up?
14:24:24 <mburns> going once....
14:24:36 <mburns> twice....
14:24:44 <mburns> gone
14:24:50 <mburns> thanks everyone
14:24:52 <mburns> #endmeeting