15:00:13 <rbergeron> #startmeeting oVirt Weekly Sync Meeting
15:00:13 <ovirtbot> Meeting started Wed Nov 30 15:00:13 2011 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:13 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:22 <rbergeron> #meetingname oVirt Weekly Sync Meeting
15:00:22 <ovirtbot> The meeting name has been set to 'ovirt_weekly_sync_meeting'
15:00:41 <sgordon> >.>
15:00:41 <rbergeron> #topic Who's here?
15:00:45 * aglitke is here
15:00:45 * sgordon 
15:00:52 * oschreib1 is here
15:00:54 * ykaul is here
15:00:56 * jimjag is present
15:00:57 * masayag is here
15:01:09 * dannf is here
15:01:12 * ovedo is here
15:01:16 * pmyers is here
15:01:24 * jumper45 here
15:01:40 <rbergeron> Whee. Lots of people
15:01:40 <cctrieloff> ***cctrieloff here
15:01:44 * smoser is here
15:02:05 <doron_{^_^}> here
15:02:11 <rbergeron> #info cctrieloff, jumper45, smoser, pmyers, ovedo, dannf, masayag, oschreib, jimjag, ykaul, sgordon, aglitke, quaid, doron present
15:02:14 * itamar here
15:02:16 <rbergeron> Cool. Let's get started.
15:02:20 <rbergeron> #info itamar present
15:02:25 <rbergeron> #topic Today's Agenda
15:02:53 <lpeer> here
15:02:59 <rbergeron> #info Today's Agenda: Press release status, upcoming event planning, First release "stuff", FTP/repository "stuff".
15:03:00 * acathrow here
15:03:04 <rbergeron> Anyone else have anything they'd like to add?
15:03:11 <rbergeron> #info lpeer, acathrow present
15:03:33 <cctrieloff> those topics are the ones I want to cover.
15:03:46 <rbergeron> Feel free to pipe up at the end in Open Floor if you have anything else between now and then. :)
15:03:52 <rbergeron> #topic Press Release Status
15:03:56 * rharper rharper is here
15:04:10 <rbergeron> #info rharper present
15:04:28 <rbergeron> Okay, so my understanding at this point is that we are still waiting on Cisco to move forward, is that correct?
15:04:36 * rbergeron looks at cctrieloff, acathrow
15:04:59 <cctrieloff> yes, then we are done.
15:05:18 <rbergeron> okay. are we hoping for this week on that?
15:05:29 <rbergeron> And then we'll send out the final draft to everyone, including board list, for review.
15:05:40 <cctrieloff> menstry: indicates that we are done, so I think it is just corp sign off etc.
15:05:55 <rbergeron> #info Still waiting on Cisco, but is in progress. Just waiting on corporate signoff, etc.
15:06:07 <rbergeron> Excellent.
15:06:13 <rbergeron> Okay, I'll move onwards then.
15:06:14 <acathrow> we've got around 2 weeks of press window after that it's worthless sending out PR until January
15:06:19 <rbergeron> acathrow: yup
15:06:19 <quaid> pmyers: please op ovirtbot
15:06:45 <cctrieloff> I'm hoping for in the next few days.
15:07:07 <pmyers> what's the mode again +o?
15:07:32 <rbergeron> I think -t
15:07:45 <jimjag> cctrieloff: Let me know if I can be of any help...
15:08:08 <rbergeron> pmyers: mode #ovirt -t ... I think
15:08:09 <cctrieloff> jimjag: thx, will do. it is with PR contacts at this point I believe.
15:08:11 <rbergeron> oh
15:08:12 <rbergeron> to op
15:08:13 <rbergeron> ;)
15:08:17 <pmyers> rbergeron: it's +o
15:08:32 <rbergeron> sorrry, I was thinlking about just making the topic writeable
15:08:38 * rbergeron jumped ahead too far
15:08:43 <rbergeron> #topic Upcoming event planning
15:09:22 <rbergeron> Okay. So: We have FOSDEM in the works. I also just got notice that we can have a full day at the Red Hat Dev conference in Brno in February, which is a pretty community-oriented conference.
15:09:36 <rbergeron> quaid: did you get any notice from the SCALE folks?
15:09:43 <rbergeron> And can someone speak to plans re: FOSDEM real quick?
15:09:57 <quaid> nothing yet from SCALE, although I think the ball is more in our court
15:10:18 <rbergeron> #info Robyn received word that we can have a full day room at the Red Hat dev. conference in Brno in Feb. (17th/18th, not sure on exact day yet)
15:10:23 <cctrieloff> before the meeting I was chatting with rbergeron, that we need to now work the list and work which events we will plan days around. FOSDEM seems logical. We should select a few that are spaced out and the meetups at the others.
15:10:24 <rbergeron> quaid: I meant wrt paper acceptance
15:10:35 * rbergeron nods
15:11:00 <rbergeron> #action rbergero to work on the events wiki page and fill up with events where we should plan presence
15:11:08 <quaid> rbergeron: ah, sorry, no, that just went in, will be a short bit
15:11:22 <cctrieloff> also which ones we should submit papers too
15:11:43 <rbergeron> #action rbergeron to also add confs with papers, when to submit, etc.
15:12:00 <cctrieloff> finally we should work out where and when we want to do a multi day event, and if we want to collocate it.
15:12:00 <rbergeron> itamar: iirc, you were working on the FOSDEM stuff?
15:12:10 <acathrow> we should also ad fudcon and the next UDS to the list
15:12:19 <rbergeron> acathrow: agreed
15:12:44 <rbergeron> and the openSUSE conf as well, when that's announced
15:12:54 <itamar> rbergeron - yes, submitted an ovirt session to FOSDEM. no status update on it.
15:12:55 <pmyers> acathrow: FUDCON is already on the list in the wiki and I'll be attending and presenting once I have the official presentation to use :)
15:13:25 <rbergeron> #info waiting on FOSDEM to find out about availability for conference session
15:13:38 <cctrieloff> It would be good to get the basic planning done in the next two weeks, so that people can get it into their corp budgets, as everyone is working budgets this time of year
15:14:22 <rbergeron> itamar: so just the session info is what you're working - do we want to see if we can get a booth as well? (bearing in mind booth space there is... crowded, noisy, etc)
15:14:25 <rbergeron> cctrieloff: yup.
15:14:47 <rbergeron> #info is probably best to get basic planning for conferences done in the next 2 weeks or so, people are working budgets.
15:15:07 <rbergeron> itamar: we can get a booth easily, my concern is whether or not anyone will be around to staff it.
15:15:09 <quaid> rbergeron: may be instead of a booth at FOSSDEM, how about a BoF?
15:15:20 <itamar> rbergeron: need someone to be at the booth. acathrow - anyone in europe relevant for this (demoing, etc.)?
15:15:37 <quaid> then it's simpler - make fliers and ask all our friendly booths-that-exist to hand them out, etc.
15:15:41 <acathrow> I should be able to get a resource to do that
15:15:50 <cctrieloff> booth with demo and beer.
15:15:56 <quaid> there ya go
15:16:13 <quaid> keg'o'virt
15:16:23 <cctrieloff> plugs, tech guys to help install it, beer -- even better.
15:16:28 <oschreib> +1 on the beer
15:16:44 <doron_{^_^}> beer-demo or real beer? maybe oBeert?
15:16:49 * rbergeron wonders if anyone present has actually been to FOSDEM
15:17:05 <cctrieloff> good post of meetups -- http://www.mikealrogers.com/posts/on-meetups.html
15:17:11 <cctrieloff> related...
15:17:24 <cctrieloff> real beer.
15:17:36 * rbergeron notes that there is already a large social night at FOSDEM
15:17:46 * rbergeron also notes that the second night of FOSDEM is when the Super Bowl is
15:18:51 <rbergeron> #info Booth interest exists, but we need to see WHO CAN GO :) (for FOSDEM)
15:19:10 <rbergeron> Any other events?
15:19:21 <rbergeron> cctrieloff: do you have the opening presentation from the workshop?
15:19:23 <rbergeron> or quaid
15:19:36 <cctrieloff> rbergeron: yes, it is on the site.
15:19:49 <rbergeron> is that something we can use as an "official" presentation?
15:20:03 <rbergeron> ie: what pmyers was just referring to as needed for FUDCon in january
15:20:08 <cctrieloff> we should update it. I can hack on that a bit this week.
15:20:12 <pmyers> cctrieloff: can you post link so I know exactly which one you are referring to?
15:20:21 <pmyers> and then link will be in minutes :)
15:20:24 <rbergeron> #chair cctrieloff
15:20:24 <ovirtbot> Current chairs: cctrieloff rbergeron
15:20:30 <rbergeron> #chair quaid
15:20:30 <ovirtbot> Current chairs: cctrieloff quaid rbergeron
15:20:46 <rbergeron> #action cctrieloff to hack on an official presentation this week for use by others at events
15:21:34 <rbergeron> okay, cctrieloff, if you find the link, post it - i'll move on in the meantime
15:21:39 <quaid> #link http://www.ovirt.org/wp-content/uploads/2011/09/Ovirt-WorkShop-Invitation.pdf
15:21:42 <quaid> I think
15:21:45 <rbergeron> #topic First Release stuff.
15:21:51 <quaid> but that should get replaced with an updated copy on the wiki
15:21:52 <rbergeron> Okay, so  few things here:
15:22:09 <rbergeron> First: Last week we agreed on coming to an agreement on release manager ... this week.
15:22:31 <cctrieloff> quaid:  there is a newer one that I'll upload and post he link
15:22:40 <rbergeron> So if someone would like to move that we move ahead with the candidate, and a few can +1 it, I think we can make it official. Yes?
15:22:40 <itamar> quaid: I would add much more "GUI" to it from the other presentations for to include an overview of what it does than just the concepts of its inception. I believe most would find an intro to oVirt more interesting with an overview of what it does
15:22:54 <pmyers> itamar: +1
15:22:56 <cctrieloff> +1
15:23:01 <acathrow> j+1
15:23:15 <abaron> this presentation is totally not suited for the audience in fosdem
15:23:23 <abaron> it should be technical, not about governance
15:23:57 <pmyers> I think that was what itamar was getting at, but maybe we just need a new preso vs. adapting this one
15:23:58 <itamar> abaron": actually, perry asked for it for fudcon, buy i still agree
15:24:02 <pmyers> yes
15:24:09 <pmyers> fudcon/fosdem same audience basically
15:24:15 <abaron> exactly
15:24:17 <pmyers> (in terms of technical anture)
15:24:22 <pmyers> nature
15:24:32 <rbergeron> yup
15:24:33 <abaron> Itamar, you should have the basis of such a preso at hand I believe
15:24:33 <quaid> shall we work out a new preso via arch@ then?
15:24:42 <acathrow> I'm happy to take a crack at a presentation starting with features, gui stuff etc and then we move into tech architecture etc and then someone adds contributions/getting started
15:24:49 <rbergeron> they're both developer-heavy conferences
15:24:50 <cctrieloff> we need the 2 or three side from it, on what is oVirt, and then mostly the content from itamars preso.
15:24:59 <quaid> it would be good to cover the project overview - history, governance, etc. - but not as a entirety
15:25:03 <itamar> i uplaoded mine.
15:25:07 <cctrieloff> in maybe a slightly shorter form
15:25:08 <itamar> +1 to acathrow starting it
15:25:10 <rbergeron> acathrow: I think that would be lovely
15:25:22 <abaron> +1 acathrow
15:25:29 <alon> rbergeron, can you let me know if you get a booth? in spice we have about 4 people going and we decided against it so far.
15:25:37 <cctrieloff> acathrow: thx, let me know if you need help
15:25:46 <quaid> ok, I think we can move back to the topic-at-hand?
15:25:47 <rbergeron> #action acathrow to take a crack at a presentation starting w/features, gui sutff, move into tech architecture, someone else can add contributions/getting started
15:25:58 <rbergeron> quaid: yup
15:26:03 <rbergeron> okay, back to Release Manager
15:26:09 * rbergeron gets out her rope to wrangle
15:26:54 * rbergeron will repeat herself really quicklike
15:26:59 <sgordon> was oschreib the lucky winner or was that my imagination?
15:26:59 <rbergeron> So if someone would like to move that we move ahead with the candidate, and a few can +1 it, I think we can make it official. Yes?
15:27:02 * ichristo is late but listening
15:27:22 <abaron> +1 for oschreib
15:27:24 <itamar> sgordon: indeed. ofer it was. +1
15:27:27 <cctrieloff> I thought we had a volunteer and just voted them in...  correct oschreib
15:27:29 <doron_{^_^}> +1 for oschreib,
15:27:29 <cctrieloff> +1
15:27:30 <jimjag> +1 on both
15:27:44 <sgordon> yes well, for the purposes of minutes i nominate ofer, and above are +1s :P
15:27:57 <abaron> jimjag: who is the second one?
15:28:02 <lpeer> +1 for ofer
15:28:08 <ovedo> +1 for ofer
15:28:15 <pmyers> +1 for ofer
15:28:18 <jimjag> I meant +1 on the move ahead and +1 on the offer :)
15:28:26 <jimjag> to ofer
15:28:44 <rbergeron> cctrieloff: we decided last week to make sure everyone was aware that nominations were essentially open, and that we'd be deciding this week, just in the interest of transparency. :)
15:28:49 <sgordon> probably more importantly if anyone else wants to nominate now would be the time to speak up
15:29:00 <doron_{^_^}> looks like we have a winner?
15:29:01 * oschreib hopes he won't end up like Gaddafi (being the only nominee)
15:29:14 <rbergeron> sgordon: iirc, that was the point of waiting a week - that they had to pipe up before now ;)
15:29:22 <sgordon> yeah i figured rbergeron
15:29:24 <rbergeron> I think it does look like we have a winner. :)
15:29:27 <sgordon> but last chance offer for the sake of it :P
15:29:32 <rbergeron> sgordon: hehe
15:29:35 <rbergeron> indeed.
15:29:36 <quaid> oschreib: only worry if that happens _next_ time we pick a new release manager :)
15:29:40 * jimjag snickers to himself
15:30:01 * doron_{^_^} congrat's the new Release Manager
15:30:03 <rbergeron> #info oschreib is confirmed as the Release Manager for the first release. :)
15:30:46 <rbergeron> And with that, I'd like to briefly call attention to the mail sent to the arch and board lists re: First Community release - re: timeline, dates, etc.
15:31:54 <cctrieloff> Can we start and see if we have agreement on what a release is?
15:32:03 <rbergeron> cctrieloff: here, or on-list?
15:32:28 <quaid> +1 to on-list
15:32:43 <pmyers> cctrieloff: doesn't the wiki page sort of summarize that?
15:32:47 <pmyers> so we just need to ack that wiki page?
15:32:49 <quaid> #link http://www.ovirt.org/wiki/First_release
15:33:00 <doron_{^_^}> +1 on list + wiki.
15:33:07 <itamar> wrt to versioning: code assumes in both vdsm and engine this is "3.0". I vote for a fedora/suse like cadence of 6 months between versions. next upstream version would be a 4.0, 5.0, etc. however, I assume  first few versions will be 3-4 months, then we can move to 6 months cadence
15:34:00 <cctrieloff> makes sense.
15:34:04 <oschreib> itamar: I'm not sure we want to change the major version each 6 monthes
15:34:35 <doron_{^_^}> oschreib: firefox and chrome does it w/ explorer now.
15:34:45 <sgordon> yeah and people hate it
15:34:47 <rbergeron> itamar: i think that seems reasonable
15:34:48 <oschreib> doron_{^_^}: and I hate it :)
15:34:50 <sgordon> because the version info is meaningless
15:34:52 <doron_{^_^}> but's I agree it's too much.
15:35:16 <rbergeron> well, it needs to have a name of some sort that makes it identifiable.
15:35:19 <oschreib> major version change = major change in the product IMO
15:35:59 <jimjag> Numbering should really refer to API
15:36:02 <rbergeron> So it sounds like ... we have to make decisions on if a release is feature-based or time-based, and if time-based, what that time period should be?
15:36:16 <cctrieloff> just do 3.1 3.2 3.x etc untill we find a good reason to call a release 4.0
15:36:18 <jumper45> any chance we can release on features rather than dates?
15:36:18 <oschreib> and what is the base version
15:36:23 <rbergeron> Or every 6 months, just cut a release and give it a number?
15:36:35 <rbergeron> minor if minor, and major if major
15:36:35 <oschreib> +1 cctrieloff
15:37:08 <cctrieloff> release frequently is more important than the number.
15:37:27 <jimjag> for the record, I've always been a fan of MAJOR.MINOR.PATCH version numbers...
15:37:34 <doron_{^_^}> timed versions usually describe that. ie- v_20111204 as the binary version.
15:37:54 <jimjag> +1 re: frequency
15:38:19 <itamar> every ovirt minor version has enough features to justify a major version change...
15:38:23 <quaid> jumper45: a number of FOSS projects have learned to prefer time-based because it creates a rhythm people can get used to - but you try to hit features specifically in that time, so it's ultimately feature-focused but not promising specific features per release
15:38:24 <itamar> and the version does matter
15:38:44 <abaron> major releases more often has to do with how long we preserve deprecated APIs
15:38:45 <itamar> it syncs cluster level and data center level with vdsm.
15:38:50 * jimjag wondering if this discussion would be better onlist...
15:39:05 * rharper votes for on-list
15:39:12 <itamar> so vdsm versions in distro's need to be aligned with these versions (at least until we consider feature level negotiation rather than version level one)
15:39:16 <rbergeron> jimjag: yeah, or if a separate meeting might be better at some point after discussion on-list to come to agreement on proposals
15:39:16 <jumper45> quaid - but users have to wait for the release for feature x that was finished 2 months before.  slow to market.
15:39:19 * doron_{^_^} agree on list.
15:39:48 <jimjag> +1 for onlist and then a follow-up irc meeting
15:40:07 <abaron> why not just settle it here? we've got all the relevant people and can converge rather quickly I think
15:40:08 <rbergeron> jumper45: it depends on what they want - 2 months is a good time frame for bugs to get resolved and make sure it's well-integrated/working with distro features.
15:40:38 * rbergeron odenst know if we're doing nightly builds offhand, but that's an easy way to grab what is absolutely new for developers, contributors, etc.
15:40:50 <jimjag> versioning is a direct to how the community "consumes" the code...
15:41:05 <rbergeron> right. and how they can report back with feedback
15:41:08 <cctrieloff> we can settle here and then post to list for comment for anyone that missed the meeting, with IRC log. or do on list -- both work.
15:41:13 <jimjag> "is a direct impact" I mean
15:41:19 <ykaul> jimjag: or how consumable it is. with no one mentioning quality of the code here.
15:41:36 <quaid> +1 to move-discussion-to-list
15:41:42 <quaid> which I think makes a consensus :)
15:41:44 <jimjag> yeppers... version number must *mean* something
15:42:33 <abaron> jimjag: as Itamar mentioned, at the current pace, every version we release downstream *is* a major version (as far as features are concerned)
15:42:44 <jumper45> do we need to define the process of how the release is approved? Some form of vote or something?
15:43:12 * rbergeron suggests that someone volunteer to bring this on-list, and make a list of the major questions we need to address in the discussion
15:43:29 * sgordon nominates the release manager... :p
15:43:31 <oschreib> rbergeron: I'll do it.
15:43:59 <oschreib> although I think we can decide now.
15:44:18 <quaid> that's actually fine, since folks seem to want to discuss a bit further now
15:44:52 <cctrieloff> jumper45: do we need to define the process of how the release is approved? Some form of vote or something?, yes
15:45:49 <cctrieloff> I would propose that a candidate is proposed and then people download, and smoke test it. if a few people are happy with it, without objections(major issues) we release it.
15:46:03 <cctrieloff> the process can be light weight to start and we can add as need.
15:46:03 <oschreib> +1
15:46:04 * rbergeron sees a multitude of questions - how to approve the release, how to define version numbers, dates/time periods for release, how long from release to inclusion in a distro, how long we will support that specific version
15:46:51 <rbergeron> are we just tackling the first 2 right now?
15:47:00 <rbergeron> and figure out the rest later?
15:47:08 <cctrieloff> dates/time periods for release,  -- I woudl say, get the first one out and then do every 3 months.
15:47:15 <sgordon> i dont even know that we strictly need to answer the versioning question right at this second
15:47:26 <sgordon> the gates around what constitutes a release are more important
15:47:33 <cctrieloff> how long from release to inclusion in a distro ---  as soon as feasibility possible ....
15:47:39 <abaron> rbergeron: the versioning question has direct linkage to the support question
15:48:39 <quaid> as a rapidly changing upstream, how locked do we want to be with 'support'?
15:48:46 <cctrieloff> abaron: what support?  we can say we provide work update between minor versions, and require a fress install for majour versions for now
15:48:46 <rbergeron> okay, well, i'm going to +1 what carl said above, and say we can figure out the rest when we get there.
15:48:59 <smoser> cctrieloff, that really depends on the quality of the output and history of distro<->upstream relationship.
15:49:10 <cctrieloff> abaron: i.e. we can make that up.
15:49:37 <cctrieloff> smoser: correct, but we can get better, and provide more 'support' with each release.
15:49:39 <smoser> many upstreams come in to a distro immediately upon release because the do things well. (i guess it also depends on how many things depend on that).
15:50:13 <quaid> also, each distro has a different policy on how they handle updates within an existing release
15:50:16 <smoser> right. so what i was getting at is that its not terribly important to pick something based on distros release cycle at the moment. and you can't really mathc up with all of them.
15:50:26 <rbergeron> smoser: yup
15:50:32 <smoser> so dont worry about that.
15:51:02 <itamar> cctrieloff: you still assume a version is "minor". we can't sustain so many "minor" versions wrt backward compatibility. the changes are not trivial
15:51:43 <smoser> i personally think 3 months is too short, and would think 6 is better, but then to me, i dont see why not just name 3.X and increment X until there is an api incompatibile change.
15:51:52 <smoser> or perhaps major feature that you just want to highlight.
15:52:08 <cctrieloff> itamar: no, just provided an example, i.e. we can decide what meaning to tie to numbering etc was my point.
15:52:11 <itamar> so i'm for treating the versions as major, going 6 months cycle (except for maybe first few which will do more rapidly to shape things up). and we provide upgrade support for last 2 major versions
15:52:16 <smoser> (or, as in linux, "random time release manager wanted to change number")
15:52:30 <acathrow> 6 months does feel like the right cadence but since we're still coming up to speed doing a couple of shorter cycles would help
15:52:40 <rbergeron> acathrow: yup
15:52:45 <itamar> acathrow: yes, that's what i'm saying as well.
15:52:50 <oschreib> +1
15:53:01 <cctrieloff> +1
15:53:12 <oschreib> I think in the first few monthes we should release every 2 months
15:53:47 <jimjag> +1
15:53:48 <oschreib> and when we stabilize upstream we can move to something else (time/features based).
15:54:42 <itamar> oschreib: i think we should do one once we can, then do another major one for move to AS7 (in two months), then revisit the schedule...
15:54:43 <oschreib> so first few releases will be 3.1  (maybe without upgrade support)
15:54:46 <cctrieloff> #info itamar: so i'm for treating the versions as major, going 6 months cycle (except for maybe first few which will do more rapidly to shape things up). and we provide upgrade support for last 2 major versions
15:55:13 <cctrieloff> IF we have consensus we can move to next topic...
15:55:39 <cctrieloff> #topic ftp
15:55:58 <cctrieloff> quaid: you have the floor..
15:56:01 <quaid> so what is the open question about ftp?
15:56:12 <quaid> I don't think I requested the agenda item :)
15:56:29 <quaid> is it about /releases? how is that going for folks?
15:56:38 <cctrieloff> ah.
15:56:41 <cctrieloff> ok
15:56:43 <oschreib> I created the basic structure there.
15:56:50 <oschreib> not sure it's the best form though.
15:56:58 <quaid> sgordon's RPM work looks good, glad you found my repo file work :)
15:57:11 <sgordon> ah yes about that
15:57:24 <sgordon> the repo file you provided technically doesnt match our current repo structure
15:57:40 <quaid> I adjusted the file as per a discussion with mburns a few weeks ago
15:57:42 <sgordon> as the repo mixes the noarch and x86_64 packages in the same dir
15:57:50 <quaid> so it reflects that discussion
15:57:51 <quaid> ah, ok
15:57:52 <sgordon> yes i think the file is probably correct long term
15:58:00 <sgordon> it just doesnt match what we actually have atm tho
15:58:57 <sgordon> i think we do need to split the archs out like you normally would, and also provide the SRPM directory
15:59:08 <quaid> which supports the reason for putting that repo file in an RPM, so it's easier to update as we updated the /releases structure
15:59:09 <sgordon> but perhaps that is best followed up on list
15:59:15 <sgordon> as i only sent it out yesterday
15:59:18 * rbergeron returns
15:59:30 <sgordon> yes that is my main reason for wanting it to be an rpm
15:59:47 <sgordon> that we are likely to continue messing with it in the short term, and that we are likely to want to add a GPG key at some point
16:01:23 <rbergeron> okay. sooooo - follow up on-list then?
16:02:07 * rbergeron looks around - sgordon, does that sound reasonable?
16:02:25 <oschreib> sounds good to me
16:02:38 <sgordon> that was my suggestion yes
16:02:52 <sgordon> there are a few bits and bobs in the post i made to arch for people to digest
16:03:15 <rbergeron> #info sgordon discussed RPM / repo stuff onlist yesterday in arch@; please read and digest and respond
16:03:23 <sgordon> basically for the action from last week if/when we want it i believe i have the structure for an ovirt-release rpm
16:03:28 * rbergeron nods
16:03:36 <sgordon> but we need to continue working on the releases/ structure
16:03:37 <sgordon> EOM
16:03:48 <cctrieloff> one last topic if I may
16:03:54 <rbergeron> sure.
16:03:59 <rbergeron> take it away
16:04:19 <cctrieloff> aliguri requested again that we open teh list for anyone to post
16:04:48 <cctrieloff> since it keeps coming up, shall we try for a few weeks and see if we can deal with the spam.
16:04:56 <quaid> my major concern is about how incoming spam affects the silent majority (lurkers)
16:04:56 <rbergeron> cctrieloff: all lists?
16:05:08 <quaid> so at least, let's watch the unsubs to see that people aren't leaving in droves in response
16:05:14 <rbergeron> #topic Opening of Lists
16:05:32 <itamar> why? has any email been moderated for a long time?
16:05:53 <cctrieloff> yes, I moderate a bit.
16:06:46 <sgordon> i think the question was more 'has any email been parked for a long while'
16:06:53 <cctrieloff> seems to be an issue for some people more than other. aliguri uses multiple email addr, and I don't think want to subscribe all of them
16:06:53 <sgordon> i think people are pretty on top of approving them
16:07:25 * rbergeron would really like to see us get some spam filters added to help with the problem
16:07:35 <cctrieloff> so I think it is more a multi email issue, than parked email problem
16:07:55 <sgordon> i think they are one and the same
16:08:16 * jimjag +1
16:08:36 <cctrieloff> I'm happy to open them up for two weeks trail if other agree.
16:08:37 <quaid> rbergeron: I'm not entirely clear that is OUR problem
16:08:45 <quaid> rbergeron: don't spam filters belong on the recipient side?
16:09:00 <rbergeron> quaid: you can add blacklists to mailman
16:09:12 <rbergeron> iirc
16:09:25 <quaid> properly-maintained-by-othes blacklists?
16:09:30 <quaid> s/othes/others/
16:10:08 <rbergeron> i think so. i'll ask nirik, I seem to recall our lists have some form of it in fedora-land
16:10:23 <quaid> ok, because otherwise ... if we have a problem with moderating legit traffic, won't that be worse if we have to maintain our own blacklist?
16:10:36 <rbergeron> i may be totally insane though
16:10:43 <sgordon> i dont believe we do have a problem with moderating legit traffic though do we?
16:10:50 <itamar> it just looks unprofessional when a mailing list sends me spam, which is why i prefer filterred till we solve the issue
16:10:58 <sgordon> +1
16:11:43 <rbergeron> sgordon: not right now
16:11:53 <rbergeron> but if/when spam becomes insane it's a nightmare
16:11:58 <sgordon> certainly
16:12:06 <sgordon> but i dont think opening it up to allow everything through
16:12:07 <rbergeron> though sometimes non-spam mails get flagged as spam and I have to un-trap them
16:12:13 <oschreib> +1 itamar
16:12:16 <sgordon> before we have an actual solution for that is the right thing to do
16:12:29 <rbergeron> there's no perfect solution
16:12:49 <cctrieloff> ok, seems consensus is to keep it the way it is for now. We will let aliguori debate it on the thread, waiting to be moderated :-)
16:13:08 <rbergeron> lol
16:13:11 <aliguori> it's very unfriendly :-(
16:13:17 <quaid> at the least, moderators can add regular posters' alternate addresses to the whitelist on the fly in the moderator UI
16:13:18 <aliguori> in terms of working with other communities
16:13:23 <rbergeron> quaid: that's what I do
16:13:40 <aliguori> can you at least change the settings so it doesn't notifier the sender for messages held for moderation?
16:13:45 <itamar> quaid - all moderators add into auto-accept any legit sender
16:13:52 <smoser> i tend to agree with aliguori here. i've never received significant spam on a mailing list, and i'm subscribed to dozens.
16:14:06 <quaid> smoser: how many have open-to-the-world posting?
16:14:11 <smoser> most do.
16:14:14 <aliguori> quaid, every mailing list i'm on
16:14:23 <itamar> smoser - how many don't have spam filters?
16:14:27 <sgordon> i would be surprised if at least some of them arent moderated
16:14:30 <quaid> I happen to have it in reverse, I guess - most I'm on do not
16:14:31 <sgordon> and you just dont get notified
16:14:40 <aliguori> yeah
16:14:43 <aliguori> i was going to suggest that
16:14:47 <smoser> where 'significant' is relevant.  i get *significant* spam to 'smoser@brickies.net' and rarely see it due to filtering.
16:14:56 <itamar> aliguori - I'm fine with removing the notification if that helps
16:15:00 <aliguori> yeah, it would
16:15:07 <quaid> +1
16:15:09 <sgordon> yes +1 on that
16:15:15 <sgordon> i dont see harm in removing the notification
16:15:27 <sgordon> as long as we are actively approving non-spam posts in a timely manner
16:16:14 <quaid> ok
16:16:20 <quaid> can moderators here make that change?
16:16:56 <quaid> I'll post on arch@ about doing that, all admins should be on that list.
16:17:34 <itamar> sure, just send the howto to make sure everyone did it right.
16:18:19 <quaid> ok
16:18:22 <quaid> so
16:18:27 <quaid> anything else today?
16:18:36 * rbergeron doesn't think so
16:18:44 * rbergeron looks around to see who's still here ;)
16:18:48 <oschreib> me hopes nothing :)
16:19:16 <cctrieloff> where do you set it?
16:19:29 <cctrieloff> think it is EOM
16:20:09 <quaid> I'll get the instructions on setting to arch@ in a few minutes
16:20:13 <quaid> +1 eom
16:20:14 <rbergeron> cctrieloff: privacy, sender options I think
16:20:22 <rbergeron> okay, i'll close out
16:20:28 <cctrieloff> board list updated
16:20:29 <rbergeron> Thanks for coming today, everyone, see you next week!
16:20:36 <rbergeron> #endmeeting