15:00:41 <rbergeron> #startmeeting oVirt Weekly Sync Meeting
15:00:41 <ovirtbot> Meeting started Wed Nov 23 15:00:41 2011 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:41 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:54 <rbergeron> #meetingname oVirt Weekly Sync Meeting
15:00:54 <ovirtbot> The meeting name has been set to 'ovirt_weekly_sync_meeting'
15:00:58 <jumper45> karamatronic - gratz!
15:01:01 <rbergeron> #topic Anyone here? :)
15:01:06 * aglitke is here
15:01:09 * rbergeron looks around for participants
15:01:23 <rbergeron> hey aglitke :)
15:01:35 * yzaslavs is here
15:01:44 * jumper45 is here
15:01:57 * sgordon is here
15:02:03 <gargya> is here
15:02:07 * masayag is here
15:02:08 * karmatronic is here
15:02:24 <rbergeron> Wow. Very nice :)
15:02:36 * itamar1 in
15:02:39 * rgolan is here
15:03:04 <itamar1> rbergeron - they are here still on the engine-core weekly meeting (over intercall)...
15:03:21 * jumper45 doubling up on meetings!!
15:03:22 <rbergeron> #info aglitke, yzaslavs, jumper45, sgordon, gargya, masayag, karmatronic, itamar1, rgolan are here
15:03:25 <rbergeron> ;)
15:03:34 <rbergeron> itamar1: ahh
15:03:49 <itamar1> rbergeron - just ending now
15:03:57 <rbergeron> okay, well, i'll get started, and we'll see who comes :)
15:03:59 <rbergeron> itamar1: thanks
15:04:09 <rbergeron> #topic Today's Agenda
15:04:43 <rbergeron> A few things on today's agenda that I put in, and feel free to pipe up if you have something:
15:05:13 <rbergeron> #info Press release status, Upcoming Event planning, First release/release date feedback, ftp/repo setup status, <your item here> are on the agenda for today.
15:05:28 <rbergeron> Anyone else? :)
15:05:52 <rbergeron> Okay, I'll move ahead - it sounds like people may be filtering in slowly
15:06:00 * oschreib1 is here
15:06:02 <rbergeron> Also, it's turkey week here in teh US, so I think a lot of folks are out.
15:06:06 <jumper45> core meeting just ended
15:06:25 <rbergeron> #info oschreib1 is present
15:06:30 <rbergeron> #topic Press release status
15:07:14 <rbergeron> #info Robyn heard back from Kerri this morning - we are still waiting on press release approval from Intel and Cisco at this point.
15:07:51 <rbergeron> So she's still pursuing that, and I'm hoping she'll have something early next week. This week is kind of a bad week for getting things done here which require chains of approval because inevitably someone is out all week. :\
15:08:03 <rbergeron> Also, to answer Ryan's question from last week...
15:08:20 <rbergeron> #info When we do have a Final Draft that has been approved by everyone, we'll send it out to the board list for everyone's information.
15:08:42 <rbergeron> #info rbergeron to respond on-list to Ryan's question from last week re: getting to see the final draft.
15:08:50 <rbergeron> I think that wraps that up. Any questions?
15:09:00 * rbergeron will move on, then
15:09:07 <rbergeron> #topic Upcoming Event Planning
15:09:31 <rbergeron> #info Robyn looked into getting a table at FOSDEM, and we can do that, but we need volunteers who are willing to booth all week.
15:09:52 <rbergeron> Does anyone else have any event stuff they want to talk about?
15:10:07 <rbergeron> Meetups, conferences, etc? :)
15:10:58 <rbergeron> nothing, nothing?
15:11:06 <aglitke> none for me
15:11:12 <gargya> i'll be talking about oVirt at a cloud computing conference in darmstadt, germany next week
15:11:24 <rbergeron> gargya: Awesome. Do you have everything you need for that?
15:11:31 <gargya> yes
15:11:49 <itamar1> we're looking at FOSDEM
15:11:56 <rbergeron> itamar1: from what angle?
15:11:57 <gargya> i have the ovirt part "embedded" in a larger present
15:12:12 <gargya> managing kvm with open source and ibm poducts
15:12:19 <aglitke> Do we have a repo of oVirt presentations for this purpose?
15:12:22 <gargya> products
15:12:32 <itamar1> rbergeron: still trying to figure out
15:12:34 <rbergeron> #info Tony Gargya (IBM) talking about oVirt in a larger presentation at a cloud computing conf. in germany next week
15:12:41 <rbergeron> itamar1: it's too late for presentations, but I can get a table still
15:12:51 <aglitke> I haven't found the overview one (from the workshop) yet
15:12:52 <rbergeron> itamar1: unless someone submitted a preso before the deadline
15:13:06 <rbergeron> aglitke: I'll see if I can find that today and send that to the list. I'm not sure who has it
15:13:19 <aglitke> rbergeron, thanks!
15:13:19 <itamar1> rbergeron: they are checking for session. looking at devel rooms.
15:13:21 <rbergeron> #action rbergeron to track down the overview presentation from the oVirt workshop and send to list
15:13:47 <rbergeron> itamar1: cool, can you keep us up to date on how that goes?
15:13:53 <itamar1> rbergeron: no preso prior to deadline - didn't hear about it till too late.
15:14:01 <rbergeron> #info itamar1 looking into FOSDEM re: sessions, looking at devel rooms
15:14:21 <rbergeron> aglitke: I know we linked some of the presentations into the worshop wiki page, but not sure if that's one of them.
15:14:39 <aglitke> Last time I checked it was not there
15:14:45 <aglitke> Seemed only about half were
15:14:48 <rbergeron> aglitke: okay. I'll see what I can find
15:14:59 <aglitke> perfect
15:15:03 <gargya> BTW, the ovirt  workshop wiki is currently also missing Livnats pres on the ovirt engine
15:15:08 <itamar1> rbergeron: also considering hosting people in TLV for hands-on lab/help/feature development/design/brainstorming/etc in february with the devel team if thre is interest from other parties to come over for a week with a group of the maintainers
15:15:17 <rbergeron> aglitke: would you like to send mail to the list asking people to add their presentations if they haven't done so, and add in the wiki link? :) it would be nice to have them all there
15:15:40 <rbergeron> itamar1: oh, wow. Do you know when exactly, or still looking into it?
15:16:01 <rbergeron> itamar1: I know we're also doing the RHT Dev Conf in Brno in Feb.
15:16:08 <aglitke> #action aglitke to send an email to the list to request remaining oVirt workshop presentations
15:16:27 <rbergeron> #info itamar1 also looking into hosting people in TLV for hands-on lab/help/feature dev/design/brainstorming in feb. with the devel team if there is interest
15:16:31 <rbergeron> #chair aglitke
15:16:31 <ovirtbot> Current chairs: aglitke rbergeron
15:16:34 <aglitke> rbergeron, which list is most appropriate?
15:16:48 <rbergeron> hit your up arrow, I'm not sure if it will take actions from a non-chair ;)
15:16:51 <aglitke> #action aglitke to send an email to the list to request remaining oVirt workshop presentations
15:17:00 <rbergeron> thank you, sir!
15:17:24 <rbergeron> itamar1: keep us up to date, i'm sure people would be interested in that
15:17:49 <rbergeron> aglitke: I'm not sure about which list, TBH - maybe hit project-planning and board, since a lot of project-planning people were at theh conference
15:18:00 <rbergeron> they should all be on the board list by now but just in case :)
15:18:02 <aglitke> alright, will do
15:18:07 <rbergeron> coolio, thanks
15:18:20 <rbergeron> anything else in events-land?
15:18:22 <itamar1> rbergeron: we can decide on the date to not conflict. will help to understand if people are interested, and any global national holidays to take into consideration date wise
15:19:11 <rbergeron> gargya: let us know how your presentation goes - feedback, questions, etc. so we can try and take those things into account for future presentation-givers :)
15:19:21 <rbergeron> itamar1: sounds good
15:19:51 <gargya> sure
15:20:01 <rbergeron> #topic Moving towards release
15:20:09 <rbergeron> I know we're making progress towards having a release manager.
15:20:19 <rbergeron> Is that official yet, or still in the works?
15:21:14 <rbergeron> I also know we're still waiting to hear back on potential release dates and readiness from some companies.
15:21:21 <rbergeron> Packaging and all that jazz.
15:21:30 * rbergeron looks around for comments, questions, fires
15:22:37 <rbergeron> Nada?
15:22:51 <rbergeron> #info No updates on progress here, will look for more next week.
15:22:52 <oschreib> rbergeron: amm, so when will we decide on the release manager?
15:23:16 <rbergeron> oschreib: well, that's the answer I was looking for ;) I know there's been a nomination, but not sure how the rest of that process will proceed.
15:23:57 <oschreib> I guess we should decide about that. AFAIK I'm the only nominee, lol
15:24:00 <jumper45> what is the rest of the process?
15:24:13 <rbergeron> oschreib: I think you are ;)
15:24:34 <rbergeron> jumper45: not sure. Maybe someone should ask in a mail to the arch list? :)
15:24:45 * rbergeron looks around for volunteers to wrangle wrapping that up...
15:25:06 <rbergeron> or pushing towards a "next step" ....
15:25:15 <rbergeron> otherwise I'll send the email... ;)
15:25:17 <itamar1> rbergeron - ofer was suggested as release manager
15:25:53 <rbergeron> itamar1: Yup. But how do we make that official? Do we need to vote, or does the board need to vote, or do we need a date by which people should nominate, etc?
15:26:31 <itamar1> if there is only one candidate, i don't see a need for a vote?
15:26:45 <itamar1> less someone will object by say next week
15:26:51 <rbergeron> #info Ofer Schreiber is the only nominee right now.
15:26:54 <rbergeron> I think that sounds reasonable.
15:27:01 <rbergeron> By, say, prior to this meeting next week?
15:27:07 <itamar1> yes
15:27:09 * rbergeron looks around for nodding heads
15:27:15 * jumper45 nods
15:27:21 <itamar1> for rpms - ronen sent an email with links to an rpm based install guide. so no need to compile, build, etc.
15:27:45 <itamar1> it is still a moving target, but it should be easier to consume than the devel guideline
15:28:08 <itamar1> rpms include "jboss 5 as for ovirt in rpm form", vdsm, engine-core, webadmin, etc.
15:28:26 <rbergeron> #agreed Any additional candidates for release mgr should step forward prior to this meeting next week, will agree on release manager and announce at next week's meeting.
15:28:58 <rbergeron> #info re: releases: for rpms - ronen sent an email with links to an rpm based install guide. so no need to compile, build, etc. it is still a moving target, but it should be easier to consume than the devel guideline. rpms include "jboss 5 as for ovirt in rpm form", vdsm, engine-core, webadmin, etc.
15:29:15 <jumper45> should sub-project managers be nominated by then as well? Or does that come later?
15:30:24 <rbergeron> jumper45: not sure. I would expect that would come later, or at least, following this.
15:31:00 * rbergeron looks around for other comments/questions on this topic before moving onwards
15:31:30 <rbergeron> #topic FTP and Repository setup status
15:31:30 <itamar1> rbergeron - each subproject maintainers group need to provide release manager with their contact person
15:31:37 <rbergeron> #undo
15:31:37 <ovirtbot> Removing item from minutes: <MeetBot.items.Topic object at 0x910958c>
15:31:52 <rbergeron> #info each subproject maintainer gropu should provide release manager with their main contact person
15:32:15 <rbergeron> itamar1: should that person be named on each subproject's wiki page, as well? or at least on a release contacts wiki page?
15:32:27 <rbergeron> Or let the release manager decide? :)
15:32:40 <itamar1> let's not make subprojecs page an active wiki - a release wiki can have them
15:32:54 <itamar1> release page on the wiki, per release
15:33:04 <oschreib> itamar1: what is actually a sub-project? mom? ovirt-config?
15:33:25 <itamar1> http://www.ovirt.org/project/subprojects/
15:33:38 <itamar1> mom I'm not sure will be ready for the first version
15:34:07 <rbergeron> #info release manager and subproject manager/contacts should be listed on a release wiki page, per release
15:34:10 <itamar1> as for others, each group should say "I'm ready on master / release branch", etc.
15:34:22 <itamar1> or "will be ready for the relevant date, per planning phase"
15:34:41 <oschreib> ok, thanks for clarification
15:35:06 <itamar1> doesn't matter if they are on same git or not - they need to sync to a reasonable stable state, then cherry pick for decent stability/maturity near release freeze
15:35:12 <itamar1> etc
15:35:48 <aglitke> correct on MOM... I am still working on vdsm integration.
15:36:55 * rbergeron nods
15:37:12 <rbergeron> okay, anytihng else? /me will move on otherwise....
15:38:54 <rbergeron> #topic FTP and Repository setup status
15:39:10 * rbergeron isn't quite sure where this is. itamar1: do you know offhand?
15:39:18 <sgordon> well, what we discussed seemed to be working?
15:39:40 <sgordon> not sure it is accessible via ftp yet though
15:40:00 <oschreib> rbergeron: I guess it's about the "releases" directory on ovirt.org
15:40:07 <itamar1> a sec
15:40:20 <sgordon> http://ovirt.org/releases/
15:40:26 <itamar1> http://www.ovirt.org/wiki/Installing_ovirt-engine_from_rpm
15:40:33 <sgordon> the only thing is that 0.0.1_0001-0/ in the base directory
15:40:34 <itamar1> covers:
15:40:35 <itamar1> wget http://www.ovirt.org/releases/nightly/fedora/16/ovirt-engine.repo -P /etc/yum.repos.d/
15:40:39 <sgordon> should probably be cleaned up
15:40:57 <oschreib> sgordon: true
15:40:59 <itamar1> sgordon - that's on purpose till the rpm is more than a scratch one
15:41:08 * oschreib will erase that directory in a sec
15:41:12 <sgordon> heh, but isnt it under nightlies
15:41:14 <rbergeron> I think that last week quaid was also going to ask the other distro folks to comment on repo setup details.
15:41:16 <sgordon> as per the instructions you just pasted
15:41:18 <itamar1> right
15:41:27 <sgordon> so why do we still need the top level one
15:41:44 <itamar1> i agreed with "right"...
15:41:59 <sgordon> ok, i thought you said it was on purpose
15:42:00 <sgordon> anyway
15:42:04 <oschreib> sgordon: done
15:42:08 <itamar1> and
15:42:08 <itamar1> http://www.ovirt.org/wiki/Installing_VDSM_from_rpm
15:42:16 <sgordon> who was actioning making an ovirt-release rpm to install the repo file? i know it was talked about
15:42:29 <sgordon> if the answer is nobody that seems like something i could do
15:42:47 <rangluster> why is it necessary?
15:42:49 <itamar1> sgordon - i think they went with a wget for the repo file instead of an rpm -i for an rpm doing the same
15:42:54 <sgordon> it's not *necessary*
15:43:03 <sgordon> but it's the way it's generally done and it's pretty easy to do
15:43:07 <rangluster> if the user will need to run "wget" anyway. what is the difference?
15:43:33 <sgordon> like i said
15:43:36 <sgordon> it's convention
15:44:03 <rangluster> could you please supply examples for projects that use this convention?
15:44:08 <sgordon> Fedora
15:44:20 <sgordon> it's also nice if you ever need to change the repo file for some reason
15:44:53 <rangluster> in order for it to be streamlined we'll need that rpm to be in Fedora's repository
15:45:18 <rangluster> until it is the case, its just another RPM the user will need to install. but if it'll make you happy, i have no objection
15:45:27 <sgordon> ...
15:45:27 <ovirtbot> sgordon: Error: ".." is not a valid command.
15:45:44 <sgordon> i dont see what the problem is, im just saying that is the way new repository files are generally distributed
15:45:53 <sgordon> fedora, rpmfusion, adobe's stuff, etc
15:47:30 <rangluster> sgordon: do you wish to create the said RPM or should i publish it?
15:47:38 <sgordon> i am happy to do it
15:48:28 <rangluster> sgordon: k, where will you place it? where should the spec file for the rpm reside?
15:48:51 <rbergeron> #action sgordon to make an ovirt-release rpm to install the repo file
15:49:31 <rbergeron> sgordon: if you don't know the answers yet, you might want to think about posting your thoughts on it to the mailing list (arch, I suppose)
15:49:37 <sgordon> i will
15:49:40 <sgordon> also i checked my logs
15:49:47 <sgordon> it was quaid who brought it up in a previous meeting
15:50:01 <rbergeron> #action sgordon to take discussion re: ovirt-release rpm to mailing list, inc. where it will go, where should the spec file for rpm reside
15:51:32 <rbergeron> Okay. Anything else on this topic?
15:51:34 <rbergeron> sgordon: yeah, i think it was
15:51:59 <rbergeron> well, i know it was, but I wasn't sure of the whole context from the minutes alone, and juggling typing here and reading old logs is Hard :)
15:52:16 <sgordon> yeah it's ok, it is not a particularly complicated task anyway
15:52:20 * rbergeron nods
15:52:21 <sgordon> so i will just check he hasn't done it
15:52:28 <sgordon> and if he hasn't then i will
15:52:36 <rbergeron> #topic Any other topics for today?
15:52:45 <sgordon> yeah i had one action from last week
15:52:47 * rbergeron looks around for anything else that anyone wants to bring up before we close up.
15:52:49 <sgordon> which was the mailing list moderators
15:52:50 <rbergeron> sure, go for it
15:52:52 * rbergeron nods
15:52:57 <rbergeron> #topic Mailing list moderators
15:53:01 <rbergeron> #chair sgordon
15:53:01 <ovirtbot> Current chairs: aglitke rbergeron sgordon
15:53:04 <sgordon> so the two responses i got were Ayal for the arch list
15:53:14 <sgordon> and Omer for the engine-devel list
15:53:23 <sgordon> and i myself would be happy to help mod the users list
15:53:47 <sgordon> so barring objections i just think we need whoever is the admin for those lists to add them as moderators?
15:53:55 <rbergeron> Sure.
15:53:57 <itamar1> moderator is 99% about accepting emails from non members and making them members + auto discarding emails from spam
15:53:57 <sgordon> if everyone is happy with that i will send the request to infra@
15:54:07 <sgordon> yeah i know :)
15:54:07 <rbergeron> sgordon: I think that sounds dandy.
15:54:20 <itamar1> question
15:54:26 <rbergeron> #info We have a few people hwo have volunteered to help moderate
15:54:30 <rbergeron> yes?
15:54:38 <itamar1> is it possible to make multiple users admin, or must they share the admin password for the list?
15:54:50 <rbergeron> #action sgordon to mail the infrastructure list re: adding people to be admins
15:54:51 <sgordon> i think they have to share
15:55:00 <sgordon> but you moderators are a second tier
15:55:04 <sgordon> *your moderators
15:55:12 <rbergeron> itamar1: I think you can have multiple people moderating/approving emails
15:55:19 <sgordon> yeap
15:55:21 <rbergeron> list owners
15:56:03 <sgordon> a moderator cant do *everything* the list admin can
15:56:13 <sgordon> mostly they can just approve/dump emails in the moderation queue
15:56:13 <rbergeron> the admin can add more moderators, though. ;)
15:56:20 <sgordon> and add people to the white and black lists
15:56:24 <sgordon> if i recall correctly
15:56:31 <itamar1> please add to a wiki how to add a moderator then please. thanks
15:56:32 <rbergeron> yup, I think that's correct.
15:56:52 <sgordon> ok, ovirt.org is just using mailman right?
15:56:57 <rbergeron> sgordon: yup
15:56:59 <oschreib> yep
15:57:00 <sgordon> coolies
15:57:22 <rbergeron> #action quaid to add info to wiki on how to add a moderator to a mailing list
15:57:38 <rbergeron> itamar1: I assume you mean "what is the process to request additional moderators" and not "how to go in and physically add another moderator"
15:59:58 <rbergeron> okay, anything else?
16:00:05 * rbergeron lights the fuse for end of meeting
16:00:52 <rbergeron> Happy thanksgiving to the US folks, and ... happy a-few-days-with-less-email to everyone not in the US :)
16:00:57 <rbergeron> Thanks for coming today, everyone!
16:01:12 <rbergeron> #endmeeting