14:11:20 <doron> #startmeeting oVirt Weekly Sync
14:11:20 <ovirtbot> Meeting started Wed Oct 22 14:11:20 2014 UTC.  The chair is doron. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:11:20 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:11:21 <doron> #topic Agenda and roll Call
14:11:23 <doron> #info infra update
14:11:24 <doron> #info 3.5 status
14:11:26 <doron> #info conferences and workshops
14:11:27 <doron> #info other topics
14:11:33 * bkp here
14:11:36 <doron> let's start with infra
14:11:37 <doron> #topic infra update
14:11:40 * amureini here
14:12:02 <doron> eedri: here?
14:13:06 <doron> ok, we'll have to skip the ovirt infra update.
14:13:13 <doron> #topic 3.5 status
14:13:42 <doron> #info 3.5.0 GA;ed last week.
14:13:46 * lvernia is here.
14:13:54 <doron> We'e currently working on 3.5.1
14:14:21 <doron> #info full details on 3.5.1 current status: http://lists.ovirt.org/pipermail/users/2014-October/028419.html
14:15:00 <doron> #info current plan for 3.5.1 is: RC Build: 2014-11-25 GA on 2014-12-02
14:15:31 * awels is here
14:15:39 <doron> #info 3.5.1 tracker is available here: http://bugzilla.redhat.com/1155170
14:15:53 <doron> feel free to add the blocking items
14:16:50 * danken is here, too.
14:17:50 <doron> #action amureini lvernia ecohen mskrivanek oved danken fabiand sandro please add blockers the 3.5.1 tracker.
14:18:23 <doron> Does anyone have any further updates on 3.5.1?
14:18:28 <karimb> doron, https://bugzilla.redhat.com/show_bug.cgi?id=1145241
14:18:47 <karimb> doron, doesnt seem that big a deal if it s just a matter of creating the default disk profile
14:18:49 <lvernia> doron: Ack.
14:19:17 <doron> karimb: indeed, good point. already there :P
14:19:34 <doron> and this was a nasty one.
14:19:37 <karimb> :)
14:19:49 <doron> Anything else related to 3.5.1?
14:20:07 <doron> fabiand: care to give a short update on 3.5.1 plans?
14:20:16 <doron> for node / ovirtr-appliance
14:20:17 <danken> we have plenty of patches already backported in vdsm
14:20:17 <fabiand> sure!
14:20:20 <danken> for 3.5.1
14:20:27 <YamakasY> what is vdsmdummy doing enytime ? it's messing up my foreman mac-address
14:20:37 <doron> danken: just make sure the blockers are tracked.
14:20:38 <YamakasY> *everytime
14:20:39 <danken> doron: now is also the time to reinroduce the sla backports
14:20:43 <fabiand> doron, for node: we've got some fixes we really need to get in before we can really provide a stable node, those are partly 3.5.1 ...
14:20:53 <bkp> Hang on, please YamakasY, in weekly meeting.
14:20:55 <doron> danken: indeed it's in the plan.
14:20:57 <YamakasY> oops
14:20:58 <YamakasY> sorry
14:21:01 <bkp> NP
14:21:02 <YamakasY> did someone bring the cookies ?
14:21:04 <danken> msivak is more than welcome to unabandon and verify them.
14:21:08 <fabiand> doron, for the appliance: nothign big came up, it's usable, we'll just be pulling in the updates after 3.5.1 has been build
14:21:34 <doron> danken: will handle it.
14:21:53 <doron> fabiand: will we have el6 based node?
14:21:58 <fabiand> doron, yes
14:22:06 <doron> fabiand: and el7?
14:22:11 <fabiand> doron, not yet
14:22:17 <fabiand> but it's planned for the 3.5 timeframe
14:22:45 <doron> fabiand: ok. so current plans are arounf el6 node for 3.5.1 and better ovirt appliance.
14:23:51 <fabiand> yep
14:23:59 <doron> very well.
14:24:06 <doron> lvernia: anything important for 3.5.1?
14:24:22 <lvernia> doron: Nothing I'm aware of.
14:24:26 <doron> #info node plans for 3.5.1: el6 node for 3.5.1 and better ovirt appliance.
14:24:32 <doron> lvernia: no blockers?
14:25:05 <lvernia> Doesn't look like it.
14:25:09 <doron> #info network updates for 3.5.1: no specific updates.
14:25:12 <doron> lvernia: thanks
14:25:16 <lvernia> doron: Sure.
14:25:23 <doron> amureini: anything on the storage?
14:25:36 <doron> (for 3.5.1)
14:26:24 <doron> ok...
14:26:25 <amureini> doron, a couple of issues with sanlock on el7/f19/f20 which are basically closed - but important to note for 3.5.1, nothing else major to report
14:26:34 * eedri here now
14:26:40 <doron> amureini: thanks.
14:27:17 <doron> #info storage updates for 3.5.1: a couple of issues with sanlock on el7/f19/f20 which are needed and already handled.
14:27:26 <doron> awels: still here?
14:27:37 <awels> doron: yes
14:27:50 <awels> doron: Nothing to report on UX side
14:27:50 <doron> awels: your plans / updates for 3.5.1?
14:28:08 <doron> #info ux updtaes for 3.5.1: nothing to report.
14:28:12 <doron> awels: 10x.
14:29:13 <doron> #info sla 3.5.1 updates: adding missing qos patches as previously mentioned by danken, and some additional stabilization issues.
14:29:19 <doron> mskrivanek: here?
14:30:21 <doron> ofrenkel: here?
14:30:54 <danken> fromani_ maybe?
14:31:28 <doron> #action mskrivanek please report virt 3.5.1 updates offline.
14:31:39 <doron> danken: care to share your jhighlights for 3.5.1?
14:31:46 <mskrivanek> i'll try....
14:32:23 <doron> mskrivanek: ?
14:32:42 <danken> doron: well, we have a couple of important fixes
14:32:52 <danken> (supervdsm no longer eats all your memory)
14:33:11 <danken> NetworkManager no longer kill your bond options if it's running
14:33:58 <doron> danken: life should be much better post 3.5.1 based on your update :)
14:34:08 <danken> yep.
14:34:30 <mskrivanek> ...report virt 3.5.1 updates offline
14:34:30 <ovirtbot> mskrivanek: Error: "..report" is not a valid command.
14:34:32 <danken> doron: provided that sla late feature does not break anything ;-)
14:34:57 <doron> danken: sla is nver late, it may only be delayed....
14:35:24 <danken> doron: amureini btw, 3.5.1 can take laravot's guest disk api
14:35:45 <danken> now that 3.5.0 is out of the door.
14:35:49 <doron> #info updates from danken on 3.5.1: much needed fixes expected around memory consumption, bond options, and others.
14:35:55 <doron> danken: thanks
14:35:57 <amureini> danken, doron yup, already on our radar :-) but thanks for raising attention to it
14:36:13 <doron> ok, let's move beyone 3.5.1 to the future...
14:36:26 <doron> #topic 3.6
14:36:44 <doron> yes... 3.6.0 is the next big thing and we should start preparing for it.
14:36:50 <YamakasY> indeed, but 3.5.1 needs some fixing on vdsmdummy macaddresses it seems
14:37:18 <doron> #info Detials on 3.6.0 available here: http://lists.ovirt.org/pipermail/users/2014-October/028423.html
14:37:22 <YamakasY> vdsmdummy sets it's on mac address a primary macaddress
14:37:46 <doron> in the next week or so we'l lstart discussing release criteria and release process to improve what we had in 3.5.0
14:38:04 <doron> I would like developers / maintainers start looking at release process / release criteria and close the discussion in 2 weeks with an agreement on both.
14:38:36 <doron> We also need to start planning 3.6
14:38:52 <doron> so please start looking into it.
14:39:08 <doron> Does anyone have anything specific around 3.6.0?
14:39:40 <amureini> doron, wrt features? process? what exactly is the question right now?
14:40:11 <doron> amureini: one at a time- we need to nail down the release process by clarifying the milestones.
14:40:25 <doron> making sure nothing slips all the way to ga.
14:40:28 <danken> we should agree on a time for 3.6.0
14:40:33 <danken> and then fit features
14:40:46 <danken> I heard rumors of people wanting it to be looong
14:40:53 <danken> but I beg to differ.
14:41:01 <doron> danken: indeed. but milestone definition is probably first.
14:41:24 <danken> milestone can be feature-based or time-based.
14:41:26 <doron> danken: we'll start a thread on timelines to make it clear as well.
14:41:59 <doron> amureini: once we have the above we will fit in the features.
14:42:17 <doron> ok guys. let's proceed with our agenda.
14:42:20 <lvernia> doron: So how could anyone have anything "specific" around 3.6.0? :)
14:42:34 <doron> lvernia: you tell me.
14:43:12 <doron> lvernia: there are special cases wwhere we wish to support some hotshot architecture for example.
14:43:23 <lvernia> doron: Ah-ha.
14:43:38 <lvernia> doron: Okay, then I don't have anything specific.
14:43:47 <doron> Thanks.
14:43:50 <doron> #topic conferences and workshops
14:43:54 <doron> bkp: here?
14:44:03 <bkp> Yup
14:44:11 <doron> bkp: busy weeks?
14:44:27 <bkp> And how.
14:44:41 <bkp> The oVirt Workshop went off without a major hitch! Thanks to all involved, particularly bazulay, who organized a lion's share of the program agenda!
14:44:58 <bkp> A blog on the workshop will be posted this afternoon (I hope), just was waiting on slides to which I could post and link.
14:45:11 <bkp> Coming up: gshereme is speaking at All Things Open here in Raleigh this afternoon, and I did the VM/container lightning talk last night at a pre-ATO event.
14:45:22 <doron> #info The oVirt Workshop went off without a major hitch! Thanks to all involved, particularly bazulay, who organized a lion's share of the program agenda!
14:45:26 <bkp> Next up, a virtualization talk at Open World Forum in Paris on Oct. 31, followed by a number of folks attending OpenStack Summit in that city the following week.
14:45:38 <doron> #info A blog on the workshop will be posted this afternoon (I hope), just was waiting on slides to which I could post and link.
14:45:50 <doron> #info Coming up: gshereme is speaking at All Things Open here in Raleigh this afternoon, and I did the VM/container lightning talk last night at a pre-ATO event.
14:45:53 <doron> Cool ;)
14:45:56 <bkp> LISA'14 in Seattle from Nov. 9-13 will feature an oVirt demo lab, as well as booth presence.
14:46:02 <doron> #info Next up, a virtualization talk at Open World Forum in Paris on Oct. 31, followed by a number of folks attending OpenStack Summit in that city the following week.
14:46:19 <doron> #info and more: LISA'14 in Seattle from Nov. 9-13 will feature an oVirt demo lab, as well as booth presence.
14:46:27 <bkp> Finally, OSAS is working on event planning for 2015, which we hope to feature more subsidization for engineering/QE travel. I will let you know when we hammer out the details soon!
14:46:49 <doron> #info: Finally, OSAS is working on event planning for 2015, which we hope to feature more subsidization for engineering/QE travel. I will let you know when we hammer out the details soon!
14:46:57 <doron> bkp: thanks!
14:47:03 <bkp> (Sorry for dump, have to leave soon to host all-company meeting!)
14:47:12 <doron> #info other topics
14:47:23 <doron> Does anyone want to raise / ask anything ?
14:47:24 <bkp> I have three things...
14:47:28 <doron> bkp: shoot
14:47:36 <bkp> mgoldboi has put together a great article on containerizing oVirt... I am polishing it up, and hope to get it posted this week on the Red Hat Community blog, and perhaps the Project Atomic blog as well.
14:47:47 <bkp> I am meeting with Content Services here in Raleigh tomorrow to discuss documentation for all OSAS projects, but will be highlighting oVirt. Also, OSAS has a new documentation specialist, just hired on Monday. *Now* we're going to get some action on upstream docs!
14:48:02 <bkp> A reminder, I will be traveling to TLV next week, arriving Sun. morning, leaving on Thurs. afternoon. eedri, bring dessert again! And bazulay, don't think I've forgotten my mouse! :)
14:48:22 <bkp> And that's it from me!
14:48:42 <bkp> Gotta book, see many of you soon!
14:48:47 <doron> bkp: wow, lots of stuff. Thanks a lot!
14:48:51 <bkp> NP
14:48:58 <doron> ok, anyone else?
14:49:32 <doron> Going once?
14:50:13 <doron> Going twice...
14:51:10 <doron> Gone! Thanks everyone for coming, see you next week!
14:51:13 <doron> #endmeeting