13:01:28 <fabiand> #startmeeting oVirt Node Weekly Meeting
13:01:28 <ovirtbot> Meeting started Tue Sep  9 13:01:28 2014 UTC.  The chair is fabiand. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:28 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:01:31 <fabiand> #chairs dougsland rbarry
13:01:49 * rbarry here
13:02:33 <fabiand> hey rbarry
13:02:38 <utkarshsins> itamar, Hello.
13:02:39 <fabiand> I believe dougsland will not join us today
13:02:40 <dougsland> here
13:02:44 <fabiand> Oh
13:02:49 <fabiand> there he is :)
13:03:01 <dougsland> :)
13:03:23 <fabiand> here we go
13:03:25 <fabiand> #topic Agenda
13:03:33 <fabiand> #info Action Item Review
13:03:39 <fabiand> #info oVirt 3.5
13:03:43 <fabiand> #info Jenkins
13:03:45 <fabiand> #info Other Items
13:03:56 <fabiand> #topic Action Item Review
13:04:04 <fabiand> #link http://resources.ovirt.org/meetings/ovirt/2014/ovirt.2014-09-02-13.01.txt
13:04:16 <fabiand> First item: fabiand to investigate to build necessary tools in copr for el7
13:04:23 <fabiand> I did not investigate it.
13:04:29 <fabiand> Seems as if we are still busy with 3.5 …
13:04:37 <fabiand> Second item: fabiand to fix ovirt-appliance jenkins job to be more stable
13:04:44 <fabiand> I also did not update that job
13:04:48 <fabiand> But my update:
13:05:01 <fabiand> #action fabiand to fix appliance job during the next week
13:05:09 <fabiand> #info el7 builds tools delayed ..
13:05:17 <fabiand> #topic oVirt 3.5
13:05:29 <fabiand> It seems as if we slowly stabilize on 3.5 and el7
13:05:42 <fabiand> Yesterday we found a nasty bug related to selinux
13:05:48 <fabiand> apuimedo|lunch, made some nice patches some time ago
13:05:58 <fabiand> they affect persistence and are great
13:06:08 <fabiand> Just one thing was missing,setting the correct selinux labels
13:06:16 <fabiand> luckily we found that by accident and we'll have a fix shortly
13:06:19 <apuimedo> fabiand: setting the correct labels for what?
13:06:24 <fabiand> apuimedo, heya
13:06:36 <fabiand> apuimedo, of the file on the writable partition
13:06:43 <fabiand> apuimedo, shutil.copy2() is used
13:06:52 <fabiand> this copy the contents and permissions, but no file attributes
13:07:02 <fabiand> Also no selinux contexts
13:07:31 <fabiand> There is even a bug
13:07:32 <fabiand> http://bugs.python.org/issue14082
13:07:37 <fabiand> which I did not read yet
13:07:57 <apuimedo> oh, sorry about that
13:08:03 <fabiand> no problem at all
13:08:06 <fabiand> I still like your work :)
13:09:26 <fabiand> ah
13:09:29 <fabiand> it's only fixe in py 3.3
13:09:53 <fabiand> Anyway, we need a patch which is also included for 3.5
13:10:02 <fabiand> #info Basically quite stable
13:10:13 <fabiand> #info Nasty bug discovered (missing labels on persisted files)
13:10:40 <fabiand> I hope that we'll be able to use enforcing=1 (default) in the next Node build
13:10:52 <fabiand> besides some selinux problems, I'm not awar eof any bigger issues
13:10:59 <fabiand> I'd carry on ..
13:11:05 <fabiand> #topic Jenkins
13:11:45 <fabiand> #info jenkins jobs look good so far, except the appliance job ..
13:12:02 <fabiand> I think we'll need to move the migration to el7 after 3.5 ga
13:12:10 <fabiand> s/need/should/
13:14:10 <fabiand> going fwd
13:14:18 <fabiand> #topic Other Items
13:14:32 <fabiand> rbarry, dougsland anything from your side?
13:14:36 <dougsland> fabiand, nop
13:14:53 <rbarry> Nothing here
13:15:03 <fabiand> okay
13:15:12 <fabiand> the only thing I want to mention is  our longterm plan
13:15:23 <fabiand> rbarry, dougsland we already discussed this a bit
13:15:38 <fabiand> That we are thinking of how we can improve the usability and maintainability of Node on the long run ..
13:16:05 <fabiand> So just for any interested reader we want to note that there are thoughts going on on changing Node to meet new demands and be easier to handle ..
13:16:57 <itamar> utkarshsins: hello
13:18:11 <fabiand> right
13:18:15 <fabiand> thenm, if there is nothing else
13:18:17 <fabiand> going once
13:18:44 <fabiand> twice
13:18:53 <fabiand> and a third time
13:18:55 <fabiand> Thanks
13:18:57 <fabiand> #endmeeting