13:59:08 <doron> #startmeeting oVirt Weekly Sync
13:59:08 <ovirtbot> Meeting started Wed Sep  3 13:59:08 2014 UTC.  The chair is doron. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:08 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:59:09 <doron> #topic Agenda and roll Call
13:59:11 <doron> #info infra update
13:59:12 <doron> #info 3.4.z updates
13:59:14 <doron> #info 3.5 status
13:59:15 <doron> #info conferences and workshops
13:59:17 <doron> #info other topics
13:59:25 * amureini_ here
13:59:27 <doron> hi everyone, who's here for each team?
14:00:24 <doron> let's give the guys a minute to hook in
14:00:54 * bkp here
14:00:56 * lvernia is here.
14:01:14 <lvernia> YamakasY: I vaguely remembered this being discussed in the past, have a look at http://lists.ovirt.org/pipermail/users/2014-January/019412.html.
14:01:53 * sbonazzo here
14:02:05 <doron> hi everyone
14:02:11 <doron> let's (re-)start
14:02:29 <doron> #topic infra update
14:02:48 <doron> dcaro: can you update us on infra status?
14:03:00 <dcaro> doron: sure
14:03:23 <dcaro> last week we had a couple jenkins slaves already running on phx lab
14:03:43 * alitke here
14:03:52 <dcaro> but we had an issue with the hosted engine, that is solved now, but I have to look into it to find the root cause
14:04:16 <doron> dcaro: please check with jmoskovc for known issues.
14:04:19 <dcaro> we got an issue with space on ovirt.org wiki, that prevents login, misc cleared some space to keep going until we can migrate
14:04:27 <dcaro> doron: will do :)
14:04:49 <misc> dcaro: oh, so you can give me a VM for the wiki on phx2 ?
14:05:04 * awels here
14:05:06 <dcaro> misc: I will wait a bit until the issue is pinned out
14:05:18 <misc> :(
14:05:23 <dcaro> misc: I can give you a vm to start migrating and testing if you want
14:05:36 * misc prepare to îng dcaro "are we done yet" every day :p
14:05:44 <doron> #info ovirt infra updates: several jenkins slaves sopped due to HE issue, currently resolvd. Wiki chocked on storage, should be ok now.
14:05:44 <dcaro> xd
14:05:47 <doron> dcaro: thanks
14:05:53 <doron> #topic 3.4.z updates
14:05:55 <dcaro> welcome
14:05:58 <misc> dcaro: I can test on some os1 stuff, no need to make you lose time on this
14:05:58 <doron> sbonazzo: here?
14:06:03 <sbonazzo> doron: yes
14:06:17 <doron> sbonazzo: how are we doing with 3.4.z?
14:06:42 <dcaro> misc: we are out of quote on os1 iirc :S
14:06:42 <sbonazzo> doron: sent status this morning, bottom line we're on track:  http://lists.ovirt.org/pipermail/users/2014-September/027136.html
14:07:13 <sbonazzo> doron: still 5 bugs open, no blockers
14:08:16 <doron> #info full 3.4.z update details in:  http://lists.ovirt.org/pipermail/users/2014-September/027136.html
14:08:26 <doron> sbonazzo: when is the build expected?
14:08:45 <sbonazzo> doron: next week RC, sept 9th
14:09:11 <sbonazzo> doron: GA for 2014-09-23
14:09:34 <doron> #info 3.4.4 RC build planned for 9/9. Current plan for GA is 2014-09-23. No blockers.
14:09:36 <doron> sbonazzo:
14:09:39 <doron> sbonazzo: thanks
14:09:59 <doron> #topic 3.5 status
14:10:07 <doron> sbonazzo: how are we doing with 3.5.0?
14:10:23 <sbonazzo> doron: we were supposed to compose rc2 today
14:10:31 <sbonazzo> doron: but we still had 5 blockers still morning
14:10:50 <sbonazzo> doron: sent bug status this morning:  http://lists.ovirt.org/pipermail/users/2014-September/027137.html
14:11:03 <sbonazzo> doron: we need to discuss blocker status and define a new date
14:11:11 <doron> #info full details on 3.5.0 RC2 available in: http://lists.ovirt.org/pipermail/users/2014-September/027137.html
14:12:12 <doron> #info blockers: https://bugzilla.redhat.com/showdependencytree.cgi?id=1073943&maxdepth=1&hide_resolved=1
14:12:33 <doron> amureini_: alitke https://bugzilla.redhat.com/show_bug.cgi?id=1109920 status?
14:13:25 <alitke> Patches for both live merge blockers are merged to master and +1/Verified on the 3.5 branch.  Waiting to be merged.
14:14:01 <alitke> danken should be able to take them now if he is comfortable
14:14:06 <doron> alitke: is there an eta for merging into 3.5?
14:14:17 <alitke> ask danken / ybronhei
14:14:31 * fabiand is here
14:15:05 <doron> danken: ybronhei is there an eta for live merge blockers?
14:16:05 <danken> doron: it shouldve been in already, ybronhei.
14:16:15 <danken> I don't think that it would take more than an hour
14:16:29 <doron> danken: very well, I'll take your word for it.
14:16:40 <doron> let's check the other blockers
14:16:40 <YamakasY> lvernia: thanks!
14:16:42 <moimael> Hi, I'm having a bunch of errors right now when installing ovirt3.4 repo, i get a lot of these : http://mirror.karneval.cz/pub/linux/fedora/epel/6/x86_64/repodata/repot foundomd.xml: [Errno -1] repomd.xml does not match metalink for ovirt-3.4-epel
14:16:43 <moimael> Trying other mirror.
14:16:45 <moimael> ovirt-3.4-epel      then 404 n
14:16:47 <moimael> not found
14:16:50 <moimael> any ideas ?
14:17:04 <doron> ybronhei: here for infra?
14:17:17 <bkp> moimael, can you hold your question a bit? We are having our weekly meeting.
14:17:29 <moimael> ok sorry !
14:17:36 <bkp> np
14:17:42 <doron> jhernand: here?
14:17:52 <jhernand> doron: Yes
14:18:10 <doron> jhernand: https://bugzilla.redhat.com/show_bug.cgi?id=1131030 is confusing me-
14:18:27 <doron> targeted for 3.6, however marked as regression. can you shed some light?
14:19:02 <jhernand> doron: I'm re-targeting to 3.5, it is a regression
14:19:35 <doron> jhernand: thanks for clarifying. we will need an eta for it.
14:20:00 <jhernand> doron: Note that it isn't a RESTAPI issue, but backend issue, so I can't give you an ETA
14:20:45 <doron> jhernand: thanks. we need someone from infra. Maybe ybronhei is here?
14:21:01 <bazulay> doron:  I'm here
14:21:17 <doron> bazulay: https://bugzilla.redhat.com/show_bug.cgi?id=1131030 blocking 3.5.0
14:21:24 <doron> we need an eta for it.
14:21:58 <doron> jhernand: in the meantime do you have an eta for https://bugzilla.redhat.com/show_bug.cgi?id=1134233 ?
14:22:21 <jhernand> doron: Yes, it will be fixed this week
14:22:36 <bazulay> Doron - Eli is looking into it with Juan ... no ETA yet ... this is definitly not a blocker
14:22:57 <jhernand> bazulay: It breaks backwards compatibility of the RESTAPI, should be a blocker in my opinion
14:23:03 <doron> jhernand: we were hoping to start building rc2 today / tomorrow. So we need to wait?
14:23:13 <doron> bazulay: it's a regression, right?
14:23:48 <jhernand> doron: Yes, you need to wait
14:24:16 <doron> jhernand: thanks. When do you expect we'll be able to build?
14:24:36 <bazulay> jhernand:  is the problem in the engine or in the API ? it looks like an issue in the searchBackend
14:25:08 <jhernand> doron: The bug that I can fix will be fixed latest end of the week probably earlier, the other one I don't know
14:25:29 <jhernand> bazulay: The problem is in the searchBackend, and was discovered because it breaks backwards compatibility of the RESTAPI
14:25:37 <doron> jhernand: ok. So we need an update from Eli / you on the other one.
14:25:51 <jhernand> doron: Yes
14:26:06 <doron> jhernand: thanks.
14:26:32 <doron> sbonazzo: we should postpone the RC2 build for Monday. To make sure we have most blockers handled.
14:26:50 <doron> ie- 2 storage issues and a REST API regression.
14:27:05 <sbonazzo> doron: ok. postponing by one week also test day? or keeping it?
14:27:09 <doron> hopefully by this time we'll have a fix for all of the issues :(
14:27:39 <doron> sbonazzo: if we build on Monday, can we do a test day on Wednesday / Thursday?
14:28:09 <doron> Thursday is not a good day. will Wednsday work?
14:28:16 <sbonazzo> doron: Thursday will be better
14:28:47 <sbonazzo> doron: but maybe there will be less people around for testing
14:28:48 <doron> sbonazzo: I fear many will be missing due to some local event
14:29:03 <sbonazzo> doron: let's keep it wor wed
14:30:19 <doron> #info due to current blockers, build will be done on Monday 8/9. If all goes well Test day will be on Wednesday, 10/9.
14:30:36 <doron> sbonazzo: how are we soing with general bz count?
14:30:39 <doron> (doing)
14:31:04 <sbonazzo> doron: it's stil over 200 bugs but it's ~100 bugs less than last week
14:31:34 <doron> sbonazzo: do you have an updated query?
14:31:55 <sbonazzo> doron: http://red.ht/1q7SqNL
14:32:48 <doron> #action: doron and fabiand to handle node bugs. doron to handle sla bugs.
14:33:02 <fabiand> Yeah, definetly
14:33:07 <doron> #action: amureini_ to handle storage bugs (48 right now)
14:33:42 <doron> #action ybronhei bazulay please push forward infra bugs (23 currently)
14:34:02 <amureini_> doron, known - I'm intentionally not pushing out anything (more) right now, but none of these are blockers. if we get to ga, remaining items will be moved to 3.5.1
14:34:03 <doron> #action mskrivanek please push forward virt bugs (23 currently)
14:34:15 <Netbulae> I'm having the same errors with EPEL but it's to do with an issue with the epel repo itself
14:34:22 <Netbulae> sorry
14:34:56 <doron> amureini_:  you have 20% of the total open issues. this is a lot. we have to reduce it to the minimal we can handle
14:35:31 <mskrivanek> doron: none of those should be a blocker, some pending on needinfos...it's a big reduction from the past week:)
14:35:45 <doron> amureini_: 3.5.1 is available for you right now. so start pushing critical things.
14:36:33 <doron> mskrivanek: amureini_ regardless of blockers, there's a reasonable amount of open issues we can have when closing a version. If you cannot fix it in the next 1-2 weeks, please push forward.
14:37:12 <amureini_> doron, I've already pushed out ~30 bzs that are obviously not critical, the remaining are mostly medium priotity. if you want, i can move them ALL out now and start bringing them back as we solve them. but that sounds awefully dumb to me.
14:37:21 <doron> awels: please try to do the same for ux open issues.
14:37:59 <doron> amureini_: I know you did some good work (total of 100 issues reduced). Still, going to GA with so many left overs is not a good sign.
14:38:20 <doron> let's clean our table for 3.5.1 and 3.6.0....
14:38:42 <doron> ok, moving on
14:38:49 <doron> sbonazzo: anything else on 3.5.0?
14:39:03 <awels> doron: with Einav on PTO, it is sort of hard, but I expect most if not all of the current open issues to be pushed. Except the ones marked regression, I am working on fixing those.
14:39:06 <sbonazzo> doron: no, nothing else
14:39:34 <doron> awels: when is
14:39:41 <doron> awels: when is Einav expected back?
14:39:43 <awels> doron: Monday
14:40:07 <doron> awels: this is fine. please update her on Monday and we'll check it in next week's meeting.
14:40:29 <awels> doron: Will do, I have gone over the open bugs, and like I said I think most will be pushed.
14:40:39 <doron> awels: for the record UX currently have 21 open issues.
14:40:49 <doron> awels: thanks.
14:40:56 <doron> moving on
14:40:56 <awels> doron: It was 22 last week, I fixed one :)
14:41:02 <doron> :)
14:41:16 <doron> #topic conferences and workshops
14:41:21 <doron> bkp: here?
14:41:27 <bkp> Yo!
14:41:49 <doron> bkp: welcome back :)
14:41:53 <doron> updates?'
14:42:00 <bkp> Yeah...
14:42:05 <bkp> Fossetcon "Enterprise Linux Day" next week is now a CentOS dojo. Ultimately, it does not affect any oVirt content--gshereme will still do a detailed tech overview of oVirt, using live USB sticks I am making now. There may even be a chance to expand oVirt-oriented content into the afternoon's hackathon.
14:42:24 <bkp> LinuxCon EU is still in good shape, as is KVM Forum.
14:42:37 <bkp> oVirt Workshop: bazulay is doing a great job on the program. The room for the oVirt Workshop will hold 70-100 people, depending on chair configuration.
14:42:54 <bkp> Also, I have gotten word on the number of additional passes that are available for KVM Forum: 6. To make this easier on jzb, send requests for the passes to me by Sept. 26. I will remind everyone as the date gets nearer. If I get more then six requests, I will work with team leaders to determine need.
14:43:18 <doron> #info Fossetcon "Enterprise Linux Day" next week is now a CentOS dojo. gshereme will still do a detailed tech overview of oVirt, using live USB sticks I am making now. There may even be a chance to expand oVirt-oriented content into the afternoon's hackathon.
14:43:31 <bkp> ^^^ That's it for events, unless questions.
14:43:40 <doron> #info oVirt Workshop: bazulay is doing a great job on the program. The room for the oVirt Workshop will hold 70-100 people, depending on chair configuration.
14:44:26 <doron> #info passes available for ovirt dev's: Also, I have gotten word on the number of additional passes that are available for KVM Forum: 6. To make this easier on jzb, send requests for the passes to me by Sept. 26. I will remind everyone as the date gets nearer.
14:44:52 <doron> Does anyone have any question on upcoming events?
14:45:20 <gshereme> no questions but
14:45:41 <gshereme> i am also sort-of presenting ovirt at NCDevCon which is right after I get back from fossetcon
14:46:01 <gshereme> it's a "how we created PatternFly and then used it in oVirt" talk
14:46:17 <bkp> gshereme: Coolness, will add to list.
14:46:38 <gshereme> that's it :)
14:46:45 <doron> #info gshereme will have an ovirt related session in NCDevCon
14:46:54 <doron> gshereme: bkp thanks!
14:47:05 <doron> #topic other topics
14:47:24 <doron> Does anyone want to discuss something?
14:47:37 <doron> Ask something?
14:48:04 <doron> Going once...
14:48:40 <doron> Going twice!
14:49:31 <doron> Gone.... thanks everyone for joining. See you next week and... Be good!
14:49:36 <doron> #endmeeting