14:22:27 <dcaro> #startmeeting
14:22:27 <ovirtbot> Meeting started Mon Aug 18 14:22:27 2014 UTC.  The chair is dcaro. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:22:27 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:22:35 <dcaro> #chair rbarry eedri
14:22:35 <ovirtbot> Current chairs: dcaro eedri rbarry
14:22:51 <dcaro> #topic Hosting
14:23:24 <dcaro> #info PHX lab has vm for foreman-proxy installed, and being added to foreman
14:23:48 <dcaro> this week we should be able to start provisioning vms from foreman
14:23:59 <clarkee> nice
14:24:22 <eedri> dcaro, just us?
14:24:34 <eedri> dcaro, great news
14:24:36 <dcaro> eedri: want to wait for anyone else?
14:24:42 <eedri> dcaro, no, its ok
14:24:50 <eedri> dcaro, let's do a review on current status
14:25:44 <dcaro> #info setting up subdomain phx.ovirt.org for the catacenter
14:26:18 <dcaro> managed by the foreman-proxy, for the provisioning
14:27:40 <dcaro> #action dcaro: Document the setup and main maintenance tasks for the new hosting
14:28:32 <dcaro> #info OS1 ready to roll, all the issues are closed (need to confirm though)
14:29:45 <dcaro> #okok, anything else on hosting?
14:32:55 <dcaro> I'll take that as a NO
14:32:57 <dcaro> okok
14:33:10 <dcaro> #topic Jenkins
14:33:41 <dcaro> I've been neglecting a little jenkins last week
14:34:22 <dcaro> #info Publisher duplicated rpms issue fixed
14:34:55 <dcaro> We were not cleaning up properly the workspace and it was pushing old artifacts from previous runs to the nightly
14:35:13 <dcaro> that should make the repo closure tests pass and free some space
14:36:44 <dcaro> I think we can upgrade jenkins soon
14:37:45 <dcaro> 1.574 or 1.570 seem like good candidates
14:38:53 <dcaro> anyone against?
14:39:05 <eedri> dcaro, +1
14:39:18 <eedri> dcaro, anything to backup or prepare before?
14:39:23 <dcaro> #action dcaro program jenkins upgrade to 1.574
14:39:38 <eedri> dcaro, btw - going forward we'll migrate jenkins to a production vm on phx right?
14:39:40 <dcaro> eedri: yes, I'll backup the jenkins config, the plugins and all that before upgrade just in case
14:39:52 <eedri> dcaro, +1
14:39:56 <dcaro> eedri: yep, but once the lab is ready
14:40:00 <eedri> obasan, can help if needed i guess
14:40:12 <eedri> dcaro, yes, and after we finish verying the jenkins dc
14:42:37 <dcaro> gerrit can also be upgraded, 2.9 is already out, that will allow the creation of full pages by gerrit plugins
14:43:00 <dcaro> (and a lot of other fixes/inprovements)
14:47:03 <Rydekull> Hello
14:48:29 <dcaro> Rydekull: welcome :)
14:48:32 <dcaro> #chair Rydekull
14:48:32 <ovirtbot> Current chairs: Rydekull dcaro eedri rbarry
14:48:34 <Rydekull> dcaro: got a question for later, when you reach a suitable point the schedule :-)
14:48:36 <eedri> dcaro, nice
14:48:50 <Rydekull> err, agenda*
14:49:19 <dcaro> #action dcaro schedule gerrit upgrade to 2.9 (look first if its backwards compatible)
14:49:30 <gmiguel> Hi. I'm using ovirt 3.4.3-1.el6 with Active Directory configuration. I would like to know if it is possible to associate a VM to a user in order for the user to be able to take actions only under this VM.
14:51:28 <dcaro> gmiguel: hey, we are in a meeting right now, do you ming waiting 10 min?
14:55:55 <dcaro> ok, any other issues on jenkins?
14:56:23 * Rydekull knows nothing
14:56:38 <gmiguel> ok, sorry.
14:56:48 <Rydekull> gmiguel: dont worry about it, just stick around :-)
14:59:05 <eedri> dcaro, hmm
14:59:14 <eedri> dcaro, are we still migrating jobs to yaml?
14:59:35 <dcaro> eedri: the rate on which we are migrating dropped, but yes
14:59:57 <dcaro> eedri: I think that documenting and maybe a tutorial will help a lot to get others to use it
15:00:15 <eedri> dcaro, +1
15:00:17 <eedri> dcaro, i think so too
15:01:13 <dcaro> #action Add docs and tutorial to yaml process
15:03:08 <dcaro> okok, anything else before I close?
15:03:38 <Rydekull> Yes, Debian. I'm wondering if there's been any thoughts of getting oVirt to run on Debian, and in turn of course, setting up repos for it
15:03:55 <Rydekull> I remember (and found them again) some older wiki articles on the subject, just wondering what your thoughts are
15:04:10 <Rydekull> Cause, my plan is to try and build it on debian and see what I run into
15:04:24 <Rydekull> then if you guys are ok with it, we could setup some jenkins machine for debian aswell
15:04:45 <Rydekull> and then repo for that of course
15:05:19 <dcaro> I'd love to get debian builds, I think that there was some work done in that regard
15:05:35 <dcaro> eedri: obasan do you remember who worked on that?
15:05:39 <Rydekull> http://www.ovirt.org/Ovirt_build_on_debian/ubuntu
15:06:27 <eedri> dcaro, you mean ubunto slaves?
15:06:29 <obasan> dcaro, hmm...
15:06:45 <dcaro> eedri: well, the question is about debian, but it should be similar
15:06:56 <Rydekull> I think it predates obasan's involvement? :-P
15:06:57 <eedri> dcaro, https://fedorahosted.org/ovirt/ticket/155
15:07:05 <eedri> dcaro, there was this - using travis CI
15:07:23 <eedri> dcaro, and also https://fedorahosted.org/ovirt/ticket/88
15:07:39 <eedri> dcaro, but basicaly we said we'll try adding a slave on os1 but i guess that didn't work
15:07:52 <eedri> dcaro, we can add an ubunto template on phx2
15:08:13 <Rydekull> Hmm, ubuntu template seems odd. debian being the upstream. Kinda like starting on CentOS when Fedora is there :-P
15:09:19 <obasan> Rydekull, nono. I did not :)
15:10:25 <dcaro> Rydekull: always thought of them the other way around :/, ubuntu as the 'latest and gratest features' and debian as the stable one
15:10:35 <Rydekull> Truly isnt :-)
15:10:47 <Rydekull> https://wiki.ubuntu.com/Upstream
15:11:24 <eedri> Rydekull, good to know
15:11:53 <Rydekull> Aaanyway, no objections it seems
15:13:51 <dcaro> +1 from me :)
15:15:04 <dcaro> #info /22
15:15:07 <dcaro> oops
15:15:09 <dcaro> xd
15:15:17 <Rydekull> heh
15:15:33 <dcaro> #info Rydekull wants to start looking into debian packaging
15:16:00 <dcaro> Rydekull: we can try to allocate a vm with debian or ubuntu for you to play with if you need it
15:16:56 <Rydekull> Would be good
15:17:28 <Rydekull> I'll start messing with a machine at home, but yeah, would be good to have a "official" one where I can reproduce my steps to verify its working
15:18:17 <dcaro> Rydekull: can you open a ticket for it so I don't forget?
15:18:33 <Rydekull> alright
15:20:31 <dcaro> thanks :)
15:22:06 <Rydekull> So, we are done? :-)
15:27:38 <dcaro> yep
15:27:43 <dcaro> #endmeeting