14:09:50 <dcaro> #startmeeting
14:09:50 <ovirtbot> Meeting started Mon Jul 14 14:09:50 2014 UTC.  The chair is dcaro. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:09:50 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:09:55 * rbarry here
14:10:06 <obasan> hello!
14:10:07 <dcaro> #chairs eedri obasan rbarry
14:10:08 * obasan here
14:10:47 * fabiand is here
14:11:09 <dcaro> #chairs fabiand
14:11:28 <dcaro> #chair fabiand
14:11:28 <ovirtbot> Current chairs: dcaro fabiand
14:11:32 <dcaro> #chair eedri obasan rbarry
14:11:32 <ovirtbot> Current chairs: dcaro eedri fabiand obasan rbarry
14:12:23 <dcaro> not too much assistance from outside :/, let's get started anyhow
14:12:41 <dcaro> #topic Hosting
14:13:11 <dcaro> #info phx lab still waiting for final networking setup (cabling and swithces)
14:14:25 <dcaro> there have been no issues with storage on linode lately right? After eyal's cleanup?
14:14:45 <eedri> dcaro, not that i know off, though jenkins master has out of space this morning
14:15:27 <dcaro> eedri: yep, it's where all the artifcts are stored (and allthe jobs logs), lately we are starting to store isos and other big artifacts...
14:15:52 <dcaro> eedri: was it any particular process taking the space?
14:16:04 <ewoud> dcaro: here
14:16:53 <eedri> ewoud, publishers were talkign lots of space
14:16:57 <eedri> dcaro, ^
14:17:04 <eedri> dcaro, i didn't really solve the problem, just mitigated it for now
14:17:13 <eedri> dcaro, a deeper look and adjustments is needed
14:17:22 <eedri> dcaro, also, 3.3 jobs i changed some of the history there
14:17:36 <eedri> dcaro, looking forward we'll migrate it to a vm on phx1
14:17:37 <eedri> 2
14:17:52 <dcaro> #action review publishers to leverage disk usage
14:18:23 <dcaro> eedri: but the publishers do not archive any artifacts right?
14:19:07 <eedri> dcaro, thier workspace took space
14:19:12 <eedri> dcaro, master tool 4.5 gb
14:21:36 <dcaro> eedri: mmm.... maybe we are fingerprinting artifacts or something :/, will have to look
14:22:03 <dcaro> ok, any other issue with hosting?
14:22:26 <eedri> dcaro, any update on os1 with centos 7
14:22:35 <eedri> dcaro, now that centos7 is publically availiable
14:23:01 <dcaro> eedri: not really, but we are getting short in space there also
14:23:18 <eedri> dcaro, really?
14:23:24 <eedri> dcaro, they have a quaote
14:23:37 <dcaro> eedri: we don't have enough quota to launch a new xlarge instance
14:25:05 <dcaro> (last time I tried at least, I created a small instance instead
14:25:34 <dcaro> eedri: maybe we can review current instances and clean up a bit
14:25:45 <eedri> dcaro, ok, i guess we should stop relying on it and push forward phx2
14:26:45 <dcaro> eedri: sure
14:28:07 <dcaro> ok, we can move then
14:28:17 <dcaro> #topic Jenkins
14:28:46 <dcaro> eedri: obasan you did a good job creating the 3.5 jobs right? What's still missing?
14:29:20 <eedri> dcaro, yea, also repo closure was fixed for master & 3.5, though there are some errors still there from time to time
14:29:29 <eedri> dcaro, still missing aaa projects & hosted engine ha
14:29:47 <eedri> dcaro, afair.. also vdsm-json-rpc for el6 needs fixing (it had issue with maven + mock..)
14:29:57 <msivak> eedri: I need help from Jay
14:30:11 <msivak> eedri: I created the errata and builds, but I can't add them there
14:30:42 <msivak> eedri: I already sent him an email
14:30:44 <eedri> msivak, we're in the infra meeting, i will sync with you later
14:31:02 <dcaro> #chair ewoud
14:31:02 <ovirtbot> Current chairs: dcaro eedri ewoud fabiand obasan rbarry
14:32:02 <eedri> dcaro, ok, let's continue..
14:32:03 <dcaro> #action create aaa projects jobs
14:32:16 <eedri> dcaro, also - we're still missing some jobs on 3.5, for verifying patches
14:32:31 <dcaro> eedri: any specific project?
14:32:33 <eedri> dcaro, like upgrade db, dao tests and other
14:32:44 <eedri> dcaro, upgrade db has open trac ticket on it
14:33:13 <dcaro> eedri: ok, we'll review later then
14:36:37 <dcaro> what about the copr jobs? Will we keep pushing them?
14:37:49 <eedri> dcaro, yea, i think it will make life easier for official releases, but not high priority i guess
14:38:04 <dcaro> ok
14:38:34 <dcaro> #topic puppet/foreman
14:39:49 <eedri> dcaro, about jenkins, we have failures also on upgrade jobs 3.3/3.4
14:39:55 <dcaro> there was a discussing a couple weeks ago about how to arrange the manifests, anyone did not have time to participate?
14:39:57 <eedri> dcaro, not sure if these are known bugs or not
14:40:09 <dcaro> #info failures on upgrade hobs 3.3/3.4
14:40:22 <dcaro> #action check if there are open bugs on 3.3/3.4 upgrade failures
14:41:04 <eedri> dcaro, also vdsm job failed due to new python-pthreading
14:41:14 <eedri> dcaro, should be OK now, after you added them to the ci-tools repo
14:41:20 <dcaro> eedri: but that's already on ci-tools
14:41:22 <dcaro> yeah
14:41:30 <dcaro> let's check if it did xd
14:42:17 <dcaro> looks ok, master right?
14:45:04 <dcaro> about the puppet manifest layout, I'll try to gather the comments and make an etherpad so we can decide what to do
14:45:22 <dcaro> #action gather puppet layot discussion arguments and create a pad
14:46:11 <dcaro> #topic tickets
14:47:06 <dcaro> let's review as many tickets as we can
14:47:11 <dcaro> with the time left
14:47:22 <dcaro> https://fedorahosted.org/ovirt/ticket/188 - ovirt-appliance can not be build because of unreachable mirror
14:47:29 <dcaro> fabiand: ^ any updates on this?
14:47:38 <fabiand> dcaro, yep
14:47:50 <fabiand> dcaro, you solved most of it, and I played a bit with proxying to improve it.
14:47:54 <fabiand> So we can close it
14:48:01 <fabiand> and thanks a lot dcaro !
14:48:05 <fabiand> to you, personally! :)
14:48:34 <dcaro> fabiand: good job with the proxy, I'm looking forward to get it set up on all the slaves
14:49:00 <fabiand> yep, I'll write it up and then we can use it elsewhere
14:49:45 <dcaro> https://fedorahosted.org/ovirt/ticket/144 - ovirt-reports_3.4_create-rpms_gerrit needs jasperreports-server >= 5.5.0-6
14:50:21 <dcaro> eedri: sbonazzo this ^ was solved? Partially solved?
14:51:18 <eedri> dcaro, was the job migrated to mock?
14:52:03 <dcaro> eedri: no
14:52:07 <sbonazzo> dcaro http://jenkins.ovirt.org/job/ovirt-reports_master_create-rpms_merged/286/console looks ok so maybe it has been fixed
14:52:18 <sbonazzo> dcaro I don't know what changed
14:52:35 <dcaro> that's why I'm asking, maybe we should close that one and open a new one to migrate the job to mock
14:53:21 <sbonazzo> dcaro +1
14:53:26 <eedri> dcaro, sounds right to me, via yaml when it's ready
14:53:41 <eedri> dcaro, also not critical for sure
14:53:45 <dcaro> okok
14:55:22 <dcaro> https://fedorahosted.org/ovirt/ticket/204 - [jenkins][java] fix issues where JAVA_HOME has different locations on various slaves
14:55:53 <dcaro> I forgot about this one, I have to fix it, was gonna create a non-mvn job for it so we ca use any system installed java instead of having to specify one
14:56:10 <dcaro> I'll accept it
14:56:25 <eedri> dcaro, i'm not sure it's relvant fpr non-maven jobs
14:56:41 <eedri> dcaro, it happens if jobs are not set to 'default' java on matrix jobs
14:56:44 <eedri> dcaro, iirc...
14:56:44 <dcaro> eedri: yep, that's why move it to non mvn
14:56:55 <eedri> dcaro, way before the mvn section
14:56:59 <eedri> dcaro, right after the clone
14:57:11 <dcaro> eedri: yes, it's that two combination
14:57:19 <eedri> dcaro, matrix jobs are "mvn type"
14:57:20 <eedri> ?
14:57:42 <dcaro> eedri: noo
14:57:45 <dcaro> *no
14:57:52 <dcaro> mm... *nop xd
14:58:00 <eedri> dcaro, so not sure you're right about the mvn tyhpe
14:58:14 <eedri> dcaro, i think it's related to the jdk you choose on the job of the job,
14:58:26 <dcaro> eedri: when creating a multiconfig job, you can add a maven build step
14:58:36 <eedri> dcaro, yea i know
14:58:46 <dcaro> then the java installation becomes relevant
14:58:55 <dcaro> just as if it were a maven type job
14:59:32 <eedri> dcaro, for example - http://jenkins.ovirt.org/job/ovirt-engine_3.4_find-bugs_merged/configure
14:59:40 <eedri> dcaro, is this a maven job or freestyle
15:00:44 <eedri> dcaro, see the JDK option right after the params
15:00:51 <dcaro> eedri: I'd say it's freestyle
15:00:59 <eedri> dcaro, ok, so that job was failing
15:01:16 <eedri> dcaro, cause it had some jdk definition choosen which didn't match the jdk path on the slave
15:01:25 <dcaro> eedri: it has configured a specific installation of jdk, not told to use the default one
15:01:29 <eedri> dcaro, i suspect cause the path on the master is different from the slave
15:01:54 <dcaro> eedri: anyhow, to solve it, just remove the maven build step and change it for a shell script runnin gmaven
15:01:55 <eedri> dcaro, yea, so i wonder how you overcome an issue where the jdk is on one path on the master and different on the slave
15:02:14 <eedri> dcaro, if you do that, it won't try to use the "JDK" value from the job?
15:02:28 <dcaro> eedri: no afaik
15:02:31 <eedri> dcaro, i see
15:02:41 <eedri> dcaro, ok, so then you have a different problem :)
15:02:46 <dcaro> it uses the system PATH
15:02:47 <eedri> dcaro, no official maven on el6
15:02:55 <eedri> dcaro, unless we have a custom rpm for it..
15:03:10 <dcaro> if mvn is installed system wide, it should not care where it comes from
15:03:36 <dcaro> and we have a custo maven3 rpms for el6 on ci-tools repo iirc
15:04:05 <eedri> dcaro, ok, so we're good
15:04:50 <dcaro> (got deleted not long ago xd, but we restored it soon after)
15:05:53 <dcaro> okok, so for the record:
15:06:09 <dcaro> i'll write it down in the ticket xd
15:06:51 <eedri> hehe
15:06:52 <eedri> dcaro, ok
15:07:47 <dcaro> ok, last ticket
15:07:53 <dcaro> https://fedorahosted.org/ovirt/ticket/140 - [jenkins] ovirt-node jobs issue
15:08:49 <dcaro> fabiand: ^ any insight on i, have you looked?
15:11:59 <dcaro> ok, fabiand is not around xd
15:12:21 <dcaro> okok, so, anything before we end the meeting?
15:13:23 <dcaro> obasan: eedri ewoud misc orc_orc rbarry ?
15:13:41 <eedri> dcaro, hmmm
15:13:51 <rbarry> Nothing from me
15:14:02 <eedri> dcaro, fabiand rbarry what about ovirt-node publishers
15:14:17 <eedri> currently we don't publish ovirt-node via nightlies
15:14:21 <fabiand> eedri, I'm getting squashed between two meetings right now.
15:14:30 <eedri> fabiand, hehe.. ok, will take this offline
15:14:34 <fabiand> eedri, the biggest issue is that ovirt-node still does not build.
15:14:39 <rbarry> The ovirt-node master rpm job is working, ISOs aren't
15:14:52 <eedri> fabiand, oh.. that will make adding nightlies a problem then :D
15:14:53 <rbarry> repo problems with the ISO build, I think. But hopefully building this week
15:15:18 <eedri> sbonazzo, someone talked about improving nightlies usage, either by ovirt-release rpm or documentation
15:15:33 <eedri> sbonazzo, people might not be aware they need to use other repos like pattenfly..and so on
15:15:50 <eedri> sbonazzo, i think there is a ticket on it
15:16:40 <dcaro> okok, I'll close the meeting so we can take this offline
15:16:44 <eedri> dcaro, +1
15:16:44 <dcaro> #endmeeting