15:37:33 <dcaro> #startmeeting oVirt Infra
15:37:33 <ovirtbot> Meeting started Mon Jun 23 15:37:33 2014 UTC.  The chair is dcaro. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:37:33 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:37:53 <dcaro> #chairs eedri_ obasan rbarry obasan
15:37:59 <dcaro> #chair eedri_ obasan rbarry obasan
15:37:59 <ovirtbot> Current chairs: dcaro eedri_ obasan rbarry
15:38:00 <sasl> when runnig ovirt-hosted-engine per http://community.redhat.com/blog/2014/03/up-and-running-with-ovirt-3-4/ should i see the NFS mount in /etc/fstab on the hpervisor or does the ovirt engine somehow dynmaically mount it?  I see no reference to the NFS share with the "mount" command either
15:38:02 <misc> dcaro: yep
15:38:11 <dcaro> #chair misc
15:38:11 <ovirtbot> Current chairs: dcaro eedri_ misc obasan rbarry
15:38:34 <sasl> oop...meeting time
15:40:11 <dcaro> okok, let's start then
15:41:01 <dcaro> #topic Hosting
15:41:31 <dcaro> Two of the phx servers are installed and I started setting them up for the storage services
15:41:51 <dcaro> misc: you started the pad right?
15:41:54 <misc> dcaro: yep
15:42:04 <misc> http://etherpad.ovirt.org/p/service_list_ovirt
15:42:22 <dcaro> #info inventory pad started http://etherpad.ovirt.org/p/service_list_ovirt
15:43:22 <dcaro> misc: in my opinion you can get rid of all those unused domains
15:43:53 <misc> dcaro: me too, but I prefer to be cautious for now :)
15:44:24 <dcaro> eedri_: obasan ewoud dneary any of you know what are the domains:  puppet.ovirt.org plugin/plugins.ovirt.org  ftp.ovirt.org glance.ovirt.org?
15:44:41 <dcaro> bkp: ^
15:45:52 <misc> I would move puppet.ovirt to the foreman server, since puppet by default will go there
15:46:27 <dcaro> misc: we don't really use it anywhere, but I see no problem
15:46:48 <dcaro> not sure if we might get to a pint where they aould be two different services
15:46:53 <dcaro> *servers
15:47:02 <misc> we could have 2 puppetmaster
15:47:23 <misc> but e will see then, and I guess by then, puppet will be puppet managed :)
15:47:32 <misc> (so the switch would be easy)
15:47:32 <dcaro> yep :)
15:48:55 <dcaro> and I usually prefer having just what you need instead of too much you don't, so if we don't use it and don't need it, I vote out, will add when needed
15:49:14 <misc> yep
15:49:56 <dcaro> ok, I'd give a few more days for someone to have the chance to reply the email though
15:50:31 <dcaro> #action if noone disagrees, in a few days remove the unused domains
15:50:54 <dcaro> ok, any other hosting issues?
15:51:51 <dcaro> moving on
15:51:58 <dcaro> #topic Foreman and Puppet
15:52:28 <dcaro> ok, we still have to decide the layout for our puppet manifests
15:52:42 <dcaro> ewoud: around?
15:54:28 <dcaro> we can give it another week for everyone to have time to have a say, and then gather the proposals and take them to a vote
15:54:36 <dcaro> agree?
15:55:10 <dcaro> eedri_: obasan ewoud misc ^
15:55:58 <eedri_> dcaro, +1
15:56:20 <dcaro> #action wait one week and gather all the puppet organization proposals and take them to a vote
15:56:33 <misc> ok
15:56:46 <dcaro> btw misc ewoud any of you is familiar with the new 'eviroments directories' in puppet 3.6?
15:57:03 <dcaro> it will obsolete the current way we work... and r10k :/
15:57:08 <misc> nope
15:57:27 <misc> but it will break r10k ?
15:57:30 <dcaro> we are getting deprecation warning right now, I'll investigate, but if any of you has experience with that is reallt welcome
15:57:35 <dcaro> as it is yes
15:58:13 <dcaro> (well, as we use it also, r10k will have no problem running, but the new way only reads the modules and manifests dirs inside the env, not the site)
15:58:52 <dcaro> we might be able to get our modules inside the modules dir with r10k?
15:59:11 <misc> yeah, using a external git repo
15:59:13 <dcaro> I haven't played with it do much :)
15:59:23 <dcaro> *too
15:59:31 <misc> (as I proposed, but I will be honest, i proposed mostly because I didn't realize than r10k was reading site/* )
15:59:57 <misc> (but I will ask that to be erased from my biography and will pretend it was the plan from the start :p )
16:00:22 <dcaro> ok, so extra point in favor of adding that extra repo, we will have to think before the next puppet upgrade
16:00:38 <dcaro> ok, next
16:00:52 <dcaro> #topic New members
16:01:10 <dcaro> we have rbarry with us today :), care to introduce yourself?
16:01:54 <rbarry> Just observing today, really
16:02:17 <eedri_> rbarry, is from the ovirt-node team right?
16:02:24 <rbarry> Member of the node team, former sysadmin (with experience with both puppet and chef, even if the world is moving to newer, cooler things)
16:03:03 <eedri_> rbarry, we're cool with puppet :) no rushing into adventures other tools other projects are experimenting with
16:03:21 <eedri_> rbarry, let the kids play, we'll use what works..
16:03:51 <misc> eedri_: so we are not deploying Fedora server anymore :) ?
16:04:10 <eedri_> misc, talking only in the context of CM
16:04:20 <eedri_> misc, os is completely differenct :P
16:05:06 <dcaro> rbarry: thanks :), you are always welcome here
16:05:29 <dcaro> ok, moving
16:05:34 <dcaro> #topic Jenkins
16:06:00 <dcaro> we had an outage on os1 slaves, all of them disconnected at the same time
16:06:09 <dcaro> I rebooted them and they are back up
16:06:34 <eedri_> dcaro, any reply from the os1 team?
16:06:36 <dcaro> it was a network issue (host not reachable when sshing to the pulic ips)
16:06:56 <dcaro> eedri_: I did not stopped to ask :/
16:06:59 <dcaro> *stop
16:07:29 <eedri_> dcaro, ok
16:07:44 <eedri_> dcaro, just note to ourselves not to put anything critical there :)
16:07:49 <eedri_> dcaro, yet..
16:07:52 <dcaro> yep
16:08:23 <dcaro> Also, we have the first test on yaml files!
16:08:46 <dcaro> http://jenkins.ovirt.org/job/vdsm_master_install-rpm-sanity-fc19_created/ <- for example
16:09:08 <dcaro> you can see that they say so in the description, will be adding the new ones like that, and replacing bit by bit the current ones
16:09:28 <dcaro> still have to document and create a howto for anyone to be able to add jobs easily
16:09:56 <eedri_> dcaro++
16:10:03 <eedri_> dcaro, +1 great news on yaml!
16:10:36 <dcaro> #info We have a centos7 slave (not added yet, but just installed and configured)
16:10:51 <dcaro> will add it right after the meeting
16:11:37 <dcaro> any other issues?
16:11:51 <dcaro> yes!
16:12:11 <dcaro> I tried to run vdsm finctional tests inside docker and mock, no luck at all xd
16:12:27 <dcaro> they rely strongly on systemd, and it's not supported yet
16:14:53 <dcaro> #topic Urgent issues
16:15:21 <dcaro> ok, any urgent issues?, we still have 10 mins, if nothing urgent will get the list and start checking until out of time
16:16:04 <misc> afaik, nothing
16:16:33 <dcaro> ok, let's see then...
16:17:14 <dcaro> https://fedorahosted.org/ovirt/ticket/146 - [jenkins] create ovirt-engine setup+upgrade job from 3.4->3.5
16:17:31 <dcaro> I'll take care of that, now that we have a base for the yamls, I'll create it with yaml too
16:18:38 <dcaro> https://fedorahosted.org/ovirt/ticket/146 - [jenkins] add a rhel7 slave to jenkins (using os1)
16:19:07 <dcaro> I tried creating an image and uploading it to os1, but it did not work, have to ask on irc about it (now it's a goot time :))
16:19:29 <dcaro> https://fedorahosted.org/ovirt/ticket/167 - ioprocess & python-ioprocess - ensure pkg is available on resources.ovirt.org
16:19:39 <dcaro> ovirtbot: ^ this was already there right?
16:19:39 <ovirtbot> dcaro: Error: "^" is not a valid command.
16:19:47 <dcaro> obasan: ^ xd
16:23:47 <dcaro> ok, I think that we have enough for today xd
16:23:53 <misc> yep
16:24:02 <dcaro> #endmeeting