14:05:17 <doron> #startmeeting oVirt Weekly Sync
14:05:17 <ovirtbot> Meeting started Wed Jun 18 14:05:17 2014 UTC.  The chair is doron. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:17 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:05:35 <doron> #topic Agenda and roll Call
14:05:36 <doron> #info infra update
14:05:38 <doron> #info 3.4.z updates
14:05:39 <doron> #info 3.5 status
14:05:41 <doron> #info conferences and workshops
14:05:42 <doron> #info other topics
14:05:44 <doron> #topic infra update
14:05:52 <doron> dcaro: orc_orc here for infra updates?
14:06:15 * fabiand is here
14:06:23 <doron> hey fabiand :)
14:06:27 <doron> dcaro: here?
14:06:34 <dcaro> doron: sure, We finally started installing phx servers
14:06:40 * dougsland here
14:06:42 <dcaro> (that's today's news)
14:06:51 <doron> dcaro: yei!
14:07:05 <dcaro> so soon we will have enogh space to grow :)
14:07:08 <doron> #info phx servers installation started
14:07:36 <doron> dcaro: any other big updates?
14:07:58 <dcaro> doron: not really, well, we will start to give more attention to github repos as mirrors
14:08:05 <dcaro> and use them as such
14:08:13 <doron> dcaro: true. let's track it next week.
14:08:23 <doron> moving on
14:08:23 <dcaro> that's mostly it )
14:08:29 <doron> (dcaro thanks)
14:08:33 <doron> #topic 3.4.z updates
14:08:36 <doron> sbonazzo: here?
14:08:40 <sbonazzo> doron: sure
14:08:50 <doron> sbonazzo: how are we doing?
14:09:13 <sbonazzo> 3.4.3 status sent to mailing list this morning http://lists.ovirt.org/pipermail/users/2014-June/025221.html
14:09:22 <sbonazzo> no blockers up to now
14:09:36 <sbonazzo> 38 bugs remaining
14:10:02 <doron> sbonazzo: when is the expected ga for 3.4.3?
14:10:03 <sbonazzo> RC scheduled for 2014-07-10
14:10:22 <sbonazzo> GA for 2014-07-17
14:10:28 <doron> sbonazzo: thanks.
14:10:51 <sbonazzo> 3.5.0 status also sent this morning
14:10:53 <doron> #info 3.4.3  RC scheduled for 2014-07-10 GA for 2014-07-17 no blockers so far.
14:10:58 <doron> sbonazzo: sec ;)
14:11:02 <sbonazzo> :-)
14:11:11 <doron> moving to 3.5.
14:11:14 <doron> #topic 3.5 status
14:11:17 <doron> sbonazzo: shoot
14:11:31 <sbonazzo> 3.5.0 status also sent this morning http://lists.ovirt.org/pipermail/users/2014-June/025223.html
14:11:47 <sbonazzo> 3 blockers still open up to now
14:11:51 <sbonazzo> only on integration
14:12:04 <doron> sbonazzo: what is the blocker tracker?
14:12:06 <sbonazzo> 2 of them will be solved as soon as sos 3.1 exit updates-testing
14:12:17 <sbonazzo> http://bugzilla.redhat.com/1073943
14:12:41 <doron> #info 3.5.0 tracker http://bugzilla.redhat.com/1073943
14:13:10 <danken> doron: we have a serious issue of a broken vdsm master branch
14:13:20 <doron> danken: what is it?
14:13:24 <danken> currently vdsm cannot answer getVdsStats
14:13:39 <danken> due to missing mom depdendency
14:14:02 <doron> danken: what's needed to fix it?
14:14:11 <doron> ie- new mom or something else?
14:14:21 <danken> mom should be updated with kobi's patch, and a spec Requires: be added to vdsm
14:14:43 <msivak> danken: are you sure? I was told it reports an error, but everything else works (at least for mperina)
14:15:10 <danken> msivak: as nsoffer reported, and verified by me, getVdsStats raises an error
14:15:11 <msivak> there is also a shor term fix in gerrit that just removes the offending modules from a  config file
14:15:21 <danken> and the host is thorown to no-op
14:15:43 <danken> msivak: do you suggest that I merge it in?
14:15:57 <danken> to be reverted with the proper Requires: clause?
14:15:59 <msivak> danken: yep, we can add them back in when new mom lands in Fedora
14:16:03 <msivak> exactly
14:16:07 <danken> msivak: which is the vdsm patch?
14:16:16 <danken> (url please)
14:16:26 <msivak> http://gerrit.ovirt.org/28904
14:18:03 <doron> danken: will it do for now?
14:18:47 <danken> doron: I need to trust msivak's verification
14:18:56 <doron> danken: iiuc the mom proper fix is almost there. the main concern it'll take some time for mom to land in fedora
14:19:04 <danken> who was not aware that getVdsStats breaks
14:19:53 <sbonazzo> doron: we can ship it on ovirt repo
14:20:40 * danken is verifying myself
14:20:43 <doron> danken: if we have 2 guys in fedora who +1 it, the new version will be available soon
14:21:27 <doron> so I'd prefer to expedite the fedora process if possible.
14:21:57 <doron> if alitke is fine with it we can move mom to the ovirt repo which will also resolve it.
14:22:13 <doron> so these are the options;
14:22:17 <msivak> we discussed this option as well
14:22:18 <danken> msivak: alitke: I still get AttributeError: 'NoneType' object has no attribute 'statistics'
14:22:19 <danken> with http://gerrit.ovirt.org/#/c/28904/2/vdsm/mom.conf.in applied  and vdsmd restarted
14:22:42 <msivak> danken: so that is probably something else...
14:22:46 <doron> 1. temp patch.
14:23:01 <doron> 2. expedite fedora
14:23:07 <doron> 3. move mom to ovirt repo.
14:23:30 <msivak> danken: are you sure the config was applied? .rpmnew maybe?
14:25:43 <danken> msivak: I've changed it manually... and restarted vdsm.
14:26:02 <msivak> I am checking the history
14:26:07 <danken> I might have missed something - but I'd appreciate if you try getVdsStats, too.
14:26:10 <danken> msivak: ^^^
14:26:17 <msivak> yep I will, jsut s sec
14:26:35 <doron> danken: msivak I'm continuing the meeting. will wait for your update.
14:27:04 <doron> I want to do a quick 3.5 round to see if there are any group specific issues
14:27:19 <doron> sahina: here?
14:28:23 <doron> anyone here for gluster?
14:29:13 <doron> #info no gluster rep this week.
14:29:24 <doron> moving next to infra
14:29:34 <doron> who's here for the infra team?
14:29:58 <danken> anyway, there gfsapi patch has been merged to vdsm
14:29:59 <dougsland> doron, me
14:30:04 <doron> hi dougsland
14:30:15 <sahina> hi doron, all good for gluster
14:30:16 <doron> 3.5 updates for infra/
14:30:32 <doron> sahina: any issues you have for 3.5.0?
14:30:51 <dougsland> doron, the ioprocess is delayed because need more tests but the others features are good for 3.5
14:31:03 <sahina> doron, we couldn't add the vdsm to a 3.5 cluster- the compat versions don't report 3.5
14:31:11 <doron> dougsland: thanks. anything else?
14:31:29 <danken> dougsland: ioprocess needs more unit tests, and placing requirements in spec
14:31:43 <doron> danken: are you aware of this issue?
14:31:44 <dougsland> doron, ^ :)
14:31:48 <danken> dougsland: and pushing python-ioprocess.rpm to jenkins slaves.
14:32:33 <danken> sahina: doron: http://gerrit.ovirt.org/28793
14:32:50 <danken> 3.5 features are not fully in
14:32:59 <danken> so vdsm does not report it yet
14:33:06 <sahina> danken, thanks.
14:33:12 <sahina> doron, no other issues
14:33:15 <danken> apply the above patch manually to skip this.
14:33:26 <doron> sahina: thanks. danken+
14:33:51 <doron> #info gluster ready for 3.5.
14:34:14 <doron> #info infrar 3.5 updates: ioprocess is delayed because need more tests but the others features are good for 3.5
14:34:33 <doron> moving next to integration
14:34:37 <doron> sbonazzo: 3.5 updates?
14:34:55 <sbonazzo> websocket proxy on separate host has been merged
14:35:07 <sbonazzo> WGT iso is available
14:35:16 <sbonazzo> iSCSI support for hosted engine is in
14:35:30 <sbonazzo> still pending patches on DWH and reports on separate hosts
14:35:58 <sbonazzo> Fedora 20 support looks to be near to be completed
14:36:01 <doron> sbonazzo: thanks. I understand DWH & reporting is an exception.
14:36:20 <sbonazzo> doron: yes
14:36:35 <doron> sbonazzo: very well. eta?
14:36:54 <sbonazzo> doron: if nothing bad happens, it should go in the beta
14:37:10 <doron> sbonazzo: thakns
14:37:14 <doron> sbonazzo: thanks
14:38:04 <doron> #info integration 3.5 updates: DWH & reporting delayed. Currently an exception. Should make it into beta
14:38:20 <doron> moving on to network
14:38:24 <doron> lvernia: updates?
14:38:38 <lvernia> doron: Hi. Nothing interesting for 3.5.
14:38:48 <doron> lvernia: thanks.
14:38:54 <lvernia> doron: No problem :)
14:39:06 <doron> #info network 3.5 updates; all set, no updates.
14:39:22 <doron> moving on to node
14:39:26 <doron> fabiand: here?
14:39:34 <fabiand> yep
14:39:44 <doron> fabiand: hey, 3.5 updates?
14:39:52 <fabiand> Well.
14:39:58 <fabiand> All 3 features were merged
14:40:02 <fabiand> But testing is outstanding
14:40:12 <fabiand> Also there is a small discussion about the generic-registration.
14:40:37 <fabiand> That discussion will be brought to the devel ml to clear the expectations of that Node feature
14:40:48 <fabiand> So the delat to last week is that now everything is reviewed and merged
14:40:54 <doron> fabiand: very well. if there's an issue with generic-registration it may be pushed to 3.6?
14:41:10 <fabiand> Yes
14:41:14 <doron> fabiand: thanks
14:41:17 <fabiand> we can/could push it without any probelm
14:41:19 <fabiand> it's self contrained
14:42:13 <doron> #info node 3.5 updates; features ready for testing. There's a discussion on generic-registration which may push it forward to 3.6.
14:42:22 <doron> fabiand: thanks again.
14:42:27 <fabiand> doron, you are welcome
14:42:34 <doron> jmoving next to sla...
14:43:06 <brad[]> What's the best way to add gluster bricks to an ovirt 3.4 data center? I notice that after a reboot, newly partitioned disks are assigned a device mapper entry. Is that the entry that should be used? Should I create LV's instead?
14:43:46 <doron> #info sla 3.5 updates; CPU and IO are an exception. other features merged.
14:43:58 <doron> moving next to storage
14:44:11 <doron> is someone here for storage?
14:44:46 <doron> will skip storage for now and revisit soon.
14:44:57 <doron> ux next. awels here?
14:45:10 <ecohen> doron, I will give an update this week
14:45:11 <ecohen> - 5 features done [tree automatic refresh, tooltip on 'feedback', UI Plugin 'SystemTreeSelectionChange' event, automatic grid item selection, initialization-queries optimization]
14:45:11 <ecohen> - "exception" approval requested for the following 4 features:
14:45:11 <ecohen> - [APPROVAL REQUESTED] PatternFly adoption - code already merged for a long time, however we are currently working on proper packaging of patternfly/gwtbootstrap3, should end no later than next week, hopefully.
14:45:11 <ecohen> - [APPROVAL REQUESTED] introduce Italian (requested by Gianluca Cecchi) - as far as I can see, Gianluca is working hard on completing the Italian translation (currently stands on ~13%).
14:45:11 <awels> doron: ecohen will do it today
14:45:14 <ecohen> if completion will stand on ~70% (everyone - feel free to suggest a different number) soon enough - I think we can introduce it to ovirt-3.5 (in general, I suggest to not treat translations as "regular" features, at least from the feature-freeze milestone perspective).
14:45:18 <ecohen> - [APPROVAL REQUESTED] GUI column sorting - we are finalizing last infrastructural issues, I assume that the UI maintainers may proceed towards completing it even post feature freeze, as this is a very important feature.
14:45:21 <ecohen> hopefully: infra will be finalized by the end of this week, applying it in the various grids - by the end of next week.
14:45:24 <ecohen> - [APPROVAL REQUESTED] translation updates cycle#1-#3 - are schedule intentionally post feature-freeze, as we want to "catch" as many strings as possible during the translation process. I assume this is OK.
14:46:00 <doron> ecohen: wow this was a bit nosiy
14:46:53 <doron> ecohen: what is APPROVAL REQUESTED?
14:47:14 <ecohen> doron, features that are still not done, we are post feature freeze -> need an explicit approval to work on them post feature freeze.
14:47:43 <doron> ecohen: very well. do you want to have a poll now?
14:48:19 <ecohen> doron, regarding patternfly adoption and translation updates cycles #1-#3 - pretty much straight forward, no need to poll.
14:48:42 <ecohen> doron, I need an approval specifically for the column-sorting (on which a lot of the UI maintainers are working on)
14:48:56 <doron> #agreed patternfly adoption and translation updates cycles #1-#3 - exception granted
14:49:20 <msivak> doron: the patch was working and is merged now, dan had other issue in his setup
14:49:38 <doron> ecohen: very well. so on  column-sorting who needs to be involved?
14:49:53 <doron> msivak: tanks for the update. danken thanks for helping!
14:50:24 <danken> doron: msivak: fire extinguished. I'll be waiting with 3.5 for the revert + Requires
14:50:39 <doron> danken++
14:51:01 <ecohen> doron, I think that GUI column sorting is an important-enough feature to work on post feature freeze. if no one objects, I suggest to grant it an exception as well.
14:51:15 <doron> ecohen: ETA?
14:51:42 <ecohen> doron, (all written above) - infra: this week, applying by the other UI maintainers: end of next week
14:52:13 <doron> sbonazzo: based on this info, sounds reasonable to me. any objections to grant an exception?
14:52:33 <sbonazzo> no objections on my side
14:52:39 <doron> sbonazzo: thanks.
14:53:00 <doron> #agreed exception granted on column-sorting to the ux team.
14:53:16 <ecohen> doron, thanks. another exception request: Italian: not sure if we have Gianluca Cecchi online and if he can provide an ETA for reasonable translation completion, in any case - if it will be soon enough - I suggest to introduce it to ovirt-3.5 as well
14:54:11 <doron> sbonazzo: you cannot object here.... sounds reasonable to me. any objections to grant an exception?
14:54:25 <sbonazzo> doron: no objections :-)
14:54:31 <doron> sbonazzo: thanks.
14:54:48 <ecohen> doron, sbonazzo - many thanks.
14:54:55 <doron> #agreed exception granted on Italian translation to the ux team.
14:55:00 <doron> ecohen: yw
14:55:06 <ecohen> doron, no more updates (I think)... thank you.
14:55:36 <doron> #info ux 3.5 info: several exceptions granted. Should be tracked in the next weeks.
14:55:45 <doron> moving next to virt
14:55:49 <doron> mskrivanek: here?
14:56:20 <doron> mskrivanek: here?
14:56:29 * mskrivanek is not here
14:56:34 <mskrivanek> :)
14:56:40 <doron> mskrivanek: anyone who can update on virT?
14:56:41 <mskrivanek> what's up?
14:56:53 <doron> mskrivanek: 3.5 updates for virt
14:57:06 <mskrivanek> virtio-rng is finished, that was the last item
14:57:40 <doron> mskrivanek: anything else?
14:58:17 <mskrivanek> just still one last little one-line patch is missing, so still not green:) rest is all green
14:58:36 <doron> mskrivanek: thanks
14:59:06 <doron> #info virt 3.5 updates: everything but a minor patch ready.
14:59:23 <doron> so
14:59:33 <doron> sbonazzo: any blockers for 3.5?
14:59:42 <sbonazzo> 3 blockers
14:59:46 <doron> sbonazzo: ?
14:59:48 <sbonazzo> 2 on sos
14:59:59 <sbonazzo> and one on fedora 20 support
15:00:07 <sbonazzo> other than that, nothing listed
15:00:37 <doron> sbonazzo: what is the url?
15:01:15 <sbonazzo> https://bugzilla.redhat.com/show_bug.cgi?id=1073944
15:01:22 <sbonazzo> https://bugzilla.redhat.com/show_bug.cgi?id=1060198
15:01:29 <sbonazzo> the thirs has been fixed on fedora side
15:01:31 <doron> sbonazzo: do we have a tracker for there?
15:01:35 <doron> (these)
15:01:39 <sbonazzo> 1073943
15:02:11 <doron> #info current 3.5 blockers: 1073944, 1060198. Should be tracked next week.
15:02:20 <doron> sbonazzo: let's have a tracker for next week.
15:02:32 <doron> anything else on 3.5?
15:02:38 <danken> doron: eedri: that's another infra, but now that el7 is out, I think we should step on https://fedorahosted.org/ovirt/ticket/123
15:02:51 <danken> I'd like to see how 3.5 behaves on el7
15:02:52 <sbonazzo> we've seen some issue in upgrading from 3.4, we're already working on that
15:02:54 <eedri> danken, i agree
15:03:07 <eedri> danken, dcaro will handle it soon i hope if possible this week
15:03:09 <sbonazzo> and also some dependencies broken, already pushed a fix for that
15:03:29 <danken> eedri: good, /me is looking forward to it
15:03:35 <eedri> danken, we're pushing hard on new lab for upstream ovirt, it will enable us to support much more disterbutions
15:03:46 * dcaro nods
15:03:46 <sbonazzo> danken: el7 should work once f20 support is in
15:03:49 <doron> #agreed el7 to be used for 3.5 tests
15:03:50 <eedri> danken, hopefully it will be ready within the next month if all goes to plan
15:03:56 <danken> I think that we should consider adding el7 to out supported platforms
15:04:19 <doron> sounds like a plan.
15:04:19 <danken> sbonazzo: form vdsm it should mean NOW
15:04:35 <sbonazzo> danken: sure
15:05:04 <danken> doron: sbonazzo: but how about releasing an el7 vdsm builds for vdsm and co.?
15:05:24 <doron> danken: sounds right to me.
15:05:34 <sbonazzo> danken: ok for me
15:05:37 <doron> although it'll require more tests, etc
15:05:54 <doron> danken: I do suggest we wait for about a week until phx lab becomes funcitonal
15:06:19 <sbonazzo> doron: +1 on waiting phx
15:06:44 <doron> danken: any objections
15:06:46 <doron> ?
15:07:41 <doron> I'll assume no....
15:07:45 <danken> doron: the sooner the better
15:07:56 <doron> danken: I know. I'm with you on this.
15:08:31 <doron> #agreed we hsould start building vdsm for .el7. Work to be started next week once phx lab is operational
15:08:41 <doron> moving on
15:08:42 <doron> #topic conferences and workshops
15:08:47 <doron> bkp: here?
15:08:54 <bkp> Yup
15:09:03 <doron> bkp: updates?
15:09:04 <bkp> Will be repping oVirt at OSCON booth. Anyone else going to OSCON, let me know. Apparently there's an opportunity to host a poker table at Open Cloud Days for us and anyone we care to invite.
15:09:29 <bkp> I am working with the KVM Forum team to help set that event up.
15:09:34 * sbonazzo need to leave, have a nice evening / good day
15:09:49 <bkp> I have submitted a talk to Open World Forum in Paris and Fossetcon in Orlando.
15:09:50 <doron> #info bkp to represent oVirt at OSCON booth. Anyone else going to OSCON,ping bkp.  Apparently there's an opportunity to host a poker table at Open Cloud Days for us and anyone we care to invite.
15:10:21 <doron> bkp#info bkp working with the KVM Forum team to help set that event up. Also bkp submitted a talk to Open World Forum in Paris and Fossetcon in Orlando.
15:10:26 <doron> sbonazzo: ciao
15:10:28 <bkp> Finally, I am getting the venue for oVirt Workshop around LinuxCon. Will need to discuss underwriting the event, as OSAS budget is strained with new community efforts.
15:10:38 <bkp> I have put the word out to itamar and Miki, and will make a proposal to the Board for assistance as well.
15:10:52 <bkp> That's all for events this week.
15:11:12 <doron> #info bkp getting the venue for oVirt Workshop around LinuxCon. Will need to discuss underwriting the event, as OSAS budget is strained with new community efforts.
15:11:15 <doron> bkp: thnks
15:11:22 <doron> #topic other topics
15:11:29 <doron> anything else?
15:11:41 <doron> Anyone wants to discuss something?
15:12:02 <bkp> I got some topics
15:12:08 <doron> bkp: shoot
15:12:20 <bkp> Debate on QEMU package continues on Devel list... http://lists.ovirt.org/pipermail/devel/2014-June/007704.html Feel free to add to discussion.
15:12:40 <doron> bkp: what is it about?
15:13:52 <bkp> Whether we will maintain a QEMU package within the CentOS virt SIG that has the snapshotting flag turned on, or continue to host our own version in the oVirt repo.
15:14:24 <doron> bkp: sounds important.
15:14:25 <bkp> It would be great to participate in the SIG, but we would need to maintain the package for everyone.
15:14:40 <bkp> Yeah, dougsland is very much behind this.
15:14:52 <doron> #info there's a debate on QEMU package within the CentOS virt SIG: . http://lists.ovirt.org/pipermail/devel/2014-June/007704.html Feel free to add to discussion.
15:15:00 <doron> dougsland++
15:15:05 <doron> bkp: anything else?
15:15:15 <bkp> I am continuing to work on oVirt documentation. It looks as if ECE may not have time to assist, as earlier indicated, so we will have to come up with an internal solution.
15:15:41 <bkp> I have yet another meeting lined up with them this week.
15:16:02 <bkp> Mirror news: AARNET in Australia *will* be adding us to their mirrors... they had a Ceph problem over the weekend, and could not get to us.
15:16:18 <doron> #info bkp continuing to work on oVirt documentation. If docs may not have time to assist we will have to come up with an internal solution.
15:16:41 <doron> #info mirror updates: AARNET in Australia *will* be adding us to their mirrors... they had a Ceph problem over the weekend, and could not get to us.
15:16:43 <doron> Yei!
15:16:45 <bkp> Finally, I have created an oVirt G+ community page and have posted content. Folks, join in, please. Any links to good content will be very welcome.
15:16:52 <clarkee> nice
15:17:05 <doron> #info bkp  created an oVirt G+ community page and have posted content. Folks, join in, please. Any links to good content will be very welcome.
15:17:10 <doron> bkp: thanks!
15:17:16 <doron> Anything else?
15:17:23 <doron> Anyone else?
15:17:29 <bkp> Just the G+ link https://plus.google.com/u/0/communities/109346090491400112913
15:17:44 <doron> #info G+ link https://plus.google.com/u/0/communities/109346090491400112913
15:17:45 <bkp> I'm done!
15:17:53 <doron> bkp: thanks!
15:17:57 <doron> Going once?...
15:17:57 <bkp> NP, sir
15:18:28 <doron> Going twice...
15:19:03 <doron> Thanks all for joining. See you next week!
15:19:06 <doron> #endmeeting