13:01:20 <fabiand> #startmeeting oVirt Node Weekly Meeting
13:01:20 <ovirtbot> Meeting started Tue Jun 17 13:01:20 2014 UTC.  The chair is fabiand. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:20 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:01:27 <fabiand> #chairs jboggs rbarry
13:01:36 <fabiand> #topic Agenda
13:01:42 <fabiand> #item Action Item Review
13:01:51 * rbarry here
13:01:53 * bkp here
13:01:55 <fabiand> #info Build Status (3.0.5)
13:02:01 <fabiand> #info Feature Status (3.5)
13:02:13 <fabiand> #info Feature Status (ovirt-node-3.1)
13:02:17 <fabiand> #info Other Items
13:02:22 * doron_afk here in spirit
13:02:24 <fabiand> #chairs bkp
13:02:34 <fabiand> morning rbarry bkp!
13:02:36 * doron here in spirit
13:02:41 <fabiand> good afternoon doron
13:02:48 <fabiand> #chairs doron
13:02:49 <bkp> What up fabiand!
13:02:50 <doron> fabiand: hello Fabian!
13:03:04 <fabiand> Hey there! :)
13:03:09 <fabiand> So cheerfull everybody today.
13:03:20 <fabiand> I think jboggs can't attend today, so we can start right away.
13:03:35 <fabiand> #topic Action Item Review
13:03:40 <bkp> Virtual appliance!
13:03:43 <bkp> w00t!
13:03:55 <fabiand> We'll come to that later ;)
13:03:56 <doron> bkp: :))
13:04:05 <fabiand> #link http://resources.ovirt.org/meetings/ovirt/2014/ovirt.2014-06-10-13.01.txt
13:04:10 <fabiand> The action item's from last week!
13:04:47 <fabiand> #info fabiand to finish OVA builds and push
13:05:08 <fabiand> I actually managed to finish this and push a working repo to gerrit.ovirt.org
13:05:27 <fabiand> #info ovirt-appliance is pushed (sources)
13:05:41 <rbarry> What's the repo?
13:05:48 <rbarry> I wish gerrit subscribed me to new repos...
13:05:54 <fabiand> ah
13:05:57 <fabiand> I could have added you.
13:06:02 <fabiand> #link http://gerrit.ovirt.org/gitweb?p=ovirt-appliance.git
13:06:30 * fabiand currently tries to come up with the ml link to the announce
13:06:42 <fabiand> rbarry, does lists.ovirt.org/mailman/listinfo/devel work for you?
13:06:57 <rbarry> No, none of the lists work for me at the moment
13:07:02 <fabiand> hrm
13:07:03 <fabiand> great
13:07:08 <bkp> Define "not work"
13:07:13 <rbarry> Timeout
13:07:15 <fabiand> bkp, no http response
13:07:16 <bkp> (Please)
13:07:32 <fabiand> Then I am using this one for now:
13:07:35 <fabiand> #link http://dummdida.tumblr.com/post/88944206100/say-hello-to-the-ovirt-engine-virtual-appliance
13:07:43 <bkp> Yeah, just pointed out resources.ovirt.org is going up and down.
13:07:44 <fabiand> #info announced on devel@ovirt.org
13:07:57 <fabiand> rbarry, what about your action item?
13:08:11 <fabiand> bkp, our ressources have their own moods ..
13:09:20 <rbarry> I don't remember what my action item was this week :/
13:09:30 <fabiand> Ah, that's what I can remind you of :)
13:09:44 <fabiand> rbarry to drop an email to devel@ to discuss the introductio and
13:09:45 <fabiand> compatability issues of the generic registration
13:09:50 <bkp> * rbarry to drop an email to devel@ to discuss the introductio and
13:09:50 <bkp> compatability issues of the generic registration
13:10:15 <bkp> ^^^ From the link fabiand posted earlier
13:10:28 <rbarry> Ah, yes -- I forgot to do that, but it's even more important now. I'll start composing
13:10:29 <bkp> Jinx
13:10:34 <fabiand> rbarry, ack
13:10:45 <fabiand> #info rbarry about to post the email
13:10:57 <fabiand> Right
13:11:15 <fabiand> Besides that I actually planned to rebuild ovirt-node for 3.4.2 and 3.5, but sadly the new repo-gen tool does not work yet
13:11:24 <fabiand> repo-gen == gather all necessary repos to build Node
13:11:41 <fabiand> #info fabiand did not yet build images for 3.4.2 and 3.5 b/c of a failing tool
13:12:02 <fabiand> right
13:12:14 <fabiand> #topic Build Status (3.0.5)
13:12:30 <fabiand> #info 3.0.5 is ready, just needs to be published with 3.5 packages
13:12:47 <fabiand> #info Feature Status (3.5)
13:12:52 <fabiand> #undo
13:12:52 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x8c7ec0c>
13:12:56 <fabiand> #topic Feature Status (3.5)
13:13:09 <fabiand> #info hosted-engine-plugin -- Merged awaits testing
13:13:27 <fabiand> rbarry, do you want to give an update on the recent happenings on the generic-registration?
13:14:32 <rbarry> It's merged and ready for testing, but is not currently enabled in the autoinstall arguments or ovirt-node-plugin-vdsm
13:14:57 <rbarry> The process it follows was merged in 3.4, and we're not ready to break compatibility with 3.3 yet, so it can't be used to replace vdsm-reg until we are
13:15:08 <fabiand> #info generic-registration -- Merged and needs testing, not enabled by default
13:15:17 <fabiand> Yes.
13:15:38 <rbarry> Additionally, there's now some discussion about whether to refactor it already, which will hopefully get uptake on devel@ instead of bugzilla
13:15:40 <fabiand> IIUIC also only the "generic" part was merged. Not the specific bit#s to interact with Engine. Do I understand this correctly?
13:16:06 <fabiand> Agreed. devel@ is a good place for that. Also to clarify the expectations and assumptions of all involved parties.
13:16:51 <rbarry> Right. I mean, the example json file it ships with will talk to an engine, and pointing ovirt-node-registration at it will interact with the engine (if new enough)
13:17:01 <fabiand> #info generic registration needs more discussion, which will hopefully take place on the devel@ ml
13:17:17 <fabiand> Oh, is the Engine part already in place in their master?
13:17:33 <rbarry> We're talking to this: http://gerrit.ovirt.org/#/c/20815/
13:17:53 <fabiand> Oh nice.
13:18:00 * fabiand wasn't aware that it is already merged.
13:18:09 <fabiand> #info Engine part of generic registration is merged.
13:18:11 <rbarry> It works, mostly, but the PKI trust is finicky
13:18:43 * fabiand notes the term finicky in his personal dictinonary.
13:18:45 <fabiand> yep
13:18:46 <fabiand> I agree.
13:18:47 <rbarry> But I was pointed at further information for that, so it's hopefully correctable from the node side
13:19:06 <fabiand> I wonder if we could add a karg or so, to enable the generic-registration, to allow easier testing ..
13:19:13 <fabiand> Cool.
13:19:39 <rbarry> It's possible. The primary reason I didn't enable it is that I didn't want to maintain a fallback codepath which said "try generic registration, and if that fails, then try vdsm-reg, and..."
13:19:52 <fabiand> rbarry, regarding backwards compatibility. Maybe we can have some fallback mechanism. To try generic first, and fallback to the legacy mechanism
13:20:02 <fabiand> :D
13:20:09 <fabiand> Okay
13:20:17 <fabiand> Any reason why you don't want to maintain that codepath? :)
13:21:40 <rbarry> Mostly, it's additional places where it could go wrong. It'd be relatively easy to do it for the autoinstall. But the TUI presentation of the vdsm plugin and following transactions would be messy
13:22:00 <fabiand> Yeah ..
13:22:22 <fabiand> Tho I am affraid that we'll need to look into it.
13:22:24 <rbarry> We'd almost have to swap out an entire page if we wanted to use it
13:22:34 <fabiand> Unless we want to intorduce the gen-reg with 4.0, and break b/c
13:22:46 <fabiand> rbarry, maybe that can even be the solution.
13:23:07 <fabiand> Create a new page, which uses the new reg mechanism, based on the karg the new or old page is shown (or something like that)
13:23:45 <rbarry> I guess that's the rabbit hole we'll go down on devel@. My personal take is that, if users add a karg, why wouldn't they just add a karg to register off the bat?
13:24:02 <fabiand> Yes ..
13:24:16 <fabiand> There are other ways as well.
13:24:20 <fabiand> But we can take that offline
13:24:46 <fabiand> Maybe this can be a separate or the same discussion: How to migrate to the new registration
13:24:52 <fabiand> I'd add an action item for it ..
13:24:54 <fabiand> :)
13:25:46 <rbarry> I imagine this would be substantiatively similar to the extant action item about a discussion on devel@
13:25:53 <fabiand> Agreed.
13:25:58 <fabiand> So there you go with one item.
13:26:21 <fabiand> #info rbarry to also discuss how the migratoin to the genric-registration can take place (in the TUI, and AI)
13:26:26 <fabiand> carrying on.
13:26:46 <fabiand> #info ovirt-appliance -- Pushed to gerrit and announced
13:26:49 <fabiand> #info needs testing
13:27:02 <fabiand> Basically we need to test it with hosted-engine
13:27:05 <fabiand> That is pending on my side
13:27:27 <fabiand> So that means that we are quite good with all 3 features.
13:27:37 <fabiand> That brings me to the next topic
13:27:57 <fabiand> #topic Feature Status (ovirt-node-3.1)
13:28:18 <fabiand> Lately I thought that we've been in some kind of maintenance mode for the last months because of the many problems we were facing
13:28:27 <fabiand> But now it could be time to do a fresh and new minor release.
13:28:44 <fabiand> That way we can deliver all the new features (including an unannounced i18n support) for oVirt 3.5
13:29:03 <fabiand> The crucial thing I see is, that we'll need to do the release before the test days
13:29:15 <fabiand> Doing it before the test days means that Node will probably get more testing.
13:29:27 <fabiand> Additionally the new release means that we don't need to backport the 3.5 features.
13:29:59 <fabiand> #info Considering to release ovirt-node-3.1 with all 3.5 features plus some additional before 3.5 TestDays
13:30:06 <fabiand> Questions on this?
13:30:12 <fabiand> Thoughts
13:30:13 <fabiand> Flames?
13:30:15 <fabiand> :)
13:30:53 <rbarry> I think this is a good idea with many of the pending patches merged master
13:30:59 <fabiand> Yes
13:31:00 <fabiand> definetly
13:31:19 <fabiand> #action Node team to review and merge pending patches (as long as the patch is in a good shape)
13:31:29 <fabiand> Great
13:31:33 <fabiand> #topic Other Items
13:31:34 <bkp> Seems reasonable
13:31:38 <fabiand> :)
13:31:50 <fabiand> Even nicer!
13:33:03 <fabiand> #info Some patches in gerrit are pending and -1'ed - because they basically go ointo the blivet directipon
13:33:09 <fabiand> but as we also consider anaconda, they are on hold.
13:33:16 <fabiand> #undo
13:33:16 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x8cb096c>
13:33:33 <fabiand> #info Some patches in gerrit are pending and -1'ed - because they basically go into the blivet direction, but we also consider anaconda, they are on hold
13:33:50 <fabiand> I believe this is all from me for this week.
13:34:05 <rbarry> Nothing else from me, either
13:34:09 <fabiand> Nice
13:34:12 <fabiand> One last thing to say.
13:34:36 <fabiand> A nvm.
13:34:40 <fabiand> .)
13:34:40 <ovirtbot> fabiand: Error: ")" is not a valid command.
13:34:44 <fabiand> Going once
13:34:45 <fabiand> Zwei.
13:34:49 <fabiand> Drei.
13:34:51 <fabiand> Vier Tore.
13:34:54 <fabiand> Thanks
13:34:56 <fabiand> #endmeeting