14:00:33 <doron> #startmeeting oVirt Weekly Sync
14:00:33 <ovirtbot> Meeting started Wed Apr 30 14:00:33 2014 UTC.  The chair is doron. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:33 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:47 <doron> #topic Agenda and roll Call
14:00:49 <doron> #info infra update
14:00:50 <doron> #info 3.4.z updates
14:00:52 <doron> #info 3.5 status
14:00:53 <doron> #info conferences and workshops
14:00:55 <doron> #info other topics
14:01:03 <doron> #topic infra update
14:01:18 <doron> dcaro: orc_orc_ here for infra updates?
14:02:20 <doron> dcaro: orc_orc_ here for infra updates?
14:02:33 <doron> knesenko: here?
14:02:46 * jb_netapp waves at doron and dneary
14:03:00 * doron waves back to jb_netapp ;)
14:03:07 <dcaro> we updated some jenkins plugins, and added a couple of slaves from os1 to support the per-patch findbugs
14:03:17 <jb_netapp> and mburns and acathrow1
14:03:18 <dcaro> will add more slaves soon from os1
14:03:24 <knesenko> doron: yes
14:03:34 <doron> knesenko: dcaro is updating, hanks.
14:03:37 <doron> (thanks)
14:03:50 <mburns> hi jb_netapp
14:03:53 <knesenko> doron: no problem
14:04:08 <dneary> Hi jb_netapp
14:04:25 <dcaro> keeped up migrating jobs to mock based builds (host-deploy and hosted-engine-setup)
14:04:47 <doron> #info infra ain updates;additional slaves based on OS1 added,
14:05:11 <dcaro> more or less those are the most relevant changes
14:05:28 <doron> #info Also, more work on new tasks  (host-deploy and hosted-engine-setup)
14:05:32 <acathrow1> pong
14:05:32 <doron> dcaro: thanks!
14:05:41 <doron> #topic 3.4.z updates
14:05:53 <doron> sbonazzo: how are we doing with 3.4.z?
14:06:10 <sbonazzo> doron: 3.4.1 RC has been released last week
14:06:17 <doron> sbonazzo: noted ;)
14:06:24 <sbonazzo> doron: we've branched 3.4.1 this morning
14:06:40 <sbonazzo> doron: we're preparing to release 3.4.1 GA on May 7th
14:07:06 <sbonazzo> doron: no known blokers so far
14:07:19 <doron> #info 3.4.1 branched today. we're preparing to release 3.4.1 GA on May 7th. No blockers currently.
14:07:23 <doron> sbonazzo: thanks.
14:07:48 <doron> let's move to 3.5, and I'll need your patience here to make sure we cover everything
14:07:50 <doron> #topic 3.5 status
14:08:09 <doron> who's here for gluster?
14:10:17 <doron> ok, we'll need to get them offline
14:10:39 <doron> #info Gluster to update on 3.5 readiness.
14:10:52 <doron> moving to infra
14:11:06 <ovedo> hi
14:11:13 <doron> ovedo 3.5 readiness?
14:11:23 <ovedo> we're still working on the features... most won't make it into feature freeze (which is tomorrow).
14:11:32 <doron> ovedo: I need update per feature please.
14:11:38 <ovedo> updated all the dev owners as you requested, and put some on postponed.
14:11:50 <ovedo> I'll update it on the planning doc.
14:12:02 <ovedo> most are updated already
14:12:19 <ovedo> all the ones that are finished, and the ones that may miss feature freeze.
14:12:25 <ovedo> but I'll make sure everything is updated.
14:12:31 <doron> ovedo: first 5 may slip?
14:12:46 <ovedo> doron, ?
14:13:05 <doron> first 5 features?
14:13:19 <ovedo> there are many other features on the list that we haven't even started working on.
14:13:34 <ovedo> currently, the only ones that are finished are the ones marked with green color
14:13:43 <ovedo> the rest are still in progress / design.
14:13:57 <doron> ovedo: 7 features done
14:14:12 <ovedo> yes
14:14:15 <doron> ovedo: 1090520	[RFE]Provide informations about fencing in the oVirt engine	Not strated yet
14:14:26 <doron> this means that it should be taken out of 3.5
14:14:41 <ovedo> okay. I was told not to delete entries from the planning doc.
14:14:49 <doron> ovedo: same for [RFE] Improve fencing robustness by retrying failed attempts
14:14:53 <ovedo> but if you open "3.6" spreadsheet then I'll move it there.
14:15:12 <doron> ovedo: just delet dev owner and marked as postponed.
14:15:29 <ovedo> why delete dev owner?
14:15:35 <ovedo> I'll mark it is Postponed.
14:15:41 <doron> ovedo: we're going to cleanup 3.5 tonight and remove all the postponed items.
14:16:14 <ovedo> and move those to 3.6 tab?
14:16:18 <doron> ovedo: what about [RFE]Add periodic power management health check to detect/warn about link-down detection of power management LAN  ?
14:16:23 <doron> it's marked as design
14:16:32 <doron> which means no implementation yet.
14:16:45 <ovedo> right.
14:16:53 <doron> and there's a similar one.
14:17:03 <ovedo> why are we going over all items now?
14:17:10 <ovedo> I'll put them on Postponed.
14:17:22 <doron> ovedo: since we got into feature freeze.
14:17:25 <doron> So, let's summarize it;
14:17:28 <ovedo> and please move them to 3.6, as it will be targeted there.
14:18:08 <doron> 7 done, 3 in progress. All others should be re-evaluated and possibly postponed.
14:18:12 <doron> ovedo: ok?
14:18:17 <awels> can I get a link to that document so I can see it?
14:18:26 <ovedo> okay.
14:18:45 <doron> #info infra 3.5 feature readiness: 7 done, 3 in progress. All others should be re-evaluated and possibly postponed.
14:19:12 <doron> ovedo: thanks. please make sure you mark it properly today so we'll be able to clean it.
14:19:29 <lvernia> awels: https://docs.google.com/spreadsheet/ccc?key=0AuAtmJW_VMCRdHJ6N1M3d1F1UTJTS1dSMnZwMF9XWVE&usp=drive_web#gid=1
14:19:33 <doron> moving next to integration.
14:19:38 <doron> sbonazzo: 3.5 readiness?
14:19:50 <doron> for integraiton
14:19:55 <awels> lvernia: Thanks
14:20:04 <sbonazzo> doron: iSCSI support is almost completed, we're validating the patch
14:20:22 <sbonazzo> doron: same for websocket on separate host
14:20:44 <doron> #info integration 3.5 feature readiness: websocket on separate host and hosted-engine iSCSI support almost done.
14:20:53 <doron> sbonazzo: and the others?
14:20:58 <sbonazzo> doron: DWH and Reports on separate host will reuse partially the work done for websocket, but no patch ready so far
14:21:31 <doron> #info integration 3.5 feature readiness: DWH and Reports on separate host still in progress.
14:21:34 <sbonazzo> doron: and for the guest tools we're stil lin design phase
14:21:53 <doron> sbonazzo: very well, so we should check on WGT in 3,5
14:22:12 <doron> #info integration 3.5 feature readiness: guest tools still requires some more design.
14:22:15 <doron> sbonazzo: thanks
14:22:25 <doron> let's move to network.
14:22:30 <doron> lvernia: 3.5 features?
14:22:55 <lvernia> doron: Yes, most look good.
14:23:12 <doron> lvernia: 4 postponed, 1 done, everything else in progress?
14:23:19 <lvernia> doron: The bridging_opts, ethtool_opts and the warning about the display network are being merged, and will be in by tomorrow.
14:23:47 <lvernia> doron: The two MAC pool ones won't make it in.
14:23:54 <lvernia> doron: At least not by tomorrow.
14:23:57 <danken> bridging_opts depends on a fix in initscripts
14:24:20 <doron> danken: initscripts of which distro / version?
14:24:24 <danken> (the vdsm patch, that is)
14:24:27 <lvernia> doron: Neutron on track, still being tested, the oVirt code of it is already in.
14:24:34 <danken> doron: on el6 only
14:24:43 <danken> they have built a fix today
14:24:49 <doron> danken: thanks, so it ma yslip?
14:25:14 <doron> danken: if they have a new build it may be ready on time.
14:25:15 <danken> we can merge the patch today, but it won't work on el6
14:25:27 <doron> ok, so we will need to track it.
14:26:00 <doron> Let's summarize it;
14:26:34 <doron> #info network 3.5 readiness; The bridging_opts, ethtool_opts and the warning about the display network are being merged, and will be in by tomorrow.
14:26:41 <danken> doron: theoretically, yes
14:26:48 <doron> lvernia: is there an ETA for  two MAC pool ?
14:27:16 <lvernia> doron: Not that I know of, design is still being discussed.
14:27:31 <lvernia> doron: When is code freeze for 3.5?
14:27:37 <lvernia> For bugs, etc.
14:27:43 <doron> lvernia: so wh yis it not updated as in design?
14:28:36 <lvernia> doron: Because code has been written according to the original design, people have been late to comment...
14:29:20 <doron> lvernia: note that we are going to clean the doc based on status, so it should reflect current status. So I suggest you update to make sure we get the right picture.
14:29:29 <lvernia> Ack, will do.
14:30:08 <doron> lvernia: so we have one feature ready, which others are expected o make it in the next week?
14:30:27 <doron> Assuming it's written and pending last reviews, etc.
14:30:40 <lvernia> doron: Neutron, both property features, and the display network warnings (up to one GUI patch).
14:30:55 <doron> lvernia: and everything else postponed?
14:31:25 <lvernia> doron: Probably.
14:31:40 <doron> lvernia: very well. please make sure to update the doc.
14:31:43 <doron> lvernia: thanks
14:31:46 <lvernia> doron: Sure.
14:32:24 <doron> #info network 3.5 readiness; 1 feature ready, Neutron, both property features, and the display network warnings expected to make it by next week. Everything else will probably be postponed.
14:32:34 <doron> moving next to node;
14:32:44 <doron> fabiand: 3.5 readiness status?
14:33:49 <doron> fabiand: here?
14:34:40 <doron> k, we'll come back to node.
14:34:51 <doron> moving next to sla
14:35:59 <doron> #info sla 3,5 features update: iscsi for hosted engine almost done. 2 features postponed. 1 may slip and everything else should be ready in the coming week.
14:36:09 <doron> moving next to storage.
14:36:19 <doron> amureini_: 3,5 feature readiness
14:36:40 <doron> amureini_: 2 already done?
14:37:31 <doron> amureini_: here?
14:38:35 <doron> k, we'll give them another chance later.
14:39:01 <doron> who's here for ux today?
14:39:09 <awels> doron: I am
14:39:25 <doron> awels: hi, can you update on your 3.5 readinesS?
14:39:57 <awels> doron: Einav is on PTO. Yes, new look and feel phase #1 is almost ready to merge, hopefully we will get it merged this week, if not early next week.
14:39:58 <doron> awels: you have 2 features;
14:40:17 <awels> doron: Doing final review and verification on that patch.
14:40:38 <awels> doron: REST API, still in design, getting close to starting implementation, so that will not make feature freeze.
14:40:48 <doron> awels: very well. REST based UI should move to postponed?
14:41:09 <awels> doron: I will have Einav do that when she gets back from PTO
14:41:16 <doron> awels: just did it. thanks!
14:41:21 <awels> doron: Thanks
14:41:41 <doron> #info UX 3.5 readiness: new look and feel should be ready. REST based UI postponed.
14:42:01 <doron> moving next to virt, mskrivanek here?
14:42:45 * mskrivanek here
14:43:07 <doron> mskrivanek: hi! 3.5 feature status?
14:43:20 <mskrivanek> well....;-)
14:43:37 <mskrivanek> shame on not enough attention to review instance types
14:43:47 <mskrivanek> which are at risk due to that
14:43:59 * amureini_ here [damn dst issues]
14:44:01 <mskrivanek> spice&vnc also still at risk, quite likely won't make 3.5 fully
14:44:12 <doron> mskrivanek: my sources tell me it's in process.
14:44:30 <mskrivanek> :-) good. still, given the date there's quite a risk:/
14:44:42 <doron> mskrivanek: what will make it?
14:45:07 <mskrivanek> other than that it's going ok, most of the stuff will make it (give we get some slack...few days here and there to converge)
14:45:56 <mskrivanek> so far 7 features are green in the spreadsheet, next ~6 should follow. most of the stuff.
14:45:56 <doron> mskrivanek: we have a few days to complete running features, but not to start new ones. hence- freeze.
14:46:11 <doron> mskrivanek: thanks
14:46:26 <mskrivanek> yes. we're not staring anything, it's just about getting closure on reviews
14:46:55 <doron> #info virt 3.5 readiness: 7 completed, 6 should be ready and the rest should be reconsidered.
14:47:12 <doron> mskrivanek: if there's something you know will not make it please set status as postponed.
14:47:22 <doron> amureini_: here?
14:47:51 <amureini_> doron, yup. just found out my calendar has been off an hour, explaining why i'm always late :-(
14:48:10 <doron> amureini_: welcome back. 3.5 feature readiness updates?
14:49:04 <amureini_> live merge: we found some limitations in libvirt and qemu, working with stakeholders to see if they will be fixed, or we'll have to work around in ovirt
14:49:28 <amureini_> sanlock fencing: at risk, need some more inputs which we should be able to collect during this week
14:49:43 <doron> amureini_: so will live merge make it or is it t risk
14:49:44 <amureini_> others are on track - coding, reviewing, etc.
14:49:45 <doron> ?
14:50:07 <amureini_> doron, seems like it will make it, may have some limitations
14:50:42 <doron> amureini_: as for 'on track', track is basically over; we have a few days to complete running features.
14:51:16 <amureini_> doron, ack
14:51:19 <doron> amureini_: if you have features expected to take longer than 1-2 weeks please reconsider to postpone.
14:51:46 <amureini_> doron, don't see anything that will take more than that (other then the aforementioned two)
14:52:29 <doron> #info storage 3.5 feature readiness: 2 features done. live merge should make it, possibly limited. sanlock fencing: at risk and the rest should be completed soon.
14:52:32 <doron> amureini_: thanks.
14:52:36 <doron> fabiand: here?
14:52:48 <doron> sahina: here?
14:54:03 <doron> ydary: here?
14:54:22 <sahina> doron, hi..was on another call.
14:54:28 <ydary> doron: hi
14:54:43 <doron> sahina: welcome back.  how is gluster fdoing for 3.5?
14:54:45 <jmoskovc> fsimonce: ping got a sec? need some help with vdsm and lvm handling
14:55:14 <doron> ydary: I see you added features to 3.5 google doc?
14:55:24 <ydary> doron: yap
14:55:44 <doron> ydary: so can you update on dwh 3.5 readiness?
14:55:44 <sahina> doron, gluster - we will make the monitoring, volume capacity and volume profile as patches posted
14:55:55 <doron> sahina: eta?
14:55:58 <ydary> doron: in what way?
14:56:16 <sahina> doron, the gluster top feature will probably not make it.
14:56:17 <doron> ydary: what will make it next week and everything else probably postponed?
14:56:32 <doron> sahina: please mark it as postponed. anything else?
14:56:43 <sahina> doron, nope..that's it
14:56:48 <fsimonce> jmoskovc, sure
14:56:51 <doron> sahina: thanks.
14:57:01 <ydary> doron: one will be in POST, the other i'm not sure and the third is already commited
14:57:29 <doron> #info Gluster 3.5 readiness: Gluster Top should be postponed. Everything else should make it by next week.
14:57:52 <doron> ydary: will it be ready in the next 1-2 weeks?
14:58:14 <ydary> doron: integration feature aside of course
14:58:19 <ydary> features*
14:58:31 <ydary> doron: in 2 week all will be in probably
14:58:42 <doron> ydary: I'm tracking what you added to the doc.
14:59:19 <doron> ydary: note that beyond these dates you should consider to postpone features to 3.6.
14:59:23 <doron> ydary: thanks.
14:59:51 <doron> #info dwh 3.5 readiness: 1 feature done. other 2 should make it in the next 1-2 weeks.
14:59:57 <doron> fabiand: here?
15:01:02 <doron> #info node 3.5 readiness: registration feature may be postponed. Other 2 should make it on time.
15:01:14 <doron> That's it...
15:01:40 <doron> sbonazzo: for next week, can you provide some bug numbers so we'll start tracking blockers and general numbers?
15:02:09 <sbonazzo> doron: sure, I'll prepare usual release status
15:02:14 <doron> sbonazzo: thanks.
15:02:17 <doron> moving on
15:02:23 <doron> #topic conferences and workshops
15:02:28 <doron> bkp: here?
15:02:35 <bkp> Yep
15:02:37 <bkp> I am in the process of gathering locations of users who might be interetsed in helping with events. This is the first step in creating a Speaker's Bureau for oVirt, which we can use to send local oVirt community members to local events.
15:02:49 <bkp> I already have an offer from an oVirt-using company in Italy to host an event, possibly a workshop.
15:03:43 <bkp> That's it for new events news.
15:03:46 <doron> #info bkp gathering locations of users who might be interested in helping with events. Please mail bkp if you want and can assist
15:03:54 <gchaplik> mrao, ping
15:04:07 <doron> bkp: thanks.
15:04:14 <gchaplik> sherold, ping
15:04:16 <doron> #topic other topics
15:04:30 <sherold> gchaplik, ack
15:04:33 <doron> One thing I'd like to mention
15:05:03 <doron> various maintainers- please make sure you tag your releases. We found today that we're missing tags in several projects.
15:05:25 <doron> sbonazzo: can you mail this to the devel list?
15:05:53 <sbonazzo> doron: ok I'll do
15:05:56 <doron> sbonazzo: thanks.
15:06:09 <doron> Anyone want to discuss something? raise an issue?
15:06:39 <bkp> As we move through the 3.5 cycle, it would be great to cleanup the features pages.
15:06:39 <doron> Going once?
15:07:03 <doron> bkp: agree.
15:07:16 <bkp> A feature page cleanup project will be launched just after this meeting. The pages that need datestamps added are listed here http://bit.ly/1iA1HQ3
15:07:34 <bkp> Instructions/request to follow on [devel]
15:08:12 <bkp> Unrelated: does oVirt have any ties/features on Ceph?
15:08:30 <doron> #info A feature page cleanup project will be launched just after this meeting, pages that need datestamps added are listed here http://bit.ly/1iA1HQ3 more info will be provided in the devel list.
15:08:43 <doron> bkp: not that I'm aware of.
15:08:54 <doron> bkp: worth pinging over mail.
15:08:57 <bkp> Red Hat's acquisition of Ceph may be something that we as a community will have to think about. I know there's intgration at the libvirt level, (Ceph was supported before Gluster in libvirt). But moving forward, we will need to ponder.
15:09:03 <bkp> http://www.redhat.com/about/news/press-archive/2014/4/red-hat-to-acquire-inktank-provider-of-ceph
15:09:16 <bkp> ^^^ More of a heads up.
15:09:48 <doron> #info oVirt may gain from Red Hat's acquisition of Ceph. See: http://www.redhat.com/about/news/press-archive/2014/4/red-hat-to-acquire-inktank-provider-of-ceph
15:09:57 <bkp> Also, doron and I are in the process of creating an inventory of oVirt apparel and giveaways. If there is a stash at your location, help us and let us know what you have.
15:10:31 <doron> #action please mail bkp if you have a stash of ovirt apparel.
15:10:42 <bkp> Finally, next week I will be fairly out of the loop, due to travel to FISL and a CentOS dojo in Brazil. Email will be best contact method. Or WhatsApp, if there's an emergency.
15:10:42 <doron> bkp: anything else?
15:10:50 <bkp> That's all from me.
15:11:24 <doron> #info bkp will be in FISL and a CentOS dojo in Brazil next week. Expect slower response time.
15:11:30 <doron> bkp: thanks.
15:11:33 <bkp> NP
15:11:35 <doron> Anyone else?
15:11:44 <doron> Going once?
15:12:14 <doron> Going twice...
15:12:54 <doron> #info Thanks all for coming. Happy Labor day tomorrow!!!!
15:12:57 <doron> #endmeeting