14:02:58 <knesenko> #startmeeting oVirt Infra
14:02:58 <ovirtbot> Meeting started Mon Mar 31 14:02:58 2014 UTC.  The chair is knesenko. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:58 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:03:08 <knesenko> #chair dcaro ewoud eedri
14:03:08 <ovirtbot> Current chairs: dcaro eedri ewoud knesenko
14:03:16 <knesenko> bkp: meeting ?
14:03:26 * orc_orc is here but has been travelling
14:03:38 * bkp here
14:05:17 <knesenko> #chair bkp
14:05:17 <ovirtbot> Current chairs: bkp dcaro eedri ewoud knesenko
14:05:33 <knesenko> Hello all how are you today ?
14:05:46 <bkp> Pretty well.
14:06:39 <knesenko> #topic Hosting
14:06:54 <knesenko> what's the status with rackspace03 ?
14:07:14 <eedri> knesenko, last i heard it's been migrated to our vlan and waiting as new hypervisor
14:07:34 <eedri> knesenko, we can start adding new VMs on it, but we need an easier way to do that
14:07:46 <eedri> knesenko, so having a pxe server from foreman is the next step
14:08:01 <knesenko> correct
14:08:10 <knesenko> ewoud: any progress on PXe installation ?
14:08:16 <knesenko> did you had time for it ?
14:08:48 <knesenko> fabiand: what to join the infrea meeting ?
14:08:55 <fabiand> Yep!
14:08:56 <ewoud> knesenko: no, been very busy
14:09:00 <knesenko> ewoud: I see ok
14:09:01 <fabiand> knesenko, thanks for the reminder!
14:09:02 <fabiand> :)
14:09:11 <knesenko> #chair fabiand
14:09:11 <ovirtbot> Current chairs: bkp dcaro eedri ewoud fabiand knesenko
14:09:18 * fabiand is here
14:09:30 <knesenko> dcaro: any chance we can push it this week ?
14:09:35 <ewoud> knesenko: I intend to work on it this evening
14:09:45 <eedri> ewoud, +1
14:09:49 <knesenko> ewoud: ok thank you very much for it
14:09:54 <knesenko> ewoud++
14:10:19 <knesenko> #info ewoud will install PXE server on rackspace env this evening
14:10:23 <ewoud> also, this weekend I leave for a week so I really want to complete it this week
14:10:25 <knesenko> anything else on hosting ?
14:10:31 <eedri> knesenko, yes
14:10:41 <knesenko> eedri: yes please
14:10:47 <eedri> knesenko, i added 2 new slaves for jenkins running on OpenStack1 public cloud
14:11:04 <eedri> knesenko, we got access to use it, and dcaro is currently tesitng it to see any issues/performance
14:11:33 <knesenko> eedri: I heard its very slow
14:11:34 <dcaro> eedri: yep! And I'll add a f20 one too, for now, for vered to test the storage functional tests
14:11:34 <knesenko> right ?
14:11:35 <eedri> so if all goes well, we might be able to add more slaves from there, both slaves are puppetized and accessible to all infra memebers
14:11:52 <eedri> knesenko, not very, it's 2/3 the speed of rackspace from what i saw
14:12:04 <eedri> knesenko, for e.g 30 min on unit tests instead of 20
14:12:08 <eedri> something like that
14:12:10 <knesenko> eedri: so we can run ligth jobs on it
14:12:14 <knesenko> pep8 etc
14:12:30 <eedri> knesenko, either that or exotic os, like rhel7/ubunto/gentoo etc..
14:12:37 <eedri> knesenko, for testing/pakcging
14:12:51 <knesenko> eedri: +1 agreee
14:13:29 <eedri> knesenko, another update is that servers from the new lab has arrived
14:13:37 <eedri> knesenko, we should get an update soon on ETA to start using them..
14:14:04 <knesenko> #info new HW for infra arrivied
14:15:13 <knesenko> #topic Foreman and Puppet
14:15:31 <knesenko> I assume will need to discuss pep8 installation on slaces
14:15:34 <knesenko> slves
14:15:40 <knesenko> on how are we going to do that
14:15:47 <knesenko> we need to new version to be installed right ?
14:15:49 <knesenko> 1.5.1 ?
14:15:54 <dcaro> I propose creating a package and pushing it with ci-tools repo
14:16:44 <knesenko> dcaro: should be easy , right ?
14:18:22 <knesenko> dcaro: /
14:18:23 <knesenko> ?
14:19:13 <knesenko> ok nm
14:19:19 <knesenko> lets continue
14:19:49 <knesenko> #action dcaro or knesenko create a pkg for pep8 and deploy it on ci-tools repo
14:19:56 <knesenko> anything else on puppet foreman ?
14:20:06 <eedri> knesenko, yea
14:20:08 <eedri> knesenko, sort of
14:20:49 <eedri> knesenko, nm, i'll mention it in the tickets topics
14:20:59 <knesenko> eedri: ok
14:21:05 <knesenko> #topic Jenkins
14:21:59 <knesenko> dcaro: eedri ?
14:22:00 <eedri> dcaro, any updated?
14:22:36 <eedri> knesenko, i think repo_closure jobs are waiting for fabian_a fix..
14:22:41 <eedri> knesenko, should be in soon...
14:22:45 <knesenko> fabiand: hey there :) :) :)
14:23:00 <fabiand> :)
14:23:01 <eedri> fabian_a, didn't you wanted to talk about ovirt-node functional testing ?
14:23:02 <fabiand> hey hey
14:23:11 <dcaro> upgrade job is getting fixed, it has some issues with the yum groups and the repos when upgrading, I'm on it
14:23:17 <fabiand> for the repoclosure jobs ... yes. working on them
14:23:39 <fabiand> eedri, and for the node functional tests ... yes, I would like to get some speed onto that, tho I don't have something righ tnow.
14:23:54 <fabiand> What is important to use i sthat we've got some place somewhere were we can spawn VMs
14:23:55 <fabiand> :)
14:24:01 <eedri> fabian_a, we do :)
14:24:14 <eedri> fabian_a, just ping us when you're ready to start working on that
14:24:29 <fabiand> eedri, leave fabina_a alone ;)
14:24:38 <fabiand> eedri, ack, we will do!
14:24:38 <eedri> fabian_a, sorry :)
14:24:42 <fabiand> ;)
14:24:50 <dcaro> hehe
14:24:54 <eedri> dcaro, any more updates?
14:25:02 <knesenko> hahahaha
14:25:20 <dcaro> os slaves look promising, but they lack the last push (troubleshooting the connectivity to jboss mvn repos)
14:26:23 <dcaro> *os1 (openstack public cloud)
14:26:40 <eedri> dcaro, anything you think we can do on the short term to improve infra/jenkins master speed?
14:26:48 <straff> when I log on ovirt reports since webadmin ovirt portal I have error java.lang.IllegalArgumentException: An id is required to lookup a FlowDefinition
14:27:26 <dcaro> eedri: split it into two
14:27:28 <eedri> dcaro, also, i think another function tester requested ssh access to slave
14:27:45 <eedri> dcaro, 2 masters?
14:27:50 <dcaro> eedri: yes, vered, I'm preparing an os1 f20 slave for him
14:27:58 <eedri> dcaro, it's she :)
14:28:05 <dcaro> eedri: yes, one with gerrit triggered patches and another with packaging
14:28:28 <eedri> dcaro, hmm.. ok, let's see if we can run 2 HA vms on the new lab
14:28:31 <dcaro> vered: sorry she :*|
14:28:37 <knesenko> dcaro: :)
14:28:38 <eedri> dcaro, instead of the the current bare metal
14:30:46 <knesenko> anything else on jenkins?
14:30:49 <knesenko> ah yes
14:30:56 <knesenko> we have some issues with the API
14:30:59 <knesenko> dcaro: right ?
14:31:12 * fabiand would also like ot have slaves access to debug all sorts of Node problems ..
14:31:28 <knesenko> we tried to download artifacts via the API and we had some issues ...
14:31:30 <eedri> knesenko, What's new in 1.556 (2014/03/23)
14:31:30 <eedri> Access through API token and SSH key login now fully retains group memberships. (issue 20064)
14:31:37 <eedri> knesenko, maybe related?
14:31:43 <knesenko> so for now we applied a workaround
14:31:44 <eedri> dcaro, we can schdule an upgrade
14:31:52 <knesenko> eedri: +1 for upgrade
14:31:58 <knesenko> and see if it works
14:32:07 <dcaro> eedri: knesenko the issue was related to timestamps and non-ssh access
14:32:21 <dcaro> but yes, we might want tot upgrade
14:32:32 <eedri> Slave started from Java Web Start can now install itself as a systemd service.'
14:32:33 <eedri> nice
14:32:42 <knesenko> form what I read I its related to git plugin plugin
14:32:44 <eedri> no need maybe for a puppet class :)
14:33:49 <dcaro> \o/
14:34:10 <dcaro> paz solved it in a very low level... xd
14:34:59 <eedri> yea..
14:35:47 <eedri> knesenko, there is another updates on repo
14:35:54 <eedri> knesenko, but that's on repo mgmt topic
14:36:08 <knesenko> eedri: new topic...
14:36:09 <knesenko> ok
14:36:10 <eedri> knesenko, or builds..
14:36:16 <knesenko> lets move
14:36:28 <knesenko> #topic Build/Releases/Repo Management
14:36:38 <knesenko> so I have few updates here
14:36:57 <knesenko> if you don't know, me and dcaro are managing resources.ovirt.org repos
14:37:06 <knesenko> and we are release engineers for oVirt
14:37:34 <knesenko> I think we did a great job there .... but we have more in our queue
14:37:38 <knesenko> so updates
14:37:55 <knesenko> #info new layout was applied http://plain.resources.ovirt.org/pub/
14:37:59 <dcaro> |o/
14:38:03 <eedri> +1
14:38:13 <knesenko> #info next z-stream release will be published under pub/
14:38:19 <eedri> dcaro, thats playing tennis with one hand?
14:38:19 <dcaro> there are a couple of repos that can be used with both layouts, to ease the transition
14:38:28 <knesenko> #info /releases directory will be obsoleted
14:38:33 * dcaro is about to do an ace
14:38:57 <knesenko> we have automated a lot of process like publishing nightly repos
14:39:12 <knesenko> now we have nightly for 3.3, 3.4 and 3.5
14:39:23 <knesenko> #info we have nightly for 3.3, 3.4 and 3.5
14:39:51 <eedri> knesenko, dcaro and bkp are working on mirroing those repos to various universities
14:39:52 <knesenko> also we are working on signing RPMs for the official releases
14:40:03 <knesenko> I hope it will be ready for the next zstream release
14:40:33 <knesenko> #info bkp dcaro are working on mirroring repos ti various universities
14:40:38 <knesenko> dcaro: bkp +1 for that
14:41:03 <bkp> knesenko: dcaro is doing all the heavy lifting
14:42:00 <knesenko> thanks
14:42:03 <knesenko> really
14:42:16 <knesenko> ok what else do we have here
14:42:17 <knesenko> >
14:42:18 <knesenko> ?
14:42:41 <eedri> trac
14:42:42 <eedri> tickets
14:43:13 <knesenko> #topic Review Tickets
14:43:16 <knesenko> oh ...
14:43:20 <knesenko> lets do it ...
14:43:36 <knesenko> eedri: would you like to lead this topic ?
14:43:45 <eedri> knesenko, sure
14:44:05 <eedri> 1st, i'd like to propose something we did with other ovirt project
14:44:06 <eedri> s
14:44:31 <eedri> i think we might find help on the community form people wanting to pitch in and assist in various tickets
14:44:41 <eedri> like adding a puppet class or writing a script
14:44:54 <eedri> we should write a wiki on ovirt.org on how to help or a landing page
14:45:17 <eedri> and maybe on occasion ask community if anyone is volenteering to assist in a certain task
14:45:42 <eedri> it can be communicated to users & devel lists
14:46:23 <knesenko> eedri: the only problem we have is permissions
14:46:30 <knesenko> we have no level for permissions
14:46:37 <eedri> knesenko, true, but some tasks doesn't require any permisisons
14:46:38 <knesenko> we have only sudo ... and non sudo
14:46:40 <eedri> knesenko, like sending a patch
14:46:45 <knesenko> eedri: ok
14:46:47 <eedri> knesenko, you don't need access to anything
14:46:55 <eedri> knesenko, infra member can assist in verifying
14:46:57 <eedri> knesenko, if needed
14:47:17 <knesenko> yeah
14:47:18 <knesenko> ok
14:47:33 <eedri> bkp, do you know who can ask for admin rights for the fedora hosted trac instance?
14:48:01 <bkp> eedri Not sure.
14:48:07 <bkp> Lemme check
14:48:16 <eedri> bkp, also - is this ticket going to solved this week?
14:48:17 <eedri> https://fedorahosted.org/ovirt/ticket/10
14:48:22 <eedri> migrating arch list
14:48:39 <bkp> Yep. In fact, today, I believe
14:48:45 <eedri> bkp, +1
14:49:33 <eedri> https://fedorahosted.org/ovirt/ticket/32
14:49:44 <eedri> enable snytax highliting in media wiki
14:50:01 <eedri> bkp, dneary what is the process of upgrading media-wiki?
14:50:08 <eedri> is it done by openshift? or us
14:50:19 <dneary> eedri, We need to do it
14:50:19 <knesenko> eedri: bkp we also need to apply some security patches right ?
14:50:30 <dneary> The process is:
14:50:31 <eedri> dneary, do we have any plans for it?
14:50:37 <eedri> dneary, other reasons for upgrade..
14:50:39 <bkp> eedri: We are truing to figure that out now. There was a security patch issue that came up this weekend, too
14:50:47 <bkp> *trying
14:50:51 <dneary> The procedure is:
14:51:00 <dneary> * Download new MediaWiki
14:51:13 <dneary> * Over-write original files in Quickstart
14:51:50 <dneary> (* Deploy to staging, run DB update through the interface, test that it works OK)
14:52:10 <dneary> * Deploy to prod, run DB updating script through the interface, verift that the wiki is back and all is OK
14:52:35 <dneary> In brackets because to do that, you need a staging instance
14:52:51 <eedri> dneary, can we get one from openshift?
14:55:22 <eedri> dneary, ok, who is going to do the upgrade?
14:56:50 <eedri> alinefm, ping
14:57:21 <alinefm> hi, eedri
14:57:32 <eedri> alinefm, hey, how are you?
14:57:42 <dneary> eedri, I'm afraid I don't know
14:57:50 <alinefm> eedri, good and you?
14:58:14 <eedri> alinefm, any update on the ibm servers?
14:58:21 <dneary> eedri, bkp is looking for someone with the skills & comfort level to take it on, I think
14:58:29 <eedri> dneary, ok
14:58:34 <eedri> knesenko, can you add it as action item?
14:58:34 <bkp> eedri: Yes, that
14:58:52 <eedri> knesenko, planning to upgrade media wiki, still working out the details
14:58:53 <knesenko> eedri: upgrading the media wiki ?
14:58:59 <bkp> eedri: I found the person who can grant those admin rights?
14:59:23 <bkp> So I will get them connected to the Infra team.
14:59:25 <eedri> bkp, i'm not too familiar with media wiki at all, but i assume the credentials for it are i the same place
14:59:29 <alinefm> eedri, well, we finished the machine setup in a lab last week
14:59:43 <alinefm> eedri, now I am working with the legal process
14:59:55 <eedri> alinefm, nice.. so you'll let us know when can we connect it to jenkins?
14:59:57 <bkp> eedri Admin rights for the trac instance.
14:59:57 <alinefm> need some contracts to allow the machines be accessible outside IBM network
15:00:06 <eedri> bkp, ahh.. nice, who is it
15:00:13 <bkp> Karsten Wade.
15:00:20 <bkp> (quaid)
15:00:22 <eedri> quaid!
15:00:24 <alinefm> eedri, sure - I hope get all done in more 2 weeks
15:00:28 <eedri> yea... figured that
15:00:34 <alinefm> I will send a mail to mail list when it happens
15:00:34 <eedri> alinefm, btw, you don't nessasarily need that
15:00:45 <bkp> eedri: Credentials are in same place, yes
15:00:53 <eedri> alinefm, we have jenkins slaves running in a dmz in tlv, without acccess fromt he outside
15:01:20 <eedri> alinefm, we're using jnlp connections from the slaves to the jenkins instead (headless mode)
15:01:22 <alinefm> eedri, really? but how do you connect to the slave?
15:01:27 <alinefm> hmm...
15:01:40 <knesenko> alinefm: slave connects to jenkins
15:01:45 <knesenko> and not jenkins to slave
15:02:02 <knesenko> alinefm: so your slaves needs access to the world, that's all
15:02:04 <alinefm> eedri, knesenko, it can helps the process
15:02:33 <eedri> alinefm, https://wiki.jenkins-ci.org/display/JENKINS/Distributed+builds
15:02:36 <knesenko> eedri: I am pretty it is ... better is to use ssh :)
15:02:51 <knesenko> eedguys we are out of time
15:03:04 <knesenko> any urgent issues to discuss ?
15:03:11 <bkp> Nope
15:03:16 <eedri> knesenko, no, we can continue next time.
15:03:32 <knesenko> k
15:03:32 <eedri> but i suggest going over the tickets and seeing if anything can be requested from the community
15:03:35 <knesenko> thanks
15:03:40 <knesenko> #endmeeting