14:03:20 <fabiand> #startmeeting oVirt Node Weekly Meeting
14:03:20 <ovirtbot> Meeting started Tue Feb 25 14:03:20 2014 UTC.  The chair is fabiand. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:20 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:03:26 <fabiand> #chair jboggs rbarry
14:03:26 <ovirtbot> Current chairs: fabiand jboggs rbarry
14:03:30 <fabiand> #topic Agenda
14:03:49 <fabiand> #info Patch review
14:04:02 <fabiand> #info Release status
14:04:05 <fabiand> #info Build status
14:04:08 <fabiand> #info Other Items
14:04:30 * jboggs here
14:04:33 <eedri> knesenko, are we going to keep officail releases also under /pub?
14:04:34 <fabiand> Morning jbiddle__
14:04:36 <fabiand> darn
14:04:38 <fabiand> Morning jboggs
14:04:45 <jboggs> i need a less common nick lol
14:04:45 <knesenko> eedri: from 3.5
14:05:00 <eedri> knesenko, maybe cleanup script should run only on /pub/nighlies
14:05:05 <fabiand> reminds me of the fabio fabian tab-completion-fail :)
14:05:06 <eedri> knesenko, and also examnple in --help should say that
14:05:13 <knesenko> eedri: it will run on nightlies only
14:05:14 <eedri> knesenko, so people won't run it by acceident
14:05:17 <eedri> knesenko, on releases
14:05:29 <knesenko> eedri: I will edit the cronjob for that
14:06:03 <eedri> knesenko, right now it says:   ${0} --days=4 /var/www/html/pub/*
14:06:22 <fabiand> #topic Patch review
14:06:24 * rbarry here
14:06:30 <fabiand> Ah - morning rbarry - all in.
14:06:40 <Rydekull> eedri: that seems like a very dangerous script...
14:07:14 <fabiand> Looks as if we got better at patch review, our number of pending patches is down to ~40
14:07:16 <eedri> Rydekull, well.. it will only affect rpms
14:07:29 <eedri> Rydekull, you must have a cleanup somehow
14:07:48 <fabiand> That also means that we finally got some new stuff for master ..
14:08:00 <Rydekull> eedri: yeah, just need a bit more checks in it, like dont do it if ${0} is an not wanted value, like / or .
14:08:13 <eedri> Rydekull, have you reviewed it?>
14:08:20 <fabiand> We had some problems with the jenkins job doing syntax checks, pep8 or python fails on the Fedora 19 builders ..
14:08:26 * fabiand sent an email to infra@
14:08:35 <fabiand> #info patch queue down
14:08:50 <fabiand> #info small problem with syntax check due to problematic pep8 / doctests on Fedora 19 builders
14:09:01 <fabiand> #info Moved syntax checks to el6 builders
14:09:09 <fabiand> #info Release status
14:09:12 <fabiand> #undo
14:09:12 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x8b5874c>
14:09:16 <fabiand> #topic Release status
14:09:30 <fabiand> We've got 3.0.4 which is out for a while but has never been officially published
14:09:54 <fabiand> It is tagged in git and there are base image and layered-images for Engine
14:10:02 <fabiand> s/for Engine/with VDSM/
14:10:22 <fabiand> Remaining thing is to get it out ...
14:10:37 <fabiand> There were some space issues but I think they have been sorted out
14:11:24 <fabiand> #info 3.0.4 is out for a while, never officially announce nor published
14:11:34 <fabiand> #info temporary space issues have been sorted out
14:11:52 <fabiand> #action fabiand to finally reach out to infra to sort out location of rpms+isos and final image push
14:12:00 <fabiand> #info Build status
14:12:07 <fabiand> Is related to the previous item ..
14:12:55 <fabiand> Build is out and available ..
14:13:32 <fabiand> What I wonder ... if it would make sense, now that we've got plugins, and especially the vdsm plugin
14:14:31 <fabiand> To ask the vdsm people if they want to take over the Node for Engine builds - as they are more aware of their release cycle ..
14:15:05 <fabiand> But that wsa just an idea ..
14:15:07 <jboggs> I had thought that was already in place?
14:15:20 <fabiand> Well, dougsland is maintaining the vdsm plugin
14:15:26 <fabiand> But afaik they are not building their images
14:17:31 <fabiand> What we can also do is: When we've got "official" base images we can create a job which uses the latest released base image and creates the layered vdsm images automatically ..
14:17:38 <fabiand> because that is easy once the base image exists ..
14:19:27 <sbonazzo> fabiand: make sense
14:19:32 <fabiand> hey sbonazzo
14:19:43 <sbonazzo> fabiand: it also may make sense to use the base image also for oVirt Live
14:19:59 <fabiand> let use first look at the layered vdsm image, sbonazzo
14:20:14 <sbonazzo> fabiand: sure
14:20:40 <fabiand> okay
14:21:06 <fabiand> rbarry or jboggs could you help sbonazzo to create a job which takes an base image iso and runs edit-node to add the vdsm-plugin?
14:21:29 <rbarry> fabiand: I'll work on it
14:21:31 * fabiand can provide the edit-node cmd he used recently to create the layered images
14:21:34 <fabiand> rbarry, great
14:21:46 <fabiand> rbarry, once thing to take care of is that the correct repos are used
14:21:46 <jboggs> rbarry thanks /me not at all familiar with jenkins
14:22:08 <fabiand> and sbonazzo is probably a good candidate to work with to find the right repos ..
14:22:42 <fabiand> sbonazzo, rbarry - I'm not sure if we want one job which can cover 3.2 - 3.4 or if we want separate jobs covering 3.2 - 3.4 ..
14:23:04 <sbonazzo> fabiand: maybe knesenko or eedri is also better than me :-)
14:23:09 <fabiand> okya :)
14:23:14 <fabiand> knesenko, ping?
14:23:16 <fabiand> eedri, ping?
14:23:39 <fabiand> anyway
14:24:12 <fabiand> #action rbarry to create a jenkins job which takes an base image iso and adds the vdsm-plugin to create a layered iso.
14:24:14 <eedri> fabiand, piong
14:24:30 <fabiand> #info There should be one or more jenkins jobs ot create isos for 3.2 - 3.4
14:24:37 <eedri> fabiand, what can i help with
14:25:07 <fabiand> eedri, hey - We were just talking about  a jenkins job to create node isos with vdsm - and we need your or knesenkos input on where and how to get always the correct repo urls.
14:25:15 <fabiand> eedri, could you or knesenko work with rbarry to sort that out?
14:25:40 <fabiand> rbarry, you need to pass the repo urls to edit node to pull in the correct dependencies ..
14:25:41 <eedri> fabiand, i'd like dcaro to give his input as well, but he's sick today
14:25:46 <fabiand> okya
14:26:02 <eedri> fabiand, we can setup a meeting, or talk on the list with relevant info
14:26:12 <fabiand> sounds good
14:26:15 <fabiand> rbarry, ^^
14:26:45 <rbarry> I'll send an mail out on arch@
14:26:48 <fabiand> great
14:27:09 <fabiand> That should tackle the absence of Node for Engine isos a bit ..
14:27:19 <fabiand> #topic Other Items
14:27:43 <fabiand> Anything else we should discuss?
14:28:35 <jboggs> nothing here
14:29:14 <rbarry> Nothing here either
14:29:25 <fabiand> Okay
14:29:27 <fabiand> Then thanks
14:29:28 <fabiand> and
14:29:30 <fabiand> #endmeeting