14:01:44 <fabiand> #startmeeting oVirt Node Weekly Meeting
14:01:44 <ovirtbot> Meeting started Tue Dec  3 14:01:44 2013 UTC.  The chair is fabiand. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:44 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:49 <fabiand> #chair jboggs mburns rbarry
14:01:49 <ovirtbot> Current chairs: fabiand jboggs mburns rbarry
14:02:06 <fabiand> #topic Agenda
14:02:19 <fabiand> #info 3.0.3 updates
14:02:36 <fabiand> #info Fedora 20 preparations
14:02:44 * rbarry here
14:02:59 <fabiand> #info oVirt Feature sync
14:03:09 <fabiand> morning rbarry
14:03:20 <fabiand> jboggs, ?
14:03:31 * jboggs here
14:03:36 <fabiand> hey
14:03:47 <fabiand> #topic 3.0.3 update
14:04:28 <fabiand> #info 3.0.3 got released last wednesday
14:04:48 <fabiand> We've got one bug which people run into. dougsland was seeing it before, but we couldn't reproduce it.
14:05:02 <rbarry> The installer?
14:05:09 <fabiand> #info Users run into https://bugzilla.redhat.com/show_bug.cgi?id=1032228
14:05:11 <fabiand> rbarry, yep
14:05:17 <fabiand> Bug 1032228 - TUI installations fails to pass keyboard page
14:05:41 <fabiand> rbarry, it's a bit problematic because I can't reproduce it. From the distance it looks a bit like two problems.
14:05:59 <fabiand> s/bit like) might be/
14:06:35 <fabiand> In the last attachement there was one insterstign bit, which indicates that the storage part is responsible, which sounds more reasonable, then that the kbd crashes the installation
14:06:46 <fabiand> File "/usr/lib/python2.7/site-packages/ovirtnode/storage.py", line 180, in get_drive_size
14:06:46 <fabiand> ValueError: invalid literal for int() with base 10: ''
14:07:40 * fabiand currently tries to get all sorts of logs so we have more data to attack the bug
14:08:44 <fabiand> Another problem is that we currently don't ship a wrapper-rpm for the ISO
14:09:29 <fabiand> The problem here is that the ISO within the ISO will have the same name as the base iso. This stopped me from packaging the ISO
14:09:54 <fabiand> But this is probably not a big problem, because I don't expect the base image to appear in the same path as the vdsm iso.
14:10:23 <fabiand> #info wrapper RPM for ISO is pending due to some naming conflicts
14:10:29 <fabiand> #action fabiand to build wrapper rpm
14:10:42 <fabiand> Another item is el6
14:11:09 <fabiand> We don't have an el6 ISO yet, but this is currently mainly a lack of time
14:11:32 <fabiand> We'll probably need a couple of more patches, but then el6 should also be fine.
14:11:44 <fabiand> #action fabiand to do el6 draft builds
14:11:47 <fabiand> #undo
14:11:47 <ovirtbot> Removing item from minutes: <MeetBot.items.Action object at 0x9bbe7ec>
14:11:52 <fabiand> #action fabiand to do el6 ISO draft builds
14:12:07 <fabiand> #topic Fedora 20 preparations
14:12:22 <fabiand> Fedora 20 is becoming more mature and we should start to migrate ovirt-node to fedora 20
14:12:43 <fabiand> rbarry, jboggs anyone stepping up do the initial porting?
14:12:59 <fabiand> That means, adjust recipes, test builds, probably a jenkins update
14:13:02 <rbarry> fabiand: I'm up for it. I already have a running F20 environment anyway...
14:13:10 <fabiand> rbarry, great!
14:13:12 <jboggs> ill help out testing
14:13:29 <fabiand> jboggs, cool
14:13:46 <fabiand> #action rbarry to drive Fedora 20 port of ovirt-node
14:14:01 <fabiand> #action jboggs to help testing F20 based builds
14:14:24 <fabiand> The rough idea would be to start delivering F20 based Nodes after the official release of F20, which is targeted for ..
14:14:44 <fabiand> 2013-12-10
14:14:59 <fabiand> That's soon.
14:15:30 <fabiand> But let's bring F20 support to Nod 3.1 then.
14:15:54 <fabiand> rbarry, sounds reasonable, f20 for node 3.1?
14:16:18 <rbarry> Definitely reasonable
14:16:47 <fabiand> rbarry, we should probably try to sync Node 3.1 with oVirt 3.4, which is due at the end of Jan.
14:17:01 <fabiand> #info Tragetting Fedora 20 support for Node 3.1
14:17:18 <fabiand> #info Node 3.1 should be release in sync with oVirt 3.4
14:17:32 <fabiand> Which brings us to another item: versioning
14:17:54 <fabiand> It was brought up that it can be confusing when the ovirt-node versioning and ovirt versioning differs
14:18:25 <fabiand> The most visible versioning from the Node side is the versioning of the ISO
14:18:41 <fabiand> so what we could do is to keep the Node ISO versioning in sync with the overall oVirt versioning
14:19:01 <fabiand> "Internally" we could keep our feature based versioning for the ovirt-node pkg
14:19:07 <rbarry> No objections
14:19:43 <fabiand> okay, let's try that for oVirt 3.4
14:20:06 <fabiand> #info Sync ovirt-node-iso versioning with overall oVirt versioning.
14:20:22 <fabiand> #info ovirt-node-iso version should match the ovirt version it is intended for
14:20:33 <fabiand> #info ovirt-node (pkg) version is feature driven
14:20:59 <fabiand> #agreed to sync ovirt-node-iso versioning with ovirt and let the ovirt-node (pkg) vresioning be feature driven
14:21:20 <fabiand> Well, that brought us a bit off topic ..
14:21:27 <fabiand> #topic oVirt Feature sync
14:22:11 <fabiand> The oVirt features targeted for oVirt 3.4 are referenced here http://www.ovirt.org/OVirt_3.4_release-management
14:22:41 <fabiand> We just need to make sure that we - form a Node perspective - provide the necessary infrastructure to support the overall oVirt features
14:26:40 <fabiand> Let us catch up with this next week
14:27:02 <fabiand> #action fabiand to given on overview over Node related oVirt features
14:27:07 <fabiand> #undo
14:27:07 <ovirtbot> Removing item from minutes: <MeetBot.items.Action object at 0x9b9bcec>
14:27:17 <fabiand> #action fabiand to given on overview over Node related oVirt features next week
14:27:28 <fabiand> okay
14:27:32 <fabiand> That's it from my side
14:27:39 <fabiand> rbarry, jboggs anything else to bring up?`
14:27:49 <rbarry> Nothing here
14:27:57 <jboggs> nothing either
14:28:05 <fabiand> Okay, then thanks
14:28:10 <fabiand> Eins (1)
14:28:12 <fabiand> Zwei (2)
14:28:15 <fabiand> Drei (3)
14:28:18 <fabiand> #endmeeting