15:02:45 <knesenko> #startmeeting oVirt Infra
15:02:45 <ovirtbot> Meeting started Mon Nov 18 15:02:45 2013 UTC.  The chair is knesenko. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:45 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:02:55 <knesenko> #chair obasan eedri ewoud
15:02:55 <ovirtbot> Current chairs: eedri ewoud knesenko obasan
15:03:11 <knesenko> dcaroest: ping here ?
15:03:14 <knesenko> orc_orc: ping
15:03:18 * dcaroest nods
15:03:25 <dcaroest> yep I'm here
15:03:25 <knesenko> #chair dcaroest
15:03:25 <ovirtbot> Current chairs: dcaroest eedri ewoud knesenko obasan
15:03:39 <knesenko> seems like orc_orc is not here
15:03:41 <knesenko> lets start
15:03:46 <knesenko> #topic Hosting
15:04:21 <knesenko> rackspace still stuck ... we are waiting for the permissions to approive the ticket
15:04:32 <knesenko> that's all from rackspace , right dcaroest  ?
15:05:18 <dcaroest> yep, waiting for a green light
15:05:39 <knesenko> ok
15:05:48 <knesenko> anything else on hosting ?
15:06:03 <knesenko> #info we are waiting for the green light on rackspace03 server
15:06:05 * Rydekull is in another meeting in parallell, but he is here
15:06:11 <orc_orc> orc_orc: here but reading
15:06:11 <knesenko> #chair Rydekull
15:06:11 <ovirtbot> Current chairs: Rydekull dcaroest eedri ewoud knesenko obasan
15:06:13 <knesenko> helllo
15:06:18 <Rydekull> :-)
15:06:24 <knesenko> #chair orc_orc
15:06:24 <ovirtbot> Current chairs: Rydekull dcaroest eedri ewoud knesenko obasan orc_orc
15:06:26 <orc_orc> my git update was failing
15:06:41 <eedri> orc_orc, which igt?
15:06:52 <dcaroest> eedri: you speak german?
15:07:01 <dcaroest> xd
15:07:02 <eedri> dcaroest, uber
15:07:23 <eedri> dcaroest, digt vein dutch
15:07:27 <orc_orc> eedri: posible local error -- bisecting
15:07:33 <eedri> dcaroest, just kidding.. gibrishing to my best
15:08:00 <eedri> orc_orc, we something have "voodo" errors clonning from gerrit into jenkins
15:08:24 * orc_orc looks for a rubber chicken to wave at his computer
15:09:42 <ewoud> is there an ETA for rackspace03?
15:09:56 <knesenko> ewoud: hope soon ... day or two
15:10:03 <knesenko> ewoud: i sent email about it today ...
15:10:26 <ewoud> ok
15:10:40 <knesenko> anything else here
15:10:40 <knesenko> ?
15:10:49 <eedri> knesenko, on hosting?
15:10:53 <knesenko> eedri: yes
15:11:09 <eedri> knesenko, well, not sure if it's related, but we said we wanted to add ubunto slave
15:11:22 <knesenko> not related ... jenkins topic
15:11:33 <eedri> knesenko, ok
15:11:33 <knesenko> #topic foreman and pppet
15:11:40 <knesenko> hello ewoud dcaroest :)
15:11:58 <ewoud> did you see my mail from about an hour ago?
15:12:22 <knesenko> ewoud: no I am not ...
15:12:23 <orc_orc> ewoud: the one pointing to this? http://gerrit.ovirt.org/#/c/19141/
15:12:23 <ewoud> http://lists.ovirt.org/pipermail/infra/2013-November/004375.html
15:12:31 <ewoud> orc_orc: yes
15:12:54 <dcaroest> knesenko: I have as a personal task to review it today
15:13:04 <knesenko> dcaroest: +1
15:13:08 <orc_orc> hmmm: Smarter Puppet deployment, powered by killer robots    and I am still struggling to get mine working as I wish
15:13:14 <knesenko> #action dcaroest review http://gerrit.ovirt.org/#/c/19141/
15:13:38 <ewoud> orc_orc: if you have any problems, please poke me after the meeting and we can look at it together
15:13:53 <orc_orc> ewoud: lots of eggs on my plate on Monday morhings ;)
15:14:27 <ewoud> but with that mail I hope to sync up the state of our puppet and hopefully use it as a basis for documentation
15:14:56 <ewoud> so please poke at it, let me know what I forgot
15:15:03 <orc_orc> ewoud: ok
15:15:57 <knesenko> any updates on foreman ?
15:15:59 <ewoud> when http://gerrit.ovirt.org/#/c/19141/ is merged, I will also update to foreman 1.3
15:16:09 <ewoud> and document that procedure as well
15:16:16 <knesenko> ewoud: +1
15:16:41 <knesenko> #action when http://gerrit.ovirt.org/#/c/19141/ is going to be merged dcaroest and ewoud take care of foreman upgrade
15:17:00 <knesenko> #info ewoud document the foreman upgrade procedure
15:17:08 <knesenko> ok let's continue
15:17:13 <knesenko> #topic Jenkins
15:17:18 <knesenko> eedri: hello ))
15:17:45 <eedri> knesenko, yea hi
15:18:00 <eedri> knesenko, just a note on foreman/puppet - we should review current puppet classes on jenkins slaves
15:18:05 <eedri> knesenko, maybe after the r10k?
15:18:28 <ewoud> we should
15:19:41 <eedri> #action review existing puppet classes and foreman hostgroups for jenkins slaves after r10k migration
15:19:56 <eedri> knesenko, for jenkins - do we want to stop building nightlies for f18?
15:20:03 <eedri> how many are still using it?
15:20:17 <eedri> we can keep the formal builds at releases
15:20:17 <knesenko> eedri: i don't think we know ...
15:20:22 <orc_orc> eedri: F18 has not ben formally turned down I think -- wont be until 1 month after F20 goes gold
15:20:28 <knesenko> eedri: maybe it worse sending email ?
15:20:38 <knesenko> eedri: before we disable it ?
15:20:50 <eedri> orc_orc, right, question is do people use it for getting nighlies
15:21:20 <eedri> orc_orc, we're planning on adding moniring (something like google analytics) for ovirt repos, so we'll know stats on d/l per os/ver
15:21:42 <orc_orc> eedri: would not work for me as I set lftp to mirror archives and pull locally from that
15:22:07 <orc_orc> as I understand it we are tight on space ...
15:22:29 <eedri> orc_orc, yea, i'm not sure currently we can add f20 as well, we will have space after we migrate resources.ovirt.org to rackspace
15:22:57 <orc_orc> so really getting that rackspace ticket resolved is the real blocker
15:23:46 <orc_orc> ticket 80 in the tracker
15:24:19 <orc_orc> 5 weeks old for a change?
15:24:42 <knesenko> orc_orc: there were few blockers
15:24:49 <knesenko> not only this one
15:25:57 <eedri> orc_orc, we have some issue with security changes from rackspace side
15:26:06 <eedri> orc_orc, bit beurocatic stiff
15:26:53 <knesenko> ok
15:26:55 <knesenko> what else ?
15:27:58 <ewoud> what about the ubuntu slave menionted earlier?
15:28:43 <knesenko> ewoud: i don't think it make sense to install it now ...
15:29:01 <orc_orc> ewoud: where would it live, and what is the proces for accessing a new buildslave in the wiki?
15:29:03 <knesenko> ewoud: once rackspace03 will be fixed, we will start with the migration
15:29:17 <knesenko> ewoud: so will install it on rackspace03
15:29:20 <ewoud> knesenko: ok
15:29:22 <orc_orc> ... accessioning ...
15:29:22 <ovirtbot> orc_orc: Error: ".." is not a valid command.
15:29:25 <orc_orc> ... accessioning ...
15:29:39 <dcaroest> eedri: I just checked, and there are at least 2 sources external to redhat that download rpms from nightly each day
15:30:01 <knesenko> #info install ubuntu slave on rackspace03 once it fixed
15:30:33 <ewoud> orc_orc: I don't think it's documented, but once the puppet class is applied, it should have a jenkins user and you can add it as a slave in jenkins
15:31:36 <eedri> knesenko, also - fix/reinstall f19-vm03 slave
15:31:53 <knesenko> ))
15:32:00 <pablohn> how to change disk interface (IDE, Virtio, Virtio-SCSI) once you have created the disk?
15:32:07 <knesenko> anything else here ?
15:32:36 <ewoud> it seems apache-commons-collections is unavailable on EL6
15:32:39 <knesenko> pablohn: "edit" on a disk
15:32:50 <ewoud> so slave-vm10 is in the error state it seems
15:33:10 <pablohn> knesenko, no such option on DIsk tab
15:33:21 <ewoud> slave-vm11 has puppet disabled but I don't know by who
15:33:33 <pablohn> Add Remove Move Copy Export
15:33:42 <ewoud> eedri: do you know why?
15:34:11 <pablohn> knesenko, oVirt Engine Version: 3.3.0.1-1.el6
15:34:13 <eedri> ewoud, i'm trying to remember if that was me
15:34:22 <eedri> ewoud, not sure
15:34:34 <knesenko> pablohn: ok ... try to edit the disk from the webadmin
15:34:41 <eedri> ewoud, we could add a monitoring alert on slaves that have not runnign puppet > 1 day
15:34:48 <mrguitar> can anyone help w/ what I believe is a vdsm-gluster issue?
15:34:51 <eedri> obasan, you have a script for it, noi?
15:34:59 <ewoud> eedri: we have a check in nagios @ work, I can use that
15:35:09 <orc_orc> mrguitar: there is a meeting running atm -- could you stand by abt 20 minutes?
15:35:09 <eedri> mrguitar, we're currently in a meeting, can you ask in 30 min
15:35:16 <mrguitar> my logs are running this every few seconds: http://fpaste.org/54815/47886401/
15:35:21 <mrguitar> no prob. Thanks guys!
15:35:29 <obasan> eedri, I have something that queries foreman on bad slaves with error status
15:35:42 <ewoud> eedri: https://github.com/jrottenberg/check_puppet is what we use on our foreman 1.2 instance
15:35:50 <knesenko> mrguitar: better to send email to users@ovirt.org
15:35:54 <ewoud> I should publish the 1.3 version
15:36:24 <eedri> ewoud, obasan do we even have alerts enabled today ?
15:36:43 <ewoud> eedri: no, monitoring is a candidate for big improvements
15:36:54 <pablohn> knesenko, I have tried it, but do not see an Edit option inside Disk
15:37:39 <knesenko> pablohn: click on the vm, at the bottom click on disks ... and select the disk ... and try to edit it
15:37:59 <obasan> eedri, about out of sync puppet, nope
15:38:11 <obasan> eedri, we have alerts on the monitored services
15:38:40 <orc_orc> ewoud:  obasan and I have been working on monitoring ticket 48 is the placeholder for suggestions, I guess
15:38:55 <orc_orc> obasan and I set up some credentials last week
15:39:04 <pablohn> knesenko, thank you, here I have the option :)
15:39:31 <obasan> orc_orc, so it might be a good idea to add this script also
15:39:44 <ewoud> orc_orc: great
15:40:06 <orc_orc> obasan: catching suggestions in 40 would also help
15:40:08 <knesenko> pablohn: you are welcome
15:40:12 <orc_orc> ... 48 ..
15:40:21 <obasan> orc_orc, ok
15:43:03 <knesenko> #topic Other Issues
15:43:19 <knesenko> do we want to talk about something else ?
15:43:32 <ewoud> it may be early, but you often have to: anyone plans to go to FOSDEM this year?
15:44:51 <knesenko> i would like to go !
15:45:21 <silver> Good day, I installed oVirt today for the first time and I'd like to add some local host on it. The problem is, that i don't know what address I need to enter to create a new local host. when I enter 127.0.0.1 or 192.168.0.1 or some of these free adresses it responds with this error:   Error while executing action: Cannot add Host. Connecting to host via SSH has failed, verify that the host is reachable (IP address, routable address etc.) You may refe
15:45:37 <orc_orc> silver: there is a meeting running atm -- could you stand by abt 20 minutes?
15:45:58 <silver> yes, of course
15:46:02 <orc_orc> silver: ty
15:46:19 <ewoud> knesenko: then I hope to see you there :)
15:46:55 <knesenko> ewoud: are you comming ?
15:47:05 <ewoud> knesenko: most likely
15:47:26 <knesenko> ewoud: ok ... hope i will meet you there
15:48:58 <knesenko> #endmeeting