15:03:04 <knesenko> #startmeeting oVirt Infra
15:03:04 <ovirtbot> Meeting started Mon Oct 28 15:03:04 2013 UTC.  The chair is knesenko. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:04 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:03:09 <knesenko> #chair obasan
15:03:09 <ovirtbot> Current chairs: knesenko obasan
15:03:11 <knesenko> ewoud: here ?
15:03:11 <backblue> ok, argument order was not right
15:03:18 <knesenko> orc_orc: here ?
15:03:26 <knesenko> Rydekull: here ?
15:04:32 <orc_orc> knesenko: hi
15:04:43 <obasan> #chair orc_orc
15:04:43 <ovirtbot> Current chairs: knesenko obasan orc_orc
15:05:33 <knesenko> #topic Hosting
15:05:40 <knesenko> ok hello everyone
15:05:51 <knesenko> dcaro is on PTO today and eedri is not here
15:05:55 <knesenko> so lets start
15:06:06 <knesenko> I have few updates regarding the hosting
15:06:24 <knesenko> rackspace03.ovirt.org was moved to another network as we wanted
15:06:39 <knesenko> so just need to install it (add it to the rackspace01 setup)
15:06:46 <knesenko> but I have few problems with it ...
15:06:47 <knesenko> :\
15:06:52 <knesenko> hope dcaro will help
15:07:03 <knesenko> that's all from my side
15:07:10 <knesenko> orc_orc: obasan any updates ?
15:07:24 <orc_orc> I sent an email to obasan last week about my getting started thoughts
15:07:46 <orc_orc> basically get credentials, do some packaging, and get a handle on the worksapce
15:08:11 <knesenko> orc_orc: ok ... obasan what's the status ?
15:08:14 <backblue> kcormier, ok, found coreduo option now, on the interface, but can't change the cluster cpu for coreduo if it have hosts assigned, wont work the "OK" button.
15:08:23 <obasan> orc_orc, I think your mail might have moved to spam :) can you please resend it?
15:08:24 <orc_orc> one question I could not answer was: is ManageIQ going to become the preferred monitoring locus
15:08:37 <orc_orc> obasan: sure -- one moment
15:08:41 <obasan> orc_orc, thanks
15:09:02 <knesenko> orc_orc: what about monitoring.ovirt.org ?
15:09:05 <obasan> orc_orc, why do we need ManageIQ with monitoring?
15:09:51 <orc_orc> obasan: my thot was that integrating tue native tools downstream may permit6 automating additions to monitoring at time of deployment hands off
15:10:15 <backblue> kcormier, after took all the machines off the CLuster, changed to CoreDuo, and changed the machines back to the cluster, it all work, no errors now. Thanks
15:10:34 <obasan> orc_orc, I think that automating additions to monitoring will be done with puppet
15:10:38 <obasan> orc_orc, that's the plan
15:10:50 <knesenko> orc_orc: if you have some interesting ideas, please send them to infra@ovirt.org
15:10:56 <knesenko> and we will discuss them there .
15:11:17 <orc_orc> okay
15:11:37 <knesenko> orc_orc: what about puppet tasks ? iirc you told that you will take some right ?
15:12:04 <backblue> what is the SPM? :o
15:12:25 <orc_orc> knesenko: yes ... I have been building out a local ovirt setup to run such under this week
15:12:36 <orc_orc> obasan: email just resent
15:12:43 <obasan> orc_orc, thank you :) I will answer
15:12:50 <knesenko> orc_orc: thanks !
15:12:59 <obasan> orc_orc, but I think it should be done on infra list
15:13:12 <knesenko> obasan: as I told before, please sent interesting ideas to infra@
15:13:22 <knesenko> ok anything else on hosting ?
15:13:29 <obasan> orc_orc, so if you don't mind I will reply and cc the infra ml
15:13:29 <orc_orc> obasan: I sent it privately as there was some credential related matter in it.  feel free to trim and repost into the infra list, or I shall do so later today
15:13:39 <orc_orc> we think alike ;)
15:13:40 <obasan> orc_orc, ok. great
15:13:53 <knesenko> orc_orc: obasan guys ... I would like to push mitoring.ovirt.org
15:14:02 <knesenko> I wan to monitor all resources that we have
15:14:10 <knesenko> disks , cpu, memory etc
15:14:31 <orc_orc> knesenko: running services, and log exceptions come to mind
15:14:38 <knesenko> orc_orc: +1
15:14:46 <knesenko> obasan: orc_orc can you take as a project ?
15:14:48 <orc_orc> the main web site dies for a missing DB backend
15:14:54 <orc_orc> knesenko: yes
15:14:59 <obasan> knesenko, yes
15:15:21 <knesenko> #action orc_orc and obasan improve monitoring.ovirt.org to monitor all servers and services
15:15:22 <orc_orc> can we get more drive space on the wiki or move the DB off to some other machine?
15:15:39 <knesenko> orc_orc: I have no idea ... the website runs on openshift
15:15:47 <knesenko> we need to check if its possible
15:16:17 <orc_orc> we usually run DB"s on non-routable back side machines and just have clients forward facing
15:16:31 <knesenko> orc_orc: that's how it should be
15:16:56 <knesenko> ok ...
15:17:07 <knesenko> will skip jenkins and foreman topics
15:17:10 <orc_orc> #info there was another action item on my list of checking taht iptables rules were properly set up, as there were unexpected answers when nmapping
15:17:20 <knesenko> and I would like to review the ticket statuses
15:17:42 <knesenko> https://fedorahosted.org/ovirt/report/1
15:17:52 <knesenko> #topic review tickets
15:17:59 <knesenko> orc_orc: obasan https://fedorahosted.org/ovirt/report/1
15:18:21 <orc_orc> noted and on my personal booklark list, actually
15:19:41 <knesenko> lets sort tasks by Owner
15:19:57 <knesenko> I would like to review all @infra assgined tickets
15:20:09 <knesenko> https://fedorahosted.org/ovirt/ticket/73
15:20:45 <knesenko> that's mine code ... I will fix it
15:21:27 <knesenko> https://fedorahosted.org/ovirt/ticket/78
15:21:55 <knesenko> obasan: please handle this one ^^
15:22:17 <knesenko> https://fedorahosted.org/ovirt/ticket/44
15:22:21 <obasan> knesenko,
15:22:23 <obasan> knesenko, ok
15:22:43 <knesenko> orc_orc: want to take https://fedorahosted.org/ovirt/ticket/44 ?
15:22:45 <orc_orc> 44 looks like just installing awstats perhaps with a central log server
15:22:49 <orc_orc> sure
15:22:58 <knesenko> orc_orc: great !
15:23:01 <knesenko> assign to you
15:23:27 <orc_orc> done
15:23:38 <orc_orc> saving custom queries in teh trac is not working for me atm
15:24:05 <orc_orc> will address later
15:24:23 <knesenko> orc_orc: ok
15:24:24 <knesenko> https://fedorahosted.org/ovirt/ticket/77
15:24:37 <knesenko> obasan: ^^
15:24:38 <knesenko> ?
15:25:28 <obasan> knesenko, I can handle that
15:25:29 <orc_orc> is this safe or should there be a periodic reboot and clean to make sure running processes are not surprised?
15:25:52 <knesenko> orc_orc: what do you mean ?
15:26:08 <knesenko> are you talking about #77 ?
15:26:25 <orc_orc> if a working file in /tmp is in use, byt a long running test process, when interim results disappear dissapear, one can get error states
15:26:30 <orc_orc> yes as to 77
15:26:53 <knesenko> orc_orc: mmm ...
15:26:57 <orc_orc> some processes I run locall can take over a week to complete ...
15:27:20 <knesenko> orc_orc: we have jobs ... and job should take +- 1 hour max
15:27:22 <knesenko> so ...
15:27:27 <orc_orc> ok
15:27:31 <knesenko> I don't think we care about that ...
15:27:37 <knesenko> because those are only slaves
15:27:42 <obasan> orc_orc, if something is taking 3 hours then it won't succeed anyhow
15:27:57 <knesenko> if we see problem with a slave , we just reboot it or reinstall
15:28:11 <orc_orc> on one process one java rebuild process and test takes over a week, which is what I am used to protecting
15:28:54 <knesenko> orc_orc: :\
15:29:13 <knesenko> orc_orc: actually we now have problems with slaves
15:29:19 <knesenko> orc_orc: Some of them just stuck
15:29:39 <knesenko> load average is high
15:29:54 <knesenko> need to monitor it or something ...
15:29:58 <orc_orc> as it is Halloween,. perhaps adding a 'grim reaper' for such is in order ;)
15:30:04 <knesenko> I didn't have time for it
15:30:05 <clarkee> hah
15:30:08 <obasan> knesenko, the solution might need be to decrease # of executors
15:30:15 <knesenko> obasan: possible
15:31:17 <knesenko> obasan: please take this as wel https://fedorahosted.org/ovirt/ticket/72
15:31:47 <obasan> knesenko, ok
15:31:58 <orc_orc> to whom should that job report problems?
15:32:08 <knesenko> orc_orc: do you want to take something else to work on ?>
15:32:08 <obasan> orc_orc, infra
15:32:28 <orc_orc> I have written taht in the past, and when sent a ML, it tends to get ignored
15:32:28 <knesenko> orc_orc: it will sent emails to infra
15:32:44 <knesenko> orc_orc: as infra members we don
15:32:46 <orc_orc> I can work with obasan on getting that added then
15:32:50 <knesenko> 't ignore those emails
15:32:55 <knesenko> orc_orc: please do
15:33:09 <orc_orc> taken ...
15:33:14 <knesenko> good
15:33:19 <knesenko> anything else guys /
15:33:19 <knesenko> ?
15:34:04 <knesenko> ok thanks !
15:34:12 <obasan> knesenko, +1
15:34:14 <knesenko> #endmeeting