13:01:39 <mburns> #startmeeting oVirt Weekly Meeting
13:01:39 <ovirtbot> Meeting started Tue Sep 17 13:01:39 2013 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:39 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:01:53 <mburns> #topic agenda and roll call
13:02:08 * mburns wonders who will show up today given the late change in the meeting invite
13:02:49 * sbonazzo here
13:03:00 * Rydekull is here by chance and accident :-P
13:03:06 <Rydekull> Not that im supposed to be here, but yeah
13:03:20 <mburns> clarkee: just a note -- if you need help with your existing stuff (corosync, etc), you get help in #linux-cluster on feenode
13:03:36 <mburns> #topic oVirt 3.3
13:03:43 <mburns> #topic oVirt Next
13:03:51 <mburns> #topic Conferences and workshops
13:03:58 <mburns> argh...
13:04:00 <clarkee> mburns: ty
13:04:03 <mburns> those were supposed to be info
13:04:09 <mburns> #topic agenda and roll call
13:04:17 <mburns> #info oVirt 3.3
13:04:18 * oschreib here
13:04:25 <mburns> #info oVirt Next
13:04:25 * oschreib had some troubles with oftc
13:04:36 <mburns> #info Conferences and workshops
13:04:39 <mburns> #chair oschreib
13:04:39 <ovirtbot> Current chairs: mburns oschreib
13:05:01 <mburns> clarkee: not that i'm trying to send you away from oVirt
13:05:22 <mburns> but just so you can choose what's best for you in your situation
13:06:10 <mburns> #topic oVirt 3.3
13:06:14 <mburns> #info is RELEASED!!!!
13:06:30 <mburns> #info packages posted to stable repos yesterday
13:06:42 * fabiand opens the freshbottle of milk to celebrate!
13:06:42 <mburns> #info release notes, wiki, etc updated yesterday
13:06:49 <mburns> #info announcement sent to mailing lists today
13:06:54 * sbonazzo join fabiand
13:06:59 <oschreib> hallelujah
13:07:34 <mburns> now, that being said -- there are a couple of critical issues that we should get fixed very quickly in an update
13:07:39 <mburns> oschreib: do you have a list of issues?
13:08:00 <oschreib> I don't have a bug list
13:08:03 <oschreib> bug we have
13:08:18 <oschreib> 1. IDE disk issue (jbrooks encountered it)
13:08:32 <oschreib> 2. api.vms.list() issue
13:08:47 <oschreib> 3. storage pools search (which is already merged)
13:09:11 <mburns> #info some known issues with 3.3.0 release targeted for a quick 3.3.1 update
13:09:18 <mburns> #info IDE disk issue (jbrooks encountered it)
13:09:25 <mburns> #info api.vms.list() issue
13:09:33 <mburns> #info storage pools search (which is already merged)
13:09:34 <oschreib> 3.3.1 should be a short release, probably next week
13:09:39 <oschreib> I'll handle the branching
13:09:59 <sahina> oschreib, there's also a gluster storage domain issue which causes error if volume has _ or /
13:10:19 <sahina> oschreib, i mean volume name has _ or /
13:10:43 <mburns> #info there's also a gluster storage domain issue which causes error if volume name has _ or /
13:10:43 <oschreib> sahina: do we have a fix for it?
13:10:57 <sahina> oschreib, yes patch http://gerrit.ovirt.org/19219 under review
13:11:42 <oschreib> I'll create the 3.3.1 branch shortly.
13:11:52 <oschreib> on top of 3.3.0
13:11:53 <mburns> oschreib: sahina:  we should target high priority, critical issues
13:11:59 <mburns> for 3.3.1
13:12:16 <oschreib> REALLY critical issues, otherwise, we have 3.3.2
13:12:18 <mburns> #info 3.3.2, as requested, will be a rebase of ovirt-engine
13:12:37 <mburns> #info all non-critical issues should go to 3.3.2
13:12:55 <oschreib> #action oschreib to handle branching and related stuff of 3.3.1 and 3.3.2
13:13:03 <mburns> oschreib: thanks
13:13:59 <mburns> anything else needed for 3.3?
13:14:05 <mburns> oh, yes
13:14:15 <oschreib> no, I'll do all the work until Sunday.
13:14:30 <mburns> #info issue with gluster domains on EL6 -- they don't work due to old qemu/libvirt
13:15:03 <mburns> #info there is work going on to produce something like virt-preview for EL6 (similar to fedora virt-preview)
13:15:20 <oschreib> mburns: I think we should close the 3.3 tracker, and open 3.3.2 and 3.3.1 trackers
13:15:22 <mburns> #info should have an answer soon as to whether that will work out or not
13:15:26 <mburns> oschreib: sure
13:16:16 <mburns> i think that's it for 3.3
13:16:30 <mburns> #topic oVirt Next
13:16:34 <oschreib> oh yes!
13:16:43 <mburns> oschreib: for 3.3?
13:16:48 <mburns> or next?
13:16:50 <oschreib> yep
13:16:53 <oschreib> for 3.3
13:17:07 <mburns> #topic oVirt 3.3 (revisited)
13:17:31 <oschreib> no
13:17:35 <oschreib> you got me wrong :)
13:17:45 <oschreib> I was just happy we finished with 3.3
13:17:53 <mburns> oh, ok
13:18:00 <mburns> #topic oVirt Next
13:18:17 <mburns> #info open thread on users@ for feature requests
13:18:37 <mburns> #info please comment on desired features, what you want to work on, etc
13:18:50 <sbonazzo> mburns: there's an open thread also on linkedin
13:19:00 <mburns> #info we'll start prioritizing features soon for the next release
13:19:08 <mburns> #info there is an open thread on linkedin as well
13:20:44 <mburns> #info we'll also start working out dates and plans soon for the next release
13:20:55 <mburns> i'd do it now, but i don't think we have enough information
13:21:13 <mburns> any comments on oVirt next?
13:22:13 <sahina> mburns, it would be good to know tentative timeline so that we can commit to features
13:22:42 <sahina> mburns, we need to make sure gluster release is out before ovirt for dependent features
13:23:10 <mburns> sahina: i could give you a date, but it wouldn't really mean anything
13:23:26 <sahina> mburns, :)
13:23:42 <mburns> sahina: do you have tentative dates for gluster?
13:24:24 <itamar> jumping in...
13:24:31 <itamar> on 3.4 i want to change things a bit.
13:24:33 <sahina> mburns, i think there's a gluster release in oct/nov. but need to confirm
13:24:47 <itamar> i'll send a more clear email on the approach i want to promote.
13:24:48 <mburns> sahina: we'll be long after that
13:24:58 <mburns> we're usually more like 6 months or so
13:24:59 <itamar> but i'd like us to move to monthly versions.
13:25:10 <itamar> i.e., 3.4.0, 3.4.1, 3.4.2, etc.
13:25:17 <mburns> itamar: that seems aggressive
13:25:22 <itamar> we'll still change 3.4/3.5 every 6 months.
13:25:28 <mburns> itamar: ok
13:25:41 <mburns> itamar: that matches with roughly what we're thinking anyway...
13:25:49 <mburns> 3.3.1 coming out asap for critical issues
13:25:53 <mburns> and 3.3.2 in about 1 month
13:25:57 <itamar> we'll just work in iterations, and make things more consumable/tested.
13:26:07 <itamar> well, you're talking patch releases, and I'm talking feature releases...
13:26:22 <mburns> 3.3.2 is a feature release if we rebase
13:26:35 <mburns> itamar: let's take it to the arch/board lists
13:26:37 <itamar> yes, but an exception in 3.3. in 3.4 i want it to be more clear.
13:26:41 <sahina> itamar, so when we plan for major features, which release do we target? point release or major?
13:26:42 <itamar> that's my plan...
13:26:48 <mburns> seems too big a topic for this meeting
13:27:01 <mburns> but does let me say "let's move on until the release process is better defined
13:27:10 <itamar> point release will have the features, disabled by default. enabled for the next minor release.
13:27:19 <itamar> yes - lets keep 3.4 planning for a bit.
13:27:21 <itamar> for 3.x
13:27:26 <itamar> sorry, for 3.3.x
13:27:45 <itamar> i've asked to add target release for ovirt bugs to cover 3.3.1, 3.3.2, etc. so we can track critical bugs to a specific release.
13:27:58 <itamar> let's say, a monthly one.
13:28:14 <itamar> but it shouldn't prevent us from releasing a re-spin of the previous one with a critical patch.
13:28:35 <mburns> itamar: agreed that it won't prevent critical re-spin
13:28:44 <itamar> i.e., if we planned 3.3.1 for a month, with proper testing (due to rebase, etc.), and 3.3.2 a month after it (since it will have 50 patches in it)
13:28:53 <itamar> then if we re-spin 3.3.0 for critical issues it should be 3.3.0.1
13:29:12 <itamar> as it doesn't make sense to change all the bugs slated for target release 3.3.1/3.3.2 one version forward.
13:29:25 <mburns> itamar: let's get a decision on the process first, then we'll worry about naming, etc
13:29:31 <itamar> (obviously, we can decide based on timing we want to release 3.3.1/3.3.2.
13:29:49 * mburns would rather see 3.3.0-x+1 rather than 3.3.0.1
13:30:09 <mburns> but those are details to be worked out
13:30:21 <mburns> so let's take it to the list and decision can be made there
13:30:22 <itamar> i'm fine with that as well, ofer had a concern about that approach when i discussed with him,
13:30:41 <mburns> sure, but we can hash out details on list
13:30:43 <itamar> I think monthly versions make sense scheduling wise.
13:30:45 <mburns> for now --
13:31:01 <mburns> #info deferring oVirt Next discussions until we have release process ironed out
13:31:11 <mburns> #action itamar to take release discussion to mailing list
13:32:23 <mburns> #topic Conferences and Workshops
13:32:42 <mburns> #info a number of upcoming events are listed on http://www.ovirt.org/Home
13:33:08 <mburns> #info includes CloudOpen/LinuxCon in NA (going on now) and EU (21-23 October)
13:33:16 <oschreib> mburns: about x+1 -> we shouldn't do that, we're releasing tarball, which is named n-v-r, the release is just a property of rpm
13:33:32 <mburns> oschreib: true
13:33:41 * mburns just doesn't like the 3.3.0.1...
13:33:57 <mburns> #info also, oVirt developers summit happening with KVM Forum
13:34:05 <mburns> dneary: any other conference/workshop stuff?
13:34:14 <mburns> #info details on the wiki for these events
13:35:29 <mburns> #info planning has started for a Workshop in the RTP area (Raleigh, NC)
13:35:35 <dneary> I have some proposals for sessions for the developers summit
13:35:49 <mburns> #info dates and additional info still pending
13:35:58 <dneary> One on Spice/VDI, one opn storage, one on networking/SDN, and one on the UI and usability
13:36:10 <dneary> I am still looking for session ideas and leaders, though.
13:37:03 <mburns> dneary: is there interest in doing is in a barcamp type style?
13:38:23 <mburns> maybe have some sessions ready, but let people who are there drive the talks/discussions/topics?
13:40:06 <mburns> #info looking for additional session ideas/leaders for the developer workshop
13:40:35 <mburns> ewoud: eedri:  no updates from infra this week, right?  (i think i saw that you skipped meeting this week)
13:42:22 <oschreib> mburns: eedri is sick
13:42:30 <oschreib> so probably not here
13:42:48 <mburns> ok, thanks
13:42:58 <mburns> #topic Other Topics
13:43:01 <mburns> anything else?
13:43:27 <mburns> going once...
13:44:55 <mburns> twice..
13:45:45 <mburns> gone.
13:45:47 <Rydekull> \o/ Good work on 3.3 :-)
13:45:51 <mburns> #info no other topics
13:45:54 <mburns> Thanks all
13:45:57 <mburns> #endmeeting