14:00:55 <mgoldboi> #startmeeting oVirt Weekly Meeting
14:00:56 <ovirtbot> Meeting started Wed Jul 10 14:00:55 2013 UTC.  The chair is mgoldboi. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:56 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:44 * mgoldboi here
14:02:18 * mburns lurking today (distracted/conflict)
14:02:25 * ecohen here
14:02:28 * lvernia here
14:02:32 * theron here
14:03:04 <mgoldboi> #topic 3.3 Status Update
14:03:34 <mgoldboi> #link http://www.ovirt.org/index.php?title=OVirt_3.3_release-management
14:04:02 <mgoldboi> #info Feature Freeze 2013-07-15 (Next Monday)
14:04:31 <mgoldboi> (first time for me running this meeting) - please be patient
14:04:56 <mgoldboi> let's go over 3.3 features updates per topic
14:05:08 <mgoldboi> starting with virt features
14:05:22 <mgoldboi> mskrivanek: can you please update the status on virt
14:05:58 <mgoldboi> mskrivanek: let's focus on the "non-green" features
14:06:30 <mgoldboi> ofrenkel: virt update from you maybe?
14:07:48 <mgoldboi> moving on to infra
14:08:15 <mgoldboi> ybronhei: any updates on infra features for 3.3?
14:09:05 * ofri here
14:09:08 <mgoldboi> well, i guess all are really busy on development...
14:09:21 <ofrenkel> we are trying to make it happen
14:09:21 <ybronhei> mgoldboi: we're testing last issues about ssh fingerprint and public key auth methods
14:09:22 <mskrivanek> mgoldboi: sure
14:09:38 <mgoldboi> guys one by one
14:09:43 <mskrivanek> mgoldboi: cloud-init is at risk, it has issues on merge and is not yet in
14:09:59 <mgoldboi> ybronhei: infra - non green features
14:10:04 <mskrivanek> i missed the "moving to", sorry:)
14:10:26 <ybronhei> mgoldboi: supervdsm service is green already..
14:10:40 <mgoldboi> ybronhei: ExternalTasks is the only one not green, status?
14:11:14 <ybronhei> mgoldboi: in progress, will be until the 15th
14:11:30 <ybronhei> mgoldboi: anything else?
14:11:49 <mgoldboi> #info infra 3.3: ExternalTasks feature development in progress will make feature freeze
14:12:03 <ybronhei> yep
14:12:07 <mgoldboi> ybronhei: Device Custom Properties - missing test page
14:12:31 <ybronhei> mgoldboi: I'll raise it .. didn't notice. thanks
14:12:44 <mgoldboi> moving on to virt
14:12:55 <mgoldboi> mskrivanek: updates on non-green
14:13:07 <mgoldboi> mskrivanek:  RAM Snapshots?
14:13:35 <mskrivanek> in progress, REST is at risk, but the rest seems to make it by 15th
14:14:00 <mskrivanek> the rest I made green except for cloud-init, we got stuck there a little bit
14:14:51 <ofrenkel> well cloud init is ok except REST
14:15:01 <mgoldboi> #info virt: RAM Snapshots feature in progress, REST is at risk, but the rest seems to make it by 15th
14:15:20 <mgoldboi> mskrivanek: testing pages for features?
14:15:24 <mskrivanek> ofrenkel: is it now? still need at least 5 of 6 patches to get merged
14:15:24 <ofrenkel> pushing final version to review now
14:15:45 <ofrenkel> i just finished verifying
14:16:12 <mskrivanek> testing pages are still missing for half of the features. plan is to have them by end of week, but it's a second priority to finishing the feature
14:17:09 <mgoldboi> #info virt: test pages will be completed by end of week (best effort)
14:17:20 <mgoldboi> mskrivanek: thanks for the update
14:17:50 <mgoldboi> #info virt: all features are green except  RAM Snapshots
14:18:08 <ofrenkel> and cloud-init..
14:18:31 <mgoldboi> ofrenkel: thanks missed it
14:18:51 <mgoldboi> ofrenkel: is it still red or moved to orange?
14:19:22 <ofrenkel> now red, i will update once i see progress on review
14:19:42 <mgoldboi> ofrenkel: will it be ready for feature freeze?
14:20:40 <ofrenkel> engine+ui for sure, REST not sure
14:20:58 <mgoldboi> #info virt: Cloud-Init Integration currently on Red - patches are on their way, still in risk for feature freeze
14:21:13 <mgoldboi> moving on to networking - danken?
14:22:11 <lvernia> mgoldboi: I'll fill you in.
14:22:17 <mgoldboi> lvernia: thanks
14:22:36 <mgoldboi> lvernia:  Quantum Integration (name should be changed?)
14:22:39 <lvernia> mgoldboi: Both orange features are progressing, will be on time.
14:22:49 <lvernia> mgoldboi: Yes, Neutron integration :)
14:22:54 <mgoldboi> lvernia: test pages for the features?
14:23:23 <mgoldboi> #info networking Quantum Integration in progress, will make it to feature freeze
14:23:43 <mgoldboi> #info networking:NetworkReloaded in progress, will make it to feature freeze
14:23:57 <lvernia> mgoldboi: I would respond as Michal, second priority :)
14:24:13 <lvernia> mgoldboi: It's still an effort to finish the features on time.
14:24:34 <mgoldboi> #info networking: test pages will be completed by end of week (best effort)
14:24:49 <lvernia> apuimedo: You wanna add something about Network Reloaded?
14:25:39 <lvernia> mgoldboi: Sorry, I was referring to Neutron integration and to Multiple Gateways, not Network Reloaded.
14:26:03 <apuimedo> Network reloaded has seen some api cleanups and improvements over the last week
14:26:09 <lvernia> mgoldboi: I actually think Network Reloaded shouldn't be there, mburns asked it to be removed from the board last week.
14:26:16 <apuimedo> and is currently being worked in two fronts
14:26:20 <apuimedo> unified persistence
14:26:24 <mburns> oh, i forgot to remove it...
14:26:25 <mburns> sorry
14:26:28 <apuimedo> and iproute2 configurator
14:26:40 <apuimedo> but it didn't make the deadline
14:26:52 <apuimedo> so those two things will be for next time
14:26:53 <mgoldboi> apuimedo: when do you think it can make it?
14:27:44 <mgoldboi> apuimedo: if it's more than few days slide we can drop it from this release though
14:28:13 <mburns> mgoldboi: all node features are green
14:28:31 <mgoldboi> #info networking: Multiple Gateways in progress - will make it to feature freeze
14:28:38 <apuimedo> mgoldboi: I don't know yet
14:28:45 <apuimedo> I'm working on it
14:28:50 <mgoldboi> apuimedo: ok, thanks
14:29:50 <mgoldboi> #info networking: NetworkReloaded will probably not make it in, keeping it on wiki hoping for a quick turnaround
14:30:10 <mgoldboi> #info node: all features are green
14:30:22 <mgoldboi> storage time - amureini any updates?
14:31:35 <amureini> mgoldboi, Edit Connections is at a risk
14:31:35 <mgoldboi> SLA - doron / ofri ?
14:31:42 <ofri> yes
14:31:44 <mgoldboi> amureini: back to you...
14:31:56 <mgoldboi> #info storage:  Edit Connections is at a risk
14:32:18 <mgoldboi> amureini: Read Only Disks?
14:32:37 <amureini> mgoldboi, was pushed out to 3.4 - not a must feature
14:32:55 <amureini> mgoldboi, if it's not updated on the wiki it's a bug, AI on me to fix it
14:32:55 <mgoldboi> amureini: so let's drop it from the table
14:33:04 <amureini> mgoldboi, see above :-)
14:33:22 <mgoldboi> #action amureini update storage features on release table
14:33:49 <mgoldboi> amureini: need to add Edit Connection Properties to the table as well
14:34:00 <amureini> mgoldboi, ack
14:34:22 <mgoldboi> amureini: any other items which should get in, which aren't in green status?
14:34:34 <amureini> mgoldboi, nope
14:34:44 <mgoldboi> amureini: thanks
14:34:54 <mgoldboi> ofri: back to you - SLA updates
14:35:03 <ofri> Network QoS - patches are in (on review)
14:35:29 <ofri> Scheduling API and Schedualer - patches are in (on review)
14:35:34 <mgoldboi> ofri: will make to feature freeze?
14:36:03 <ofri> hopfully yes
14:36:15 <ofri> QoS should be merged soon
14:36:34 <ofri> Schedualing takes a lot of review work
14:36:41 <mgoldboi> #info SLA: Network QoS - patches are in (on review) - at risk for feature freeze
14:37:03 <mgoldboi> #info SLA: Scheduling API and Schedualer - patches are in (on review) - at risk for feature freeze
14:37:22 <mgoldboi> #info SLA: QoS should be merged soon
14:37:23 <ofri> mgoldboi:  QoS not at risk. it looks good
14:37:36 <ofri> Trusted compute pools - merged
14:37:51 <ofri> Watchdog - most parts merged. still working on REST API (on review)
14:38:05 <ofri> will be on time
14:38:22 <mgoldboi> #info SLA: Watchdog - most parts merged. still working on REST API (on review)
14:38:56 <mgoldboi> ofri: test pages?
14:39:16 <ofri> only for watchdog and TCP for now
14:39:37 <ofri> QoS test pages will be added shortly
14:40:07 <ofri> Schedualer - probobly wont have test pages ready
14:40:07 <mgoldboi> #info: SLA: test pages will be completed soon (best effort)
14:40:29 <mgoldboi> ofri: thanks for the update
14:41:11 <mgoldboi> sahina: gluster updates (i know it's kind of late in India already, next time we start with you...)
14:41:53 <sahina> mgoldboi, sure. thanks
14:41:56 <sahina> gluster hooks - rest api patch resubmitted after comments. if approved, we can make it
14:42:15 <sahina> gluster services- we have a +1 on vdsm patch from danken. need to get this merged by fri.
14:42:28 <mgoldboi> #info gluster: gluster hooks - rest api patch resubmitted after comments. if approved, can make it to feature freeze
14:42:39 <sahina> gluster services- we have a +1 on vdsm patch from danken. need to get this merged by fri.gluster services rest api - in progess. will try to make it for ff.
14:43:14 <mgoldboi> #info gluster: gluster services - patches are in review
14:43:31 <sahina> test pages for both features not yet in. will try to do so by early next week
14:44:00 <mgoldboi> #info gluster: test pages will be completed early next week (best effort)
14:44:11 <mgoldboi> sahina: thanks
14:44:50 <mgoldboi> #info integration: Otopi Infra Migration - base flows are working - fixing several bugs - will make feature freeze
14:45:23 <mgoldboi> #info integration: Self Hosted Engine - at risk for feature freeze - will probably wouldn't make it
14:45:45 <mgoldboi> #info integration: test pages will be completed next week
14:45:56 <mgoldboi> UX - ecohen your turn...
14:46:18 <ecohen> mgoldboi, two red items - won't make it to FF (I will remove them from the table)
14:46:51 <mgoldboi> #info UX:   FrontendRefactor and GWT Platform Upgrade will not make it into feature freeze
14:46:59 <mgoldboi> ecohen: test pages?
14:47:36 <ecohen> mgoldboi, for IE Performance improvements and branding package? they are not really typical "features", I am not sure if they need test pages.
14:47:43 <mgoldboi> ecohen: :)
14:48:02 <mgoldboi> ecohen: please add N/A to relevant sections...
14:48:07 <ecohen> mgoldboi, I will.
14:48:24 <mgoldboi> #info Beta builds should be prepared and delivered to mburns by Tuesday  2013-07-16 (Require:  F18, EL6, would like F19 as well)
14:48:24 <mgoldboi> - mburns to post on Tuesday
14:48:52 <mgoldboi> #action mburns to post packages on Tuesday
14:49:24 <mgoldboi> thanks for all the updates
14:49:52 <mgoldboi> as i wrote builds should be delivered to mburns for all packages
14:49:58 <mgoldboi> #topic Conference and Workshop
14:50:09 <mgoldboi> theron: dneary: any updates?
14:50:24 <dneary> mgoldboi, I'll let theron take this one
14:50:31 <mgoldboi> #chair theron
14:50:31 <ovirtbot> Current chairs: mgoldboi theron
14:51:41 <mburns> mgoldboi: CFP for KVM Forum, CloudOpen EU and LinuxCon EU closes on July 21
14:52:04 <mgoldboi> #info CFP for KVM Forum, CloudOpen EU and LinuxCon EU closes on July 21
14:52:37 <mgoldboi> #chair mburns
14:52:37 <ovirtbot> Current chairs: mburns mgoldboi theron
14:52:54 <mgoldboi> mburns: would you like to share a few words here?
14:53:24 <mburns> mgoldboi: just that people who are planning to attend the oVirt Developer meetings or planning to submit talks should be aware of the date
14:53:53 <mgoldboi> mburns: thanks.
14:54:19 <mgoldboi> dneary: any additions before we proceed?
14:54:37 <dneary> mgoldboi, I'm sorry, I don't have any info on workshops
14:54:50 <dneary> We made another update of the oVirt website last week
14:55:12 <mgoldboi> dneary: ok moving to infra
14:55:38 <mgoldboi> #topic Infra update
14:55:54 <mgoldboi> dneary: any details on the new website?
14:56:06 <mgoldboi> update..
14:56:08 <dneary> mgoldboi, A couple of bug fixes
14:56:29 <dneary> With more coming - specifically, we're going to have a fix soon for context highlighting of code in wiki pages
14:56:46 <mgoldboi> #info A couple of bug fixes were made to oVirt website. With more coming - specifically, we're going to have a fix soon for context highlighting of code in wiki pages
14:57:06 <dneary> Last week's fix was ~font issues
14:57:22 <mgoldboi> knesenko: ewoud any infra updates this week?
14:58:05 <ewoud> mgoldboi: I know knesenko is working on installing more jenkins slaves now ovirt is installed on the rackspace machines
14:58:40 <knesenko> Hello all ...
14:58:56 <knesenko> Some news regarding the infra
14:59:07 <mgoldboi> #chair knesenko
14:59:07 <ovirtbot> Current chairs: knesenko mburns mgoldboi theron
14:59:33 <knesenko> our team did a great job from my opinion
14:59:39 <knesenko> so updates ...
14:59:51 <knesenko> we have foreman installed + puppet running on it
15:00:12 <knesenko> rackspace servers were installed with local storage DCs
15:00:14 <mgoldboi> #info infra: forman instance is installed
15:00:29 <mgoldboi> #info infra: rackspace servers were installed with local storage DCs
15:00:33 <knesenko> we started to install new slaves on it
15:00:50 <knesenko> currently we have 5 F19 slaves on it ... will install more in the future .
15:00:57 <mgoldboi> knesenko: what would be the slave count after this deplyment?
15:01:06 <knesenko> the plan is to install f18 and centos64
15:01:19 <knesenko> mgoldboi: I think 20-25 slaves
15:01:22 <knesenko> matbe more
15:01:33 <knesenko> maybe
15:01:53 <mgoldboi> #info infra: Fedora 18/19  and centos64 OS will be distributed over 20-25 slaves
15:01:53 <knesenko> jenkins was upgraded
15:02:09 <knesenko> a lot of job fixes/slaves upgrades
15:02:32 <knesenko> improved the backup for jenkins.ovirt.org
15:02:39 <mgoldboi> #info infra: jenkins version was upgraded, lots of job maintenance was done
15:02:59 <knesenko> it will be great if there will be some external storage for backups
15:03:10 <mgoldboi> #info infra: backup infra for jenkins.ovirt.org was improved
15:03:35 <knesenko> we have install monitoring system
15:03:56 <mgoldboi> knesenko: any details on it?
15:04:10 <knesenko> one sec .... looking for obasan
15:04:46 <knesenko> also new infra layout was proposed for the infrastructure ...
15:05:02 <knesenko> and was approved by the team
15:05:24 <mgoldboi> #info infra: new infra layout was proposed and approved for the infrastructure
15:05:32 <knesenko> rackspace servers were added to puppet
15:05:38 <knesenko> will add slaves as well ....
15:06:04 <knesenko> and we will start working to add more puppet classes and make things easier and less manual
15:06:42 <mgoldboi> #info infra: servers and slaves were added to puppet/forman, puppet classes additions will be started soon
15:06:46 <mgoldboi> knesenko: thanks
15:06:47 <knesenko> i think that;s it for now ...
15:07:06 <knesenko> the major focus is rackspace/puppet/jenkins
15:07:09 <mgoldboi> #topic Other Topics
15:07:29 <mgoldboi> does anybody has something to bring to this table?
15:08:38 <mgoldboi> closing in 3...
15:08:43 <mgoldboi> 2..
15:08:47 <mgoldboi> 1.
15:08:52 <mgoldboi> #endmeeting