14:00:28 <mburns> #startmeeting oVirt Weekly Meeting
14:00:28 <ovirtbot> Meeting started Wed Jun  5 14:00:28 2013 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:28 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:32 <mburns> #topic agenda and roll call
14:00:42 <mburns> oschreib_: wow -- i was all of 10 seconds late ;-)
14:00:55 <mburns> #chair oschreib_ ewoud
14:00:55 <ovirtbot> Current chairs: ewoud mburns oschreib_
14:00:57 <oschreib_> mburns: :)
14:01:00 * ofri here
14:01:14 <dneary> hi all
14:01:18 <mburns> #info 3.2 Updates
14:01:21 <mburns> #info 3.3 status
14:01:32 <mburns> #info conferences and workshops
14:01:35 <mburns> #info infra update
14:01:40 <mburns> #info other topics
14:01:56 <oschreib_> mburns: just an small update: mgoldboi won't be online today
14:02:04 <mburns> oschreib_: ok
14:02:22 <mburns> oschreib_: side note -- can either you or mgoldboi handle the meeting next week?
14:02:30 * mburns is going to be at Red Hat Summit all day
14:02:39 <theron> Hi everyone :)
14:02:40 <mburns> (though talking about oVirt at the booth)
14:02:42 * lvernia here
14:02:56 <oschreib_> mburns: I have to check my schedule, but I don't think it's going to be a problem
14:03:06 <mburns> oschreib_: ok, thanks
14:03:27 <mburns> #topic 3.2 updates
14:03:40 <mburns> #info 3.2.2 is live (pushed early last week)
14:03:55 <mburns> #info vdsm update coming soon
14:04:07 <mburns> dougsland: fsimonce:  update on vdsm build?
14:04:54 * dneary is also going to be at the Summit
14:04:59 <dougsland> mburns, yes.
14:05:20 <dneary> mburns, We should have some kind of process for announcing stable updates
14:05:27 <dneary> Is it too late to announce 3.2.2?
14:05:33 <dneary> (I mean, on the website)
14:05:33 * theron will be w/ mburns standing talking about oVirt
14:06:01 <mburns> dneary: we can certainly announce something
14:06:31 <mburns> dneary: i normally send something to announce@
14:06:41 <mburns> but didn't this time (i didn't have the details on what was fixed
14:06:58 <mburns> dougsland: when can we expect the build of vdsm? this week?
14:07:08 <theron> if we can get that I can add it to the website yet this week mburns
14:08:02 <dougsland> mburns, I have built yesterday vdsm-4.10.3-17 on Fedora, need the votes to get pushed.
14:08:16 * oschreib_ hopes his connection will last until the end of this meeting.
14:08:53 <mburns> dougsland: ok, i need a scratch build to get vdsm-gluster and an el6 build
14:09:25 <dougsland> mburns, sure.
14:09:48 <mburns> #info vdsm build to be made available in updates testing later this week (hopefully today)
14:10:00 <mburns> #info to move to stable next week if no issues are found
14:10:57 <mburns> #info ovirt-node respin to pick up the new vdsm will happen shortly as well
14:11:31 <mburns> oschreib_: do you have details on what was fixed in the 3.2.2 update?
14:11:40 <mburns> can you get them to theron?
14:11:54 <oschreib_> I can try to find a list of bugs
14:12:00 <mburns> oschreib_: thanks
14:12:02 <theron> thanks oschreib_
14:12:19 <mburns> #topic oVirt 3.3 updates
14:13:15 <mburns> #link http://www.ovirt.org/OVirt_3.3_release-management
14:13:26 <dneary> mburns, I contacted Deepak Shetty and Sharad Mishra from IBM to get info on when they expected features to land
14:13:27 <mburns> #info updated dates are posted to the Release Management page
14:13:36 <dneary> Looks like the backup/restore API wion't be for 3.3
14:13:50 <dneary> But Gluster storage domain should be good to go already
14:13:52 <mburns> #info backup/restore api likely to miss 3.3
14:14:02 <mburns> #info gluster storage domain should be good to go already
14:15:04 <mburns> #info many geatures still show "Red" status without anticipated completion date
14:15:07 <mburns> #undo
14:15:07 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0xa40316c>
14:15:09 <mburns> #info many features still show "Red" status without anticipated completion date
14:15:41 <mburns> #info these dates are being organized by mgoldboi
14:16:03 <mburns> #info dates should be available on the chart by next week's meeting
14:18:20 <mburns> #info not much else to discuss until we have the feature information next week
14:18:55 <mburns> #info features without Release Priority and/or target date *will* be dropped after next week's meeting
14:18:57 <apuimedo> for the networking stuff
14:19:10 <mburns> apuimedo: ok
14:19:16 <apuimedo> mutliple gateways already has two patches posted and is undergoing review
14:19:33 <apuimedo> tomorrow there will be a meeting in #vdsm at freenode to discuss the finer points of it
14:19:52 <apuimedo> and for the network reloaded feature we got merged 4 or five patches more
14:20:09 <apuimedo> and decided on the remaining design open questions
14:20:11 <mburns> #info network feature:  multiple gateways:  moving to Orange -- some patches posted, under review
14:20:23 <mburns> #info meeting in #vdsm on Freenode tomorrow to discuss/review
14:21:09 <mburns> #info Network Reloaded:  design questions answered and more patches merged
14:21:53 <apuimedo> mburns: thanks
14:22:02 <mburns> apuimedo: security groups and labels are probably going to be deferred?
14:22:10 <mburns> apuimedo: any update on quantum integration?
14:22:18 <mburns> (those are the other network features that aren't green)
14:22:47 <apuimedo> mburns: I'll get back to you on those
14:22:53 <mburns> apuimedo: ok, thanks
14:23:02 <mburns> anyone have other features to discuss?
14:23:19 <mburns> otherwise, i'll defer other discussions until we have dates/priorities set for each next week
14:24:00 <ofri> SLA
14:24:16 <ofri> trusted compute pulls
14:24:46 <ofri> starting to see the end
14:25:03 <ofri> still some minor changes and reviews
14:25:11 <mburns> ofri: which feature is that?
14:25:24 * mburns sees schedule, schule api, QoS, watchdog features
14:25:32 <mburns> s/schule/schedule
14:25:54 <jurrien_> Hi, rhevm has the admin@internal account. Is it also possible to create for example jurrien@internal ?
14:26:02 <ofri> its an extarnal feature - coming from intel
14:26:16 <ofri> not on the table
14:26:25 <mburns> ofri: ok, is there a feature page or status page to track?
14:26:30 <mburns> can we add it to the table?
14:26:50 <oschreib_> jurrien_: no, there's no such option.
14:26:55 <ofri> ok - i'll check
14:27:04 <mburns> #info new feature from Intel -- trusted compute pulls -- making progress
14:27:32 <mburns> #action ofri to check on feature page and update release page with details on new intel feature (trusted compute)
14:27:47 <ofri> schedualing - progrss is stoped for next week and a half
14:27:58 <jurrien_> oschreib_: Is it possible to use a openldap server? instead of IPA?
14:28:13 <mburns> ofri: still on target for end of July?
14:28:21 <ofri> yes
14:28:36 <mburns> #info scheduling changes -- on target for end of July
14:28:43 <dneary> mburns, ofri: Perhaps it's worth stating that we don't need features to be done next week, but we need to be confident that they will be done & stable in a short period (X weeks)
14:29:07 <ofri> QoS - back to the drawing bord. featue is going under many changes
14:29:19 <mburns> dneary: yes, end of July -- that's our dev freeze
14:29:21 <ofri> we are still in design stage
14:29:38 <dneary> mburns, Can we minute that, please?
14:30:05 <mburns> ofri: dneary sorry -- meant beginning of july/end of June...
14:30:05 <dneary> mburns, end of July dev freeze means... release in ~first two weeks of August?
14:30:07 <oschreib_> jurrien_: I believe you can do that, but I guess that an email to users@ovirt.org will give you a clearer answer
14:30:24 <jurrien_> Ok thanks! oschreib_
14:30:26 <dneary> OK - s/July/June, s/August/July
14:30:36 <mburns> dneary: ga currently targeted at Aug 1
14:30:45 <mburns> +- a couple days
14:30:56 <mburns> #info Development freeze:  July 1
14:31:13 <mburns> #info all features need to be merged/relatively stable by Development freeze
14:31:20 <ofri> ok. we are still on schedual with the schedualer API. this break was known in advance
14:31:21 <mburns> #info Targeted GA:  1 Aug
14:31:35 <mburns> ofri: ok
14:32:02 <mburns> ofri: QoS -- is that also looking like end of June?
14:32:41 <ofri> still hard to say - but that is the plan
14:32:54 <ofri> last.... watchdog - on schedual
14:32:57 <mburns> #info QoS -- planned for end of june, but still in planning
14:33:06 <mburns> #info watchdog -- on schedule for End of June
14:33:40 <mburns> ok, any other feature areas to discuss today?
14:33:56 <mburns> Storage, integration, ux, infra, virt?
14:35:29 <mburns> #info node features should all be done well in advance of beta dates
14:35:44 <itamar> mburns, does that cover the 'no bridge' one?
14:35:59 <mburns> #info additional node feature (bridgeless networks) is questionable at the moment, but we're trying
14:36:35 <mburns> itamar: first wave of patches should land in gerrit this week
14:36:54 <mburns> but we need to essentially test everything with this change
14:37:23 <apuimedo> mburns: who is working on bridgeless networks?
14:37:37 <mburns> from the node side:  fabiand_
14:37:43 <apuimedo> aha
14:37:44 <apuimedo> ok ;-)
14:37:49 <mburns> apuimedo: we should have a feature page up soon
14:37:54 <apuimedo> good
14:38:19 <apuimedo> mburns: let me know if there is something with vdsm that would cause any trouble
14:38:47 <mburns> apuimedo: will do, but it will likely be a bit before we know that
14:38:54 <mburns> we have to get base node stuff to work first
14:39:15 <mburns> before we can test with vdsm
14:39:24 <apuimedo> ok
14:39:43 <mburns> ok, if nothing else for 3.3 today, then i'll move on
14:39:52 <mburns> #topic Conferences and Workshops
14:40:03 <mburns> #info oVirt will have a booth at Red Hat Summit
14:40:44 <mburns> #info multiple people will be staffing the booth at various times (theron dneary ecohen abaron itamar mburns)
14:40:50 <theron> if I haven't spoken with you re: RH summit, and you're planning on being there and would like to work the oVirt booth please let me know.
14:41:08 <dneary> mburns, I'll be right next door on the RDO stand
14:41:12 <mburns> #info if you will be there and would like to man the booth, then please get in contact with theron
14:41:20 <mburns> dneary: close enough ;-)
14:41:54 <mburns> dneary: theron:  any other conference/workshop info?
14:41:56 <itamar> jurrien_, openldap was merged couple of weeks ago, you can try and test it with nightly. should be released with 3.3, but testing prior to release is encouraged.
14:42:00 <dneary> theron, Worth mentioning KVM Forum/CloudOpen?
14:42:25 <itamar> dneary - very much worth it
14:42:47 <theron> we just wrapped up linuxcon jp
14:43:10 <mburns> #info just wrapped up linuxcon JP
14:43:21 <theron> laszlo did a great presentation on oVirt.
14:43:29 <theron> well received
14:43:46 <mburns> #info great presentation from lazlo on oVirt
14:44:19 <theron> I presented on gluster and ovirt as well during the gluster track.
14:44:30 <theron> great conversations with NTT and ....
14:44:35 <mburns> #info theron talked about gluster and ovirt in the gluster track
14:45:02 <theron> IIJ (couldn't remember name) internet initiative japan
14:45:20 <mburns> #great conversations with NTT and IIJ
14:46:44 <theron> KVM forum info here: http://events.linuxfoundation.org/events/kvm-forum
14:47:00 <theron> we're going to be holding an oVirt workshop along side.
14:47:11 <theron> more info next week, we're getting the room sorted now.
14:47:19 <mburns> #info there will be an oVirt workshop alongside KVM Forum (http://events.linuxfoundation.org/events/kvm-forum)
14:47:28 <mburns> #info more details coming next week
14:47:54 <theron> we want to make sure as many papers are submitted for oVirt DURING the KVM forum as possible, so get yours in today!
14:48:21 <mburns> theron: submit to the kvm forum?
14:48:25 <theron> yes.
14:48:27 <mburns> not a separate event?
14:48:31 <theron> and yes
14:48:36 <mburns> ok
14:48:51 <mburns> #info submit talks ASAP for KVM Forum for your oVirt talks
14:48:54 <theron> while we'll have a seperate event, we want to increase exposure during the KVM forum as well.
14:49:26 <theron> we'll do our best to not inundate presenters, and do more deep dive in the oVirt workshop itself.
14:49:38 <mburns> ok
14:49:43 <theron> although I'm sure there will be GREAT content ready to go for the KVM forum as well.
14:50:29 * mburns hopes he can get budget to be there...
14:50:54 <theron> I'm assuming the CFP for the oVirt workshop next to KVM forum should look similar to shanghai dneary?
14:51:35 * theron notes if yes that should go live and be a talking point during RH summit.
14:51:44 <dneary> theron, I was thinking more of having a "proper" unconference, but ensuring that we have oVirt content proposed for CloudOpen and the KVM Forum
14:52:01 <dneary> theron, We mentioned having this as primarily a developer planning meeting
14:52:09 <dneary> s/mentioned/discussed
14:52:22 <dneary> Sorry, multi-tasking...
14:52:28 <theron> dneary, right. was unclear if that ruled out the CFP etc etc.
14:52:34 <mburns> so perhaps have talks submitted to CloudOpen and KVM Forum
14:52:56 <mburns> but just have a couple rooms set aside for ad-hoc oVirt developer discussions?
14:52:56 <dneary> theron, I think we want to make sure we get key people there
14:53:05 <dneary> So less CFP, more "pre-planning"
14:53:11 <theron> mburns, yes.  either way we'll have talking points @ Summit for the event, and data will be online prior at ovirt.org
14:53:18 <theron> dneary, agreed.
14:53:50 <mburns> #info proposal -- submit talks to CloudOpen/KVMForum and get a room (or 2) set aside for more informal oVirt developer meetings
14:54:12 <mburns> #info details should be available on ovirt.org in the next week
14:54:28 <mburns> any other workshops/conference things to discuss?
14:55:17 <theron> linuxcon US is in the fall.
14:55:40 <mburns> yes, september in New Orleans
14:55:52 <theron> other than that, we'll need to discuss where the following workshop will be held.
14:55:54 * mburns likely to submit a talk (or 2)
14:56:34 <mburns> theron: the next corporate workshop (for lack of a better term)?
14:56:47 <theron> mburns, yes. we had discussed RTP
14:56:59 <dneary> The CFP for Nyuawlins is in a few weeks - late June (21st I think?) - for Edinburgh late July
14:57:49 <theron> Cisco Netapp and IBM were interested so there is possibility there.  will be talking with folks from Cisco and Netapp @ summit.
14:58:21 <mburns> #info CFP for LinuxCon NA is June 17
14:58:44 <mburns> #info CFP for LinuxCon EU is July 21
14:59:09 <mburns> #info additional info for the next corporate hosted workshop will be forthcoming in the next few weeks
14:59:30 <mburns> #info some discussions about going to RTP (North Carolina)
14:59:45 * mburns votes for Hawaii... ;-)
14:59:50 <mskrivanek> mburns: CFP for LinuxCon EU date means CFP for KVM as well?
14:59:54 <dneary> Ooh! June 17 is close
15:00:05 <jurrien_> itamar: Thanks! I know enough now
15:00:27 <mburns> mskrivanek: looking now...
15:01:05 <theron> let's say we're planning the following workshop for RTP but open to ideas elsewhere.
15:01:21 <theron> please reach out if companies or organizations are interested in hosting.
15:01:47 <mburns> mskrivanek: no link on that page for cfp for kvm forum
15:01:54 <mburns> so i'll have to follow up
15:02:02 <theron> I'll follow up with the folks we talked to re: RTP and see who is really interested.
15:02:43 <mburns> #info current plan is to have next corporate hosted workshop in RTP, but let theron know if there are other companies/organizations that want to host regardless of location
15:04:08 <mburns> theron: dneary:  do you know anything about kvm forum cfp?
15:04:28 <dneary> mburns, It's in progress
15:04:34 <mburns> dneary: not open yet?
15:04:55 <dneary> mburns, I would have to ask Chris Wright
15:05:04 <mburns> ok, i can follow up with him
15:05:15 <mburns> anything else with conferences and workshops?
15:06:09 <mskrivanek> so does it make sense to submit anything for LinuxCon EU when it's parallel to KVM forum?
15:07:07 <mburns> mskrivanek: you get more exposure to the general cloud ecosystem in LinuxCon, i think
15:07:20 <mburns> i'd probably submit to CloudOpen, actually, instead of LinuxCon
15:07:27 <theron> mburns, agreed.
15:07:32 <mburns> (same place, same time, different CFPs...)
15:08:59 <mburns> ok, moving on since we're already over time, but i'll follow up on details of CFPs, etc...
15:09:06 <mburns> #topic Infra Updates
15:09:12 <mburns> ewoud: anything this week?
15:09:22 <dneary> mburns, Nothing beyond http://events.linuxfoundation.org/events/kvm-forum
15:09:33 <dneary> CFP hasn't been issued yet AFAIK
15:09:43 <mburns> dneary: that's what it looks like to me too
15:11:38 <mburns> ok, no updates from infra
15:11:46 <mburns> #info no infra updates this week
15:11:49 <mburns> #topic other topics
15:11:56 <mburns> anything else?
15:12:38 <mburns> going once...
15:13:17 <ewoud> mburns: sorry, was away
15:13:50 <mburns> ewoud: anything interesting? or just point to infra minutes?
15:13:51 <ewoud> mburns: infra is looking at how we want to install the rackspace servers with ovirt
15:14:05 <ewoud> but I wasn't really available last meeting
15:14:11 <ewoud> http://resources.ovirt.org/meetings/ovirt/2013/ovirt.2013-06-03-14.24.html
15:14:22 <mburns> #info for infra updates see the minutes
15:14:27 <mburns> #link http://resources.ovirt.org/meetings/ovirt/2013/ovirt.2013-06-03-14.24.html
15:14:40 <mburns> ok, anything else?
15:14:43 <mburns> going twice..
15:15:13 <mburns> gone.
15:15:18 <mburns> ok, thanks all!
15:15:21 <mburns> #endmeeting