13:00:40 <mburns> #startmeeting oVirt Node weekly meeting
13:00:40 <ovirtbot> Meeting started Tue Apr  9 13:00:40 2013 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:40 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:00:45 <mburns> #chair fabiand rbarry jboggs
13:00:45 <ovirtbot> Current chairs: fabiand jboggs mburns rbarry
13:00:57 * fabiand is around
13:01:07 <mburns> #topic next release
13:01:44 <fabiand> After speaking with mburns I added a couple of features to the feature page of th eupcoming release ..
13:01:54 <fabiand> (just one sec)
13:02:07 <fabiand> the page is here:
13:02:08 <fabiand> http://www.ovirt.org/Node_2.7_release-management
13:02:36 <fabiand> For now I've added stuff which is (a) done and qualifies as a feature or (b) should/could/idea to go into our next release ..
13:02:44 <fabiand> mburns, shall I name our features?
13:02:53 <fabiand> so we can discuss them as needed
13:03:10 <mburns> #info additional features added to the release planning page
13:03:58 <mburns> fabiand: let's go through them each, but after we go over release numbering and dates
13:04:45 <fabiand> right
13:04:55 <mburns> in discussing the release yesterday, fabiand and i thought that it might make sense to re-number the release as 3.0
13:05:06 <mburns> #info in discussing the release yesterday, fabiand and i thought that it might make sense to re-number the release as 3.0
13:05:30 <mburns> #info since we're removing vdsm and making the image generic, changing the TUI, etc.
13:05:44 <mburns> jboggs: rbarry any thoughts on that?
13:05:59 <jboggs> mburns, agreed
13:06:07 <ovirtbot> 14[[07Node 2.7 release-management14]]4 !10 02http://www.ovirt.org/index.php?diff=8244&oldid=8226&rcid=8451 5* 03Fabiand 5* (+48) 10/* Features */ Notes about what is open
13:06:27 <mburns> ok
13:06:42 <mburns> #action fabiand to update the release management page to reflect 3.0.0 release number
13:07:08 <mburns> #action mburns to post patches to move version numbers in spec files to 3.0.0 instead of 2.7.0
13:07:34 <mburns> #agreed next version will be 3.0.0
13:08:21 <mburns> #action mburns to re-target bugs for 3.0.0 instead of 2.7.0
13:08:57 <mburns> #idea Feature freeze and beta preparation -- 01-May
13:09:30 <mburns> #idea RC Build -- 15-May
13:09:48 <mburns> #idea GA -- 31-May
13:09:55 <fabiand> sounds good
13:10:23 <mburns> #info the reasoning behind these dates:  Need to be ready prior to oVirt 3.3 builds are being posted live
13:10:33 <mburns> #info also need them out prior to F19
13:11:11 <mburns> objections about the features can be included can come when we talk about the features themselves
13:11:30 <mburns> and objections to these dates?
13:11:52 <fabiand> they sound reasonable to me
13:12:03 <mburns> jboggs: rbarry?
13:12:21 <jboggs> looks good to me
13:12:52 <mburns> #agreed on the proposed dates
13:13:09 <mburns> ok, now to the features
13:13:15 <mburns> #topic Universal Image
13:13:19 <mburns> #info owner: mburns
13:13:32 <mburns> #info status:  code complete and merged
13:13:34 <MACscr> mburns: im using the stateless fedora iso, anyway to get netstat working on it? cant believe its left off that iso
13:13:57 <mburns> MACscr: can you ping me in 20 min?
13:14:17 <MACscr> oh, my fault, just saw that your in a meeting. Sure
13:14:19 <mburns> #info no objections to inclusion in 3.0.0
13:14:24 <mburns> MACscr: no prob
13:14:42 <mburns> #action mburns to add feature page
13:14:46 <mburns> #undo
13:14:46 <ovirtbot> Removing item from minutes: <MeetBot.items.Action object at 0xa416eec>
13:14:56 <mburns> #action mburns to add feature page -- due 10-Apr
13:15:21 <fabiand> mburns, also reference it on the release management page
13:15:28 <mburns> #info this feature is making the node generic so it can be used by multiple projects (oVirt, OpenStack, Gluster, etc)
13:15:43 <mburns> fabiand: yes, i include that in the creation of the feature page...
13:15:48 <mburns> but...
13:15:59 <mburns> #action mburns to link new feature page to release management page
13:16:14 <fabiand> :)
13:16:15 <mburns> any comments/concerns/thoughts on this feature?
13:16:26 <fabiand> I'm fine with it ..
13:16:40 <fabiand> Will the Engine subproject provide the vdsm specific Node?
13:17:35 <mburns> fabiand: i expect that we'll probably still provide it
13:17:38 <mburns> at least initially
13:18:04 <fabiand> okay
13:19:20 <mburns> #topic new upgrade tool
13:19:25 <mburns> #info owner:  jboggs
13:19:36 <mburns> #info status:  patches posted, in review
13:19:54 <mburns> #info no objections for inclusion in 3.0.0
13:20:01 <jboggs> updated patches will be posted later today
13:20:15 <mburns> #action jboggs to create feature page and link to release management page -- due 12-April
13:21:08 <mburns> #info this feature is to improve support for upgrades to minimize the various upgrade issues we've found in the past
13:21:40 <mburns> any other comments/concerns/thoughts on this feature?
13:21:55 <mburns> #info jboggs will be posting updated patches later today
13:22:05 <fabiand> fine for me
13:22:19 <mburns> ok, next feature
13:22:29 <mburns> #topic Software iSCSI support
13:22:36 <mburns> #info owner:  jboggs
13:22:47 <mburns> #info status:  code complete and merged, needs testing
13:23:12 <mburns> #info this feature adds the ability to install to and boot from a software iscsi target
13:23:28 * Rydekull would like to see a redundant manager :-P
13:23:34 <mburns> #info no objections to inclusion in 3.0.0
13:23:49 <mburns> Rydekull: you mean ovirt-engine?
13:23:57 <mburns> this is all ovirt-node related...
13:24:20 <mburns> #action jboggs to put up feature page and link to release management page -- due 12-April
13:24:27 <mburns> any other comments/concerns/thoughts on this feature?
13:24:58 <fabiand> I'm also fine with this
13:25:29 <mburns> ok, next...
13:25:38 <mburns> #topic puppet configuration
13:25:45 <mburns> #info owner:  rbarry
13:25:51 <mburns> #info status:  in development
13:26:05 <mburns> #info this feature will allow ovirt-node to be configured from a puppet instance
13:26:11 <Rydekull> mburns: yeah, talking about the engine :-)
13:26:26 <mburns> #info there are 2 parts to this feature, the puppet provider and the parts in ovirt-node to allow the configuration
13:26:57 <mburns> any thoughts on this feature?  risks for it getting in?
13:27:08 <mburns> patches should be imminent...
13:27:28 <fabiand> I'd like to see an overview/feature page
13:27:33 <fabiand> describing what and how it's implementd
13:27:37 <fabiand> or some other document ..
13:27:43 <mburns> #action rbarry to add a feature page and link to the release management page -- due 12-April
13:28:08 <mburns> #info at risk until we see the code and feature page
13:28:18 <fabiand> rbarry, would be nice if you could also post a link to the existing patches on the ml ..
13:28:43 <fabiand> Just to get an idea and learn :)
13:29:48 <mburns> #info puppet provider code is located here:  https://github.com/evol262/puppet-ovirt-node-plugin?ref=commandbarr
13:30:12 <mburns> ok, moving on
13:30:26 <mburns> #topic swap enhancements
13:30:30 <mburns> #info owner:  mburns
13:30:37 <mburns> #info status:  not started
13:30:38 <fabiand> mburns, the link sis invalid
13:30:55 <mburns> fabiand: try:  https://github.com/evol262/puppet-ovirt-node-plugin
13:31:05 <fabiand> ta
13:31:30 <mburns> #info this feature is to improve allocation of swap with a couple of related sub-features
13:31:57 <mburns> #info details will be included in the feature page
13:32:13 <mburns> #action mburns to post feature page and link to release management page -- due 12-April
13:32:43 <mburns> #info no objection to inclusion in 3.0.0, but at risk until patches are posted
13:33:10 <fabiand> ack
13:33:10 <mburns> any other comments/concerns/thoughts on this feature?
13:33:59 <mburns> ok, moving on
13:34:06 <mburns> #topic TUI -- installer
13:34:12 <mburns> #info owner:  fabiand
13:34:19 <mburns> #info status:  complete and merged
13:34:44 <mburns> #action fabiand to create feature page and link to release page -- due 12-April
13:35:05 <fabiand> do we really need feature pages!? ;)
13:35:09 <mburns> #info this feature is a re-write of the TUI installer using the urwid backend
13:35:21 <mburns> fabiand: just a quick summary should be fine...
13:35:37 <mburns> with background links on what urwid is, etc...
13:36:10 <mburns> or if you have a feature page for the setup tui, link to that, instead?
13:36:23 <fabiand> I'm completely fine
13:36:31 <fabiand> I'll probably share a feature page between installer+setup
13:36:42 <mburns> #info already merged, so no objections to 3.0.0
13:36:52 <mburns> #topic TUI -- ipv6 support
13:36:59 <mburns> #info owner:  jboggs
13:37:10 <mburns> #info status:  in development
13:37:21 <mburns> #info risk for 3.0.0 until patches are posted
13:38:00 <mburns> #info in the past, we had IPv6 code in the TUI, but it was disabled, this will port that code to the new TUI infrastructure and enable it by default
13:38:23 <mburns> #action jboggs to create and link feature page -- due 12-April
13:38:33 <mburns> comments/questions/concerns?
13:39:51 <mburns> #topic TUI -- diagnostics
13:39:57 <mburns> #info owner:  rbarry
13:40:08 <mburns> #info status:  patches posted and in review
13:40:17 <mburns> #info no objections to 3.0.0
13:40:46 <mburns> #info this page enables some additional diagnostic information in the TUI and adds a scrollable table widget for future use
13:41:15 <mburns> #action rbarry to create a feature page and link to release status page --due April 12
13:41:43 <mburns> comments/questions/concerns?
13:41:51 * rbarry loves writing documentation
13:42:38 <jboggs> :)
13:42:38 <mburns> ;-)
13:42:42 <mburns> rbarry: don't we all...
13:43:12 <mburns> #topic Compatibility
13:43:57 <mburns> #info this feature is to ensure that all work is compatible on F18, F19 (pending late F19 changes), and EL6 (RHEL/CentOS)
13:44:08 <mburns> fabiand: do you want to own this particular feature?
13:44:13 <fabiand> mburns, yep
13:44:31 <mburns> #info owner:  fabiand
13:44:59 <mburns> #info status:  current master should be compatible on F18, no testing yet on F19/EL6
13:45:53 <mburns> #action fabiand to work out plan for this feature
13:46:24 <mburns> comments/questions/concerns?
13:47:25 <mburns> ok
13:47:29 <mburns> #topic other topics
13:47:31 <fabiand> I'll probably start on this quite late ..
13:47:36 <mburns> anything else?
13:47:45 <mburns> fabiand: sure
13:49:00 <mburns> ok, we'll go through feature pages and update status on next week's meeting
13:49:12 <mburns> thanks all
13:49:23 <fabiand> thanks mburns
13:49:27 <mburns> #endmeeting