15:00:43 <mburns> #startmeeting oVirt Weekly Sync
15:00:43 <ovirtbot> Meeting started Wed Feb 27 15:00:43 2013 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:43 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:49 <mburns> #topic agenda and roll call
15:01:04 <mburns> #chair quaid dneary oschreib
15:01:04 <ovirtbot> Current chairs: dneary mburns oschreib quaid
15:01:11 <mburns> #info Agenda:
15:01:20 <mburns> #info * Release Planning
15:01:27 <mburns> #info * Sub Project Reports
15:01:41 <mburns> #info Workshops and Conferences
15:01:47 <mburns> #undo
15:01:47 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0xa41abcc>
15:01:52 <mburns> #info * Workshops and Conferences
15:01:55 <mburns> #info * Other Topics
15:02:05 * dustins here
15:03:12 * aglitke here
15:04:01 * Rydekull is here, listening
15:04:56 <mburns> just fyi -- i have a contractor coming in at approx 11:00, i'll need to drop when that happens
15:05:14 <mburns> is there someone willing to run the rest of the meeting if that happens?
15:06:38 * aglitke watches the tumbleweeds
15:06:53 <mburns> ok, so we'll have an abrupt end to the meeting then...
15:07:00 <mburns> #topic Release Planning
15:07:30 * oschreib here
15:08:07 <mburns> #info current plan for 3.3 GA is 01-July
15:08:31 <mburns> #info tentative beta, dev freeze, branch date: 31-May
15:08:37 <ovirt-dever_> hi
15:08:45 <mburns> #info tentative RC build: -14-June
15:08:50 <ovirt-dever_> how to become a developper?
15:09:04 <mburns> #info Tentative Test Day 5-June
15:09:26 <mburns> #info mgoldboi and dneary working on a more robust release process
15:09:54 <mgoldboi> mburns: not too much work has been done this week on this aspect
15:10:01 <mburns> #action mburns to request new feature lists and sub-project contacts
15:10:08 * mburns didn't get to that this past week...
15:10:11 <mburns> mgoldboi: ok
15:10:17 <mburns> #chair mgoldboi
15:10:17 <ovirtbot> Current chairs: dneary mburns mgoldboi oschreib quaid
15:10:22 <aglitke> mburns: ok.  Looking forward to discussing some release features.
15:10:22 <dneary> Just FYI: I'm on vacation this week and it's actually a coincidence I'm here for the meeting - but yes, I'll be working with mgoldboi on the release process fo the next release
15:11:23 <mburns> dneary: thanks
15:11:40 <sbonazzo> ovirt-dever_: welcome! I suggest you to start reading http://www.ovirt.org/Develop.
15:12:49 <mburns> the only other thing i want to bring up w.r.t. 3.3 is the person who is going to fill the coordination role that i did (and not overly well) for the 3.2 release
15:13:09 * mburns thinks we need someone who is not tied into a specific sub-project
15:13:44 <mburns> and someone who can have an eye on not just the code and engineering targets, but also other release related things like docs, wiki updates, publicity, etc
15:13:59 <aglitke> Maybe we need to have a public nomination process on the list when the 3.3 details are announced?
15:14:10 <doron_> mburns: if no immediate suspects / volunteers we can discuss it in the arch mailing list.
15:14:15 <mgoldboi> mburns: don't you think it should be a group effort - each one on his field
15:14:46 <aglitke> mgoldboi: I think you need one top-level release manager who pulls together everything from each area expert.
15:14:47 <mburns> mgoldboi: yes, it should be a group effort, but it needs one person who is looking at all the areas...
15:15:11 <mburns> and i strongly believe they shouldn't be tied to one specific sub-project (as i am with node)
15:15:13 <mgoldboi> mburns: it is obviously a huge task to handle - like you experienced this release
15:15:24 <mburns> aglitke: yes, a public nomination is a good idea
15:15:30 <mburns> just wanted to float it here first
15:15:39 <mburns> doron_: ack
15:15:52 <aglitke> yep...  Get everyone thinking about who they would like to nominate.
15:16:14 <aglitke> Are there many people in this project who are not specialized into a specific sub-project?
15:16:18 * mburns has a thought, but want to talk to them directly first
15:16:18 <ovirt-dever_> docs, wiki updates?  how to do that?
15:16:39 <mgoldboi> aglitke: pinpoint
15:17:17 <mburns> as for the other people being involved, someone from each sub-project needs to be available for these meetings each week to give updates
15:17:32 <mburns> and to act as a point of contact for the person filling that role
15:17:49 <YamaKasY> odd, I cannot stop my VM's from the interface
15:17:53 <mgoldboi> mburns: what we need is a group of stakeholders for the release - each on his own field
15:18:02 <mburns> mgoldboi: right
15:18:25 <mburns> (with the overall person that is coordinating)
15:18:38 <mgoldboi> mburns: one person which isn't part of this group, is going to have hard time understand what is he coordinating
15:18:56 <YamaKasY> mhh strange...
15:18:57 <mburns> not necessarily...
15:19:13 <mburns> perhaps that person is elected from the group of stakeholders...
15:19:27 <aglitke> YamaKasY: We are having a community meeting at the moment.  Could you ask your question again in about 40 minutes?  We will be able to help you then
15:19:27 <mburns> but i think if we can find someone more independent, that good
15:19:47 <YamaKasY> stopping VM's from the interface doesn't work right... also when I stop them they seem to start
15:19:50 <mgoldboi> mburns: anyone you had in mind (as an example only)?
15:19:54 <YamaKasY> aglitke: oops, sorry!
15:20:06 <aglitke> YamaKasY: no problem at all! :)
15:20:22 <mburns> mgoldboi: yes, there is someone, but i want to talk to them directly before i volunteer them for something like this
15:20:24 <YamaKasY> aglitke: I just have the channel open and say whatever I see at the moment :)
15:21:08 <mburns> ovirt-dever_: for the wiki, you can get an account here:  http://www.ovirt.org/Special:RequestAccount
15:21:20 <mburns> for docs, i'll defer to sgordon ...
15:21:32 <sgordon> that will teach me
15:21:46 <mburns> ok, now to get this into the meeting minutes...
15:21:59 <mburns> #idea have a group of stakeholders for each release
15:22:13 <mburns> #idea includes at least one person from each of the subprojects
15:22:54 <mburns> #idea have an over-arching project manager that is either independent from the sub-projects or elected from the stakeholders
15:23:08 <mburns> #idea have open nominations on arch@ mailing list
15:23:43 <ovirt-dever_> any requirement ?
15:23:50 <ovirt-dever_> steps
15:24:02 <mburns> #action mburns to send email to arch explaining the reasoning and starting nominations
15:24:17 <mburns> ok, anything else for release planning?
15:24:34 <mburns> oh, fwiw, mburns is *not* volunteering for this role...
15:25:05 <Rydekull> ovirt-dever_: for signing up to the wiki there are no requirements as such, just go to the login page at the bottom of the page
15:25:05 <mburns> ovirt-dever_: for a wiki account? just fill out that form and confirm you email address
15:25:37 <mburns> for other aspects, the development page referenced above is a good place to start
15:25:54 <mburns> ok, moving on to sub-project reports
15:26:05 <mburns> #topic Sub Project Report -- Node
15:26:23 <mburns> #info nothing new to report after last week
15:26:36 <mburns> #info we're in planning for our 2.7.0 release
15:26:40 <ovirt-dever_> my work is on ovirt,make it my product
15:27:02 <mburns> #info we'll be pushing out a new ovirt-node iso that includes the vdsm fix in the next day or 2
15:27:41 <mburns> #info EL6/CentOS based ovirt-node is on our radar, but no firm ETA at the moment
15:28:02 <mburns> #topic Sub Project Report -- Infra
15:28:08 <mburns> #chair ewoud
15:28:08 <ovirtbot> Current chairs: dneary ewoud mburns mgoldboi oschreib quaid
15:28:16 <mburns> ewoud: quaid any updates on infra?
15:28:33 <mburns> danken: fsimonce:  do you have vdsm updates?
15:28:51 <ewoud> #info migration started on the jenkins master
15:29:19 * ewoud checks the minutes
15:29:22 <danken> mburns: well, we've found a regression
15:29:40 <danken> that annoys users: http://gerrit.ovirt.org/#/c/12447/
15:29:56 <danken> we'd need a rebuild for ovirt-3.2
15:30:02 <mburns> danken: timeframe?
15:30:21 <danken> I believe fsimonce can do it overnight ;-)
15:30:27 <mburns> ewoud: you can keep going -- i'll capture vdsm notes after you're done...
15:30:41 <mburns> danken: ok, thanks
15:30:48 <fsimonce> sure, I'll start a build in few hours, any other patch?
15:30:49 <ewoud> mburns: work is being started to get puppet going and work on the new infra member process
15:31:02 <mburns> #info work is being started to get puppet going and work on the new infra member process
15:31:03 <danken> I'm not aware of anything else
15:31:22 <mburns> danken: fsimonce thanks.  fsimonce can you let myself and fabiand know when the vdsm build is ready?
15:31:33 <fsimonce> mburns, sure
15:31:39 <mburns> fsimonce: thanks!
15:31:47 <ewoud> #info installing alterway02.ovirt.org with ovirt is blocked on EL6 packages
15:32:35 <ewoud> but we're trying to work around that by setting up puppet + foreman on another VM and migrate it later
15:32:50 <ewoud> mburns: I think that's the highlights
15:33:04 <mburns> #info but we're trying to work around that by setting up puppet + foreman on another VM and migrate it later
15:33:06 <mburns> ewoud: ok, thanks
15:33:11 <Rydekull> Excluding the outages that happened
15:33:38 <mburns> Rydekull: anything that needs project-wide exposure?
15:33:51 * mburns knows there was an outage last week due to OpenShift...
15:34:09 <Rydekull> yes, and depends if its important to note that or not :-)
15:34:30 <mburns> #info last weeks outage was due to an issue with OpenShift
15:34:37 <Rydekull> Dunno how many it messed with, since I dont know the community that well :-)
15:34:49 <mburns> Rydekull: what other outages were there?
15:35:12 <ewoud> gerrit had an internal server error, itamar fixed that
15:35:21 <Rydekull> mburns: Just openshift as far as I know, well, some minor issues with gerrit
15:35:25 <Rydekull> mburns: but nothing as big
15:35:48 <mburns> ok, those were all captured on infra...so i think we're ok
15:35:51 <mburns> #topic Sub Project Report -- vdsm
15:36:00 <mburns> #info regression found in latest vdsm
15:36:09 <mburns> #info patch available http://gerrit.ovirt.org/#/c/12447/
15:36:17 <mburns> #info fsimonce to build new packages today
15:36:30 <mburns> #info ovirt-node will hold their respin for these packages
15:37:11 <mburns> fsimonce: danken:  any updates on EL6/CentOS packages?
15:37:28 * mburns saw some traffic on it -- we need newer python-pep8 or something, right?
15:37:43 <Rydekull> and other packages according to.. eh... d-guy with rep
15:37:44 <Rydekull> repo*
15:38:12 <fsimonce> mburns, who was going to build the packages?
15:38:33 <mburns> Rydekull: dreyou
15:39:08 <danken> danken: I heard someone from mgoldboi team is on top of it - but I have no details.
15:39:13 <mburns> fsimonce: i assume someone from either the vdsm team...
15:39:17 <mburns> danken: for vdsm?
15:39:23 <mburns> i know oschreib is working on engine...
15:39:27 <oschreib> danken: we're working on the engine :)
15:39:55 <Rydekull> --> http://lists.ovirt.org/pipermail/arch/2013-February/001241.html z-- this was interesting aswell
15:40:16 <mburns> danken: i can put the python-pep8 in our repo...
15:40:29 <mburns> i denied that before since i thought you were looking for f18...
15:40:38 <mburns> Rydekull: yes, that is interesting...
15:41:21 <mburns> though it does beg the question of whether we want ovirt.org hosted repos for EL6
15:41:26 <danken> mburns: I would have volunteered fsimonce to do the builds, but it's a pain to add vdsm to EPEL6.
15:41:30 <fsimonce> mburns, if you find specific issues building vdsm just ask me questions right away I'll help you out
15:41:36 <mburns> and i think the answer in the past has been a resounding yes
15:41:58 <fsimonce> mburns, if I recall correctly this is what we agreed on last meeting too
15:42:13 <mburns> danken: not sure we want it in EPEL, just EL6 packages available
15:42:41 <danken> mburns: exactly, which makes it a bit of a headache to maintain
15:42:55 <mburns> #action mburns will follow up on vdsm el6 offline
15:43:18 <danken> it's not just "do the f18 thing, but for el6"
15:43:33 <mburns> danken: understood
15:44:17 <mburns> danken: fsimonce:  i'll try to get a jenkins job setup to build el6 packages for vdsm (if it's not there already
15:44:30 <mburns> and we can see what the problems are from there
15:44:45 <mburns> #topic sub-project report -- engine
15:44:54 <mburns> mgoldboi: oschreib:  engine updates?
15:45:09 <eedri_> mburns, http://jenkins.ovirt.org/view/rpms/job/vdsm_create_rpms_el6/
15:45:15 <eedri_> mburns, it's just not working due to errors
15:45:20 <oschreib> Juan and myself are working on el6 build
15:45:32 <mburns> eedri_: thanks
15:45:34 <oschreib> mainly, making the 3.3 build much easier
15:45:38 * mburns will look at that
15:45:41 <oschreib> (for el6)
15:45:54 <oschreib> and considering how to do it right for 3.2
15:46:38 <mburns> #info oschreib and jhernand working on EL6 builds
15:46:46 <mburns> #info mostly working to make 3.3 easier
15:46:56 <mburns> #info also working out best way to do it for 3.2
15:47:09 <mburns> oschreib: are you working with the centos guys?
15:47:30 <oschreib> not yet.
15:47:59 <oschreib> also, there are 10 new patches in engine_3.2 branch
15:48:10 <oschreib> we might want to consider refresh of 3.2 build
15:48:33 <mburns> oschreib: i'll defer that to you and the rest of the engine team...
15:48:45 <jhernand> We could maybe do a 3.2.1 release and then include the el6 build.
15:48:58 <mburns> jhernand: sounds like a plan to me...
15:49:15 <mburns> #info 10 new patches in engine_3.2 branch
15:49:17 <oschreib> the only issue is ~20 patches that we need to cherry-pick into the branch
15:49:38 <mburns> #idea plan a 3.2.1 with both these fixes and EL6 packages
15:49:55 <mburns> oschreib: for EL6?
15:50:11 <mburns> wouldn't you need that anyway to put out EL6 builds?
15:50:37 <fabiand> fsimonce, hey - I'm seeing this in the journal on a F18 node: vdsm vds WARNING Unable to load the json rpc server module. Please make sure it is installed.
15:51:16 <oschreib> mburns: indeed
15:51:32 <mburns> oschreib: ok, so we need it one way or the other
15:51:38 <ovirt-dever_> 'git://gerrit.ovirt.org/sample-portals '  is unavailable
15:51:42 <oschreib> mburns: all those patches are already in master, and makes the .el6 build much easier
15:51:57 <mburns> makes sense to me to coordinate the f18 refresh with and el6 release...
15:52:53 <oschreib> +1
15:53:05 <fabiand> fsimonce, any idea?
15:53:21 <mburns> #agreed makes sense to coordinate the engine f18 refresh with el6 release (as 3.2.1)
15:53:30 <mburns> ok, quickly moving on...
15:53:42 <mburns> #topic Workshops and Conferences
15:53:59 <mburns> dneary: any updates here?
15:54:07 * mburns doesn't see theron or lh online...
15:54:24 <fsimonce> fabiand, you should ask saggi about it, is it a blocker or just a warning?
15:54:29 <dneary> mburns, Reading backlog
15:54:39 <dneary> Ah
15:54:48 <SLR-722> Help: setup Power Management On Ovirt NODE !!??
15:54:53 <fabiand> fsimonce, okya, thanks, it's a warning in the journal - dunno if it should be a blocker, can't judge it myself ..
15:55:11 <dneary> mburns, theron and lh (both on a plane today) have taken over organisation of the Shanghai workshop
15:55:18 <dneary> The call for papers is in the works
15:55:32 <mburns> #info CFP for Shanghai is in the works
15:55:33 <fsimonce> fabiand, we're not using json yet so it's not a problem (unless it crashes vdsm or so)
15:55:40 <dneary> And I believe that we will be reaching out to partners requesting that they consider submitting over the next 10 days or so
15:55:53 <fabiand> fsimonce, ah right thanks!
15:55:56 <dneary> Registration should open in the next week or so
15:55:59 <Rydekull> well, im having a small "Introduction to oVirt" in Stockholm, Sweden on the 5th of March, as I mentioned last week. Isnt as big as a conference though :-)
15:56:06 <dneary> (if it's not already open!)
15:56:07 <mburns> #info will be reaching out to partners requesting submissions in the next ~10 days
15:56:15 <mburns> #info Registration to open in the next week
15:56:24 <mburns> #info (if not already open)
15:56:38 <dneary> Also, we need to get something on the site about all of the great presentations being given by oVirt community members!
15:56:42 <dneary> I am behind on this
15:56:44 <mburns> #info Rydekull doing an intro to oVirt in Stockholm on 5-March
15:57:32 <Rydekull> Speaking of which, if you guys have a "This is what you want thats new in 3.2" and "This will be coming in 3.3" wrap-up, I'd be very pleased
15:57:44 <mburns> Rydekull: we don't have 3.3 yet
15:57:51 <Rydekull> No, I know :-P
15:57:53 <dneary> Rydekull, William Hoffman in Paris, another speaker in Brussels, and a 4th which escapes me right now
15:57:59 <dneary> Jason Brooks in SCALE
15:58:09 <dneary> And there was another presentation in Brno last weekend
15:58:11 <mburns> for 3.2, see the release notes on the wiki
15:58:19 <mburns> it should have a run down of what was in 3.2
15:58:38 <mburns> #info multiple presentations recently and upcoming
15:58:45 <mburns> #info dneary to get details on the site
15:59:00 <mburns> dneary: anything else?
15:59:20 <SLR-722> no one for help
15:59:43 <dneary> Theron Conrey also presented oVirt and Gluster integration at CERN this week
16:00:02 <mburns> #info Theron Conrey also presented oVirt and Gluster integration at CERN this week
16:00:09 <dneary> Omer Frenkel gave the oVirt introduction presentation in Brno
16:00:21 <mburns> fabiand: can you see if you can help SLR-722?
16:00:33 <SLR-722> :)
16:00:55 <mburns> fabiand: or at least get to what the problem is and point in the right direction?
16:00:59 <dneary> And antoni (apuimeda) gave a presentation on oVirt networking too
16:01:01 <mburns> #info Omer Frenkel gave the oVirt introduction presentation in Brno
16:01:11 <SLR-722> setup Power Management On Ovirt NODE !!??
16:01:15 <mburns> #info  And antoni (apuimeda) gave a presentation on oVirt networking too
16:01:19 <dneary> apuimedo
16:01:21 <fabiand> SLR-722, right - so, let's see ...
16:01:28 <mburns> #undo
16:01:28 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0xa428eac>
16:01:29 <fabiand> SLR-722, so i guess it's about power management? :)
16:01:37 <mburns> #info  And antoni (apuimedo) gave a presentation on oVirt networking too
16:01:46 <SLR-722> yep for HA
16:01:56 <apuimedo> mburns, yes
16:01:58 <fabiand> SLR-722, so what do you actually wan't to do?
16:02:15 <apuimedo> mburns, dneary I have the svg and pdf from the presentation
16:02:20 <apuimedo> should anyone want them
16:02:28 <mburns> SLR-722: did you try configuring it through engine?
16:02:29 <apuimedo> I createm some custom art and diagrams
16:02:35 <mburns> apuimedo: awesome
16:02:45 <apuimedo> mburns, :-)
16:02:47 <mburns> the presentation should probably get posted online
16:02:49 <ofrenkel> yes it was nice i think it should be added to the sources
16:02:58 <apuimedo> ofrenkel, thanks!
16:02:59 <SLR-722> fabiand: i have NODE installed on machine whith V-T
16:03:00 * Rydekull agrees
16:03:09 <mburns> and the art can be useful to post on the wiki so people can re-use it
16:03:15 <fabiand> SLR-722, okay
16:03:23 <fabiand> SLR-722, and what do you want to achieve?
16:03:41 <apuimedo> mburns, right now it is all in objects inside the main svg, but I can split it into smaller svgs per object
16:03:58 <SLR-722> fabiand: wen i add this node in Ovirt-angine he ask for power management
16:04:13 <fabiand> yes, and you want to configure it properly?
16:04:45 <SLR-722> fabiand: i miss this point. i have a Lab machine no blade
16:04:58 <mburns> apuimedo: ok, we'll work it out later -- /me has to drop shortly, and i want to make sure we cover everything...
16:05:02 <mburns> #topic Other Topics
16:05:10 <mburns> anyone have other stuff to bring up today?
16:05:23 <mburns> SLR-722: do you have power management on the host at all?
16:05:38 <mburns> maybe a power strip that you can control remotely?
16:05:42 <fabiand> SLR-722, so - the problem is that you need to configure PM because you want to test HA, but you can't configure? Did I understand that correctly?
16:05:50 <mburns> or a drac/ipmi/rsa, etc interface?
16:05:59 <SLR-722> fabiand:i use ovirt-node Iso to install the node
16:06:03 * mburns has to drop now
16:06:12 <mburns> since no other topics, i'll close the meeting
16:06:15 <mburns> #endmeeting