15:03:23 <ewoud> #startmeeting infra weekly
15:03:23 <ovirtbot> Meeting started Mon Feb 11 15:03:23 2013 UTC.  The chair is ewoud. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:23 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:03:37 <ewoud> #chair quaid dcaro eedri Rydekull dneary
15:03:37 <ovirtbot> Current chairs: Rydekull dcaro dneary eedri ewoud quaid
15:03:56 <ewoud> agenda from http://www.ovirt.org/Infrastructure_team_meetings#2013-02-11
15:04:17 <ewoud> copy paste:
15:04:19 <ewoud> Hosting
15:04:19 <ewoud> Spreading logins
15:04:19 <ewoud> Puppet
15:04:19 <ewoud> Jenkins
15:04:22 <ewoud> Publishing HTML pages (trac #34)
15:04:24 <ewoud> Gerrit
15:04:27 <ewoud> ovirtbot
15:04:29 <ewoud> Other business?
15:04:32 <ewoud> Trac review
15:04:35 <ewoud> anyone missing anything?
15:04:59 <quaid> looks good to me
15:05:00 <dcaro> dneary: I have access now, thanks 8-)
15:05:27 <ewoud> #topic hosting
15:05:47 <ewoud> #info dneary created accounts for dcaro, eedri and ewoud on alterway servers
15:06:01 <ewoud> I think that we're ready to start the migration now
15:06:34 <ewoud> dcaro: eedri think you can start your jenkins migration now?
15:07:23 <dcaro> ewoud: I've got a lot of work lately, but I'll try to make some time to get it running
15:07:53 <ewoud> dcaro: cool
15:08:15 <ewoud> #action dcaro start working on the jenkins migration
15:08:33 <ewoud> I think alterway01 is going to the jenkins master
15:08:49 <ewoud> but that means we should set up alterway02 with some virtualisation
15:09:01 <ewoud> we never decided on plain libvirt vs ovirt
15:09:49 <quaid> iirc we talked about doing libvirt & migrating to ovirt?
15:10:05 <ewoud> we could do that
15:10:08 <quaid> i.e., bite off only one thing at a time
15:10:23 <ewoud> I'm in favor of that
15:10:31 <ewoud> objections?
15:11:01 <dneary> quaid, not from me
15:11:12 <dneary> s/quaid/ewoud
15:11:12 * DV__ shuts up :-)
15:11:33 <ewoud> DV__: if you have a valid reason, please let us know
15:12:16 <dneary> quaid, I don't remember that discussion, though
15:12:28 <DV__> basically  a guest started as a standalone libvirt guest may not be completely trivial to import in ovirt once you switch
15:12:48 <dneary> quaid, I thought Kevin would be able to help us get ovirt up & running for alterway02
15:12:53 <quaid> that's a good point
15:12:55 <quaid> dneary: +1
15:12:57 <dcaro> why are we usiong centos 5.8 on the servers?
15:13:01 <dcaro> *using
15:13:06 <quaid> I thought it was going to be 6.3
15:13:18 <DV__> but it should not be too hard as long as you keep your guests design simple
15:13:28 <dneary> kmaziere isn't here...
15:13:32 <ewoud> quaid: I was under the same impression
15:13:37 <dneary> dcaro, We should ask kmaziere
15:13:45 <dcaro> dneary: ok
15:13:53 <DV__> I would not use RHEL/Centos5 for a new virt setup :-)
15:14:07 <ewoud> DV__: that sounds like a valid reason to go straight to ovirt
15:14:22 <ewoud> dneary: do you have time to talk to kmaziere?
15:14:52 <dcaro> I'll use at least 6.3, but I'm ok with fedora (And I'll setup ovirt, you know, eat your own bread)
15:15:02 <dneary> ewoud, Yes
15:15:18 <dneary> He does follow the infra@ list, I expect he will see the minutes
15:15:21 <Neonlajt> centos or fedora for ovirt :D?
15:15:24 <DV__> actually libvirt->ovirt should be less of a conversion problem than RHEL-5 -> RHEL-6 in my book
15:15:30 <dneary> (we can always contact him specifically about this)
15:15:36 <ewoud> #action dneary talk to kmaziere about centos 6.3 on alterway servers
15:15:50 <ewoud> let's at least get that sorted for the next meeting
15:16:03 <quaid> my instinct is to go with centos 6.x as the hypervisor, then Fedora as guests
15:16:27 <ewoud> DV__: agreed, I think RHEL-5 is currently only for legacy applications which require it but everything new should be aiming for at least 6
15:16:31 <ewoud> quaid: same
15:16:35 <quaid> dneary: are you still looking in to RHEL subcriptions for the RackSpace hosts? I.e., setting up an ovirt account on RHN, etc.
15:16:54 <dneary> quaid, I had some issues creating the account for free entitlements
15:17:14 <ewoud> if we do choose ovirt, do we go for 3.1 or 3.2?
15:17:14 <dneary> I need to get the person who is helping on the phone, he has not been replying to emails
15:17:33 <dneary> A deadline might help there
15:18:06 <dneary> quaid, The issue is that accounts require a physical address and company details, and I don't know what to put in there
15:19:15 <ewoud> dneary: could the board help there?
15:19:29 <dneary> ewoud, It is not a big issue
15:19:40 <dneary> At worst, I will put in my address.
15:19:56 <ewoud> but should we take the libvirt or ovirt discussion to the mailing list?
15:20:26 <dneary> ewoud, infra@ or board@?
15:20:30 <ewoud> it's a blocker before we can start with puppet + foreman so I'd like to make a decission sooner rather than later
15:20:56 <ewoud> dneary: not sure, so far I think it's mostly an infra decission but now you mention it
15:21:03 <quaid> ewoud: +1 to discuss on list
15:21:33 <ewoud> I'll send the mail with a deadline for next week
15:21:46 <ewoud> so next meeting we can reach a decission
15:22:01 <quaid> (unless we decide on list, lucky us)
15:22:02 <ewoud> #action ewoud send a mail about ovirt or libvirt
15:22:20 <ewoud> anything else on hosting?
15:22:25 <ewoud> rackspace?
15:23:04 <dneary> ewoud, OK - infra@
15:23:18 <dneary> ewoud, My understanding was CentOS 6.3 and oVirt
15:23:30 <ewoud> dneary: but ovirt 3.1 or 3.2 then?
15:23:35 <dneary> ewoud, Perhaps alterway02 needs to be reinstalled (seems easiest)
15:23:42 <ewoud> but anyway, we can move that to the ML
15:23:50 <dneary> ewoud, I would say, whatever AlterWay is running
15:24:05 <dneary> They're running 3.1 for now, and eagerly awaiting 3.2
15:24:44 <ewoud> quaid: any news on rackspace or getting rid of your vacation backlog?
15:28:31 <ewoud> ok, I think that's all for hosting now then
15:28:36 <quaid> ewoud: I think rackspace is now ready, got finished last week or just before
15:28:37 <quaid> so I
15:28:41 <ewoud> ok
15:28:59 <ewoud> #info rackspace hosting is ready to be delivered
15:29:03 <quaid> so I'll be looking in and adding people right away, based on previous plans for those hosts (i.e., keys for the whole team, then we can start the build yet-another-ovirt instance, etc.)
15:29:38 <ewoud> I'd certainly like to set up a pair of ovirt hosts at rackspace
15:30:38 <ewoud> quaid: will you set up the accounts?
15:30:55 <quaid> yes
15:30:58 <quaid> today, if I can
15:31:12 <quaid> #action quaid to setup RAX accounts ASAP
15:31:23 <ewoud> and what's the next step?
15:31:35 <ewoud> can we use ovirt all-in-one on one host and add the other as a node?
15:32:59 <quaid> hmm
15:33:19 <quaid> I haven't used RackSpace before, but I take it that we can install whatever we want - we have it from the bare metal up
15:34:07 <quaid> what would be "ideal"?
15:35:14 <ewoud> I have no idea how we should manage the storage since my only experience with rhev is based on iscsi
15:35:32 <ewoud> who in the project can we ask for advice here?
15:38:02 <quaid> RobertM and maybe a Gluster friend
15:39:38 <ewoud> quaid: want to start a thread on the ML about this?
15:40:14 <quaid> yep, will do
15:40:29 <ewoud> #action quaid start a discussion about setting up rackspace
15:40:37 <ewoud> ok, then I think we can move on
15:40:46 <RobertM> What storage options has Rackspace given us?
15:40:52 <ewoud> or not :P
15:41:34 <ewoud> RobertM: I think we only have 2 dedicated servers, but not sure
15:42:00 <ewoud> given the time I'd like to move the discussion to the ML
15:42:12 <RobertM> And they are replacing what?
15:42:25 <RobertM> Guessing Jenkins / Gerrit?
15:42:44 <quaid> RobertM: basically, what we ordered originally - RAID 10 on SSD for one box, the other more plain fast disk
15:42:48 <ewoud> I think the goal was mostly jenkis slaves so maybe localstore could work
15:43:07 <quaid> RobertM: are you able to participate in a discussion on list?
15:43:16 <quaid> if not, we could catch up on the topic here right after the meeting?
15:43:16 <RobertM> quaid, Yes.
15:43:20 <quaid> great
15:43:24 <quaid> I'll start the thread right now
15:43:36 <quaid> ewoud: I think you are safe to move on :)
15:43:46 <ewoud> I think we can skip puppet on the agenda since we need to sort out hosting first
15:43:56 <ewoud> #topic jenkins
15:43:59 <RobertM> Slave would be for certain.  Master is another store.
15:44:13 <ewoud> dcaro: made any progress on publishing the HTML pages?
15:44:42 <dcaro> ewoud: no, not yet, did not have the time
15:45:08 <ewoud> ok
15:45:23 <ewoud> anything else on jenkins or gerrit?
15:45:55 <ewoud> Rydekull: here?
15:47:38 <ewoud> ok, then I think we can also skip ovirtbot
15:47:42 <ewoud> #topic other business
15:48:10 <quaid> #action quaid to get Rydekull needed access for OpenShift & linode to work on ovirtbot
15:48:26 <ewoud> I think he already had linode
15:48:32 <ewoud> dneary did that
15:48:50 <quaid> solid
15:49:00 <quaid> oh, right, needed openshift for the mediawiki side
15:49:03 <quaid> I'll solve that asap
15:49:15 <Rydekull> oh, sorry
15:49:16 <Rydekull> yeah, here
15:49:23 <ewoud> Rydekull: no problem
15:49:44 <ewoud> anything else we should discuss?
15:50:06 <Rydekull> ovirtbot, started on it, ran into access issues, mailed list, got a response, today(?) I think
15:50:06 <ovirtbot> Rydekull: Error: "started" is not a valid command.
15:50:09 <Rydekull> so havnt looked more
15:50:33 <ewoud> ok
15:50:43 <ewoud> #topic trac review
15:51:16 <ewoud> most tickets have been open for a while
15:51:43 <ewoud> Rydekull: can you claim https://fedorahosted.org/ovirt/ticket/19 (add wiki edits back to ovirtbot)? afaik you were looking into ovirtbot for that
15:52:11 <Rydekull> yes
15:52:22 <ewoud> quaid: https://fedorahosted.org/ovirt/ticket/29 more admins on openshift sounds like what you're doing
15:52:41 <Rydekull> Claimed
15:52:46 <dcaro> ewoud: no, not yet, did not have the time
15:52:59 <dcaro> ewoud: (I did not hit enter, sorry xd)
15:53:32 <quaid> +1 yep
15:53:45 <dneary> ewoud, I don't know if Rydekull's on there
15:53:55 <dneary> I know ewoud, eedri and dcaro are
15:54:11 <dneary> And any of those should be able to add new keys to .ssh/authorized_keys
15:58:26 <ewoud> sorry, colleagues asked me something
15:59:31 <ewoud> dneary: there's an account on linode01
16:00:31 <ewoud> I think we should now focus our limited time on getting hosting ready, then start clearing trac tickets
16:00:47 <ewoud> any last minute additions?
16:01:31 <ewoud> going once
16:01:36 <ewoud> going twice
16:01:41 <ewoud> #endmeeting