15:10:20 <ewoud> #startmeeting
15:10:20 <ovirtbot> Meeting started Mon Jan 28 15:10:20 2013 UTC.  The chair is ewoud. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:10:20 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:10:31 <ewoud> #chair dneary dcaro eedri
15:10:31 <ovirtbot> Current chairs: dcaro dneary eedri ewoud
15:10:37 <ewoud> http://www.ovirt.org/Infrastructure_team_meetings#2013-01-28
15:10:47 * Rydekull is here
15:11:01 <dneary> ewoud, Yes we do: http://www.ovirt.org/Infrastructure_team_meetings#2013-01-28
15:11:24 <dneary> #info Agenda: http://www.ovirt.org/Infrastructure_team_meetings#2013-01-28
15:11:29 * is is in another meeting right now...
15:12:07 <ewoud> spam:
15:12:09 <ewoud> Hosting
15:12:09 <ewoud> Puppet
15:12:09 <ewoud> Jenkins
15:12:09 <ewoud> Gerrit
15:12:09 <dneary> eedri, is?
15:12:11 <ewoud> Other business?
15:12:13 <ewoud> Trac review
15:12:28 <Rydekull> dneary: he did /nick instead of /me :-P
15:12:30 * eedri is in another meeting
15:12:35 <eedri> :)
15:12:36 <ewoud> I'd also like to add FOSDEM to the list
15:12:43 <ewoud> #chair Rydekull
15:12:43 <ovirtbot> Current chairs: Rydekull dcaro dneary eedri ewoud
15:13:02 <dneary> Hosting: Can I get a sitrep from dcaro|mtg, eedri, ewoud please? Does everyone who needs admin access to the Jenkins server have it?
15:13:14 <dneary> And do we have access to a self-service console for the second server?
15:13:25 <ewoud> we also had a suggestion about using the jenkins job builder, but we can discuss that under jenkins
15:13:28 <ewoud> #topic hosting
15:13:50 <ewoud> I haven't tried to access the servers
15:14:19 <dneary> ewoud, Do you have the username & password?
15:14:22 <eedri> i didn't got the details..
15:14:26 <eedri> or i missed the email on them...
15:14:32 <dneary> Or failing that: I think quaid uploaded your ssh key
15:14:34 <ewoud> neither did I
15:14:43 <dneary> eedri, Hmmm
15:14:46 <dneary> OK
15:14:50 <ewoud> also not sure which IPs
15:15:07 <dneary> #action dneary to ensure that ewoud, eedri and dcaro get admin access to Jenkins server
15:15:21 <dneary> ewoud, I can send the IPs on
15:16:25 * Rydekull has got a slight update on "inifiniband"-subject if that goes under hosting
15:16:27 <ewoud> dneary: could you also poke quaid about the logins for linode01?
15:16:38 <eedri> ewoud, i think quaid is ooo
15:16:45 <dneary> ewoud, quaid is on vacation this week & next week
15:16:54 <dneary> ewoud, What information do you need?
15:17:05 <dneary> He made sure to have cover for himself on everything
15:17:05 <Rydekull> Hehe, well, he said he should add me and ewoud as administrator
15:17:12 <Rydekull> havnt seen any notice of such happening, though
15:17:24 <ewoud> dneary: about that, we haven't received logins
15:17:28 <dneary> #action dneary to check who can add Rydekull and ewoud as admins for linode1
15:17:55 <dneary> Are you guys done giving me extra stuff to do now? ;-)
15:18:07 <Rydekull> You're welcome :-)
15:18:16 <dneary> Thank you!
15:18:42 <Rydekull> But, infiniband-stuff, I got a preliminary ETA of 2 weeks until we hopefully can access it
15:18:54 <dneary> Rydekull, Great!
15:19:46 <eedri> dneary, try mburns, i think he gave me access
15:20:07 <ewoud> eedri: dcaro|mtg you made any progress on installing alterway?
15:20:22 <eedri> ewoud, like i said, i didn't got details on the servers yet
15:20:32 <dcaro|mtg> ewoud, me neither
15:20:40 <dneary> OK
15:20:42 <ewoud> so preparations on VMs / puppet either?
15:20:53 * dneary absents himself from the meeting to take care of that.
15:20:58 <dneary> Carry on without me
15:21:17 <eedri> ewoud, dcaro|mtg is working on puppet classes, but they will be used only later, when foreman + puppet will be ready
15:21:18 <ewoud> #info no progress on new hosting due to missing credentials
15:21:24 <eedri> ewoud, 1st jenkins install will be manual
15:21:43 <ewoud> #info first jenkins install will be manual, puppetized later on
15:21:59 <eedri> ewoud, after we'll have a foreman/puppet vms running, we'll make sure jenkins is managed
15:22:08 <ewoud> #action dneary ensure people receive logins
15:22:13 <ewoud> I think that's enough about hosting now
15:22:29 <ewoud> and I think we can skip puppet on the agenda
15:22:33 <ewoud> #topic jenkins
15:22:52 <eedri> current rhel vms (ec2) were upgraded to 6.3
15:23:04 <ewoud> #info current rhel vms (ec2) were upgraded to 6.3
15:23:34 <ewoud> are the issues from vdsm on rhel now resolved?
15:23:45 <eedri> there was a request to create a new job to publishing reports on ovirt.org
15:23:51 * eedri is fetching infor from trac
15:24:33 <eedri> https://fedorahosted.org/ovirt/ticket/34
15:25:16 <eedri> not sure when we can start working on, probably after jenkins migration
15:25:22 <eedri> the issues on vdsm are solved
15:25:36 <eedri> #info python-nose1.1 was installed and linked on rhel vms
15:25:56 <ewoud> ok
15:26:01 <dneary> ewoud, Rydekull: Can you both send mburns your public ssh key, please? He can set you up on linode1
15:26:18 <dneary> ewoud, Rydekull: Along with your preferred username
15:26:23 <ewoud> will do
15:27:13 <ewoud> I'd like to mention jenkins-job-builder
15:27:47 <ewoud> it was suggested by an external person and I'm not sure we handled it well
15:28:00 <ewoud> maybe we should have encouraged / supported him more to attract more infra
15:28:36 <eedri> ewoud, the jenkins-jobs-builder is an advanced feature used by openstack for dynamicly createing and managing jenkins jobs
15:29:12 <eedri> personally i'm not familiar with it yet, and i'm not sure if it's needed at this stage of ovirt jenkins infra
15:29:20 <ewoud> eedri: to me it looked like moving the jenkins job configuration to yaml files, thus versioning your build configs as well
15:29:45 <ewoud> but I'm more wondering how we handled it
15:30:02 <eedri> ewoud, true, but it comes with a price of limited option to update jobs
15:30:03 <ewoud> by saying no we don't encourage people to join the team
15:30:22 <eedri> ewoud, i don't think he was really interested in joining infra
15:30:35 <ewoud> maybe dneary has a better view on this
15:30:42 <eedri> ewoud, it seems that the main purpose was to use ovirt infra for other opensource projects
15:31:03 <dneary> ewoud, ?
15:31:04 <eedri> ewoud, at least in my view
15:31:52 <ewoud> dneary: I'm wondering how we should handle new people with ideas that may not directly align with the current infra goals
15:32:18 <dneary> ewoud, In general, we should encourage them, but we should not feel obliged to say yes to every idea
15:32:44 <dneary> ewoud, One of the advantages of self-service VMs is that you can allow someone a sand-box to prove the usefulness of an idea
15:33:11 <ewoud> dneary: yes, and I think we should aim to be able to support that asap
15:33:18 <eedri> ewoud, i think that people should show interest or commitment to the project, before we accept any idea they propose...
15:33:30 <dneary> ewoud, I agree
15:33:49 <eedri> ewoud, if any new user comes and just suggest to change the world... we shouldn't just jump and implement it
15:33:52 <dneary> eedri, Does proposing an idea and offering to do the work to make it a reality not count as interest in the project?
15:33:54 <Rydekull> I agree, though speaking as someone who is trying to get involved
15:34:04 <Rydekull> Its not, easy, per see to get involved
15:34:19 * Rydekull is a bit lagged right now, just fyi
15:34:43 <ewoud> it's a fine line, but I think we should at least help them think our their idea and get a decent proposal in place
15:34:52 <eedri> dneary, he didn't just proposed an idea, he proposed merging all infra for foreman,pulp,ovirt
15:34:58 <Rydekull> And i do agree that the user that was here earlier wasnt really set to join the infra-team
15:35:15 <dneary> eedri, I'm speaking in general, did not see this particular thread
15:35:18 <eedri> at least jenkins.. , that doesn't seem like a seriois suggesion
15:35:32 <eedri> ok
15:35:42 <ewoud> would it be a fair conclusion that we should be aware how we present ourselves? as Rydekull said,, it can be hard to join
15:35:46 <eedri> but i agree we should try to formalize handing this kind of inteactions
15:36:19 <ewoud> I'd really like to have this kind of discussion over a beer at fosdem ;)
15:36:26 <Rydekull> :-D
15:36:40 <eedri> i wish i could join, got my MBA exams on that dates :/
15:36:44 <ewoud> :(
15:36:45 <ewoud> moving on to the next topic
15:36:50 <ewoud> #topic gerrit
15:36:51 <ewoud> any news?
15:37:54 <ewoud> it seems not
15:37:58 <ewoud> #topic fosdem
15:38:13 <ewoud> I know quaid will attend, as will I
15:38:26 <ewoud> dneary: you're even giving a talk I think?
15:38:42 <Rydekull> Still unsure, need to get my schedule together. But I intend to do what I can to get there
15:38:45 <dneary> ewoud, Yes, in the community marketing and development room
15:38:59 <dneary> I'll be in the virt devroom most of Saturday, though
15:39:14 <dneary> There are lots of oVirt presentations
15:39:26 <ewoud> I heard quaid talk about planning on handing out stickers at the beer event as well
15:39:27 <eedri> is there a room on automation /jenkins?
15:39:41 <fabiand> eedri, yep
15:40:28 <ewoud> I think you mean https://fosdem.org/2013/schedule/track/configuration_systems_management/
15:41:16 <ewoud> should we at least try to get a short meet & greet with everyone there?
15:41:38 <Rydekull> Yes
15:41:44 <eedri> looks nice
15:41:55 <ewoud> #action ewoud propose a time to meet at fosdem
15:42:08 <ewoud> #topic trac review
15:43:08 <ewoud> https://fedorahosted.org/ovirt/report/1
15:43:47 <ewoud> anything we should discuss here?
15:44:25 <ewoud> https://fedorahosted.org/ovirt/ticket/31 Licensing (rights) link disappears when graphic is not used
15:44:31 <ewoud> dneary: can you look at that?
15:45:00 <dneary> ewoud, Sorry, was looking through archives to get info on adding you guys to the Jenkins host
15:45:06 <dneary> look at what?
15:45:13 <ewoud> dneary: ticket #31
15:46:58 <ewoud> #topic Other business?
15:47:01 <ewoud> anything?
15:47:26 <ewoud> dneary: eedri Rydekull dcaro|mtg
15:47:36 * Rydekull shakes his head
15:47:48 <eedri> nope
15:48:01 <ewoud> going once
15:48:03 <ewoud> going twice
15:48:04 <dneary> ewoud, I don't understand the bug report
15:48:11 <dneary> I think it can wait until quaid comes back
15:48:18 <ewoud> dneary: ok
15:48:27 <dneary> Thanks for running the meeting ewoud!
15:48:33 <ewoud> you're welcome :)
15:48:36 <ewoud> #endmeeting