15:01:25 <quaid> #startmeeting Infra weekly
15:01:25 <ovirtbot> Meeting started Mon Jan 21 15:01:25 2013 UTC.  The chair is quaid. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:25 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:51 <quaid> ewoud: we really should be doing discussions and decisions on list, this meeting is more a rally-point
15:02:00 <quaid> #topic Agenda & roll-call
15:02:05 <ewoud> quaid: agreed
15:02:07 <quaid> http://www.ovirt.org/Infrastructure_team_meetings#2012-01-21
15:02:42 * quaid pastes
15:02:45 <quaid> * Coverage - quaid on vacation 25 Jan - 08 Feb
15:02:46 <quaid> * Finalize and clearly publish information on who has access to what, how access is granted, and how decisions are made about new infrastructure
15:02:49 <quaid> ** [[Becoming an Infrastructure team member]]
15:02:51 <quaid> ** [[Infrastructure team assignments]]
15:02:54 <quaid> ** [[Category:Infrastructure#Decision_process]]
15:02:57 <quaid> * Hosting
15:02:59 <quaid> * Puppet
15:03:02 <quaid> * Jenkins
15:03:04 <quaid> * Gerrit
15:03:07 <quaid> * Other business?
15:03:09 <quaid> * Trac review
15:04:06 <ewoud> it would be nice if you could ask ovirtbot to highlight you when the meeting starts
15:04:19 <ewoud> eedri: dcaro here?
15:04:40 <mburns_ovirt_ws> ewoud: set your client to alert you when you see "Meeting Started"
15:04:51 <mburns_ovirt_ws> or " Information about MeetBot at http://wiki.debian.org/MeetBot."
15:04:54 <quaid> ping for meeting RobertM Rydekull
15:05:07 <dcaro> ewoud, I'm here, but not sure for how long (lots of meeting today)
15:05:14 <ewoud> dcaro: same here
15:05:33 <quaid> ok, let me hit the important thing(s) right away
15:05:38 <quaid> #topic Vacation coverage
15:05:41 <ewoud> mburns_ovirt_ws: good idea
15:05:52 <quaid> I'm on vacation from this Friday for 2 weeks, with a few days of work in the middle of that
15:06:04 * ewoud has to go now
15:06:07 <quaid> I won't be completely offline, but I won't be hanging out watching server stats, etc.
15:06:12 <quaid> so I'll start a thread on list
15:06:22 <quaid> to make sure that whatever I'm needed for there is someone who can cover
15:06:32 <quaid> that's related to http://www.ovirt.org/Infrastructure_team_assignments
15:07:46 <quaid> ok, moving on ...
15:08:27 <quaid> #topic Missing Infra info on who, what, decisions, etc.
15:08:51 <quaid> I started working on that this weekend, got a few pages improved, more to come as part of the vacation coverage topic
15:08:58 <quaid> http://www.ovirt.org/Becoming_an_Infrastructure_team_member
15:09:03 <quaid> http://www.ovirt.org/Infrastructure_team_assignments
15:09:08 <quaid> http://www.ovirt.org/Infrastructure#Decision_process
15:09:26 <quaid> if anyone is driven to help with those, we can move content to an Etherpad to work on
15:09:34 <quaid> otherwise, I'll work on them more right after this (possibly short) meeting
15:09:37 * Rydekull is here
15:09:45 <quaid> hey!
15:10:15 <quaid> Rydekull: I'd appreciate if you could review those pages when done; I'll say when they are there on list later today
15:10:27 <Rydekull> aight
15:10:34 <quaid> Rydekull: since writing them now was partially in response to realizing that we didn't have any answers for you about how to help, join, become a maintainer, etc.
15:10:40 <quaid> :)
15:11:50 <quaid> and moving along ...
15:12:13 <quaid> #topic Hosting
15:12:50 <quaid> #info eedri should have access to the AlterWay servers to turn one of them in to the about-to-be Jenkins master
15:13:08 <backblue> hi, it's ovirt supporting AoE in release 3.1??
15:13:26 <quaid> #info those machines will be Puppetized after we get them installed, to save time (not have to wait for puppet/foreman)
15:13:41 <quaid> #info ewoud also should have access & be coordinating with eedri
15:13:59 <quaid> backblue: sorry I don't know myself, but perhaps someone else here does?
15:15:01 <quaid> #info RackSpace hosts are going to come online probably while quaid is on vacation; if he sees the keys, he'll pass along access to eedri & ewoud for turning one of them in to a Jenkins slaves host
15:15:15 <quaid> #action dneary to follow-up about RHEL entitlements for RackSpace
15:15:32 <danken2> mburns_ovirt_ws: only the fileinject hook uses libguestfs at the moment
15:15:36 <quaid> Dave is probably en route to the US right now for the oVirt workshop tomorrow in my neck of the woods
15:15:46 <Rydekull> backblue: AoE only means Age of Empires in my head. But, I assume you mean ATA-over-ethernet, I'd say, no, I believe its on the wishlist though
15:16:02 <mburns_ovirt_ws> danken2: ok, so we could, theoretically remove libguestfs without any consequences
15:16:11 <backblue> ATA over Ethernet ofcourse.
15:16:16 <mburns_ovirt_ws> fabiand: can you try a build without libguestfs?
15:16:41 <quaid> #info quaid added 15 GB of space to the Linode instance to carry us over to migration, hopefully
15:16:48 <quaid> anything else on hosting?
15:17:01 <Rydekull> Infiniband-stuff, no real news from me
15:17:09 <Rydekull> but yeah, It'd fall under hosting I believe
15:17:13 <quaid> yep, thanks
15:17:20 <backblue> Rydekull, ovirt already supporting infiniband?
15:17:38 <quaid> #info no update on Infiniband hosting sponsorship, being worked on
15:18:25 <Rydekull> backblue: not really in a good way, no
15:18:41 <backblue> what do you mean by good way?
15:18:43 <quaid> Rydekull: yeah, that was something else dneary asked me - "What's the process for making decisions about taking on new architecture, etc. for Infra?"
15:19:00 <quaid> hope to get that cleared up
15:19:10 * quaid ready to move on, he thinks
15:19:10 <Rydekull> quaid: sounds like a valid question
15:19:19 <quaid> Rydekull: yep :)
15:19:40 <Rydekull> backblue: You can have it work with ovirt, but mostly as encapsulated ethernet
15:20:06 <Rydekull> backblue: the reason I mentioned it right now, is because im trying to sort out everything needed so developers have what they need to make that support
15:20:17 <quaid> #topic Puppet
15:20:28 <Rydekull> backblue: we're having a meeting in parallell to your question, as topic states :-)
15:20:32 <quaid> #info Puppet to be hosted on AlterWay second server
15:21:03 <quaid> #info ewoud should have info to install VMs on that second server to work on Puppet, Foreman, smartproxy, etc.
15:21:19 <quaid> #info we need to schedule out this migration a bit better, but puppet will arrive after the Jenkins migration
15:21:21 <backblue> We use a lot of infiniband here, if you need any help/opinion just poke me
15:22:19 <eedri> sorry guys, i'm occupied and can't attend the meeting too long
15:22:36 <quaid> backblue: Rydekull is working on getting us some sponsored hosting that will provide Infiniband equipment for the developers to use/test on; that means there should eventually be more testing needed for Infiniband, etc.
15:22:38 <eedri> quaid, me and david are still waiting for the credentials for the jenkins master,
15:22:43 <quaid> eedri: understood, you can check the notes later, too
15:22:51 <eedri> quaid, thanks
15:22:51 <quaid> eedri: oh!
15:23:08 <quaid> #action quaid to get Jenkins master credentials to eedri & dcaro asap
15:23:15 <Rydekull> hehe
15:23:18 <quaid> I thought dneary passed them along, I'll look in to that later
15:23:29 <quaid> (after this meeting)
15:23:31 <backblue> Rydekull, yes mostly you load IPoIB and goes from there...
15:24:01 <quaid> ok, moving along if there's nothing more for Puppet right now ...
15:24:13 <backblue> but using infiniband should be about using SDP, so we can use it as FC or ATAoE.
15:24:49 <quaid> #topic Jenkins
15:24:58 <backblue> ATAoE support should be done by coraid! They should provide hardware for support it! :-)
15:25:03 <quaid> #info Working on Jenkins master migration plan - eedri, dcaro
15:26:22 <quaid> backblue: if you have any contacts there who might be interested in sponsoring hardware (and hosting it), we could be interested
15:26:37 <Rydekull> (and if they cannot host it, let me know)
15:26:39 <Rydekull> :-P
15:26:41 <quaid> :)
15:26:57 <Rydekull> Hosting is quite easy to arrange for me afteral
15:26:59 <Rydekull> l
15:27:01 <quaid> #info server for Jenkins slaves to arrive in a few weeks
15:27:39 <quaid> Rydekull: keep a spare rack handy, we'll start filling it up (I hope!)
15:27:54 <quaid> anything else on Jenkins for now?
15:28:07 <Rydekull> quaid: I will :-)
15:28:13 <backblue> quaid, they are growing very fast, and they have almost the perfect solution for storage using ATAoE, they have very big clients and they used opensource a lot, they should help community.
15:30:16 <backblue> Rydekull, getting ovirt support for there coraid hardware, should be a big bonus for them. I'm sure if you contact them will help.
15:30:18 <quaid> #topic Gerrit
15:30:37 <Rydekull> backblue: do you have a contact there we can talk to?
15:30:44 <quaid> #info Gerrit is steady, no plans underway to move it (yet), will need to plan that carefully
15:30:44 <Rydekull> backblue: seeing as I have none
15:31:22 <backblue> no, I'm from thechnical department, I don't talk with them.
15:32:10 <quaid> #topic Any other business?
15:32:20 <quaid> anything else before we do a quick Trac ticket review?
15:32:42 <backblue> you can try: sales@coraid.com
15:32:48 <Rydekull> backblue: I will
15:33:35 <backblue> they will be the storage leaders in very short time, there is a initiator for linux, should be easy to support.
15:34:06 <backblue> basically storage have no limits with them, for shorter price then FC.
15:34:33 <quaid> #topic Trac ticket review
15:34:49 <quaid> https://fedorahosted.org/ovirt/report/1
15:35:45 <quaid> main thing there that I could clear up is to fix the users@ archives
15:36:20 <quaid> ok, I've lost my desire to do a ticket-by-ticket review
15:36:27 <quaid> if anyone has any questions on those, go ahead
15:36:54 <quaid> otherwise I'll close the meeting in a few minutes, and get to the work to be done from here - wiki pages, emails to list, etc.
15:37:01 <Rydekull> None, just wish I could help out with some, but eventually :-)
15:38:12 <backblue> you guys working on ovirt team in redhat?
15:40:23 <quaid> backblue: not us, not really
15:40:27 * Rydekull is just a "regular" guy
15:40:56 <backblue> you could be :P I don't know.
15:41:25 <quaid> backblue: I work for Red Hat as a community facilitator, I happened to be the one who started facilitating all the infrastructure for the oVirt developers before the release in Nov 2011
15:41:54 <mburns_ovirt_ws> backblue: there are RH developers on this channel though (myself included)
15:41:58 <quaid> ok, closing this meeting in 10 seconds
15:42:28 <quaid> #endmeeting